Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Routingtabellen austausch zwischen BGP und OSPF

Mitglied: Mullewarf

Mullewarf (Level 1) - Jetzt verbinden

20.09.2019, aktualisiert 11:31 Uhr, 385 Aufrufe, 4 Kommentare, 1 Danke

Ich habe angefangen mich mit dem Thema Backbone Verbindungen auseinanderzusetzen und dabei bin ich auf ein paar Fragen gestoßen. Vielleicht kann mir ja einer weiter helfen.

1. Ich habe im Packet Tracer von Cisco zwei AS aufgebaut die mit OSPF routen. Die Verbindung der beiden AS läuft über BGP. Das routing innerhalb der drei Bereiche funtioniert einwandfrei. Jetzt stellt sich mir nur die Frage wie findet den der Routing Tabellen abgleich statt, zwischen den beiden Routing Protokollen? Ich weiß nicht wie ich den Border Router konfigurieren soll damit AS1 weiß wo AS2 über das Backbone zu erreichen ist.

Ich hoffe ich konnt genau genug beschreiben was mein Problem ist und, dass ich nicht irgendeinen blöden Denkfehler gemacht habe.

Wenn mir jemand weiterhelfen kann währe ich ihm sehr dankbar.
Mitglied: Tektronix
20.09.2019 um 11:54 Uhr
Moin,
wenn ich mich nicht täusche tauschen BGP Router Routingtabellen miteinander aus. OSPF Router tauschen mit benachbarten OSPF Routern die Struktur des Netzes aus, so das die OSPF Router ihre Nachbarn kennen.
Bitte warten ..
Mitglied: aqui
LÖSUNG 20.09.2019, aktualisiert um 19:52 Uhr
Das Zauberwort heisst Route Redistribution !
Nur dann "redet" der OSPF Routing Prozess mit dem BGP Routing. Du musst also die Routen vom BGP ins OSPF redistribuieren und auch vice versa !
Hier mal ein einfaches und fast selbsterklärendes Beispiel auf einem Cisco Router der lokal OSPF spricht und per BGP über ein (Test)WAN mit einem Mikrotik Router und einem RaspberryPi_mit Quagga verbunden ist und diese OSPF IP Netze darüber weitergibt:

bgp - Klicke auf das Bild, um es zu vergrößern
!
interface Loopback0
ip address 10.222.222.26 255.255.255.255
!
interface FastEthernet0/1
description WAN
ip address 10.1.1.214 255.255.255.0
!
router ospf 1
router-id 10.1.1.214
log-adjacency-changes
auto-cost reference-bandwidth 10000
redistribute bgp 64714 subnets
passive-interface default
no passive-interface Serial0/0
no passive-interface FastEthernet0/1
no passive-interface Serial0/1
network 10.26.21.0 0.0.0.255 area 26
network 10.99.99.0 0.0.0.3 area 26
network 10.99.99.4 0.0.0.3 area 26
network 10.222.222.26 0.0.0.0 area 26
network 0.0.0.0 255.255.255.255 area 0
!
router bgp 64714
no synchronization
bgp router-id 10.1.1.214
bgp log-neighbor-changes
network 10.0.0.0
neighbor 10.1.1.203 remote-as 64700
neighbor 10.1.1.203 description Mikrotik
neighbor 10.1.1.203 update-source FastEthernet0/1
neighbor 10.1.1.211 remote-as 64711
neighbor 10.1.1.211 description RasPi-Quagga
neighbor 10.1.1.211 update-source FastEthernet0/1
auto-summary
!
Bitte warten ..
Mitglied: Mullewarf
20.09.2019 um 13:02 Uhr
Danke, hast mir sehr geholfen.
Bitte warten ..
Mitglied: aqui
20.09.2019 um 13:08 Uhr
Immer gerne...
Bitte warten ..
Ähnliche Inhalte
Router & Routing
BGP Monitoring
Frage von janosch12Router & Routing1 Kommentar

Hallo, ich suche derzeit eine kleine feine Lösung um meine BGP Sessions zu monitoren, eingesetzt wird Debian9 mit Bird ...

Router & Routing
Routing Loop im BGP
gelöst Frage von KampfwurstRouter & Routing10 Kommentare

Hallo zusammen, Heute ist mir folgendes aufgefallen was ich mir nicht ganz erklären kann. Auf 2 unabhängigen Internet Anschlüssen ...

Router & Routing
BGP Setup mit EOIP
Frage von Netgear24Router & Routing7 Kommentare

Hallo Zusammen Ich habe mal eine kurze Frage an euch. Ich bin aktuell am Ausbau von meiner eigenen Infrastruktur. ...

Netzwerke
Firewall Austausch
gelöst Frage von UnbekannterNR1Netzwerke7 Kommentare

Hallo zusammen, ich bräuchte mal ein paar Ideen bzw. Anregungen von euch. Ich habe mal einen deutlich gekürzten Netzplan ...

Neue Wissensbeiträge
Firewall
Übernahme von SOPHOS durch Thoma Bravo
Information von Dilbert-MD vor 15 StundenFirewall1 Kommentar

Kam die Tage per Newsletter: Zitat: " Das Sophos Board of Directors hat gestern bekanntgegeben, dass die Private-Equity-Investment-Firma Thoma ...

Windows Netzwerk

Ereignis-ID 20226 RasClient Ursachencode 829 VPN Verbindung wird abgebrochen

Anleitung von Hardstyles vor 6 TagenWindows Netzwerk

Hallo zusammen, nach Stundenlanger Analysen und test konnten wir den Fehler Lösen. es geht um folgende Fehler Meldung in ...

Windows 10

Windows 10 Version 1903: Update KB4522015 blockt VMware Workstation

Information von kgborn vor 10 TagenWindows 10

Nur eine kurze Information für Leute, die schon Windows 10 Version 1903 in Betrieb haben und dort VMware Workstation ...

VB for Applications

Fritzbox Telefonbuch - XML-Importdatei aus Excel erstellen

Tipp von PeterleB vor 10 TagenVB for Applications1 Kommentar

Das Thema geistert schon seit Jahren durch verschiedene Foren. Habe mich jetzt mal damit etwas intensiver befasst und hoffe, ...

Heiß diskutierte Inhalte
Switche und Hubs
24 Rasperry PI vernetzen, was nimmt man da?
gelöst Frage von clkdivSwitche und Hubs25 Kommentare

Hallo, ich möchte 24 Raspberries vernetzen. Bis jetzt waren es 4 Stück, ich habe dafür einen cheap-o-cheap Edimax-Hub benutzt, ...

LAN, WAN, Wireless
Hausnetzwerk mit Routern
Frage von perhaps-labs.comLAN, WAN, Wireless22 Kommentare

Hallo an Alle, ich habe ein Riesenhaus erworben und möchte nun überall ein Netzwerk dafür installieren. Das Haus hat ...

E-Mail
Optionen des Mails-Empfangs
Frage von SchauerE-Mail19 Kommentare

Hallo an Alle. ich habe die Aufgabe bekommen zu recherchieren, welche Optionen sich anbieten Mails zu empfangen. Klingt banal, ...

Firewall
Welche Anbieter, Geräte und Programme gelten als sicher?
Frage von NordicMikeFirewall16 Kommentare

Moin zusammen, wenn man sich die vielen Sicherheitslösungungen ansieht, erkenn man nicht, auf was man sich einlassen würde. Man ...