STP blocked Alcatel-brocade switches

Hallo zusammen!

ich habe folgendes Problem- habe einen alten Alcatel Switch, der für TK Anlage vorgesehen war an einen Brocade ICX-6450 angekoppelt um voip drüber
zu betreiben. Der Brocade Switch bekommt auf port 1/1/22, der mit Alcatel port e12 verbunden ist, blocked status- ist aber up. Ist spanning tree incompatibel?
Danke für Ihre Antworten im voraus!

Alcatel TK Switch config:

tkswitch4# sh ver
SW version 1.0.0.47 ( date 09-Oct-2005 time 17:04:56 )
Boot version 1.0.0.09 ( date 23-Aug-2005 time 15:50:46 )
HW version 00.00.01
tkswitch4#
tkswitch4# sh run
spanning-tree bpdu filtering
interface range ethernet e(1-24)
spanning-tree portfast
exit
interface range ethernet g(1-3)
switchport mode trunk
exit
vlan database
vlan 2
exit
interface range ethernet g(1-3)
switchport trunk allowed vlan add 2
exit
interface range ethernet e(2-3)
no negotiation
exit
interface vlan 1
ip address 172.18.0.14 255.255.255.0
exit
ip default-gateway 172.18.0.1
hostname tkswitch4
aaa authentication login default enable
enable password level 1 b36eb6a54154f7301f004e1e61c87ce8 encrypted
enable password level 7 b36eb6a54154f7301f004e1e61c87ce8 encrypted
enable password level 15 b36eb6a54154f7301f004e1e61c87ce8 encrypted
username admin password b36eb6a54154f7301f004e1e61c87ce8 level 15 encrypted
snmp-server location "Neues Technisches Rathaus"
clock timezone 1
clock summer-time recurring eu
tkswitch4#

Brocade Switch ICX6450
SSH#sh inter b

Port Link State Dupl Speed Trunk Tag Pvid Pri MAC Name
1/1/1 Up Forward Full 100M None No 999 0 78a6.e132.eab0
1/1/2 Up Forward Full 100M None No 999 0 78a6.e132.eab1
1/1/3 Up Forward Full 100M None No 999 0 78a6.e132.eab2
1/1/4 Up Forward Full 1G None No 999 0 78a6.e132.eab3
1/1/5 Up Forward Full 1G None No 30 0 78a6.e132.eab4
1/1/6 Down None None None None No 999 0 78a6.e132.eab5
1/1/7 Down None None None None No 999 0 78a6.e132.eab6
1/1/8 Down None None None None No 999 0 78a6.e132.eab7
1/1/9 Down None None None None No 999 0 78a6.e132.eab8
1/1/10 Down None None None None No 999 0 78a6.e132.eab9
1/1/11 Down None None None None No 999 0 78a6.e132.eaba
1/1/12 Down None None None None No 999 0 78a6.e132.eabb
1/1/13 Up Forward Full 100M None No 999 0 78a6.e132.eabc
1/1/14 Up Forward Full 100M None No 999 0 78a6.e132.eabd
1/1/15 Up Forward Full 1G None No 999 0 78a6.e132.eabe
1/1/16 Up Forward Full 100M None No 999 0 78a6.e132.eabf TK-Medieng
1/1/17 Up Forward Full 100M None No 999 0 78a6.e132.eac0 TK-Medieng
1/1/18 Down None None None None No 999 0 78a6.e132.eac1
1/1/19 Down None None None None No 999 0 78a6.e132.eac2
1/1/20 Down None None None None No 999 0 78a6.e132.eac3
1/1/21 Down None None None None No 999 0 78a6.e132.eac4
1/1/22 Up Blocked Full 100M None No 999 0 78a6.e132.eac5 <
1/1/23 Up Forward Full 100M None No 999 0 78a6.e132.eac6 USV20kW
1/1/24 Up Forward Full 1G None Yes N/A 0 78a6.e132.eac7
1/2/1 Down None None None None Yes N/A 0 78a6.e132.eac9
1/2/2 ERR-DIS None None None None No 1 0 78a6.e132.eaca
Config von Port 1/1/22
SSH#sh ru inter e 1/1/22
interface ethernet 1/1/22
speed-duplex 100-full
spanning-tree 802-1w admin-edge-port

Content-Key: 1099677437

Url: https://administrator.de/contentid/1099677437

Ausgedruckt am: 21.09.2021 um 16:09 Uhr

Mitglied: aqui
Lösung aqui 29.07.2021 aktualisiert um 14:35:02 Uhr
Goto Top
Ist spanning tree incompatibel?
Jein...bzw. man muss die verschiedenen STP Optionen sehr genau beachten !
Nutzt du den Brocade Switch im Layer 2 Mode ("S" Image) ? Dort ist STP im Default aktiv.
Brocade / Ruckus ICX Switches nutzen im Default PVSTP (Per VLAN Spanning Tree) wie Cisco nur das sie die Standard BPDU Macs nutzen statt wie Cisco proprietäre BPDU Mac Adressen.
PVSTP betreibt pro VLAN eine eigenständige STP Instanz. Das hat den unschätzbaren Vorteil das wenn es in VLAN x mal im Spanning Tree "rumpelt" (STP Topology Change Event) das NICHT im VLAN y passiert. Ein sehr sinnvolles Feature also was man in einem Single Span Verfahren natürlich nicht hat (da nur ein einziger STP Prozess). Da "rumpelt" es dann auch überall wenn auch nur 1 VLAN betroffen ist. Single Span Verfahren haben also immer gravierende Nachteile.

Generell ist aber das gerade im Billigsektor häufig genutzte Single Span Verfahren NICHT kompatibel zu einem PVSTP Verfahren ! Da hast du also Recht und es gilt dann genau hinzusehen.
Leider machst du hier zum Alcatel wenig bis keinerlei Aussagen zu dem Thema was aber für eine fehlerfreie Funktion unerlässlich ist ! ;-) face-wink
Wichtig ist hier also 2 STP relevante Dinge über die Alcatel Gurken zu erfahren:
  • Ob der Alcatel ein Single Span Verfahren nutzt oder auch PVSTP kann (ggf. show spann ausführen)
  • Welches STP Protokoll der Alcatel generell nutzt ? STP, RSTP, MSTP oder PVSTP ??

Sollte der Alcatel KEIN PVSTP Verfahren supporten und kann nur Single Span, dann musst du den ICX zwingend auf Single Span Verfahren umstellen. Brocade/Ruckus supportet ALLE STP Verfahren sogar auch das proprietäre Cisco PVSTP+ Spanning Tree ! 😉
Das sieht dann (Auszug) so aus:
!
Current configuration:
!
ver 08.0.95d
!
spanning-tree single
!
vlan 1 name DEFAULT-VLAN by port
spanning-tree
management-vlan
default-gateway 192.168.1.254 1
!
vlan 10 name VLAN-10 by port
tagged ethe ethe 1/2/1 to 1/2/2
untagged ethe 1/1/6 to 1/1/7
spanning-tree
!
spanning-tree single 802-1w
(spanning-tree single 802-1w priority 12288)

!

Das o.a. Setup schaltet den ICX global auf ein Single Span Verfahren mit RSTP Protokoll um.
Eine Spanning Tree Priority musst du nur dann konfigurieren wenn der ICX Switch STP Root Switch oder Backup Root Switch ist (immer modulo 4096). Für einen einfachen Access Switch kannst du das Priority Kommando weglassen, die Priority bleibt dann auf dem Default 32768. Nur die Root Switches im Core benötigen zwingend eine STP Priority für ein sauberes STP Design !

Ein show 8 zeigt dir dann den Spanning Tree Status der Ports auf dem ICX an sofern du das moderne RSTP aktiviert hast. show spann macht es dann für das alte und lahme STP.

Tip wenn nicht schon geschehen:
Date den ICX 6450 immer auf sein latest aktuelles Image up. Latest Patch ist die 8.0.30u
Die Images sind frei von der Ruckus Support Seite downloadbar
Mitglied: chgorges
chgorges 29.07.2021 aktualisiert um 20:54:27 Uhr
Goto Top
Moin,

der TE muss auf Port E12 einfach das BPDU Filtering ausschalten, dann läuft das.
2005 gab es noch kein PVST, da muss auf dem Ruckus maximal RSTP eingestellt werden, was er ja hat. Oder sogar nur normales STP.

VG
Mitglied: aqui
aqui 30.07.2021 aktualisiert um 08:51:06 Uhr
Goto Top
Nein, das ist leider eine komplette Falschinformation !
Auf allen Foundry/Brocade/Ruckus ICX Switches gibt es seit je her PVST genau wie bei Cisco und PVSTP ist auch immer im Default aktiviert auf den Layer 2 Images. Wie kommst du jetzt auf die Jahreszahl 2005 und welche Relevanz hat das ? Cisco, Foundry und andere Hersteller machten auch schon vor 2005 PVSTP.
Solltest du eigentlich auch wissen wenn du mit Foundry/Brocade/Ruckus oder auch Cisco Switches umgehst.
Es MUSS also immer geklärt werden WAS genau Fremdswitches im STP eingestellt haben wenn man gemischte Umgebungen betreibt.
Bei Cisco (Catalysten mit IOS) ist es umso fataler, denn dort bleibt einem nur die Migration auf MSTP wegen der dort verwendeten proprietären BPDU Mac Adressen. (Siehe dazu auch hier)
Nebenbei ist auf einem L2 Switch mit STP niemals BPDU Filtering aktiv im Default. Normal wird STP geflutet wenn aktives STP auf dem Switch deaktviert sein sollte was man in redundanten Umgebungen aber niemals machen sollte wegen der Loop Gefahr.
Fazit:
  • O.a Aussage zum Foundry/Brocade/Ruckus Switch ist so nicht richtig und widerspricht aktuellen L2 Setups
  • Der TO MUSS zwingend klären welche STP Variante und Verfahren seine Alcatel Teile verwenden
  • ICX dann entsprechend customizen auf die vom Alcatel verwendeten Verfahren. Wenns Single Span ist dann eben wie oben

Vermutlich hat er wegen des fehlenden Feedbacks ja so oder so das Interesse an einer zielführenden Lösung verloren ?!
Mitglied: chgorges
chgorges 30.07.2021 um 21:48:42 Uhr
Goto Top
Cisco hat es 2003 implementiert und dann erstmal für sich behalten, du glaubst doch selber nicht, dass ein Alcatel Switch von 2005, auf den ich mich beziehe, das damals schon konnte.
Mitglied: aqui
aqui 31.07.2021 um 20:35:32 Uhr
Goto Top
Alcatel so oder so nicht, da hast du Recht. Foundry hat es allerdings schon seit 1996 in Betrieb gehabt und darauf basieren ja die Folgeprodukte von Brocade bzw. jetzt Ruckus. Ausserdem ist PVSTP seit 1996 dort auch immer das Standard STP Verfahren im Layer 2 Image was sich über die gesamte Zeit nie geändert hat.
Mitglied: alikber
alikber 02.08.2021 um 14:07:45 Uhr
Goto Top
Ich danke euch für eure tips- das ist was der Alcatel konfiguriert hat : (Also STP)

tkswitch4# sh spann


Spanning tree enabled mode STP
Default port cost method: short



Root ID Priority 1500
Address 00:d0:95:e7:74:f8
Cost 8
Port g1
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge ID Priority 32768
Address 00:12:cf:25:1b:c0
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Number of topology changes 7069 last change occurred 642:13:30 ago
Times: hold 1, topology change 35, notification 2
hello 2, max age 20, forward delay 15

Interfaces
Name State Prio.Nbr Cost Sts Role PortFast Type
------ -------- -------- --------- ------ ---- --------
e1 enabled 128.1 100 DSBL Dsbl No P2p (STP)
e2 enabled 128.2 100 DSBL Dsbl No P2p (STP)
e3 enabled 128.3 100 DSBL Dsbl No P2p (STP)
e4 enabled 128.4 100 DSBL Dsbl No P2p (STP)
e5 enabled 128.5 100 DSBL Dsbl No P2p (STP)
e6 enabled 128.6 100 DSBL Dsbl No P2p (STP)
e7 enabled 128.7 100 DSBL Dsbl No P2p (STP)
e8 enabled 128.8 100 DSBL Dsbl No P2p (STP)
e9 enabled 128.9 100 DSBL Dsbl No P2p (STP)
e10 enabled 128.10 100 DSBL Dsbl No P2p (STP)
e11 enabled 128.11 100 DSBL Dsbl No P2p (STP)
e12 enabled 128.12 19 FRW Desg No Shared (STP)
e13 enabled 128.13 100 DSBL Dsbl No P2p (STP)
e14 enabled 128.14 100 DSBL Dsbl No P2p (STP)
e15 enabled 128.15 100 DSBL Dsbl No P2p (STP)
Mitglied: alikber
alikber 02.08.2021 um 16:31:13 Uhr
Goto Top
Aqui- direkt ins schwarze getroffen!
ich habe spanning-tree single konfiguriert auf dem icx und siehe da...

SSH#sh inter b

Port Link State Dupl Speed Trunk Tag Pvid Pri MAC Name
1/1/1 Up Forward Full 100M None No 999 0 78a6.e132.eab0
1/1/2 Up Forward Full 100M None No 999 0 78a6.e132.eab1
1/1/3 Up Forward Full 100M None No 999 0 78a6.e132.eab2
1/1/4 Up Forward Full 1G None No 999 0 78a6.e132.eab3
1/1/5 Up Forward Full 1G None No 30 0 78a6.e132.eab4
1/1/6 Down None None None None No 999 0 78a6.e132.eab5
1/1/7 Down None None None None No 999 0 78a6.e132.eab6
1/1/8 Down None None None None No 999 0 78a6.e132.eab7
1/1/9 Down None None None None No 999 0 78a6.e132.eab8
1/1/10 Down None None None None No 999 0 78a6.e132.eab9
1/1/11 Down None None None None No 999 0 78a6.e132.eaba
1/1/12 Down None None None None No 999 0 78a6.e132.eabb
1/1/13 Up Forward Full 100M None No 999 0 78a6.e132.eabc
1/1/14 Up Forward Full 100M None No 999 0 78a6.e132.eabd
1/1/15 Up Forward Full 1G None No 999 0 78a6.e132.eabe
1/1/16 Up Forward Full 100M None No 999 0 78a6.e132.eabf TK-Medieng
1/1/17 Up Blocked Full 100M None No 999 0 78a6.e132.eac0 TK-Medieng
1/1/18 Down None None None None No 999 0 78a6.e132.eac1
1/1/19 Down None None None None No 999 0 78a6.e132.eac2
1/1/20 Down None None None None No 999 0 78a6.e132.eac3
1/1/21 Down None None None None No 999 0 78a6.e132.eac4
1/1/22 Up Forward Full 100M None No 999 0 78a6.e132.eac5 <<

Funktioniert !
Vielen vielen Dank!!
Mitglied: aqui
aqui 02.08.2021 um 21:41:14 Uhr
Goto Top
aqui- direkt ins schwarze getroffen! ich habe spanning-tree single konfiguriert auf dem icx und siehe da... Funktioniert !
Sag ich doch ! :-) face-smile
Vielen vielen Dank!
Immer gerne ! :-) face-smile
Mitglied: chgorges
chgorges 04.08.2021 um 12:54:30 Uhr
Goto Top
Und der Alcatel schiebt weiter fröhlich BPDU-Pakete über seinen Uplink an den Ruckus raus, das kann nicht wirklich die finale Lösung sein, von Spätfolgen abgesehen.
Mitglied: aqui
aqui 04.08.2021 um 20:14:41 Uhr
Goto Top
Ist ja kein Problem und ja absolut gewollt ! Beide Geräte sollten logischerweise aktiv am Spanning Tree teilnehmen. RSTP ist weltweit standartisiert und beide nutzen Single Span. Bilderbuchmässiger kann man es ja nicht machen !
Das „Success“ Feedback des TO bestätigt deshalb auch erwartungsgemäss die Richtigkeit dieses Setups ja eindeutig.
Heiß diskutierte Beiträge
question
Windows PrintServer 2016 - KB5005573 macht Drucken unmöglich - Fehler 0x11bbeidermachtvongreyscullVor 1 TagFrageWindows Server22 Kommentare

Moin Kollegen, verdammt den hatte ich nicht auf dem Schirm. Ich hab gestern Sicherheitsupdates auf unseren 2016ern ausgerollt und heute morgen kann keiner mehr drucken, ...

question
Rechner im Netzwerk frieren nach Neustart einCZF-MarkusVor 1 TagFrageWindows Netzwerk15 Kommentare

Seit einer Woche frieren unsere Rechner (Windows 10) im Firmennetzwerk nach einem Neustart ein, mal ist es die Outlook.exe, mal die Explorer.exe, mal die .exe ...

question
Macadresse fest auf dem Board ändernDippsVor 1 TagFrageHardware12 Kommentare

Hallo ich habe ein Mainboard was defekt ist. Nun habe ich das Typgleiche geholt und ausgetauscht. Es läuft ein Linux drauf mit einer Software die ...

question
Kauftipp für einfaches KabelmodemTheEPOCHVor 1 TagFrageHardware5 Kommentare

Hallo zusammen, ich bräuchte eine kleine Kaufberatung. Ich suche ein ganz einfaches Kabelmodem. Das Gerät soll vor eine OPNsense und das Internet bereitstellen. DOCSIS 3.0 ...

question
Clonen einer SSD Platte auf eine grösserejensgebkenVor 22 StundenFrageFestplatten, SSD, Raid9 Kommentare

Hallo Gemeinschaft habe in meinem Rechner eine alte SSD 128 und eine neu installierte mit Windows 10 drauf 512 GB nun möchte ich gerne die ...

question
Aufbau Netzstruktur für CARP mit OPNsense gelöst screemyVor 1 TagFrageLinux Netzwerk6 Kommentare

Guten Abend, wir betreiben auf 2 ProxmoxVE Hosts jeweils eine OPNsense. Diese möchten wir mittels CARP hochverfügbar konfigurieren für die LAN/WAN Schnittstelle. Folgender Aufbau ist ...

info
Druckprobleme an PrintServern nach Sept. 2021 UpdatekgbornVor 1 TagInformationWindows Server

FYI: Seit die Sicherheitsupdates vom Patchday 14. September 2021 ausgerollt wurden, stehen Administratoren vor dem Problem, dass Clients eventuell nicht mehr an einem Terminalsever oder ...

question
Fritzbox als VPNClientproton34Vor 1 TagFrageRouter & Routing7 Kommentare

Hallo, ich habe dem letzt gelesen, dass es nicht möglich sein soll eine FritzBox 7490 als VPNClient zu verwenden. Den Beitrag findet ihr hier:. Jetzt ...