martinbln
Goto Top

Telefonie über S2S-Wireguard entfernte FritzBox

Guten Abend!

Ich habe folgendes Problem. Zwei Fritzboxen 7490 (neuester FW-Stand) sind mittels S2S-VPN verbunden. Ehemals lief das mit IPSec. Ich habe über die FritzBox an Standort A die Telefonnummern der FritzBox an Standort B problemlos genutzt, also kommende und gehende Telefonate über die entfernte Box führen können.
Nun habe ich auf Wireguard umgestellt. Der Tunnel steht, allerdings sind die entfernten Rufnummern nach Zwangstrennung durch den DSL-Anbieter regelmässig nicht mehr erreichbar.

fb0 (2)

Mal keine einzige von dreien, mal alle, mal nur wenige. Neustart der Box(en) hilft manchmal, manchmal nicht. Wenn die Rufnr inaktiv angezeigt wird, dann passiert folgendes: wenn ich an Box A ein gehendes Telefonat über eine der Nummern führe, scheitert das beim 1. Versuch, beim 2. Anlauf klappt es dann regelmässig.

fbb2 (2)

AVM Hotline sagt dazu: wenn es geht, dann schön, wenn nicht, dann Pech. Dann supporten wir das nicht. Schade eigentlich face-smile
Hat hier vielleicht jemand einen Tipp, was ich noch versuchen könnte?

Dankeschön!

Fritzbox A:

fbb1a

screencapture-192-168-99-1-2024-01-04-17_38_48


Fritzbox B:

fb1

fb3

Content-Key: 71012242049

Url: https://administrator.de/contentid/71012242049

Printed on: July 21, 2024 at 22:07 o'clock

Member: MirkoKR
MirkoKR Jan 04, 2024 at 18:41:48 (UTC)
Goto Top
Laut Wireguard VPN FAQ bei AVM kann nur vom Wireguard-Client auf den Wireguard-Server und dessen Netzwerk bei S2S zugegriffen werden ...­čĄö
Member: martinbln
martinbln Jan 04, 2024 at 19:00:02 (UTC)
Goto Top
Mmh. Und das bedeutet, es kann per se nicht funktionieren? Teilweise tut es das aber ja...
Member: MirkoKR
MirkoKR Jan 04, 2024 updated at 19:02:12 (UTC)
Goto Top
Zitat von @martinbln:

Mmh. Und das bedeutet, es kann per se nicht funktionieren? Teilweise tut es das aber ja...

Abhängig, evtl. welche Site die Verbindung aufbaut?

Und ja, AVM sollte da dringend nachbessern ... ­čśë
Member: Dani
Dani Jan 04, 2024 at 21:40:08 (UTC)
Goto Top
Moin,
vermutlich hat sich durch die Zwangstrennung die IPv4 Adresse oder der IPv6 Präfix geändert? Zwar wird die neue Ipv$/IPv6 Adresse dem verwendeten DynDNS Service mitgeteilt. Allerdings löst wohl WireGuard nur beim Verbindungsaufbau den Namen auf und danach nicht mehr.

Vermutlich geht wieder alles sobald du eine FRITZ!Box neu startest?!


Gruß,
Dani
Member: martinbln
martinbln Jan 05, 2024 at 10:11:35 (UTC)
Goto Top
Ja, genau. Die Wan-IP ändert sich nach der Zwangstrennung. Neustart hilft aber nicht immer interessanterweise.
Danke für die HIlfe! Ich richte dann wieder IPSec ein...
Member: aqui
aqui Jan 05, 2024 at 10:15:14 (UTC)
Goto Top
Member: Dani
Dani Jan 05, 2024 at 21:28:20 (UTC)
Goto Top
Moin,
Neustart hilft aber nicht immer interessanterweise.
wenn sich auf beiden Seiten die IP-Adresse geändert hat, musst du nacheinander beide Boxen neu starten bzw. denn Tunnel de- und wieder aktivieren. Das sollte immer gehen.


Gruß,
Dani