liquidbase
Goto Top

Treiberinstallation durch Windows Update läßt sich nicht verhindern

Hallo an alle!

Das Problem steht bereits im Titel der Frage.
Aktuell habe ich hier ein Dell Latitude E6430 mit einem verbauten UMTS-Modem. Als Betriebssystem kommt hier Windows 10 Enterprise 1607 zum Einsatz.

Hier wird auch gleich das Problem verursacht. Der Treiber der hier von Windows Update installiert wird, läßt das Modem unbrauchbar werden. Nun könnte man sagen das man den Treiber von Dell für das Dell Wireless 5560 and 5565 Mobile Broadband Driver and GNSS (GPS) benutzt welcher auch für Windows 10 freigegeben ist. Effektiv ist das gesamte Geräte, laut Dell, für Windows 10 freigegeben.
Besagter Treiber hat hier schon einmal das Problem das er das verbaute Gerät nicht finden. Soll aber kein Problem darstellen da man im Netz für Dell-Geräte genügend Ressourcen findet welche auch funktionieren, wäre da nicht Windows Update.

Das erste was ich da nun gemacht hatte, da ich es von Windows 8.1 / 10 Pro so kenne, über die Systemsteuerung die Updates für Gerätetreiber deaktiviert hatte. Brachte nur nichts. Also nochmal Google bemüht und danach das ganze über gpedit.msc in der entsprechenden Policy deaktiviert das Treiber über Windows Update geladen dürfen (Keine Treiber in Windows-Updates einschließen => Aktiviert). Hier war dann der erste Erfolg zu verzeichnen das nach einem Reboot Windows besagten Treiber nicht mehr installiert hat. Die Freude darüber hat allerdings nur 3 weitere Reboots gehalten, da dann wieder der Treiber von Windows Updates installiert wurde.

Besagter Treiber den Windows Updates installiert ist hier der Erricsson AB - Mobile Broadband GSM - Dell Wireless 5560 HSPA+ Mini-Card Geolocation Sensor und Erricsson AB - Mobile Broadband GSM - Dell Wireless 5560 HSPA+ Mini-Card Device. Da man so keine Option mehr hat Windows Updates auszublenden wie man es unter 7, 8 oder 8.1 machen kann also wieder Google gefragt. Hier bekommt man den Verweis auf ein Problemlösungstool von MS und dem KB-Eintrag 3073930. Also dieses auch probiert und siehe da das Update konnte ich damit ausblenden. Hier hielt die Freude darüber ebenfalls nur ein Reboot und besagter Treiber war wieder da ...

Letzte Idee das ganze per pnputils zu lösen funktionierte ebenfalls nicht.

Aktuell behelfe ich mich damit das ich alle Komponenten aus dem Gerätemanager lösche (inklusive der Dateien) und dann einfach den Treiber aus dem XPS-Forum nutze, selbstverständlich hält das nur bis zum nächsten Reboot oder aufwecken.

An sich könnte ich auch ein Linux laufen lassen auf dem Laptop, aber bedingt durch die Arbeit bleibt mir die Möglichkeit verwehrt (hier gäbe es sogar einen funktionierenden Treiber). Daher seid jetzt ihr gefragt. Hat einer von euch eine Idee wie ich Windows Update noch daran hindern könnte besagten Treiber zu installieren oder die Option der Treiberinstallation über Windows Update gänzlich zu deaktivieren?

Danke schon einmal für sämtliche Ideen oder Lösungen.

greetz
liquid

Content-Key: 323383

Url: https://administrator.de/contentid/323383

Printed on: June 19, 2024 at 11:06 o'clock

Member: BassFishFox
BassFishFox Dec 09, 2016 at 13:17:28 (UTC)
Goto Top
Hallo,

Diese Option ist etwas versteckt. Schau mal hier :

http://winsupersite.com/windows-10/stop-automatic-driver-updates-window ...

Der letzte Schritt ist bei der 1607 etwas anders, siehe Bild.

2016-12-09 08_15_54-device installation settings

Gruss BFF
Member: liquidbase
liquidbase Dec 09, 2016 updated at 13:40:43 (UTC)
Goto Top
Das war das erste was ich versucht habe, steht auch im dritten Absatz face-smile
Das war dann aber auch einer der Lösungen die ich als allererstes probiert hatte und direkt keinen Erfolg versprach. Dazu muss man aber sagen das entsprechendes Fenster unter Enterprise so aussieht:

driver

Trotzdem Danke für den Hinweis!
Member: BassFishFox
BassFishFox Dec 09, 2016 at 14:05:20 (UTC)
Goto Top
Hallo,

Glatt ueberlesen so frueh am morgen. face-wink

Das Dell Gedoens Tool fuer automatische Updates ist aber nicht zufaellig aktiv?

BFF
Member: liquidbase
liquidbase Dec 09, 2016 at 14:22:01 (UTC)
Goto Top
Nope das läuft nicht, würde aber so auch keine Treiber installieren. Ist ja nur dafür da das die Support-Seite weiß um welches Gerät es sich handelt. Davon ab funktioniert der Treiber von Dell nicht mal korrekt.
Aktuell benutze ich den Treiber aus dem XPS-Forum der dort verlinkt ist für das Dell Wireless 5560.
Member: BassFishFox
BassFishFox Dec 09, 2016 at 14:33:46 (UTC)
Goto Top
Hallo,

Mal so eine Idee am Rande.
Setze mal das WindowsUpdate zurueck.


BFF
Member: liquidbase
liquidbase Dec 09, 2016 at 16:13:34 (UTC)
Goto Top
War noch eine gute Idee, aber hat leider nur einen Reboot gehalten.
So langsam aber sicher verzweifel ich an der Sache und bin kurz davor das Notebook aus dem Fenster zu werfen :/
Member: BassFishFox
BassFishFox Dec 09, 2016 updated at 18:15:37 (UTC)
Goto Top
Och menno... face-wink

Irgendwie werde ich die Vermutung nicht los, dass Dein gpedit-Eintrag nicht funktioniert. Egal. Ackere Dich mal hier durch.

https://www.deskmodder.de/wiki/index.php/Ger%C3%A4tetreiber_Treibersoftw ...

Zur Not stelle alle dort genannten "v1607 Loesungen" ein. Wenn das auch nicht klappt -> Clean Install

BFF
Member: liquidbase
liquidbase Dec 09, 2016 at 19:30:26 (UTC)
Goto Top
Ja auch daran habe ich schon gedacht, auch wenn es nicht im Eingangspost erwähnt wurde.

An sich frage ich auch immer erst dann wenn ich echt nicht mehr weiter weiß und diesen Punkt habe ich aktuell erreicht.

Clean-Install hilft auch nicht. Das war vorhin das letzte Mittel der Wahl gewesen, sprich das Notebook ist aktuell taufrisch und wieder die gleiche Problematik.

Sehr wahrscheinlich mag mich Windows einfach nicht und versucht dadurch mir zu sagen ich soll wieder zu Linux zurück.
Member: BassFishFox
BassFishFox Dec 09, 2016 updated at 19:54:03 (UTC)
Goto Top
Hallo,

Doch koennte eine erneute frische Installation helfen, wenn Du W10 installierst ohne Netzwerk, alles zum Treiberupdate deaktivierst und dann erst die Kiste an das Netz lasst.

Letzte FRage, bevor ich Dir rate ein Linux oder W7 auf der Kiste zu benutzen.
Hast Du die Anleitung hier http://xps-forum.de/index.php?thread/26073-wwan-umts-und-windows-10/ exakt so eingehalten? Dieser Eintrag dort macht mich etwas stutzig...

Für die 5550/5560 UMTS Karten findet das Windows Update (Treiber aktualisieren (automatisch) im Gerätemanager) "Ericson AB" Treiber und installiert diese. Diese reichen aber für den Betrieb der Karten nicht aus. Anschließend müssen trotzdem vorgenannte Treiber (drüber)installiert werden. Erst dieses Paket installiert auch die Initialisierungsroutine, ohne die die Karten nicht starten.

BFF
Member: liquidbase
liquidbase Dec 09, 2016 at 20:43:05 (UTC)
Goto Top
Jips, daher auch die Menge an Reboots.
Werde dann einfach wieder zu Linux zurückgehen. Wird meinem Chef zwar nicht gefallen, da er Windows auf den Laptops haben möchte aber will ja auch das man arbeiten kann.

Danke für deine Hilfe bisher ☺
Member: DerWoWusste
Solution DerWoWusste Dec 09, 2016 at 22:14:51 (UTC)
Goto Top
Hi.

Hab das Thema schon vor längerer Zeit durch: http://www.howtogeek.com/223864/how-to-uninstall-and-block-updates-and- ... zeigt, wie man einzelne Updates verweigern kann.
Member: liquidbase
liquidbase Dec 09, 2016 at 22:42:09 (UTC)
Goto Top
Danke @DerWoWusste
Schaue ich mir nochmal an, melde mich dann morgen nochmal und Berichte wie es gelaufen ist.
Member: BassFishFox
Solution BassFishFox Dec 09, 2016 updated at 23:57:49 (UTC)
Goto Top
Keine Ursache. face-smile

Kennst Du das Teil schon? Vergleiche mal die Version des Treibers von DELL mit der Version von MS bei Dir.

http://en.community.dell.com/techcenter/enterprise-client/w/wiki/11501. ...

Ich kann mir einfach nicht vorstellen, dass Dein Geraet kein W10 richtig kann zumal ja DELL angeblich selbst die Kompatibilitaet mit dem Annidingsbums getestet hat.

http://www.dell.com/support/article/us/en/4/SLN297954 -> Frag die Dell-Leute mal danach.

BFF

P.S. Eine Idee vielleicht noch...
Woran erkennt eigentlich W10, dass Dein Treiber "veraltet" ist und tauscht ihn aus? Registry oder *.inf oder an sonst was?
Lies mal hier -> Gerätemanager: Faken der angezeigten Hardware
Eventuell ist es moeglich irgendwo die Versionsnummer des funktionierenden Treibers so hoch zu setzen, das WindowsUpdate denkt er ist aktuell?
Member: BassFishFox
BassFishFox Dec 10, 2016 at 13:52:00 (UTC)
Goto Top
Morgens,

Eine Idee habe ich noch.
Habt ihr zufaellig einen Windows-Server? Wenn ja, lasst den zusaetzlich als WSUS arbeiten und lasst die Treiberverteilung per WSUS weg. Eure Windows-PC lasst die Updates vom WSUS holen.

Wenn nicht, trag doch mal ein IP-Adresse und Port bei der entsprechenden Richtlinie per gpedit ein.

Schoenes WE
BFF
Member: hildefeuer
hildefeuer Dec 10, 2016 at 17:56:43 (UTC)
Goto Top
Kann man das nicht mit dem o un o tool unterbinden?
https://www.oo-software.com/de/shutup10
bei mir geht das bei der Win10 Home version.
Member: liquidbase
liquidbase Dec 10, 2016 at 18:51:30 (UTC)
Goto Top
Zitat von @hildefeuer:

Kann man das nicht mit dem o un o tool unterbinden?
https://www.oo-software.com/de/shutup10
bei mir geht das bei der Win10 Home version.
Macht auch nur das was man bereits per Hand einstellen kann, nur mit dem Vorteil das man dabei nicht in die Systemeinstellungen muss.

@BassFishFox
Der WSUS ist an sich eine gute Idee, aber bei einem Notebook was auch unterwegs oder ich beim Kunden nutze ist das eher unpraktisch.
Zu deiner Frage woran erkannt wird das es der "falsche" Treiber ist, könnte am GPS-Modul liegen was hier ebenfalls verbaut ist auf dem Modem. Wird der Treiber von Windows Update benutzt habe ich ein GPS-Modul im Gerätemanager welches bei den funktionierenden Treibern nicht mit dabei ist oder besser gesagt im eigentlichen Modemtreiber integriert ist.
Die Jungs von Dell anschreiben wegen dem Problem hat nichts gebracht. Die schieben die Schuld auf den User und nicht auf dem Treiber. Da gibt es auch nur den Link auf die Support-Seite mit dem Treiber von Dell der darin endet das kein passendes Gerät gefunden wird.

@DerWoWusste
Die Schritte die in deinem verlinkten Posting bei HowToGeek abgelaufen werden, hatte ich auch soweit alle durch. Problem hier ist das bei dem Tool womit man die Updates ausblenden kann der Treiber bisher nur ein einziges Mal aufgetaucht ist und da hat das ausblenden auch nicht wirklich etwas gebracht.

Allerletzte was ich jetzt noch mache, dass ich das Enterprise-Treiberpackage was @BassFishFox gelinkt hat austeste. Haut das nicht hin entferne ich Windows einfach wieder. Nichts ist nerviger wenn man unterwegs ist und erst mal wieder den Treiber für das Mobile Modem zu installieren bis man was machen kann.
Member: DerWoWusste
DerWoWusste Dec 10, 2016 at 19:29:44 (UTC)
Goto Top
Problem hier ist das bei dem Tool womit man die Updates ausblenden kann der Treiber bisher nur ein einziges Mal aufgetaucht ist und da hat das ausblenden auch nicht wirklich etwas gebracht.
Ging bei mir. Hatte das selbe Problem. Wie darf ich das verstehen? Das Tool lässt ihn dich ausblenden und danach findet windows update ihn nicht mehr.
Member: liquidbase
liquidbase Dec 13, 2016 at 08:05:16 (UTC)
Goto Top
Zitat von @DerWoWusste:

Problem hier ist das bei dem Tool womit man die Updates ausblenden kann der Treiber bisher nur ein einziges Mal aufgetaucht ist und da hat das ausblenden auch nicht wirklich etwas gebracht.
Ging bei mir. Hatte das selbe Problem. Wie darf ich das verstehen? Das Tool lässt ihn dich ausblenden und danach findet windows update ihn nicht mehr.
Ja so hatte ich das auch verstanden gehabt.
Ausblenden konnte ich das ganze Update, allerdings war es dann beim nächsten mal, nachdem ich die funktionierenden Treiber installiert hatte, wieder vorhanden und wurde auf ein neues installiert ...

Das Wochenende hat das ganze mit dem Treiber auch wunderbar funktioniert den @BassFishFox als letztes verlinkt hat. Allerdings muss ich jetzt feststellen, nachdem im Büro angekommen bin, das der Treiber sofort ausgewechselt wird wenn ich das Notebook in die Dockingstation hänge an welcher auch ein fester LAN-Anschluß vorhanden ist. Mittlerweile habe ich den Eindruck das der Treiber solange funktioniert wie keine Kabelgebundene Internetverbindung vorhanden ist, sobald diese hergestellt ist greift wieder Windows Update.

Werde das ganze aber auch nochmal ohne Dockingstation testen und nur das Netzwerkkabel anschließen und schauen ob das gleiche Verhalten auftritt. Melde mich dann spätestens heute Nachmittag nochmal.
Member: DerWoWusste
DerWoWusste Dec 13, 2016 at 09:20:46 (UTC)
Goto Top
Was Du ausblendest, wird nicht wieder angezeigt. Was sich da installiert hat, war eine Vorversion des Treibers. Die musst Du auch ausblenden oder generell ausstellen, dass Treiber upgedatet werden.
Member: liquidbase
liquidbase Dec 14, 2016 at 18:49:43 (UTC)
Goto Top
Das ist mir schon klar. Die Möglichkeit das Treiber über Windows Updates bezogen werden ist eh deaktiviert, war soweit das erste was ich gemacht habe.

Was das ausblenden betrifft, kann ich nicht mehr ausblenden was mir angezeigt wurde. Jedes mal wenn der Treiber installiert wurde war auch die erste Maßnahme das Tool von MS zu nutzen um dieses auszublenden, Dabei durfte ich dann aber feststellen das es nicht angezeigt wurde und ich es dadurch auch nicht wirklich ausblenden kann.

Aktuell läuft es mit den Treibern das die von MS nicht mehr installiert werden, allerdings auch erst seit dem ich die DockingStation von Dell nicht mehr nutze. Ich behalte das aber weiter im Auge und die Option auf Linux zu wechseln habe ich auch noch, auch wenn mir mein Chef dann erst mal eine Ansage machen wird >.<
Member: DerWoWusste
DerWoWusste Dec 14, 2016 at 19:47:13 (UTC)
Goto Top
Jedes mal wenn der Treiber installiert wurde war auch die erste Maßnahme das Tool von MS zu nutzen um dieses auszublenden
Verstehe ich das richtig, du benutzt das Tool nach der Installation des unerwünschten Treibers und nicht davor?
Member: liquidbase
liquidbase Dec 14, 2016 at 20:41:46 (UTC)
Goto Top
Zitat von @DerWoWusste:

Jedes mal wenn der Treiber installiert wurde war auch die erste Maßnahme das Tool von MS zu nutzen um dieses auszublenden
Verstehe ich das richtig, du benutzt das Tool nach der Installation des unerwünschten Treibers und nicht davor?
Nope, definitiv nicht.

Der Weg das Tool zu nutzen sah eher so aus:

Windows Update aufmachen => sich darüber lautstark ärgern => Tool öffnen => darauf hoffen das der Treiber angezeigt wird => ausblenden wenn möglich