tommy70
Goto Top

Update KB931125 wird immer wieder zur Installation angeboten

Hallo

ich habe auf mehreren XP SP3 Rechnern das Problem, dass das Update für Stammzertifikate [September 2009] (KB931125) immer wieder zur Installation ansteht obwohl die vorhergehende Installation nicht fehlgeschlagen ist.
Ich habe schon einiges versucht. Allerdings hat bisher nichts geholfen.
Auch im Windowsupdate.log steht so weit ich sehe nichts Verdächtiges.

2009-11-24	08:45:46:297	1644	 b4	AU	<<## SUBMITTED ## AU: Install updates / installing updates [CallId = {89A1D917-CC90-46F1-831D-5ED5F7614F98}]
2009-11-24	08:45:46:297	1644	584	Agent	*************
2009-11-24	08:45:46:297	1644	584	Agent	** START **  Agent: Installing updates [CallerId = AutomaticUpdates]
2009-11-24	08:45:46:297	1644	584	Agent	*********
2009-11-24	08:45:46:297	1644	584	Agent	  * Updates to install = 1
2009-11-24	08:45:46:297	1644	584	Agent	  *   Title = Update für Stammzertifikate [September 2009] (KB931125)
2009-11-24	08:45:46:312	1644	584	Agent	  *   UpdateId = {20E6483F-EBA9-40D1-89F4-1940F79CBA3B}.101
2009-11-24	08:45:46:312	1644	584	Agent	  *     Bundles 1 updates:
2009-11-24	08:45:46:312	1644	584	Agent	  *       {2D5D7333-4C16-40E8-891E-55E46D44E976}.101
2009-11-24	08:45:48:875	1644	584	Handler	Attempting to create remote handler process as DOMAIN\Administrator in session 0
2009-11-24	08:45:49:031	1644	584	DnldMgr	Preparing update for install, updateId = {2D5D7333-4C16-40E8-891E-55E46D44E976}.101.
2009-11-24	08:45:49:047	3392	c3c	Misc	===========  Logging initialized (build: 7.4.7600.226, tz: +0100)  ===========
2009-11-24	08:45:49:047	3392	c3c	Misc	  = Process: C:\WINDOWS\system32\wuauclt.exe
2009-11-24	08:45:49:047	3392	c3c	Misc	  = Module: C:\WINDOWS\system32\wuaueng.dll
2009-11-24	08:45:49:047	3392	c3c	Handler	:::::::::::::
2009-11-24	08:45:49:047	3392	c3c	Handler	:: START ::  Handler: Command Line Install
2009-11-24	08:45:49:047	3392	c3c	Handler	:::::::::
2009-11-24	08:45:49:047	3392	c3c	Handler	  : Updates to install = 1
2009-11-24	08:45:50:297	3392	c3c	Handler	  : Command line install completed. Return code = 0x00000000, Result = Succeeded, Reboot required = false
2009-11-24	08:45:50:297	3392	c3c	Handler	:::::::::
2009-11-24	08:45:50:297	3392	c3c	Handler	::  END  ::  Handler: Command Line Install
2009-11-24	08:45:50:297	3392	c3c	Handler	:::::::::::::
2009-11-24	08:45:50:312	1644	e30	AU	>>##  RESUMED  ## AU: Installing update [UpdateId = {20E6483F-EBA9-40D1-89F4-1940F79CBA3B}, succeeded]
2009-11-24	08:45:50:359	1644	584	Agent	*********
2009-11-24	08:45:50:359	1644	584	Agent	**  END  **  Agent: Installing updates [CallerId = AutomaticUpdates]
2009-11-24	08:45:50:359	1644	e30	AU	Install call completed.
2009-11-24	08:45:50:359	1644	584	Agent	*************
2009-11-24	08:45:50:359	1644	e30	AU	  # WARNING: Install call completed, reboot required = No, error = 0x00000000
2009-11-24	08:45:50:359	1644	e30	AU	#########
2009-11-24	08:45:50:359	1644	e30	AU	##  END  ##  AU: Installing updates [CallId = {89A1D917-CC90-46F1-831D-5ED5F7614F98}]
2009-11-24	08:45:50:359	1644	e30	AU	#############
2009-11-24	08:45:50:359	1644	e30	AU	Install complete for all calls, reboot NOT needed
2009-11-24	08:45:50:359	1644	e30	AU	Setting AU scheduled install time to 2009-11-24 11:00:00
2009-11-24	08:45:53:219	1644	e38	AU	Triggering Offline detection (non-interactive)

Hier meine fehlgeschlagenen Lösungsversuche.
Virenscanner habe ich bei den Tests immer deaktiviert.

1.Datei direkt von Microsoft runtergeladen und installiert

2. Downloadcache gelöscht
net stop wuauserv
rd /s /q %windir%\SoftwareDistribution
net start wuauserv
wuauclt /detectnow
wuauclt /reportnow

Laut Google haben auch andere das Problem. Allerdings habe ich bisher keine Lösung dafür gefunden.

Gruß
Tom

Content-Key: 130086

Url: https://administrator.de/contentid/130086

Printed on: June 22, 2024 at 20:06 o'clock

Member: SaarAdmin
SaarAdmin Nov 24, 2009, updated at Oct 18, 2012 at 16:40:04 (UTC)
Goto Top
Hallo !

Ich hab das gleiche Problem. Vor ein paar Monaten hatte ich ein ähnliches Problem schon einmal, damals mit sämtlichen 64-bit Maschinen. Microsoft musste damals eine aktualisierte Version des Patches rausbringen. Nach Download und Freigabe hatten wir dann keine Probleme mehr.

Siehe hier: Windowsupdate KB973869 vom 11.08.2009 für Windows XP 64 bit lässt sich nicht installieren

Vielleicht ist es ja diesmal wieder was ähnliches.
Member: stiftmaster6
stiftmaster6 Nov 24, 2009 at 10:08:32 (UTC)
Goto Top
Hallo, ich habe/hatte dieses Problem heute auch und es hat nicht lang gedauert bis das Telefon geklingelt hat....

Ich habe nun fürs erste das Stammzertifikate (September 2009) (KB931125) im WSUS abgelehnt und nun ist Ruhe...

Da das Update nun bereits auf allen Clients drauf ist warte ich mal ab was das kommt

Update für Stammzertifikate [September 2009] (KB931125)
Letztes Veröffentlichungsdatum: 22.9.2009
Member: KURR01
KURR01 Nov 24, 2009 at 11:07:52 (UTC)
Goto Top
Hallo.

hatten genau das gleiche Problem. Konnte das Problem wiefolgt lösen:

Als Vorinformation:
Der KB931125 setzt sich aus folgenden Teilen zusammen (diese Lösen sich nacheinander ab).

Namen im WSUS: Update für Stammzertifikate ----> Update für Stammzertifikate [Mai 2009] (KB931125) ----> Update für Stammzertifikate [September 2009] (KB931125)
Namen nach Datum: Update von Februar ----> Update von Mai ----> Update von September


Aus irgendwelchen Gründen war auf dem WSUS nur das Update von Februar und September genehmigt, aber das Update von Mai war abgeleht.

Dadurch sind die Beziehungen der Updates durcheinander gekommen in haben sich immer wieder erneut installiert.
Denn nach Installaton des "Updates von September" war "Update von Februar" ohne Nachfolger, d.h. Neuinstallation und nach Installation des Updates von Februar musste das Update von September installiert werden, da dieses Neuer ist. Ein ständiger Kreis.

Habe nun das Update von Mai im WSUS wieder genehmigt (Über Suchfunktion nach KB931125 suchen und das Update mit Rechtsklick genehmigen). Musste jetzt noch das aktuelle Septemberupdate installieren und nun kam keine Installationsaufforderung mehr.
Hat auf 2 unterschiedlichen Clients funktioniert.
Member: Tommy70
Tommy70 Nov 24, 2009 at 11:14:34 (UTC)
Goto Top
Zitat von @KURR01:
Habe nun das Update von Mai im WSUS wieder genehmigt (Über
Suchfunktion nach KB931125 suchen und das Update mit Rechtsklick
genehmigen). Musste jetzt noch das aktuelle Septemberupdate
installieren und nun kam keine Installationsaufforderung mehr.
Hat auf 2 unterschiedlichen Clients funktioniert.

Das funktioniert bei mir nicht. Das Update vom Mai lässt sich nicht mehr genehmigen da es bereits abgelaufen ist.
Member: SaarAdmin
SaarAdmin Nov 24, 2009 at 11:16:23 (UTC)
Goto Top
Bei mir das gleiche, es lässt sich nicht mehr zulassen.
Member: stiftmaster6
stiftmaster6 Nov 24, 2009 at 11:19:31 (UTC)
Goto Top
ja so sieht es auch bei mir aus
Member: Tommy70
Tommy70 Nov 24, 2009 at 11:31:33 (UTC)
Goto Top
Habe das Update vom Mai jetzt, so wie vom WSUS vorgeschlagen, abgelehnt. Ändert allerdings auch nichts am Problem.
Mitglied: 21277
21277 Nov 24, 2009 at 12:48:29 (UTC)
Goto Top
Auch wir haben das Problem. Allerdings nur auf XP Rechnern. Vista und Win7 ist wohl nicht betroffen.
Mitglied: 56844
56844 Nov 24, 2009 at 13:23:06 (UTC)
Goto Top
Confirmed face-smile

Auch hier, das gleiche Problem.
SBS 2003 mit aktuellem Patchstand und aktuellem WSUS.
Cients: XP Prof.
Mitglied: 17243
17243 Nov 24, 2009 at 13:24:26 (UTC)
Goto Top
Hi Tommy70

Gleiches Szenario bei uns in der Firma. Betroffen ca. 300 XP-Clients.

Der Vorschlag von stiftmaster6 ist auch eine Lösung, jedoch nicht eine kluge. Wenn der von KURRO1 geschriebene Ablauf stimmt, hat er beim nächsten Update der Stammzertifikate das gleiche Problem wieder.

Danke KURRO1, dein Vorschlag zeigt Wirkung. Habe auf unserem WSUS das Update vom Mai 2009 nochmals genehmigt. WSUS meldet, dass es abgelaufen ist. Danach eine manuelle Synchronisation* des WSUS. Auf den Cleints ist noch ein einmaliges Installieren notwendig (jedoch nicht auf jedem Client) und nun ist Ruhe bei uns.

Danke für die Inputs.

gretz drop

  • Lustig ist, dass unser WSUS letzte Nacht die Mai-Version als 'abgelaufen' synchronisiert hat face-wink
Member: SaarAdmin
SaarAdmin Nov 24, 2009 at 13:38:35 (UTC)
Goto Top
Danke KURRO1, dein Vorschlag zeigt Wirkung. Habe auf unserem WSUS das
Update vom Mai 2009 nochmals genehmigt. WSUS meldet, dass es
abgelaufen ist. Danach eine manuelle Synchronisation* des WSUS. Auf
den Cleints ist noch ein einmaliges Installieren notwendig (jedoch
nicht auf jedem Client) und nun ist Ruhe bei uns.

Funktioniert bei uns leider nicht, ich hab das Update nun bei uns auch wieder versucht zu genehmigen, erhalte aber wie erwartet die Fehlermeldung und habe danach neu syncronisiert. Danach erneut bei mir auf der XP-Maschine beide Updates installiert, aber ich stecke weiterhin in der Endlosschleife.
Member: Phalanx82
Phalanx82 Nov 24, 2009 at 13:42:43 (UTC)
Goto Top
In solchen Fälle könnte es eventl. helfen die Updates via "Herunterfahren und Updates installieren" einzuspielen.
Habe selbst die Beobachtung gemacht das manchmal Updates einfach fehlschlagen, aber wenn man sie beim
Rechner herunterfahren installiert geht alles ohne Probleme. Einfach warten bis das Update unten in der Taskleiste
aufschlägt als bereit zur Installation und bei Gelegenheit einfach den Rechner normal herunterfahren. Wenn das
Problem damit nicht zu lösen ist habe ich gerade auch keinen anderen Tipp parat.

Mfg.
Member: SaarAdmin
SaarAdmin Nov 24, 2009 at 13:47:31 (UTC)
Goto Top
Also bei mir hat das leider auch nicht geholfen, ich habs mal testweise an 2 Rechnern auspobiert, aber die Updates wurde nach dem Neustart wieder angeboten
Member: stiftmaster6
stiftmaster6 Nov 24, 2009 at 13:50:15 (UTC)
Goto Top
Also bei uns läuft es auch nicht

PS

es sollte keine kluge Lösung sein, nur hab ich keine Lust meinen Anwendern zu erklären was da los ist

und ich bin mir sicher das die Rechner auch so laufen bis es eine vernünftige Lösung gibt face-wink
Member: Tommy70
Tommy70 Nov 24, 2009 at 13:55:27 (UTC)
Goto Top
Funktioniert bei mir nicht. Das Update vom Mai lässt sich bei mir nicht mehr genehmigen da es abgelaufen ist.
Mitglied: 21277
21277 Nov 24, 2009 at 14:06:32 (UTC)
Goto Top
hilft wie erwartet nicht....ist zu einfach face-wink

Phalanx82
Kommentar Phalanx82 schreibt am 24.11.2009, 14:42:43 Uhr
In solchen Fälle könnte es eventl. helfen die Upadtes via "Herunterfahren und Updates installieren" einzuspielen.
Habe selbst die Beobachtung gemacht das manchmal Updates einfach fehlschlagen, aber wenn man sie beim
Rechner herunterfahren installiert geht alles ohne Probleme. Einfach warten bis das Update unten in der Taskleiste
aufschlägt als bereit zur Installation und bei Gelegenheit einfach den Rechner normal herunterfahren. Wenn das
Problem damit nicht zu lösen ist habe ich gerade auch keinen anderen Tipp parat.
Member: BAMBOIHH
BAMBOIHH Nov 24, 2009 at 14:13:37 (UTC)
Goto Top
Auch bei uns besteht das Problem.
Wird sicherlich in den kommenden Tagen von MS gefixt...
Mitglied: 21277
21277 Nov 24, 2009 at 14:25:40 (UTC)
Goto Top
Zitat von @BAMBOIHH:
Auch bei uns besteht das Problem.
Wird sicherlich in den kommenden Tagen von MS gefixt...

Du hast Hoffnung....
Member: skrApy
skrApy Nov 24, 2009 at 14:39:44 (UTC)
Goto Top
natürlich wird das Update noch auf den Clientrechner angeboten wenn ihr es auf dem WSUS ablehnt.

Ihr müsst noch den WSUS Cache auf dem Clientrechner löschen, danach holt er sich die Sachen neu vom WSUS-Server und das Update wird dann auch nicht mehr angeboten.

Also bei mir hat es geklappt damals face-smile
Member: skrApy
skrApy Nov 24, 2009 at 14:40:15 (UTC)
Goto Top
natürlich wird das Update noch auf den Clientrechner angeboten wenn ihr es auf dem WSUS ablehnt.

Ihr müsst noch den WSUS Cache auf dem Clientrechner löschen, danach holt er sich die Sachen neu vom WSUS-Server und das Update wird dann auch nicht mehr angeboten.

Also bei mir hat es geklappt damals face-smile
Member: mainbug
mainbug Nov 24, 2009 at 18:32:42 (UTC)
Goto Top
Moin!

Bin auch voll in den Wald gerannt.
Hat sich aber (zumindest bei mir) wie folgt gelöst:

Das Stammzellenupdate vom September habe ich auf dem WSUS "unapproved, same as parent" gesetzt, nicht "declined".
Danach habe ich auf einem Rechner /detectnow und /reportnow abgesetzt.
Warten(!), bis dieser Rechner im WSUS aktualisiert wird.
Im WSUS habe ich dann pro Rechner zwei "Updates needed" gesehen, das vom Mai und das vom September.
Das Mai-Update lies sich wie erwartet nicht freigeben, ist ja "expired".
Dann das September-Teil freigegeben und wieder /detectnow und /reportnow.
Nun installierten alle betroffenen Rechner das Update zwar nochmal, aber danach war Ruhe.

Probierts mal aus. Würde mich interessieren, ob es woanders auch hilft.

Grüße

--
Nach einem Reboot ist alles wieder gut.
Member: SaarAdmin
SaarAdmin Nov 24, 2009 at 19:35:16 (UTC)
Goto Top
@ mainbug:

Kann ich voll und ganz bestätigen, ich habs an zwei Rechnern getestet und funktioniert prima, allerdings ist dies bei meinen ca. 50 Rechnern recht zeitaufwändig.

Ich hab grad von meinem WSUS eine Meldung erhalten, dass neue Updates verfügbar sind und da war auch dieses dabei:

Update für Stammzertifikate [November 2009] (KB931125)
Mit diesem Update wird die Liste der Stammzertifikate auf dem Computer auf die Liste aktualisiert, die von Microsoft im Rahmen des Microsoft-Programms für Stammzertifikate akzeptiert wird. Durch Hinzufügen zusätzlicher Stammzertifikate auf dem Computer können Zertifikate für die erweiterte Überprüfung in Internet Explorer 7 verwendet werden. Außerdem lassen sich E-Mails verschlüsseln, und das sichere Browsen im Web sowie die Sicherheit von abgerufenem Programmcode werden verbessert. Nach der Installation dieser Komponente müssen Sie den Computer möglicherweise neu starten. Diese Komponente kann nach der Installation nicht mehr entfernt werden.

Ich warte jetzt mal ab, wie sich ein anderer Rechner, an dem ich deinen Workaround nicht ausprobiert habe, verhält, ich vermute mal dass MS da was behoben hat ... ich hoffe es jedenfalls. face-smile
Member: SaarAdmin
SaarAdmin Nov 24, 2009 at 19:52:49 (UTC)
Goto Top
Mein WSUS hat gerade folgendes Update heruntergeladen:

Update für Stammzertifikate
Mit diesem Update wird die Liste der Stammzertifikate auf dem Computer auf die Liste aktualisiert, die von Microsoft im Rahmen des Microsoft-Programms für Stammzertifikate akzeptiert wird. Durch Hinzufügen zusätzlicher Stammzertifikate auf dem Computer können Zertifikate für die erweiterte Überprüfung in Internet Explorer 7 verwendet werden. Außerdem lassen sich E-Mails verschlüsseln, und das sichere Browsen im Web sowie die Sicherheit von abgerufenem Programmcode werden verbessert. Nach der Installation müssen Sie den Computer gegebenenfalls neu starten. Das Update kann nach der Installation nicht mehr entfernt werden.

Hat aber auch nicht wirklich das Problem behoben, denn nun ist der Rechner, an dem ich eben deinen Workaround getestet habe und der ja auch erfolgreich war, auch wieder in der Endlosschleife drin. face-sad
Member: stiftmaster6
stiftmaster6 Nov 24, 2009 at 20:11:32 (UTC)
Goto Top
Da es mich nun nach den News auch interessiert hat:

Nachdem ich manuell synchronisiert hab ist:

-Update für Stammzertifikate abgelaufen
-Update für Stammzertifikate [November 2009] dazu gekommen

wie oben beschrieben hatte ich, um nervende Anrufe zu vermeiden, das

-Update für Stammzertifikate [September 2009]

abgelehnt, dieses hab ich nun wieder genehmigt, wuauclt /detectnow und reportnow

und schon sagt der WSUS 100% und kein gelbes !

und DANKE MS, fürs außerplanmäßige Neustarten der Server
Member: SaarAdmin
SaarAdmin Nov 24, 2009 at 20:35:14 (UTC)
Goto Top
Bei mir sieht es nun so aus, dass der Download der beiden Updates das Problem wohl behoben hat. Allerdings müssen sich die Rechner erstmal neu beim WSUS melden, was ja unter umständen manchmal ein wenig länger dauern kann. Wie oben von mainbug bereits aufgezeigt, kann dies ja abgekürzt werden durch die beiden Befehle /detectnow und /reportnow. Danach noch einmal das Update installieren und der Spuk hat ein Ende. face-smile
Member: Dani
Dani Nov 24, 2009 at 20:43:31 (UTC)
Goto Top
@stiftmaster6
der Neustart reisst es auch nicht raus. Einer mehr oder weniger in der Woche. face-smile

@SaarAdmin
Wir haben kurzerhand über ein Script "wuauclt /detectnow" auf allen Clients ausgelöst und zur Sicherheit alle Startupscripts erweitert. So dass morgen keinerlei Probleme auftauchen sollten.


Grüße,
Dani
Member: SaarAdmin
SaarAdmin Nov 24, 2009 at 20:55:50 (UTC)
Goto Top
@ Dani: Das mit den Scripten ist eine gute Idee, ich belasse es nun bei dem automatischen Prüfen, alternativ dazu habe ich meinen Usern eine Mail geschrieben, falls sie auf Nummer sicher gehen möchten, können sie manuell /detectnow ausführen. Im WSUS habe ich ja einen Überblick darüber bei wem aktualisiert ist und bei wem nicht.
Member: Tommy70
Tommy70 Nov 25, 2009 at 05:35:26 (UTC)
Goto Top
@mainbug
Bei mir hat deine Methode nicht funktioniert.

Allerdings hat sich das Problem mit dem Update für Stammzertifikate [November 2009] erledigt.
Member: mainbug
mainbug Nov 25, 2009 at 07:14:19 (UTC)
Goto Top
Moin!

Ebendt.
Die ganze Aufregung umsonst.

Grüße
Member: nic7575
nic7575 Nov 30, 2009 at 15:57:40 (UTC)
Goto Top
Zitat von @mainbug:
Moin!

Ebendt.
Die ganze Aufregung umsonst.

Grüße

???
Member: mainbug
mainbug Nov 30, 2009 at 16:13:38 (UTC)
Goto Top
Hallo nic7575!

Mit "Die ganze Aufregung umsonst." meinte ich, daß die ganze Aufregung (Anlegen und Verfolgen von Foren-Threads,
Internet-Recherche etc.) um das Update Stammzertifikate [September 2009] (Endlosinstallation) umsonst war,
da am nächsten Tag mit dem Update Stammzertifikate [November 2009] der Fehler sich selbst behoben hatte, ergo ein Tag Aufregung umsonst.

Grüße
Member: nic7575
nic7575 Dec 13, 2009 at 21:18:53 (UTC)
Goto Top
Zitat von @mainbug:
Hallo nic7575!

Mit "Die ganze Aufregung umsonst." meinte ich, daß die ganze Aufregung (Anlegen und Verfolgen von Foren-Threads,
Internet-Recherche etc.) um das Update Stammzertifikate [September 2009] (Endlosinstallation) umsonst war,
da am nächsten Tag mit dem Update Stammzertifikate [November 2009] der Fehler sich selbst behoben hatte, ergo ein Tag
Aufregung umsonst.

Grüße

Achso (-;