Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Vista explorer.exe Start

Mitglied: phat

phat (Level 1) - Jetzt verbinden

25.08.2011 um 04:30 Uhr, 3572 Aufrufe, 4 Kommentare

Hallo,


habe da mal ein delikates Problem das es zu lösen gilt ;)
(sorry schon mal für den langen Text)

Sytem: Vista Home Premium mit aktuellem Updatestatus und AdminRechten

Vorgeschichte:
Da ich des öfteren mal gern am System rumbastle (Registry/Dienste) habe ich scheinbar irgendwann mal etwas "verbastelt" mit dem Effekt das ich Ordner generell nicht mehr umbenennen/verschieben kann.

Fehlermeldung: "Die Datei bzw. der Ordner ist nicht vorhanden"

An Diensten kann es nicht liegen da der Fehler bleibt selbst wenn ich den HomePremium DefaultStatus der Dienste wiederherstelle.
Darum spekulierte ich das es an der Registry liegen muss und begann die Recherche.
Natürlich wurde ich auch fündig und fand eine reg-datei (Patch) die den Schlüssel Folderdescriptions inc. aller Unterschlüssel unter hklm\software\microsoft\windows\currentversion\explorer\ neu setzte.
Nach einem Reboot stellte ich jedoch fest dass der Fehler beim Ordner umbenennen geblieben ist und noch ein viel gravierenderer dazukam. Und bitte nicht Schimpfen aber nein ich habe vorher kein Backup von dem Schlüssel Folderdescriptions gemacht

Nun zu dem Fehler dessen Lösung mir deutlich mehr am Herzen liegt.

Ich kann den WindowsExplorer (explorer.exe) nicht mehr starten bzw. öffnet dieser nicht. Er wird zwar beim VistaStart ganz normal geladen (d.h. Desk und Taskleiste sind vorhanden) jedoch wenn ich z.B. Arbeitsplatz öffnen will oder auch die Systemsteuerung passiert nichts. Es wird kein zusätzlicher Prozess explorer.exe gestartet wie es eigentlich sein sollte. Der einzige Prozess explorer.exe hat dann nur eine höhere CPU-Auslastung.
Abhilfe: Prozess killen und neu starten.

Nach stundenlangen Tests und Suchen im Netz (sfc /scannow oder neu registrieren des explorer-dll-files im system32 etc...) fand ich dann heraus dass die Vista eigene Suche (nach Dateien/Ordnern) ganz normal startet (startet auch einen zusätzlichen Prozess explorer.exe).
Solange ich nun das Suchfenster (zusätzliche explorer.exe) offen lass kann ich auch den WindowsExplorer über den Arbeitsplatz oder die Systemsteuerung wieder ganz normal öffnen.
Weiterhin fiel mir auf dass solange ich mehr als 2 explorer.exe im Taskmanager offen hab egal ob durch die Vista-Suche oder durch das Öffnen eines WinExplorers (ermöglicht durch das Öffnen der Suche) ich auch weitere explorer.exe starten kann.

Sobald im Taskmanager wieder nur die eine explorer.exe offen ist die durch Vistastart automatisch geladen wird ist es nicht mehr möglich den Arbeitsplatz oder Systemsteuerung zu öffnen wenn ich nicht voher die Suche öffne und offen lass.

Also irgendwie muss da was in der Registry den normalen explorer.exe Start behindern was den explorer.exe Start duch die Vista Suche nicht behindert.
Umgebungsvariablen ? Registry FolderDescriptions? Ich weiss es nicht

Ich weiss es handelt sich hier um ne vielleicht wirklich harte Nuss die es zu knacken gilt und die auch einige Kenntnis der Registry voraussetzt.
Dennoch hoffe ich auf Eure erfahrene Hilfe. Und bitte nicht sowas wie "Neu Installieren" o.ä. ;)


MfG phat
Mitglied: Connor1980
25.08.2011 um 08:19 Uhr
Hi,

Es wird kein zusätzlicher Prozess explorer.exe gestartet wie es eigentlich sein sollte. Der einzige Prozess explorer.exe hat dann nur eine höhere CPU-Auslastung.
wie jetzt? wird gestartet oder nicht? Vll.t nur das Fenster außerhalb des Sichtbereiches?

Wie sieht es aus, wenn du dich mit einem anderen Benutzer bzw. im abgesicherten Modus anmeldest?

Nach stundenlangen Tests und Suchen im Netz
Dann weißt du ja jetzt wofür Systemwiederherstellungspunkte und Sicherungen dienen...

Grüße
Bitte warten ..
Mitglied: Pago159
25.08.2011 um 10:29 Uhr
Hallo Phat,

such mal nach der Explorer.exe und gib mal die Pfade an,
an welchen du die Explorer.exe gefunden hast.

Desweiteren könntest du mal einen Virenscan von einer Live CD machen und ein HiJackThis Log erstellen und hier Posten.

Dieses Verhalten kenne ich von Viren,
welche sehr hartnäckig waren (Neuinstallation vorraussetzten, da System auf keinen Fall Virenfrei zu bekommen war).

Lg Grapper
Bitte warten ..
Mitglied: phat
25.08.2011 um 15:53 Uhr
Huhu,

danke euch für die raschen Antworten

@Connor1980
Es wird kein ZUSÄTZLICHER Prozess gestartet. Ein Prozess explorer.exe ist ja normal immer da sonst hättest Du keine Taskleiste und Icons. Nix ausserhalb des Sichtbereiches.
Im abgesicherten Modus ist das gleiche Problem.

@Grapper
Ich hatte gestern schon vorm Post mal nach den Pfaden geschaut. Jetzt bin ich gerade auf Arbeit und erst um 20:00 wieder am Lappy.
Ich weiss aber noch das die explorer.exe nur in c:\windows zu finden war und noch in diesen offiziellen Servicepack?oder auch WindowsUpdateOrdnern auf c:.
HiJackThis werde ich wenn ich zu Hause bin mal laufen lassen wobei ich noch nicht an eine Infection glaube da man auch nichts diesbezüglich in den 3 RUN Schlüsseln in der Registry (HKCU; HKLM; HKU) findet.
Des Weiteren sind auch keine neuen (unbekannten) Conections auf "Listen" oder "Established" in netstat -a was ja auch bei Infectionen oft der Fall ist.
Aber werde trotzdem heut Abend erstmal Scannen.

LG phat
Bitte warten ..
Mitglied: phat
30.08.2011 um 05:18 Uhr
Hi Leute,

nach langer "Frickelei" hab ichs doch noch hinbekommen dass der WindowsExplorer sich wieder normal starten lässt

Es war keine Infektion. Hätte mich ehrlichgesagt auch gewundert weil ich die üblichen Anzeichen eigentlich kenne.
Vmtl. war MicrosoftFixit50202.msi die Lösung sowie einige manuelle Bearbeitung von SystemFiles im abgesicherten Modus.
Kann zwar nach wie vor noch keine Ordner umbenennen oder verschieben (kopieren geht) aber das Hauptproblem wäre schonmal gelöst.

MfG phat
Bitte warten ..
Ähnliche Inhalte
Debian
OPENVPN Start Error
gelöst Frage von jacco245Debian2 Kommentare

Hallo, ich habe heute meinen VServer neu installieren lassen, da dort einige Fehler aufgetreten sind. Wenn ich jetzt OPENVPN ...

Batch & Shell
Powershell start-process
gelöst Frage von Cougar77Batch & Shell4 Kommentare

Guten Morgen, ich habe da ein kleines Problem, das ich nicht ganz verstehe. Es geht um ein kleines Powershell-Skript, ...

Windows 10

Jedesmal Systemwiederherstellung beim Start

Frage von jefflorbergWindows 101 Kommentar

Hallo, ich hab nun seit einigen Tagen das Problem, dass mein PC beim erstmaligem Anschalten am Feierabend immer das ...

Microsoft Office

Excel start mit Druckereinrichtung

gelöst Frage von SebastianProMicrosoft Office1 Kommentar

Hallo, wir haben ein File welches einige Verknüpfungen mit anderen Files hat. Unabhängig von Infrastruktur, Office, Windows & Co ...

Neue Wissensbeiträge
Firewall
PfSense 2.5.0 benötigt doch kein AES-NI
Tipp von ChriBo vor 21 StundenFirewall1 Kommentar

Hallo, Wie sich einige hier erinnern werden hat Jim Thompson in diesem Aritkel beschrieben, daß ab Version 2.5.0 ein ...

Internet
Copyright-Reform: Upload-Filter
Information von Frank vor 2 TagenInternet1 Kommentar

Hallo, viele Menschen reden aktuell von Upload-Filtern. Sie reden darüber, als wären es eine Selbstverständlichkeit, das Upload-Filter den Seitenbetreibern ...

Google Android

Blokada: Tracking und Werbung unter Android unterbinden

Information von AnkhMorpork vor 2 TagenGoogle Android1 Kommentar

In Ergänzung zu meinem vorherigen Beitrag: Blokada efficiently blocks ads, tracking and malware. It saves your data plan, makes ...

Google Android
Facebooks unsichtbare Datensammlung
Information von AnkhMorpork vor 2 TagenGoogle Android2 Kommentare

Rund 30 Prozent aller Apps im Play-Store nehmen Kontakt zu Facebook auf, sobald man sie startet. So erfährt der ...

Heiß diskutierte Inhalte
Linux Userverwaltung
LogIn Versuche beschränken auf EINEN Versuch
gelöst Frage von GarroshLinux Userverwaltung23 Kommentare

Folgendes Problem Ich habe einen dezidierten Server beim Hoster gemietet, installiert ist Ubuntu 18.04.2 LTS‬ und als Webinterface Plesk. ...

Backup
Wo installiert man Veeam bei SoHo?
Frage von EDVMan27Backup14 Kommentare

Hallo, nachdem ich die neue Veeam CE bei mir getestet habe, wollte ich es einmal bei einem Kunden testen. ...

Ubuntu
Exchange Alternative auf Ubuntu
Frage von TELLOUbuntu11 Kommentare

Hi NG, wir müssen für unsere Kleine Firma (5 User) das Email / Kalendersystem neu einrichten. Ich könnte jetzt ...

Batch & Shell
Tasklist überprüfen
Frage von IleiesBatch & Shell10 Kommentare

Hallo zusammen, Wie kann ich in Batch überprüfen, ob gerade der Prozess "Skype.exe" ausgeführt wird? Also nicht so dass ...