samrein
Goto Top

Vsftp server "Control connection terminated without SSL shutdown."

Moinsen zusammen,

ich habe einen vsftp Server unter Ubuntu 20.04 im Einsatz.

Der funktionert eigentlich auch, allerdings hab ich heute zufällig folgende Meldung im Log gesehen

 "Control connection terminated without SSL shutdown."  

Sobald jemand eine Verbindung zum FTP Server aufbau wird die scheinbar wieder getrennt. Beim Arbeiten mit Filezilla merkt man das erstmal nicht, irgendwann erscheint im Client die Meldung:

Fehler:	GnuTLS-Fehler -15 in gnutls_record_recv: An unexpected TLS packet was received.
Fehler:	Konnte vom Socket nicht lesen: ECONNABORTED - Verbindung abgebrochen
Fehler:	Verbindung zum Server getrennt

Der Server ist mit TLS konfiguriert. Die entsprechenden Passiv Ports sind in der Firewall freigeschaltet.
Bei meiner Recherche im Netz hab ich immer wieder Hinweise gefunden das die Firwall der Grund für diese Meldung sein wird.

Wenn ich ein Zeitfenster finde werd ich den Server auf SFTP umstellen, vielleicht kennt trotzdem jemand eine Lösung.

pasv_address=xx.xx.xx.xx
pasv_enable=YES
pasv_max_port=40500
pasv_min_port=40000
#max_per_ip=15
allow_anon_ssl=NO
ssl_tlsv1=YES
#ssl_tlsv1_2=YES
#ssl_tlsv1_3=YES
ssl_sslv2=NO
ssl_sslv3=NO
require_ssl_reuse=NO
ssl_ciphers=HIGH

Grüße
Stefan

Content-Key: 2410672761

Url: https://administrator.de/contentid/2410672761

Printed on: May 23, 2024 at 00:05 o'clock

Mitglied: 148523
148523 Apr 05, 2022 at 08:13:24 (UTC)
Goto Top
Warum mit FTP frickeln wenn es mit SCP viel einfacher und out-of-box ohne FTP geht ?!
Ein klassischer Windows Client ist z.B. WinSCP:
https://winscp.net/eng/docs/lang:de
Member: samrein
samrein Apr 05, 2022 at 08:18:55 (UTC)
Goto Top
Zitat von @148523:

Warum mit FTP frickeln wenn es mit SCP viel einfacher und out-of-box ohne FTP geht ?!
Ein klassischer Windows Client ist z.B. WinSCP:
https://winscp.net/eng/docs/lang:de

Hi,
es handelt sich um einen bestehenden FTP Server auf dem große Datenmengen von verschieden Usern übertragen werden. Ich kann den nicht einfach umstellen, ich wollte nur der Fehlermeldung auf den Grund gehen. Ich vermute das hier eine EInstellung vermutlich inkorrekt ist.