Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Webmin Problem -> Benutzer und Kennwort nicht bekannt !

Mitglied: chillkroete

chillkroete (Level 1) - Jetzt verbinden

14.12.2004, aktualisiert 15.12.2004, 17409 Aufrufe, 3 Kommentare

Hallo,

ich habe ein kleines Problem....
Ich soll für einen Kunden einen bestehenden Linux - Server verwalten. (Mandrake 9.1)
Das root-Kennwort ist mir bekannt, allerdings ist ein Login per webmin nicht möglich.
-> Root+bekanntes Kennwort funktionieren nicht. - Account+Kennwort für webmin UNBEKANNT

Frage: Wie kann ich als root das vordefinierte webmin-konto löschen, OHNE die Konfiguration
zu beeinträchtigen ? Ich muss bei jeder Aktion ins Auto springen und zum Kunden fahren....
- administration über webmin wäre da eine große erleichterung......

Hoffe auf Antwort

Gruß Micha
Mitglied: mku
15.12.2004 um 10:19 Uhr
Wie sieht die Datei /etc/webmin/miniserv.conf aus?
Was steht in der Datei /etc/webmin/miniserv.users? Bitte nicht das PW hier posten

Mirko
Bitte warten ..
Mitglied: chillkroete
15.12.2004 um 16:47 Uhr
Wie sieht die Datei /etc/webmin/miniserv.conf
aus?
Was steht in der Datei
/etc/webmin/miniserv.users? Bitte nicht das
PW hier posten

Mirko

Hi Mirko,

die miniserv.conf sieht so aus:
---
port=10000
addtype_cgi=internal/cgi
realm=Webmin Server
logfile=/var/webmin/miniserv.log
errorlog=/var/webmin/miniserv.error
pidfile=/var/webmin/miniserv.pid
logtime=168
ppath=
ssl=0
env_WEBMIN_CONFIG=/etc/webmin
env_WEBMIN_VAR=/var/webmin
atboot=1
logout=/etc/webmin/logout-flag
listen=10000
denyfile=\.pl$
log=1
blockhost_failures=5
blockhost_time=60
syslog=1
session=1
userfile=/etc/webmin/miniserv.users
keyfile=/etc/webmin/miniserv.pem
passwd_file=/etc/shadow
passwd_uindex=0
passwd_pindex=1
preroot=mscstyle3
root=/usr/local/webmin/webmin-1.110
mimetypes=/usr/local/webmin/webmin-1.110/mime.types
---

So wie ich das sehe, sind die Benutzer in der miniserv.users definiert.
Die sieht so aus:

---
admin:hierstehtdaskennwortleiderverschlüsselt
---

Also ist der vorgegebene Benutzername admin.... Leider ist das Kennwort verschlüsselt... ;)
Gibt es in der config evtl. eine Option, mit der ich die Anmeldung als root aktiviere ??

Gruß,
Micha
Bitte warten ..
Mitglied: chillkroete
15.12.2004 um 18:05 Uhr
Ich habs !

- vorhandenen Webmin stoppen
- Webmin neu installieren
--> dabei NICHT die vorhandenen Pfade nehmen, sonden neue anlegen
- Webmin fragt dann nach dem neuen Benutzernamen + Kennwort
- FERTIG

Ist zwar alles andere als "sauber", funktioniert aber.

Gibt es vielleicht noch eine bessere Lösung ?

Danke an alle,

Micha
Bitte warten ..
Ähnliche Inhalte
LAN, WAN, Wireless
WPA2 sicher, wenn Kennwort bekannt?
Frage von stephan902LAN, WAN, Wireless12 Kommentare

Hallo, ist WPA2 für die Datenübertragung noch sicher, wenn ein Angreifer das Kennwort kennt? Es geht nicht um die ...

Ubuntu
SSL Zertifikat für Webmin
Frage von ClepToManixUbuntu2 Kommentare

Hallo, ich habe ein kleines Problem und benötige Hilfe dabei ein SSL Zertifikat (am besten von Let's Encrypt erstellt) ...

Debian
Debian Webmin - Domains anlegen
gelöst Frage von ZockervogelDebian17 Kommentare

Hallo, ich habe per Webmin 3 Domains auf meinem VServer angelegt. Bei meinem Provider habe ich die Domains auf ...

Ubuntu
Webmin Root Benutzer gelöscht
gelöst Frage von ClepToManixUbuntu4 Kommentare

Hallo, ich habe es irgendwie geschafft, mein Root User aus Webmin zu entfernen( /etc/webmin/miniserv.users) Fragt bitte nicht wie ich ...

Neue Wissensbeiträge
iOS
IOS hat nen Cursor !!!
Tipp von Criemo vor 14 MinuteniOS

Nette Funktion im iOS. iPhone-Mauszeiger aktivieren „Nichts ist nerviger, als bei einem Tippfehler zu versuchen, den iOS-Cursor an die ...

Off Topic
Avengers 4: Endgame - Erster Trailer
Information von Frank vor 2 TagenOff Topic1 Kommentar

Ich weiß es ist Off Topic, aber ich freue mich auf diesen Film und vielleicht geht es anderen hier ...

Webbrowser
Microsoft bestätigt Edge mit Chromium-Kern
Information von Frank vor 2 TagenWebbrowser5 Kommentare

Microsoft hat nun in seinem Blog bestätigt, dass die nächste Edge Version kein EdgeHTML mehr für die Darstellung benutzen ...

Sicherheit

MikroTik: Sicherheitslücke wird ausgenutzt obwohl ein Update seit langem verfügbar ist

Information von sabines vor 2 TagenSicherheit

Obwohl ein Update, dass die nun massenhaft ausgenutzte Lücke schließt, seit langem (März 2018) verfügbar ist, wird es offensichtlich ...

Heiß diskutierte Inhalte
Rechtliche Fragen
Systemhaus auf Abwegen
Frage von rocco61Rechtliche Fragen13 Kommentare

Hallo zusammen, bin derzeit ratlos bei dem folgenden Scenario: In einen Seniorenheim wurde beschlossen, die IT an eine andere ...

Exchange Server
Exchange Server 2010: Keine Eingehenden E-MAils
Frage von gabeBUExchange Server13 Kommentare

Hallo Zusammen Ich habe das kurzen auf dem Exchange 2010 Server das Problem, dass ich keine externen E-Mails mehr ...

Router & Routing
MikroTik - Routing, Bridging, Switching
gelöst Frage von Alex29Router & Routing9 Kommentare

Hallo in die Runde, als Hobby-Admin würde ich bitte mal wieder Eure Hilfe benötigen. Seit der Umstellung auf RouterOS ...

Windows Server
HP Proliant DL 380G7 ILO2 Problem und DL 580G6 OS Prolem
gelöst Frage von Home-NeulingWindows Server6 Kommentare

Hallo, ich bin neu hier, und hoffe das ich hier jetzt auch richtig Poste. Ich habe mir zuhause ein ...