Win2016 - Verhalten USOclient vs. Sconfig

emeriks
Goto Top
Hi,
wir haben hier ein paar Server mit Win2016 (LTSC), welche ein komisches Verhalten bzgl. Windows Update zeigen.

Alle Server werden vom selben internen WSUS-Server versorgt.
Alle Server sind der selben WSUS-Gruppe zugeordnet und melden sich auch mit dieser beim WSUS-Server.
Einige von diesen Server verhalten sich jedoch anders.

Verhalten
  • Update über den USOclient: Es wurden alle freigegeben Updates erfolgreich installiert. Danach werden keine zu installierenden Updates mehr angezeigt.
  • Update über den SCONFIG: Wenn man dann SCONFIG ausführt, dann werden Defender-Updates angezeigt, welche der USOclient nicht anzeigt. Wenn man diese Updates dann über SCONFIG installiert, dann werden diese auch als erfolgreich installiert gemeldet. Aber nur damit SCONFIG diese dann anschließend wieder als fehlend anzeigt. Und das in Endlosschleife. Neustart des Servers zwischendurch ändert nichts. Die Kollegen haben auch schon zwischendurch den SoftwareDistribution-Ordner bereinigt. Es ändert nichts.

Alle Monitoring-Software, welche über die gleiche API gehen wie SCONFIG, melden dann diese Updates ebenfalls als noch fehlend. (Am Rande: Das stellt unser eigentliches Problem dar.)

Hat jemand ne Idee, wo man da ansetzen kann?

E.

Content-Key: 1759587547

Url: https://administrator.de/contentid/1759587547

Ausgedruckt am: 18.05.2022 um 18:05 Uhr

Mitglied: Doskias
Doskias 25.01.2022 um 11:49:02 Uhr
Goto Top
Moin,

vielleicht suchst du an der falschen Stelle. :) face-smile Ich hatte vor etwa 6 Monaten als ich ein neues Monitoring-Tool ausgerollt habe folgende Situation. 1 Update wurde immer als fehlend angezeigt. Habe ich dann auf den entsprechenden Servern (waren auch nicht alle) geschaut, hat der Server immer nur gesagt, dass ihm ein Defender-Update fehlt. Also Update installiert, Prüfung wiederholt und wieder 1 fehlendes Update entdeckt. Gemeldet hat der Server dann wieder das exakt gleiche bzw. immer das zuletzt von MS verfügbare Defender-Update, also das was ich grade installiert hatte. Der WSUS hingegen hat gesagt, dass alle Updates erfolgreich installiert wurden.
Ich habe dann gemeinsam mit dem Hersteller die erweiterte Protokollierung aktiviert und konnte über die Abfrage den fehlenden KB ermitteln, die dazu führen, dass das Monitoring der Meinung ist, dass ein Update fehlt. Am Ende hat sich herausgestellt, dass der letzte Silverlight KB gefehlt hat. Dieser wird nicht via WSUS verteilt und ist mit dem online-Update ebenfalls nicht mehr verfügbar. Das fehlende Update führte aber kurioserweise im Windows-Update immer dazu, dass das aktuelle Defender Update als fehlend angezeigt wurde. Nachdem ich den letzte Silverlight-KB händisch installiert hab, stimmte dann auch die Anzeige wieder.
Auch bei mir betraf es nicht alle Server, sondern nur 2 von 14, allerdings waren es Server 2019 DC (Datacenter und Domaincontroller), bei denen das kuriose Verhalten auftrat.
Vielleicht hast du hier ein ähnliches Phänomen, dass das SCONFIG zwar korrekt ein fehlendes Update erkennt, aber es anschließend nicht korrekt zuordnet und immer ein "falsches" Update installiert, nicht aber das Update was wirklich fehlt.

Gruß
Doskias