chris-75
Goto Top

Windows Server 2016 Freigabenproblem

Hallo,

ich habe hier ein verzwicktes Problem mit einem virtualisierten 2016 Server (per Hyper-V) eines Kunden. Eine dateibasierte Datenbankanwendung auf den Clients bekommt regelmäßig (so zwischen 15-60 Minuten) Fehlermeldungen dass der Zugriff auf seine Datenbankdateien nicht mehr möglich ist (diese Software benötigt dauerhaften Zugriff auf diese Dateien). Die Laufwerke am Client sind ganz normal gemappt auf die Serverfreigabe. Auch der Zugriff per Explorer geht immer.
Auf dem alten 2008R2 ging das noch problemlos. Die Clients sind Windows 7 und 10 gemischt, der Fehler tritt aber nur auf den Windows 10 PCs auf.

In einer nachgestellten Testumgebung bei uns im Haus können wir das Problem nicht replizieren, da klappt alles.

Wir haben schon probiert am Server die Energieverwaltung der Netzwerkkarte auszuschalten, ebenso die A/V deinstalliert. Bringt aber leider keine Änderung. Hat der Server 2016 im Zusammenspiel mit Windows 10 vielleicht andere Timeoutvorgabe oder ähnliches? Vielleicht hat jemand Tipps für mich wo man ansetzen kann.

Lg,
Chris

Content-Key: 363748

Url: https://administrator.de/contentid/363748

Printed on: June 20, 2024 at 22:06 o'clock

Member: DerWoWusste
DerWoWusste Feb 06, 2018 at 11:33:48 (UTC)
Goto Top
Hi..

Kenne das Phänomen nicht und kann mir keinen guten Grund vorstellen.
Win7 verwendet SMB2, während Win10 mit Server 2016 versuchen wird, SMBv3 zu sprechen. Teste mal auf Win10, smbv3 (samt SMBv2) zu deaktivieren, siehe https://support.microsoft.com/en-us/help/2696547/how-to-detect-enable-an ...
Member: Chris-75
Chris-75 Feb 06, 2018 at 18:20:21 (UTC)
Goto Top
Naja das ist nicht wirklich eine Lösung weil dann diverse Dienste nicht mehr korrekt funktionieren. Trotzdem danke.
Member: DerWoWusste
DerWoWusste Feb 06, 2018 at 18:27:31 (UTC)
Goto Top
Wer spricht von Lösung... es geht am Anfang immer um Diagnose.
Member: funki-sahib
funki-sahib Feb 06, 2018 at 20:40:00 (UTC)
Goto Top
wenn die LW ueber eine GPO gemappt werden aendere doch mal die Settings fur "Aktion"

Auf Anhieb nicht ganz klar ist die Entscheidung zwischen Erstellen, Ersetzen und Aktualisieren (default):
clip_image002


Erstellen bedeutet, dass eine Zuordnung eingerichtet wird, wenn eine Freigabe \\server\share noch nicht verbunden wurde, andernfalls passiert nichts.

Ersetzen löscht eine vorhandene Verbindung mit einem Share und richtet sie gemäß den GPP-Einstellungen neu ein. Wurde jedoch eine Freigabe noch nicht verbunden, dann erzeugen die Client Side Extensions eine neue Zuordnung.

Aktualisieren verändert eine bestehende Zuordnung, indem die Einstellungen aus der GPP übernommen werden, wenn eine Verbindung für die Freigabe bereits besteht. Beispielweise würde dadurch der Laufwerksbuchstabe geändert. Existiert für ein Share keine Zuordnung, dann wird sie eingerichtet.

Hatte auch mal so ein Problem das die Clients immer wieder die Verbindung verloren haben. Von "aktualisieren" auf "ersetzen" umgestellt hat das Problem geloest.
Member: Chris-75
Chris-75 Feb 07, 2018 at 06:51:31 (UTC)
Goto Top
@funki-sahib:

ich glaube du hast da etwas Missverstanden: Nicht die Laufwerke gehen verloren sondern nur die Verbindung der Software zu den Datenbankdateien.
Member: DerWoWusste
DerWoWusste Feb 07, 2018 at 07:22:53 (UTC)
Goto Top
Wenn Du die SMB-Tests nicht machen möchtest, dann eben nicht.
Dann such nach anderen Unterschieden softwareseitig (anderer AV-Scanner?) - von sich aus ist 10 nicht instabiler was Netzwerk angeht.
Member: Chris-75
Chris-75 Feb 07, 2018 at 18:36:11 (UTC)
Goto Top
Von nicht machen möchten war nicht die rede, es ist dort beim Kunden einfach nicht möglich.
Und hättest du meinen ersten Post genau gelesen dann wüsstest du das es nicht die A/V-Software ist.
Member: DerWoWusste
DerWoWusste Feb 07, 2018 updated at 19:27:49 (UTC)
Goto Top
Also, du hast am Client auch die AV-Software deinstalliert? Das stand nicht geschrieben.
Warum es nicht möglich sein sollte zu testen, musst du mal erklären - es reicht ja, einen Testclient zu nehmen - am Server musst Du nichts verändern.