jokurt
Goto Top

"Zählenwenn" wenn benachbarte Zelle "4"

Moin face-smile
Mit der Formel
=ZÄHLENWENN(AA7:OB7;"f")  
zähle ich in der jeweiligen Zeile die Anzahl von "f". Dies funktioniert soweit auch gut, ist jedoch mit zwei Problemen beim "runterziehen" behaftet.
Zum einen wird auch für eine sonst leere Zeile eine "0" ausgegeben (siehe Screenshot) zum anderen führt das bei der Sortierung dazu, dass beim Sortieren nach Ende Datum der gesamte Bereich um rd 80 Zeilen nach unten, irgendwo in die Mitte rutscht.
Das ganze in
Wennfehler(
zu packen hat mich leider nicht weiter gebracht.

screenshot 2023-11-16 070259

Hat jemand eine Idee wie das gelöst werden kann?
Gedanke: "Zählenwenn" wenn die benachbarte Zelle eine "4" enthält, dann ggf. 0 ansonsten ""

Grüße, Uwe

Content-Key: 73310746264

Url: https://administrator.de/contentid/73310746264

Printed on: June 22, 2024 at 18:06 o'clock

Member: em-pie
em-pie Nov 16, 2023 at 06:24:42 (UTC)
Goto Top
Moin,

Sofern ich dich richtig verstanden habe:
Schaue dir mal =ZÄHLENWENNS() an. Dort kannst mehrere Kriterien angeben.
Member: Blackmann
Blackmann Nov 16, 2023 updated at 06:59:14 (UTC)
Goto Top
Zitat von @em-pie:
Schaue dir mal =ZÄHLENWENNS() an. Dort kannst mehrere Kriterien angeben.

Nö, Zählenwenn hat 2 Argumente:

Zählenwenn(Bereich, der durchsucht werden soll; Suchkriterium, was im Bereich gefunden werden soll)

=ZÄHLENWENN($A$A7:$O$B7;"f")    

(Im Code: Ob die $-Zeichen hier richtig sind kann ich aus dem Stehgreif nicht sagen!!!)

Du musst den betrachteten Bereich FESTSETZEN!
In der obersten, ersten Formelzeile setze den Cursor in das erste Argument AA7:OB7 und betätige F4 solange, bis Zeilen und Spalten mit einem $-Zeichen belegt sind.
DANN kannst Du die Formel nach unten erweitern, ohne das dein betrachteter Bereich mitwandert.

Versuchs mal.

BG BM

PS:
- aber ist Zählenwenn hier der richtige Ansatz?
- ich werde aus Deinem Screenshot nicht richtig schlau, die betrachteten Zellen fehlen...
Member: em-pie
em-pie Nov 16, 2023 updated at 07:12:27 (UTC)
Goto Top
@Blackmann

ZÄHLENWENN() != ZÄHLENWENNS()

Edit:
Mit den Dollar-Zeichen hast du aber recht. Die müssen korrekt platziert werden.
Mitglied: 8030021182
Solution 8030021182 Nov 16, 2023 updated at 07:10:19 (UTC)
Goto Top
=WENN($T7=4;ZÄHLENWENN($AA7:$OB7;"f");"")  
Gruß Katrin
Member: Blackmann
Blackmann Nov 16, 2023 at 07:17:40 (UTC)
Goto Top
Zitat von @em-pie:

@Blackmann

ZÄHLENWENN() != ZÄHLENWENNS()

Jupp ... das 'S' hatte ich übersehen ....
Member: Jokurt
Jokurt Nov 16, 2023 at 17:23:38 (UTC)
Goto Top
So hab ich*s tatsächlich dann auch gemacht face-smile
Mir fiel nur zwischendurch nochmal auf, dass ich "=4" durch ">=4" ersetzen muss, da 4 der kleinste Wert ist der drin stehen kann.
Grüße Uwe