BIOS-RAID mit 4 TB platten werden im System als nur 1802GB RAID-Verbund angezeigt - Debian

Mitglied: Gansterjo2

Gansterjo2 (Level 1) - Jetzt verbinden

31.01.2016, aktualisiert 13:05 Uhr, 1274 Aufrufe, 4 Kommentare

Liebe Forumsmitglieder

Mein Ziel: Aus einem herrkömlichen Computer soll ein NAS werden. Dabei werden die Platten über das BIOS-RAID zu einem Festplattenverbund konfiguriert (25GB als Systemdisk und 4001GB als Datendisk)

Mein System:
- Mainboard: ASUS Z170M-Plus
- CPU: i5-6500
- RAM: 16GB RAM
- Festplatten: 2x 251GB Platten [RAID 1], 2x 4001GB Platten [RAID 1] (Über BIOS-Raid konfiguriert)

Betriebssystem: Linux linux-nas 3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt20-1+deb8u3 (2016-01-17) x86_64 GNU/Linux

Also ein Debian 3.16.7


Mein Problem:
Die 4 TB Platten werden als RAID-Verbund im Betriebssystem nur als 1,8 TB angezeigt

6f78ce1530757078855c9715e1fc9938 - Klicke auf das Bild, um es zu vergrößern


Das habe ich schon Probiert:
- Den RAID-Verbund abgebrochen und im BIOS neu konfiguriert
- Den RAID-Verbund als GPT formatieren
- Den RAID-Verbund zu formatieren und anzugeben, dass es 4 TB sind
- mit GParted versucht den RAID-Verbund zu formatieren (bricht das Raid selbständig ab, da nur im Lesemodus darauf zugegriffen werden kann ?!?)

Wie kann ich den Fehler beheben?

Ich bedanke mich schon jetzt für die Antworten.
Mitglied: Lochkartenstanzer
31.01.2016, aktualisiert um 14:53 Uhr
Zitat von @Gansterjo2:

Mein Ziel: Aus einem herrkömlichen Computer soll ein NAS werden. Dabei werden die Platten über das BIOS-RAID zu einem Festplattenverbund konfiguriert (25GB als Systemdisk und 4001GB als Datendisk)

Wieso machst du das überhaupt über das BIOS? Für mich sieht das wie ein Fakeraid aus, bei dem der BIOS-Progframmierer geschlampt hat. Wenn dda nur 2 TB angezeigt stimmt irgendetwas mit der "Blockanzahl" ncht. Das Ding rechnet anscheinend Modulo 32bit.

ich würde einfach die RAIDs manuell mit mdadm zusammenbauen.

lks

Nachtrag


Boote mal mit veschiedenen live-linuxen wie z.B. knoppix, kali, ubuntu, cenOS, etc. udn ggf noch einem Windpws-PE (Installationsmedien reichen) und schau, ob die Größenangabe immer noch so falsch ist. Sollte das dre fall sein, ist es vermutlich ein BIOS-Problem. Ansonsten ein treiberproblem.

lks
Bitte warten ..
Mitglied: Gansterjo2
31.01.2016 um 15:48 Uhr
Vielen Dank für diese Tipps.

Ich wollte ein RAID über das BIOS erstellen, weil ich dachte, dass dies eine saubere Lösung wäre. Das booten über mehrere Systeme (und anschauen des RAID-Laufwerks) werde ich morgen machen, da ich im Geschäft einen Multiboot USB-Stick erstellen muss und diesen gleich ausprobieren könnte. Testen sollte ich das eigentlich sowieso.

Falls es ein Treiberproblem wäre könnte ich sowieso nicht viel dagegen unternehmen, da ASUS keine Treiber für Linux bereitstellt. Ich müsste dann einfach, wie du es bereits geschrieben hast, ein RAID mit mdadm erstellen.

Morogenabend werde ich Rückmeldung geben.

Liebe Grüsse aus der Schweiz :-) face-smile
Bitte warten ..
Mitglied: Gansterjo2
03.02.2016 um 19:42 Uhr
Hallo Zusammen

So ich konnte nun testen, ob ein Fehler im RAID liegt.

Ich habe von einer Windows 8.1 CD gebootet. Windows zeigt als möglichkeit eine normale 4 TB platte (also das RAID). Es ist also davon auszugehen, dass entweder der Treiber nicht stimmt oder Linux nicht mit so grossen Festplatten ohne zusätzliche Konfiguration umgehen kann...

Was soll ich als nächstes tun?

Freundliche Grüsse

Gansterjo2
Bitte warten ..
Mitglied: Gansterjo2
08.02.2016 um 09:29 Uhr
Hallo Zusammen

Das Problem ist nun abgeschlossen, bin auf Widnows Server 2012 umgestiegen.

Freundliche Grüsse

Gansterjo2
Bitte warten ..
Heiß diskutierte Inhalte
Windows 10
Wie komme ich von WIN10pro auf Windows 10 Enterprise
LegofrauVor 18 StundenFrageWindows 1058 Kommentare

Guten Tag, Wie komme ich auf legale weiße von Windows 10 professionell auf Windows 10 Enterprise? Ich habe viele widersprüchliche Antworten gefunden. Also muss ...

Off Topic
Bewerbungsfragen FISI
IT-ProVor 1 TagFrageOff Topic15 Kommentare

Hi, Ja, der Titel mag etwas komisch klingen. Aber das wird sich in den folgenden Zeilen hoffentlich lösen. Ich habe mich hier gerade durch ...

Linux
Bootable Win7 stick from Raspberry commandline
winlinVor 1 TagFrageLinux12 Kommentare

Hallo zusammen Ich benötige einen bootfähigen Win7 USB Stick. Muss diesen über meine Raspberry erstellen. Was ist die beste Variante habe schon ein paar ...

Microsoft
Client verhält sich im Home Office wie Gerät vor 10 Jahren
Finchen961988Vor 19 StundenFrageMicrosoft10 Kommentare

Hallo liebes Forum, ich mal wieder und ich habe riesen ??? über den Kopf! Das Verhalten zu beschreiben wird nicht ganz einfach, da ich ...

Off Topic
Verwaltungskosten von Passwörtern
IT-ProVor 1 TagFrageOff Topic5 Kommentare

Guten Morgen liebe Menschen. Ich benötigte für die Erstellung meiner IHK-Projektarbeit ein paar Informationen zu den Kosten von Passwörtern. Ich habe aus folgendem Beitrag ...

Windows Server
Remotedesktopgateway Zertifikat - Zugriff überall
lukas0209Vor 1 TagFrageWindows Server9 Kommentare

Guten Abend zusammen, ich habe eine Frage bzgl. des Windows Remotedesktopgateways. Wir nutzen einen Windows Server 2016 Essentials, dieser bringt von Haus aus die ...

Exchange Server
Mails fehlen im Exchange-Server 2016
it-basixsVor 1 TagFrageExchange Server4 Kommentare

Moin, moin zusammen. Ich habe leider ein Problem mit einem Exchange Server 2016 CU20 inkl. aller Patches. Laut Ereignisanzeige von POPcon, werden die Mails ...

Internet
Starlink SpaceX
chrisittVor 1 TagFrageInternet4 Kommentare

Hallo, ich suche dringend Informationen über Starlink, da wir planen Starlink in einem Unternehmen einzusetzen. Kennt einer von euch eine gute Informationsquelle oder hat ...