USB Wechsellaufwerk wird nach WinXP-Reparatur nicht angezeigt

Kunibert
Hallo zusammen!
Ich hatte an meinem Rechner (WinXP SP2) immer ein Kartenlesegerät angeschlossen und USB-Sticks in Verwendung - einwandfrei!
Nun hatte ich eine kleines Problem mit meinem Rechner (hat nichts mit dem hier zu tun) und musste das Windows-Setup durchführen um den Rechner zu reparieren (nicht Wiederherstellungskonsole). Nach der Reparatur-Installation funktionierte alles nach wie vor, ausser das keine Wechsellaufwerke angezeigt werden.
Ich habe schon alles deinstalliert was USB betrifft, auch über die Umgebungsvariable "DEVMGR_SHOW_DETAILS 1" und "DEVMGR_SHOW_NONPRESENT_DEVICES 1", sodass man auch die versteckten, deaktivierten Geräte deinstallieren kann. Des Weiteren habe ich über "SFC /scannow" die Systemdateien gecheckt. Mit einem Registry-Tool habe ich auch schon die Registry von fehlerhaften Einträgen befreit. Den Tipp mit der manuellen Laufwerksbuchstabenverteilung in der Computerverwaltung funktioniert leider auch nicht.
Und jetzt kommt der Knüller... ich habe mein WinXP privat ebenfalls repariert, weil sich mein RAID unglücklich verabschiedet hat und ich die Mirror-Platten nicht mehr normal ans laufen bekommen habe. Wie auf der Arbeit auch, alles klappt einwandfrei, nur die USB-Datenträger nicht, obwohl sie in beiden Fällen korrekt erkannt und installiert werden.

Für Vorschläge schonmal vorab besten Dank!

Gruss, Kunibert

Content-Key: 33421

Url: https://administrator.de/contentid/33421

Ausgedruckt am: 27.01.2022 um 12:01 Uhr

Mitglied: Lars1082
Lars1082 01.06.2006 um 09:42:59 Uhr
Goto Top
Hallo Kunibert

es könnte sein das deinem System eine bzw zwei dateien fehlen oder es keine rechte zu schreiben hat!

Such mal unter den Pfaden: C:\winnt\inf\ die datei usbstor.inf
C:\winnt\system32\driver\ die datei USBSTOR.SYS

Sieh unter den sicherheitseinstellungen mal nach ob das system bzw der Nutzer Schreibrechte besitzt.

Ich Sperre so meine USB-Ports das Nutzer keine Sticks etc verwenden können alles andere z.B. Drucker, Maus etc sollten weiterhin funktionieren!

Hoffe das hilft

Gruß Lars
Mitglied: Kunibert
Kunibert 01.06.2006 um 10:09:29 Uhr
Goto Top
Danke für den Vorschlag... ist aber leider nicht die Ursache. SYSTEM und Benutzer (sprich ich) haben Vollzugriff. Die beiden Dateien sind auch vorhanden (den Trick verwende ich hier übrigens auch im Netzwerk, klappt gut und ist simpel). Nun, die Dateien sind klar vorhanden, weil installiert werden der Stick und das Kartenlesegerät ordnungsgemäß. Ich könnte sie ja über "Hardware sicher entfernen" anhalten. Komisch ist aber auch, das dort dann nur "USB-Massenspeichergerät entfernen" steht und nicht so wie sonst 'ne andere Beschreibung mit Laufwerksbuchstaben.
Mitglied: Lars1082
Lars1082 01.06.2006 um 10:35:07 Uhr
Goto Top
Tja dann bin ich auch fast etwas Radlos!
Guck mal ins Bios vielleicht hat sich dort was umgestellt. Ich hab da eine Funktion für Massenspeichermedien!

Sonst fällt mir dazu auch nix mehr ein, Sorry!

Gruß Lars
Mitglied: Kunibert
Kunibert 08.06.2006 um 13:01:53 Uhr
Goto Top
Hallo!
Ich habe neue Erkenntnisse bez. des Problems:
Irgendwie habe ich es geschafft, jetzt dem USB-Stick einen Laufwerksbuchstaben manuell über die Computerverwaltung zu vergeben, was ja erst nicht so ganz klappte. Allerdings wird der Buchstabe (B:) face-smile jedesmal wieder verworfen, wenn ich den Stick ab- u. wieder anklemme oder den Rechner neu starte. Des Weiteren ist mir aufgefallen dass das Laufwerk nicht im Win-Explorer angezeigt wird und ich nur über den UNC-Pfad daran komme und dann aber auch nur, wenn ich die administravie Freigabe B$ verwende. Kurios ist auch, dass das Laufwerk B im "Mini-Explorer" angezeigt wird - heißt wenn ich z.B. auf "Officedokument öffnen" gehe, nicht aber im normalen Windows-Explorer und ja, ich habe F5 gedrückt und ihn öffters geschlossen und wieder geöffnet...

Nun könnte ich jedesmal wenn ich den Stick anklemme, einen Laufwerksbuchstaben vergeben und über den UNC-Pfad drauf zugreifen, aber das ist mir etwas zu mühselig jedesmal. Vielleicht jetzt jemand 'ne Idee??? Bitte!

Vielen Dank im Voraus!
Gruß, Kunibert
Mitglied: 23442
23442 05.09.2006 um 22:06:44 Uhr
Goto Top
Hallo Kunibert!

Hab das selbe Problem auf meinem P4 Shuttle-XPC. Nach bzw. trotz einer Windows Reperatur werden keine USB-Sticks/Digicams/Festplatten/Kartenleser mehr als Laufwerk angezeigt. Das jeweilige USB-Gerät wird ordnungsgemäß installiert, aber danach kein Wechsellaufwerk dafür vergeben.
Komischerweise funktioniert noch eine einzige meiner externen Festplatten(vielleicht Dank einer Autorun.inf die das ICON des LW ändert und WinXP wie eine CD-LW behandelt? ;-) face-wink )

Lasse gerade im Hintergrund "SFC /scannow" drüber laufen, mal schaun ob die Windows-Orginal Dateien helfen.

Kann mir nicht vorstellen, dass es hardwarebedingt ist, weil alle anderen USB Geräte funktionieren.

Reg-Cleaner, besonders "1 Klick Wartung" von Tuneup Utilities verwende ich häufig. Hatte aber noch nie ein Problem aufgrund eines gelöschten wichtigen Schlüssels ...


lg
x - den chicken account habe ich mir schnell auf bugmenot.com geholt :-) face-smile

PS.: Ich installier mir wohl besser schnell Linux, Ubuntu/Suse funktioniert wunderbar auf meinem Laptop ... dann klappts auch mit den USB-Wechseldatenträgern!
Mitglied: Kunibert
Kunibert 12.10.2006 um 16:20:47 Uhr
Goto Top
Na, ich hatte einfach den PC neu installiert und von dem anderen Rechner, wo ich das Prob. auch hatte, hatte ich noch ein recht junges Image.

So long!
Kunibert
Heiß diskutierte Beiträge
question
Marode Netzwerk-Infrastruktur im kleinen Unternehmen - wo anfangen?StephanXVor 1 TagFrageNetzwerkmanagement48 Kommentare

Guten Abend zusammen, es geht um einen kleinen Betrieb (Kfz-Werkstatt) mit einer recht wirren und planlosen Netzwerkstruktur und Datensicherung, welche ich so langsam mal richten ...

general
Generator für endlose, kostenlose Energie? Ein gut gemachter Schwindel? gelöst beidermachtvongreyscullVor 23 StundenAllgemeinOff Topic25 Kommentare

Mahlzeit Kollegen! Wenn ich mich strikt an physikalische Grundsätze halte, müsste ich sagen: Nein. Es ist nicht möglich. Ich stieß aber im Internet auf ein ...

question
Fritzbox mir Batterie betreibenberndsilberoVor 1 TagFrageHardware11 Kommentare

Hallo, welche Akkus bzw. Batterien oder Möglichkeiten gibt es wenn ich die Fritzbox mobil nutzen möchte, da wo kein Stromnetz vefügbar ist. Der Akku darf ...

question
Tips für Raid-Controller für bis zu 24 Platten?coltseaversVor 1 TagFrageSAN, NAS, DAS7 Kommentare

Hallo zusammen, ich möchte mir ein Datengrab für bis zu 24 HDDs 3,5 Zoll basteln, welches unter Windows Server laufen soll. Rack-Gehäuse mit entsprechend vielen ...

question
APC USV - Zugriff über die Konsole gelöst newit1Vor 1 TagFrageSicherheit10 Kommentare

Hallo zusammen, ich habe eine APC Smart UPS 1000 (RackMount) im Einsatz und komme nicht auf die Konsole. Die eingebaute "Network Management Card 1" zieht ...

question
NAS-Platz aufbohren, ohne TEMP-Platte?winackerVor 1 TagFrageSAN, NAS, DAS6 Kommentare

Hallo, ich muß ein 4-Bay QNAP-NAS, bestückt mit 4 x 4TB in RAID5, aufrüsten. Da sind heute ca. 10TB Daten drauf. Ziel ist 3 x ...

general
FYI: In zwei Tagen zieht LetsEncrypt zahlreiche Zertifikate zurückipzipzapVor 15 StundenAllgemeinVerschlüsselung & Zertifikate1 Kommentar

Hallo, zur Info, falls bei Euch übermorgen was knallt: Ruhiges Wochenende! ipzipzap ...

question
"minimale" Cloud-Telefonanlage gesuchtDatenreiseVor 21 StundenFrageVoice over IP7 Kommentare

Hallo zusammen, ich bin auf der Suche nach einer Cloud-Telefonanlage, die sich für einen einzelnen Arbeitsplatz eignet und wollte hier fragen, ob jemand dazu einen ...