Dieser Beitrag ist schon älter. Bitte vergewissern Sie sich, dass die Rahmenbedingungen oder der enthaltene Lösungsvorschlag noch dem aktuellen Stand der Technik entspricht.

Anwendung im Netzwerk wieder i.l.d. Tages immer langsamer

Mitglied: Ati
Guten Morgen,
ich bin neu hier und weiß nicht ob mein Problem hier überhaupt richtig plaziert ist. Es handelt sich um folgendes. Ich habe eine Access-Anwendung für meine Firma geschrieben und diese in Frontend und Backend aufgeteilt. Das Frontend wird lokal auf dem Client ausgeführt das Backend liegt auf dem Server. Wenn ich jetzt morgens diese Anwendung starte und ein spezielles Formular öffnen will, dauert es so 2-3 Sekunden. Je später am Tag ich nun diese Anwendung starte um so länger dauert das öffnen (bis zu 40 Sek.). Erst dachte ich es liegt daran das tagsüber ja alle User im Netzwerk rumfuchteln, als ich aber mal abends hier alleine war und es nochmal testete dauerte es trotzdem Ewigkeiten. Ich vermute jetzt mal das tagsüber irgendwas auf dem Server "aufläuft" was die Performance so stark beeinflußt.
Hatte hier vielleicht jemand mal ein ähnliches Problem, oder kann mir jemand einen Tip geben was wir mal untersuchen sollten????

Danke im voraus
Ati

P.S. bei uns kommt ein Windows 2000 Server zum Einsatz

Content-Key: 6718

Url: https://administrator.de/contentid/6718

Ausgedruckt am: 18.06.2021 um 08:06 Uhr

Mitglied: phpchris
phpchris am 10.02.2005
Moin moin,

also, was ich checken würde, ist ob auf dem Server, wo dein Backend läuft, ein OnAccess-Virenscanner läuft.
Wenn ja, schließe das Verzeichnis aus, in dem sich das Backend befindet.

Weiter solltest du mal im Netzwerk checklen, ob bei den Clients eine Funktion "Netzlaufwerke schützen" oder so ähnlich eingeschaltet ist.

Das war die Ursache für Netzwerk-Ausbremsung bei den meisten meiner Kunden.
Mitglied: Ati
Ati am 10.02.2005
Danke für Deine Antwort. Das mit dem Scanner geb ich zwar mal weiter aber ich mein nicht das sowas bei uns läuft.
Das mit dem "Netzlaufwerke schützen" kenn ich gar nicht. Wo befindet sich die Option und was mich interessieren würde ist was die Funktion genau bewirkt.

Ati
Mitglied: phpchris
phpchris am 10.02.2005
Einige Virenscaner haben ein "Feature" mit dem Netzlaufwerke, also Freigaben auf anderen Servern, die al Netzlaufwerke verbunden sind, automatisch mitgescannt werden, sobald sich dort eine Datei verändert.
Das hat zur Folge, dass sich mehrere User (bzw. deren Virenscanner) gleichzeitig auf eine Datei stürzen, sobald diese sich verändert.
Ein Virenscanner sperrt den zugriff für andere Programme, während er eine Datei durchsucht.
So kann es kommen, dass die Datei erst nach so einigen Sekunden endgültig für eine Anwendung freigegeben wird.
Mitglied: Ati
Ati am 10.02.2005
Sorry da war ich auf dem Holzweg. Das mit dem OnAccess-Scanner muß ich doch nochmal hinterfragen, sieht so aus als ob es einer ist (Kaspersky Antii-Virus 3.5.133.0). Die Einstellung auf den Clients sind meines Wissens alle gleich und da habe ich mal meine Einstellung kontrolliert und dort sind Netzlaufwerke ausgeklammert. Es erscheint mir auch seltsam das es daran liegen soll, da ja auch spät abends wenn keiner mehr hier ist die Anwendung so langsam startet und da sind ja sämtliche Clients ausgeschaltet. Wenn ich hier einen Denkfehler habe bitte aufklären.

Ati
Mitglied: phpchris
phpchris am 10.02.2005
Nein, einen Denkfehler hast du nicht.
Ich dachte bloß, da du ja schreibst "i.L.d.Tages", dass tagsüber, also wenn mehrere Leute die Rechner anhaben, die Anwendung langsam wird.

Wenn der Virenscanner auch auf dem Server läuft, versuch mal diesn Pfad, wo dein Programm läuft aus dem On-Access-Scanner auszuschließen.
Mitglied: gemini
gemini am 10.02.2005
Der Rest des Netzwerkes läuft normal?
Ist die Datenbank schon mal stabil gelaufen?

Die Datenbank ist also den ganzen Tag offen und viele User machen viele Transaktionen.
Wann wird sie denn komprimiert?

Anderer Ansatz: Besteht die Möglichkeit, dass durch einen Programmierfehler irgendwelche Speicher vollaufen bzw. Variablen nicht geleert werden etc. pp?
Mitglied: Ati
Ati am 11.02.2005
"Der Rest des Netzwerkes läuft normal?"
Naja was man so normal nennt. Spaß beiseite eigentlich läuft der Rest normal.

"Ist die Datenbank schon mal stabil gelaufen?"
Das ist es ja.... morgens läuft sie normal. D.h. für mich auch stabil.

"Die Datenbank ist also den ganzen Tag offen und viele User machen viele Transaktionen."
Eben nicht. Es handelt sich hierbei um eine hausgemachte Information über unsere Logistik! D.h. es werden eigentlich nur Daten abgefragt und nicht eingegeben.

"Wann wird sie denn komprimiert?"
Das wird speziell gar nicht gemacht, da es sich hierbei um ein Fe und mehrere Access-DB´s als Be handelt. Könnte aber mal ein Ansatz sein.

"Anderer Ansatz: Besteht die Möglichkeit, dass durch einen Programmierfehler irgendwelche Speicher vollaufen bzw. Variablen nicht geleert werden etc. pp?"
Einen Programmierfehler habe ich als erstes vermutet, paßt aber nicht mit der Tatsache zusammen das morgens alles normal läuft. Zum Thema Variablen kann ich nur sagen das ich in dieser Anwendung kaum mit Variablen arbeite, da ja nur Daten angezeigt (Formulare+Unterformulare) werden. Ich habe zwar einige optimierungen vorgenommen (z.B. die dartsellung eines Unterformulares als Snapshot statt Dynaset) was auch leicht was gebracht hat, aber wie gesagt der Knaller ist das irgendwie alles noch nicht.
Leider seh ich hier nicht die Möglichkeiten was hochzuladen, sonst würd ich Euch mal meine geistige Erfindung zur Verfügung stellen, da ich ja bestimmt nicht frei von Fehlern bin.

Ati
Mitglied: Ati
Ati am 11.02.2005
Was eventuell wichtiges habe ich noch vergessen. Und zwar wird unser Server jeden morgen um 5.oo Uhr neu gestartet, was für mich einIndiz ist das es am Server liegen könnte. Weshalb sollte sonst nach einem Neustart alles wieder normal funktionieren???

Ati
Mitglied: gemini
gemini am 11.02.2005
Das sehe ich auch so.

Kannst du den Server einmal nicht durchstarten, wie sich die DB dann verhält.
Evtl. gibt auch der Systemmonitor etwas her.

Den Virenscanner würd ich jetzt mal ausschließen.
Da wäre die DB imho den ganzen Tag langsam; der Scanner prüft ja morgens ganuaso wie abends.
Mitglied: Ati
Ati am 11.02.2005
So jetzt wird es kompliziert. Also unser Warenwirtschaftssystem läuft auf einer Alpha-Anlage unter OpenVMS. Mit einer speziellen Software (Pathworks) habe wir die Möglichkeit über den Explorer auf diverse Verzeichnisse der Alpha-Anlage zuzugreifen (Netzlaufwerk). Jetzt ist es aber passiert, das unser Server Abends bzw. Nachts aus unerfindlichen Gründen diese Verbindung verliert. Nach Tagen des Suchens und Testens haben wir uns für die "Kreuzknobelschaltung" mit dem zeitgesteuerten Neustart ausgedacht. Deswegen kann ich den Neustart auch nicht auslassen.

Ati
Heiß diskutierte Beiträge
Administrator.de Feedback
Neue Administrator Version
FrankVor 1 TagInformationAdministrator.de Feedback77 Kommentare

Hallo User, heute Nacht haben wir Release 5.9 unserer Seite veröffentlicht. Diese bringt ein paar grundlegende Neuerungen für unsere User mit sich: Die Suche nach ...

Windows 10
Windows 11 Vorabversion aufgetaucht
NixVerstehenVor 1 TagTippWindows 1024 Kommentare

Auf Deskmodder.de ist ein Bericht über eine im Netz aufgetauchte Vorabversion von Windows 11 aufgetaucht. Der Bericht: Deskmodder.de - Windows 11 Vorabversion Bericht Download der ...

Internet Domänen
Domaine Join via VPN
SpryceeVor 1 TagFrageInternet Domänen4 Kommentare

Hallo, ich bin gerade dabei die namen einiger rechner umzubenennen dabei verwende ich ein Powershell script welches auf dem rechner ausgeführt wird. Jetzt gibt es ...

Hardware
PC und Monitor über Entfernung verbinden
gelöst ben1300Vor 1 TagFrageHardware14 Kommentare

Guten Morgen :) folgende IST Situation: Ich habe einen Gaming PC, welchen meine Freundin gerne nutzt, z.B. für das "legendäre" Spiel Sims 4 ;) Normalerweise ...

Windows Server
Durchgeschliffener Drucker funktioniert auf dem Server nicht
Disse1987Vor 1 TagFrageWindows Server12 Kommentare

Hallo zusammen, wieder einmal muss ich mich an euch wenden da wir mit unserem Latein am Ende sind. Seid ein paar Tagen hat eine Kundin ...

Netzwerke
Internetprobleme seit Serverinstallation
beepboopVor 17 StundenFrageNetzwerke14 Kommentare

Guten Tag zusammen Bei einem Kunden habe ich ein sehr merkwürdiges Problem. Wir haben vor zwei Wochen einen Server beim Kunden installiert. Vorher waren nur ...

Windows Server
Auf Active Directory Benutzer und Computer von Windows 10 zugreifen
RealThoreVor 1 TagFrageWindows Server9 Kommentare

Hallo zusammen, da wir in der Abteilung (10 Leute) uns regelmäßig um die RDP Sessions auf unseren DCs (2012 R2) prügeln, wolle ich mal nachfragen, ...

Sonstige Systeme
Womit ist eine Nextcloud am Besten zu betreiben. Linux-PC oder RaspiPI
gelöst frosch2Vor 19 StundenFrageSonstige Systeme15 Kommentare

Hallo, wieder einmal möchte ich eure Meinungen. Es soll eine nextcloud in einer produktiven Umgebung eingesetzt werden. Ca. 6 Aussendienst- und 7 Innendienstmitarbeiter. Zusammen 13 ...