erikro
Goto Top

Apticron sendet keine Mails

Moin,

ich habe hier zwei nahezu identische Server unter Debian:

Linux servername 5.10.0-21-amd64 #1 SMP Debian 5.10.162-1 (2023-01-21) x86_64 GNU/Linux

Bei beiden habe ich apticron in der Version 1.2.5 installiert und identisch konfiguriert. Bei beiden ist anacron nicht installiert. Bei beiden ist in cron.daily ein entsprechendes Skript vorhanden:

root@servername:/etc/cron.daily# ls -l
insgesamt 32
-rwxr-xr-x 1 root root 1478 10. Jun 2021  apt-compat
-rwxr-xr-x 1 root root  120 19. Jan 15:12 apticron
-rwxr-xr-x 1 root root 1298  1. Sep 04:03 dpkg
-rwxr-xr-x 1 root root 4722  4. Mai 2021  exim4-base
-rwxr-xr-x 1 root root  377 30. Jan 2022  logrotate
-rwxr-xr-x 1 root root 1186 25. Jan 10:51 man-db
-rwxr-xr-x 1 root root 1007 19. Jan 2021  rkhunter

Inhalt des Skripts:

13 * * * * root if test -x /usr/sbin/apticron; then /usr/sbin/apticron --cron; else true; fi

Bei beiden ist postfix zum Versenden der Mails installiert. Auch hier ist die Installation identisch. Das Versenden der Testmails funktioniert auf beiden Servern. Der einzige Unterschied zwischen den beiden Servern ist der Dienst, der angeboten wird. Auf dem einen, der funktioniert, läuft Apache für eine lokale Webanwendung (wiki). Auf dem anderen läuft der Anydesk on-premise.

Von einem Server bekomme ich die Mails von apticron vom anderen nicht. Der rkhunter versendet die Mails auch auf dem betroffenen Server automatisch. Führe ich auf dem Server, der keine Mails sendet, apticron händisch aus, wird die Mail versendet. Ich habe jetzt so ziemlich alles, was mir einfällt und was ich so im Netz gefunden habe, durchgesehen. Ich kann keine Fehler finden.

Hier noch die apticron.conf aus /etc/apticron (ohne Kommentare):

EMAIL="me@acme.com"  

DIFF_ONLY="0"  

LISTCHANGES_PROFILE=""  

ALL_FQDNS="0"  

SYSTEM=$(/bin/hostname -f)

IPADDRESSNUM="1"  

IPADDRESSES=""  

NOTIFY_HOLDS="1"  

NOTIFY_NEW="1"  

# Aktiviert zu Testzwecken
NOTIFY_NO_UPDATES="1"  

GPG_ENCRYPT="0"  

Ich bitte Euch um Ideen, woran das noch liegen könnte.

<edit>Beide sind im selben Netz.</edit>

Liebe Grüße

Erik

Content-Key: 5648335355

Url: https://administrator.de/contentid/5648335355

Printed on: July 19, 2024 at 17:07 o'clock

Member: SlainteMhath
SlainteMhath Jan 26, 2023 at 09:07:52 (UTC)
Goto Top
Moin,

schonmal eine Blick in die Logfiles geworfen? Irgendwo wird das (nicht-)Versenden der Mails ja Spuren und im besten Fell sogar Fehlermeldungen hinterlassen

lg,
Slainte
Member: erikro
erikro Jan 26, 2023 at 09:22:44 (UTC)
Goto Top
Zitat von @SlainteMhath:

Moin,

schonmal eine Blick in die Logfiles geworfen? Irgendwo wird das (nicht-)Versenden der Mails ja Spuren und im besten Fell sogar Fehlermeldungen hinterlassen

lg,
Slainte

Ja klar.
Server, der funktioniert:
Im mail.log steht, dass die Mail verschickt wurde. Im syslog steht, dass der cronjob ausgeführt wurde.

Server, der nicht funktioniert:
Im mail.log steht nichts. Im syslog steht, dass der cronjob ausgeführt wurde.

Man vergisst bei der Fehlerbeschreibung immer irgendwas. face-wink