Bestimmten Browser als Standard über GPO setzen

Mitglied: LaBomba

LaBomba (Level 1) - Jetzt verbinden

04.05.2021 um 09:40 Uhr, 316 Aufrufe, 7 Kommentare

Hallo,

ich habe nun schon einige Seiten im Netz und auch hier im Forum durch, leider konnte ich mein Problem noch nicht lösen.
Ich möchte bei unseren Rechnern ( alles Windows 10 Pro. ) einen bestimmten Browser als Default setzen. Im Netz findet
man viele Anleitungen, es geht aber meist immer auf das gleiche Vorgehen raus.

Unser Netzwerk besteht aus Windows Server 2016 als Domänencontrollern, die Funktionsebene befindet sich jedoch noch auf Windows Server 2008.
Upgrade ist in Planung, dafür müssen jedoch noch ein paar Altlasten entsorgt werden.
Könnte dies eventuell schon das Problem sein, kann die GPO eventuell erst mit einer höheren Funktionsebene korrekt angewendet werden ?

zu meinem Vorgehen:

- Testclient installliert mit Windows 10, als Benutzer mit Administrationsrechten angemeldet und den Browser auf den gewünschten geändert.
- Export der xml Datei mit " Dism /Online /Export-DefaultAppAssociations:\\Server\NETLOGON\AppAssoc.XML

dies funktioniert. Danach habe ich die xml Datei angepasst und alle unnötigen Einträge entfernt.

- GPO erstellt und unter Computerkonfiguration\Richtlinien\Administrative Vorlagen\Windows-Komponenten\Datei-Explorer\Konfigurationsdatei für Standardzuordnungen festlegen den Pfad zur "AppAssoc.xml " eingetragen. GPO aktiviert und auf eine Test OU verknüpft. In der Test OU liegen drei Testrechner.

Führe ich nun ein gpupdate / force durch, wird die GPO verarbeitet aber der Browser wird nicht gesetzt. Habe zum testen auch einmal einen Ordner über die gleiche GPO anlegen lassen, dies funktioniert. Die GPO wird angewendet, aber der Browser wird einfach nicht gesetzt.

In diversen Beiträgen habe ich teilweise gelesen, das die GPO nur bei neuen Benutzern funktioniert, Verweise auf Lösungen zu diesem Problem waren dann aber wieder Verweise auf die gleichen Anleitungen die ich durchgearbeitet habe.

Der Einsatz von frei verfügbaren Scripten oder Hilfsprogrammen ist nicht zulässig.

Ich hoffe hier im Forum kann mir jemand weiterhelfen. Den Wunsch Standardprogramme über eine GPO zu setzen, sollte ja nichts ausergewöhnliches sein.

Gruß Sven
Mitglied: newit1
04.05.2021, aktualisiert um 09:59 Uhr
Moin,

Danach habe ich die xml Datei angepasst und alle unnötigen Einträge entfernt.
Was hast du denn entfernt und warum?

Gruß
newit1
Bitte warten ..
Mitglied: Tezzla
04.05.2021 um 10:01 Uhr
War das nicht so, dass die Standardprogramme ein Usersetting sind?

VG
Bitte warten ..
Mitglied: newit1
04.05.2021, aktualisiert um 10:16 Uhr
@Tezzla

War das nicht so, dass die Standardprogramme ein Usersetting sind?
Hatte ich auch so im Kopf.
Bitte warten ..
Mitglied: LaBomba
04.05.2021 um 11:03 Uhr
Ich habe die Einträge für PDF, Bilder, Mediadateien entfernt. Warum ? ich möchte ja nur den Browser setzen. Eventuelle bereits getroffene Einstellungen sollen ja nicht verändert werden. Ich möchte nur die Browser Einstellungen überschreiben, alles andere darf/soll gerne so bleiben wie es aktuell am Client eingestellt ist.
Bitte warten ..
Mitglied: LaBomba
04.05.2021 um 11:05 Uhr
In allen Anleitungen die man so im Netz findet, sind es immer Computer Settings.
Bitte warten ..
Mitglied: ukulele-7
04.05.2021, aktualisiert um 11:29 Uhr
Tatsächlich wurden glaube ich aus Sicherheitsgründen diverse Möglichkeiten das zu setzen von Microsoft abgeschafft so das vor allem Software bei der Installation nicht mehr die Standard-Programme ungefragt abändern kann. Das hat sich sicherlich auch auf GPOs ausgewirkt.

Ich habe den Edge neulich als Standard gesetzt und der hat eine eigene GPO, vermutlich nicht ganz ohne Grund. Vielleicht auch der Browser deiner Qual?

Natürlich würden sich die Einstellungen auch auf Computer-Ebene setzen lassen aber die werden natürlich nicht die Einstellungen eines bereits existierenden Nutzers überschreiben, also Users-GPO klingt in jedem Fall richtig.
Bitte warten ..
Mitglied: LaBomba
04.05.2021 um 12:04 Uhr
Tatsächlich wurden glaube ich aus Sicherheitsgründen diverse Möglichkeiten das zu setzen von Microsoft abgeschafft so das vor allem Software bei der Installation nicht mehr die Standard-Programme ungefragt abändern kann. Das hat sich sicherlich auch auf GPOs ausgewirkt.
heißt die Lösung über GPO funktioniert eventuell gar nicht mehr. Gibt es denn niemanden hier im Forum der diese Lösung erfolgreich angewendet hat.

Ich habe den Edge neulich als Standard gesetzt und der hat eine eigene GPO, vermutlich nicht ganz ohne Grund. Vielleicht auch der Browser deiner Qual?

Funktioniert leider nicht da " unser " Standard Browser sozusagen eine .exe Datei in einer Isolierten Browserumgebung ist die selbstständig entscheiden kann ob ein aufgerufener Link intern oder extern ist und dann den korrekten Browser aufruft.

Natürlich würden sich die Einstellungen auch auf Computer-Ebene setzen lassen aber die werden natürlich nicht die Einstellungen eines bereits existierenden Nutzers überschreiben, also Users-GPO klingt in jedem Fall richtig.

liegen die Einstellungen für die " Konfigurationdatei ..... " dann ganz wo anders ? im gleichen Pfad nur unter USER anstelle von Benutzer finde ich den Punkt der Konfigurationsdatei . . . überhaupt nicht.
Bitte warten ..
Heiß diskutierte Inhalte
Windows Server
Lizenzen für Virtualisierungshost
TakworianVor 1 TagFrageWindows Server16 Kommentare

Hallo, ich werde demnächst einen HA-Cluster aus 3 x HP DL580 in Betrieb nehmen. Der Cluster wird unter Proxmox betrieben und es sollen diverse ...

Netzwerke
Erfahrungen mit HPE Aruba Switches (Aruba OS)
sixofeightVor 11 StundenAllgemeinNetzwerke11 Kommentare

Holla zusammen, Wer von euch setzt Aruba Switches (Aruba OS, ehemals HP ProCurve) ein und wie sind eure Erfahrungen bzw. wie zufrieden seid ihr ...

Router & Routing
Suche Tipps für Selfmade-Load-Balancing-Router auf HP MicroServer Gen10+
gelöst MagicChris86Vor 1 TagFrageRouter & Routing7 Kommentare

Hi Leute, ich habe einen HP MicroServer Gen10+ Performance übrig, der bei einer Kundin rausgeflogen ist, weil sie mehr Power brauchte für Desktopvirtualisierung für ...

Windows 7
Win7 64bit - ssd - Dateien verschwinden
rellixVor 1 TagFrageWindows 77 Kommentare

Grüße in die Runde, ich hab nach 20+ Jahren IT Erfahrung viel gesehen und schreibe hier meist erst, wenn ich keine Idee mehr habe ...

Webentwicklung
Webdesigner ist verschwunden
Janno100Vor 20 StundenFrageWebentwicklung3 Kommentare

Hallo zusammen Kunde hat einen Webdesigner der die Domain des Kunden vor einigen Jahren einfach unter seinen eigenen Name weiter geführt hat. Diese haben ...

Netzwerke
Sporadisch, temporäre nicht erreichbare IPs
BlueBookVor 1 TagFrageNetzwerke7 Kommentare

Hallo zusammen, ich habe ein Problem seit mehreren Monaten schon mit meinem Netzwerk. Ich hoffe jemand hat eine Idee oder einen Tipp. Hin und ...

Router & Routing
Routing Verständnisfrage
gelöst GrueneSosseMitSpeckVor 1 TagFrageRouter & Routing6 Kommentare

Moin, ich steh gerade etwas auf dem Schlauch. Ich habe im Wesentlichen zwei Netze: 1.) 192.168.0.0 / 24 Das ist das Netz hinter meinem ...

Netzwerkgrundlagen
Aufgabe - Subnetting
gelöst cornflakes01Vor 1 TagFrageNetzwerkgrundlagen5 Kommentare

Hi, bin zufällig auf diese Seite gestoßen und habe eine Frage bezüglich Subnetting. Wir haben kurz vor unserer Abiturprüfung eine Aufgabenstellung im Unterricht behandelt, ...