Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Cisco Packet Tracer - Allgemeine Fragen zum OSPF Routing

Mitglied: AbstrackterSystemimperator

AbstrackterSystemimperator (Level 1) - Jetzt verbinden

21.09.2019 um 15:01 Uhr, 550 Aufrufe, 4 Kommentare, 2 Danke

Hi zusammen,

mir ist aktuell noch einiges beim OSPF Routing unklar, weshalb ich nochmal Hilfe benötige.

Im Anhang habe ich mein Screenshot von meinem Netzwerk beigefügt. Hoffentlich ist das Netzwerk gut sichtbar.

OSPF Quelle Ich beziehe mich dabei, auf diese Aufgabe.

Ich habe als erstes das Netzwerk soweit konfiguriert, in dem ich dem PC, dem Server jeweils eine statische IP Adresse vergeben habe und folglich die Interfaces von den Routern konfiguriert habe.

Beispiel vom Router 6:
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R6
!
ip cef
no ipv6 cef
!
spanning-tree mode pvst
!
interface FastEthernet0/0
ip address 192.168.1.6 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 20.0.0.1 255.0.0.0
duplex auto
speed auto
!
interface Serial0/0/0
ip address 192.168.0.10 255.255.255.252
!
interface Serial0/0/1
bandwidth 64
ip address 192.168.2.10 255.255.255.252
clock rate 64000
!
interface Vlan1
no ip address
shutdown
!
ip classless
!
ip flow-export version 9
!
no cdp run
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
end

Das gleiche habe ich ebenso auf den jeweiligen anderen fünf Routern erledigt.

Zu dieser Konfiguration habe ich direkt zwei Fragen:

Warum muss ich eigentlich eine bandwidth und eine clock rate bei den Serialinterfaces angeben?
Die Erklärung auf der Seite habe ich nämlich nicht so ganz verstanden..."In real life environment this parameter controls the data flow between serial links and need to be set at service provider’s end"

Heißt es nur, das dieser Parameter den Datenfluss kontrolliert?

Zur der Bandbreite ist mir solches klar, das ich die für OSPF benötige, damit z.B. die Metric Cost unterschieden werden kann. Höhere Bandbreite = geringere Kosten und umgekehrt.
Könnte ich hier nicht auch den Befehl "auto cost..." nutzen? Wenn nicht, warum?


Zur OSPF - Konfiguration:


OSPF configuration

Router R0
enable
config t
router ospf 10
network 10.0.0.0 0.255.255.255 area 0
network 192.168.0.0 0.0.0.3 area 0
network 192.168.1.0 0.0.0.3 area 0
network 192.168.2.0 0.0.0.3 area 0
exit

Router R1
enable
config t
router ospf 10
network 192.168.0.0 0.0.0.3 area 0
network 192.168.0.4 0.0.0.3 area 0
exit

Router R2
enable
config t
router ospf 20
network 192.168.0.4 0.0.0.3 area 0
network 192.168.0.8 0.0.0.3 area 0
exit

Router R6
enable
config t
router ospf 60
network 20.0.0.0 0.255.255.255 area 0
network 192.168.0.8 0.0.0.3 area 0
network 192.168.2.8 0.0.0.3 area 0
network 192.168.1.4 0.0.0.3 area 0
exit

Router R5
enable
config t
router ospf 50
network 192.168.1.0 0.0.0.3 area 0
network 192.168.1.4 0.0.0.3 area 0
exit

Router R4
enable
config t
router ospf 40
network 192.168.2.8 0.0.0.3 area 0
network 192.168.2.4 0.0.0.3 area 0
exit

Router R3
enable
config t
router ospf 30
network 192.168.2.0 0.0.0.3 area 0
network 192.168.2.4 0.0.0.3 area 0


Fragen & Probleme:


Ich verstehe hier nicht die Vergabe der Netzwerke.

Als Beispiel der Router R4:
Se0/0/1 = IP 192.168.2.9 /30
Se0/0/0 = IP 192.168.2.6 /30

Wieso muss ich hier in der angegebenen Lösung die

network 192.168.2.8 0.0.0.3 area 0
network 192.168.2.4 0.0.0.3 area 0

eintragen? Das gleiche verstehe ich ebenso nicht, wenn ich mir die andern Router anschaue.

Als letztes verstehe ich nicht, warum die Befehle

log-adjacency-changes
passive-interface default
auto-cost reference-bandwidth 10000

nicht eingetragen sind. Gerade den ersten brauche ich doch, wenn ich sehen möchte, ob sich etwas im Netzwerk verändert oder?

Ich möchte nämlich am Ende mal einen Routerausfall simulieren bzw. und oder einen neuen Router dazu ins Netz hängen.

LG und danke für die Hilfe.

Schönen Samstag euch.
netzwerk - Klicke auf das Bild, um es zu vergrößern
Mitglied: Pjordorf
21.09.2019 um 17:59 Uhr
Hallo,

Zitat von AbstrackterSystemimperator:
Warum muss ich eigentlich eine bandwidth und eine clock rate bei den Serialinterfaces angeben?
Das mit Bandwidth bei seriellen Interfaces macht keinen Sinn. Baudrate hingegen schon.
https://en.wikipedia.org/wiki/Serial_port#Speed
Und clock rate ist dort auch nicht geläufig.
https://en.wikipedia.org/wiki/Serial_Peripheral_Interface

Die Erklärung auf der Seite habe ich nämlich nicht so ganz verstanden..."In real life environment this parameter controls the data flow between serial links and need to be set at service provider’s end"
Ja, das strimmt. Was genau hast du nicht verstanden?

Gruß,
Peter
Bitte warten ..
Mitglied: aqui
LÖSUNG 22.09.2019, aktualisiert um 01:38 Uhr
Warum muss ich eigentlich eine bandwidth und eine clock rate bei den Serialinterfaces angeben?
Doch, die Bandwith macht schon Sinn.
Serielle Interfaces haben keine feste Bandbreite wie Fast- oder Giagbit Ethernet, welche ja immer fest 100Mbit oder 1000Mbit als Bandwith haben. Das ist also schon durch die Infrastruktur an sich festlegt. So kann der Router die Last auf diesen Interfaces auch ohne Bandwith Parameter richtig berechnen !
Das kann er bei seriellen Interfaces wegen der vielen unterschiedlichen Geschwindigkeiten logischerweise nicht. Per Default nimmt der Router immer 64kBit an wenn du es nicht definierst.
Stellst du das serielle Interface mit der Clockrate aber physisch z.B. auf 4 Mbit dann berechnet der Router eine völlig falsche Last. Wichtig wird sowas bei Policy Routing nach Last z.B.
Es macht also Sinn, wenn man die Last richtig auslesen will, den Bandwith Parameter anzupassen. Wenn dir das egal ist kannst du es auch weglassen.
Siehe dazu auch hier in der Erklörung zum Dialer Interface !
Die Clockrate ist deshalb wichtig weil sie den physischen Takt des seriellen Interfaces vorgibt und damit dann die Übertragungs Geschwindigkeit ! Eine Seite ist immer DTE die andere DCE.

Was deine OSPF Konfigs anbetrifft sind die etwas laienhaft und rumpelig und kann man etwas eleganter machen.
Solltest du eigentlich auch wissen, denn in deinem früheren Thread haben wir dir das alles schon explizit beantwortet !!!
https://administrator.de/forum/vlan-einrichten-kommunikation-netze-nicht ...
Und die Folgethreads dort...!!

Grundsätzliche Fehler:
  • Die OSPF Prozess ID muss nicht pro Router unterschiedlich sein, das ist unsinnig !! Sie kann (und sollte) auf jedem Router gleich sein und die "1" haben !
  • Du musst nicht jedes Netz einzeln eintragen ! Sinnvoller ist network 0.0.0.0 255.255.255.255 area 0 das inkludiert dann automatisch alle Netze in die Area 0
Sinnvoll ist also folgende OSPF Grundkonfig auf den Routern:
!
router ospf 1
log-adjacency-changes
auto-cost reference-bandwidth 10000
network 0.0.0.0 255.255.255.255 area 0
!

Wenn du ein guter Netzwerker bist, dann passivierst du das OSPF auf Endgeräte Interfaces. Also in den Netzwerken wo PC sind und keine anderen Router mehr.
Das ist sicherer, denn dann kann dir von dort keiner falsche Routen injizieren und du belastest das Segment nicht unnötig mit Hello Paketen.
Das sähe dann so aus am Router 0:
!
router ospf 1
log-adjacency-changes
auto-cost reference-bandwidth 10000
passive-interface default
no passive-interface Serial0/0/0
no passive-interface FastEthernet0/1
no passive-interface Serial0/0/1
network 0.0.0.0 255.255.255.255 area 0
!


Das Meisterstück wäre dann wenn du auf den seriellen Links oder allgemein auf Links die über öffentliche Leitungen gehen und angreifbar sind mit einem Passwort absicherst.
Das sähe dann so aus für Router 0:
!
interface serial 0/0/0
description Link zum Router 1
ip address 192.168.0.1 255.255.255.252
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 geheim123
!
router ospf 1
log-adjacency-changes
auto-cost reference-bandwidth 10000
passive-interface default
no passive-interface Serial0/0/0
no passive-interface FastEthernet0/1
no passive-interface Serial0/0/1
network 0.0.0.0 255.255.255.255 area 0
!

Analog muss auf dem Seriellen Interface an Router 1 was zum Router 0 geht auch
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 geheim123

konfiguriert sein !

So nun bist du wieder dran und bitte merke dir mal das Erklärte oder sieh dir deine alten Threads an da steht doch alles !!
Bitte warten ..
Mitglied: AbstrackterSystemimperator
03.10.2019, aktualisiert um 12:28 Uhr
Zitat von aqui:

Warum muss ich eigentlich eine bandwidth und eine clock rate bei den Serialinterfaces angeben?
Doch, die Bandwith macht schon Sinn.
Serielle Interfaces haben keine feste Bandbreite wie Fast- oder Giagbit Ethernet, welche ja immer fest 100Mbit oder 1000Mbit als Bandwith haben. Das ist also schon durch die Infrastruktur an sich festlegt. So kann der Router die Last auf diesen Interfaces auch ohne Bandwith Parameter richtig berechnen !

Alles klar. Das war mir vorher nicht bewusst bzw. das wusste ich nicht. So, wie du es mir erklärst, verstehe ich es.

Das kann er bei seriellen Interfaces wegen der vielen unterschiedlichen Geschwindigkeiten logischerweise nicht. Per Default nimmt der Router immer 64kBit an wenn du es nicht definierst.

Daraus schließe ich, ich sollte es immer selbst definieren.

Stellst du das serielle Interface mit der Clockrate aber physisch z.B. auf 4 Mbit dann berechnet der Router eine völlig falsche Last. Wichtig wird sowas bei Policy Routing nach Last z.B.

Es macht also Sinn, wenn man die Last richtig auslesen will, den Bandwith Parameter anzupassen. Wenn dir das egal ist kannst du es auch weglassen.

Gilt das in diesem Beispiel nur für die Last?

Siehe dazu auch hier in der Erklörung zum Dialer Interface !
Die Clockrate ist deshalb wichtig weil sie den physischen Takt des seriellen Interfaces vorgibt und damit dann die Übertragungs Geschwindigkeit ! Eine Seite ist immer DTE die andere DCE.

Danke nochmal für den Link!


Was deine OSPF Konfigs anbetrifft sind die etwas laienhaft und rumpelig und kann man etwas eleganter machen.
Solltest du eigentlich auch wissen, denn in deinem früheren Thread haben wir dir das alles schon explizit beantwortet !!!
https://administrator.de/forum/vlan-einrichten-kommunikation-netze-nicht ...
Und die Folgethreads dort...!!

Stimmt, das war mein Fehler. Den Schuh muss ich mir selber anziehen... rückblickend betrachtet, hätte ich mir die Frage auch selbst beantworten können....


Grundsätzliche Fehler:
  • Die OSPF Prozess ID muss nicht pro Router unterschiedlich sein, das ist unsinnig !! Sie kann (und sollte) auf jedem Router gleich sein und die "1" haben !

* Du musst nicht jedes Netz einzeln eintragen ! Sinnvoller ist network 0.0.0.0 255.255.255.255 area 0 das inkludiert dann automatisch alle Netze in die Area 0

Und hier habe ich tatsächlich mein Defizit bzw. mein Problem. Ich verstehe nicht, warum die OSPF Prozess ID auf jedem Router gleich sein sollte und die 1 haben muss. Des Weiteren verstehe ich nicht, was mir die Area 0 überhaupt sagt und oder, wann sich die Area 0 in Area 1 oder so verändert. Hat das ganze mit Multiarea zu tun?

Und zu letzt ist mir unklar, warum ich "network 0.0.0.0 255.255.255.255" eintragen kann / darf und nicht die jeweiligen einzelnen Netze? Kann ich also bei jeder OSPF Konfiguration immer network 0.0.0.0 255.255.255.255 eintragen`?

So nun bist du wieder dran und bitte merke dir mal das Erklärte oder sieh dir deine alten Threads an da steht doch alles !!

Ich werde in Zukunft besser auf meine gestellten Fragen achten, bevor ich neue Fragen stelle!!!!

LG

Edit:


Zitat von aqui:

Das Meisterstück wäre dann wenn du auf den seriellen Links oder allgemein auf Links die über öffentliche Leitungen gehen und angreifbar sind mit einem Passwort absicherst.
Das sähe dann so aus für Router 0:
!
interface serial 0/0/0
description Link zum Router 1
ip address 192.168.0.1 255.255.255.252
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 geheim123
!
router ospf 1
log-adjacency-changes
auto-cost reference-bandwidth 10000
passive-interface default
no passive-interface Serial0/0/0
no passive-interface FastEthernet0/1
no passive-interface Serial0/0/1
network 0.0.0.0 255.255.255.255 area 0
!

Analog muss auf dem Seriellen Interface an Router 1 was zum Router 0 geht auch
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 geheim123

konfiguriert sein !


Die Konfig müsste ich doch dann folglich, ebenso auf den anderen öffentlichen Serialinterfaces eintragen oder irre ich mich?
Bitte warten ..
Mitglied: aqui
03.10.2019, aktualisiert um 12:36 Uhr
Gilt das in diesem Beispiel nur für die Last?
Ja !
Ich verstehe nicht, warum die OSPF Prozess ID auf jedem Router gleich sein sollte und die 1 haben muss
Sie MUSS nicht 1 haben. Zwingend ist das nicht aber es nützt der Übersichtlichkeit.
Die Prozess ID gilt immer nur für den lokalen Router ! Ein Router hat also keinerlei Ahnung was für eine Prozess ID der Router nebenan hat. Deshalb ist es auch völlig sinnlos und überflüssig den Routern unterschiedliche Prozess IDs zu geben. Im Gegenteil, es verwirrt eigentlich nur.
Der Grund warum man unterschiedliche Prozess IDs vergeben kann ist die Option das Routing auf einem System mit der VRF Funktion virtualisieren zu können.
Was VLANs für den Layer 2 sind (also mehrere getrennte, vollkommen isolierte Layer Broadcast Domains) sind VRFs für den Layer 3 (mehrere getrennte, vollkommen isolierte Layer 3 Routing Domains).
VRFs zu erklären würde den Rahmen dieses Threads sprengen.
Was du dir merken kannst:
Die OSPF Prozess ID sollte man auf jedem Router immer gleich halten !
Des Weiteren verstehe ich nicht, was mir die Area 0 überhaupt sagt
Auch das würde hier den Rahmen sprengen dir das alles zu erklären...
Nur so viel. OSPF braucht zwingend immer eine Backbone Area. In der Regel ist das die 0 oder je nach Nomenklatur auch die 0.0.0.0. An dieser Backbone Area hängen alle anderen Areas dran, sprich sie müssen immer an die Backbone Area gebunden sein. Das ist prinzipienbedingt so im OSPF Protokoll.
In kleinen Netzen mit wenig Route Neighbors macht eine Aufteilung in Areas meist wenig Sinn und dann belässt man alle Systeme in einer Area. Da es die Backbone Area ja immer geben muss ist das dann meistens die 0.
Beschaffe dir ein Buch und lies das alles nach.
Sehr zu empfehlen dazu ist:
https://www.amazon.de/Network-Warrior-Gary-Donahue/dp/1449387861/ref=sr_ ...
Eine Anschaffung die sich für dich in jedem Falle lohnt, da dieses Buch auch noch alles andere rund ums Networking erklärt !!
Bitte warten ..
Ähnliche Inhalte
Router & Routing

Cisco Packet Tracer: Lab und IP Adressbereich

gelöst Frage von PeterGygerRouter & Routing4 Kommentare

Guten Morgen Wahrscheinlich liegt es daran, dass ich eine lange Lernnacht hinter mir habe 8-) Aber ich stehe auf ...

Switche und Hubs

Cisco SG300 - Routing Problem

Frage von StandardpasswortSwitche und Hubs15 Kommentare

Okay, wie erwartet bekomme ich die das Routen mit dem SG300 nicht hin. Hier nochmal die gewünschte Zielkonfiguration: VLAN10: ...

Router & Routing

Cisco IPSEC VPN - Magic Packet (WOL) - ip helper-address

Frage von Bernhard-BRouter & Routing4 Kommentare

Hallo zusammen, ich möchte gerne Rechner aus der Ferne per Wake on Lan einschalten können. Im Ziel-Netzwerk funktioniert das ...

Router & Routing

Cisco SG300 Layer 3 Routing

Frage von Maik20Router & Routing4 Kommentare

Hallo, ich habe soeben auf dem SG300 ein neues VLAN (ID 310) angelegt und dieses als Tagged auf einen ...

Neue Wissensbeiträge
Humor (lol)
Das IoT wird schlimmer
Erfahrungsbericht von Henere vor 1 TagHumor (lol)7 Kommentare

Nun auch schon über den WSUS:

Sicherheit

Win10 1809 und höher erlauben nun das Sperren und Whitelisten von bestimmten Geräten

Tipp von DerWoWusste vor 2 TagenSicherheit1 Kommentar

Vor 1809 konnten nur Geräteklassen gesperrt werden, nun können endlich einzelne Device instance IDs gewhitelistet werden (oder andersherum: gesperrt ...

Windows 10

Hands-On: What is new in the Windows 10 November 2019 Update?

Information von DerWoWusste vor 2 TagenWindows 10

Die wenigen (aber zum Teil interessanten) Neuheiten werden in diesem Video sehr schnell erklärt und vorgeführt.

Grafik

Gute Spiele aus der Ubuntu Repository: SuperTuxKart

Information von NetzwerkDude vor 3 TagenGrafik2 Kommentare

Fall jemand die Firmenpolicy hat das man Linux Software nur aus dem default Repository installieren kann: Ich habe festgestellt ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
10G Netzwerk konfigurieren für maximalen Datendurchsatz
gelöst Frage von hukimanLAN, WAN, Wireless38 Kommentare

Guten Morgen, in unserem Betrieb wurde das Netzwerk auf 10G (Kupfer) umgerüstet. Grund dafür sind große Laserscandaten die sehr ...

Netzwerke
Subnetzmaske mit Hilfe der IP-Adresse berechnen
gelöst Frage von Jennifer21Netzwerke21 Kommentare

Hi zusammen, kann mir bitte jemand helfen bei dieser Aufgabe. Ich muss die die Subnetzsmaske berechnen von den IP-Adressen: ...

Exchange Server
Exchange 2016 550 5.7.60 SMTP Client does not have permissions to send
Frage von kermit-elmoExchange Server17 Kommentare

Hallo, ich möchte für bestimmte Mitarbeiter einen IMAP Zugang zum Firmen internen Exchange 2016 bereitstellen. Ein paar verwenden Linux ...

Windows 10
3D PDF bei WIN 10 mit Adobe Acrobat DC öffnen
Frage von DysfunktionWindows 1016 Kommentare

Hallo zusammen, Aus einem Konstruktionsprogramm ( Catia ) kann man Zeichnungen als 3 d PDF exportieren. Diese werden lokal ...