phill93
Goto Top

Cisco rapid-pvst probleme

Hallo,

ich hab hier ein kleines Problem.

Wir haben den Switch (SG550XG-24F) der unsere DCIM Netze an unseren Backbone anbindet auf rapid-pvst umstellen müssen und haben jetzt das Problem das der Port zum Backbone keinen Traffic Forwardet.
Von Seiten unserer Backbone Abteilung gibt es die Vorgabe das er Port keine BPDUs senden darf (auf der Gegenseite ist der BPDU Guard an) also hab ich den Port bei uns so Konfiguriert das er filtert. Die ganze Zeit mit RSTP ging das ohne Probleme aber seit der Umstellung geht kein Traffic mehr darüber.

Hier mal die Konfig vom Port:

interface TenGigabitEthernet1/0/22
 spanning-tree portfast
 spanning-tree link-type point-to-point
 spanning-tree bpdu filtering
 switchport mode trunk
 switchport trunk allowed vlan 1804,2386
!

Kann mir wer weiterhelfen?

Content-Key: 43278014138

Url: https://administrator.de/contentid/43278014138

Printed on: May 25, 2024 at 07:05 o'clock

Member: chgorges
chgorges Mar 14, 2024 updated at 11:17:11 (UTC)
Goto Top
Wie sieht dein Interface-Status und das der Gegenstelle inkl. zugehörigen Logauszügen aus?

Hast du den Filter erst nach dem Patchen der Verbindung eingerichtet?

Ggf ist die Gegenstelle noch im err-disable muss händisch rausgeholt werden. Oder ihr habt jetzt ein Spanning-Tree mismatch, dann muss euer Backbone die Gegenstelle auch auf rapid-pvst umstellen.

Dazu musst du
spanning-tree portfast
auf
spanning-tree portfast trunk
umstellen, da ja kein Endgerät, sondern ein Switch angeschlossen ist.
Member: aqui
Solution aqui Mar 14, 2024 updated at 12:16:33 (UTC)
Goto Top
Besteht der Backbone auch aus SG Switches oder generell Switches die durchgehend nur in einer Single Spanning Tree Instanz laufen?
Wenn ja, ist das OK.
Wenn nein und diese Backbone Switches PVSTP oder Ciscos PVSTP+ Spanning Tree fahren hast du ein Problem, denn diese beiden Spanning Tree Modi sind NICHT kompatibel und es kommt dann ggf. zu solchem Verhalten.
Die oben genannte "Umstellung" scheitert aber per se weil die SG Modelle PVSTP und auch PVSTP+ gar nicht supporten! Hier bleibt als einzige Möglichkeit nur die einheitliche Migration des ganzen Netzes auf MSTP.
Grundsätzlich sehr gefährlich ist den BPDU Filter am Port zu aktivieren. Damit schliesst man das Gerät generell vom Spanning Tree aus und riskiert einen inkonsitenten Spanning Tree und erhöht die Loop Gefahr. Du solltest dir also sehr gut überlegen ob du das an dem Port beibehalten willst. Meist ist das keine gute Idee und konterkariert ja per se auch generell die Aktivierung von Spanning Tree wenn man es "hintenrum" über die Ports dann wieder deaktiviert.

Entscheidend ist auch das der oder die Core Backbone Switches (Layer 3) zwingend eine höhere STP Priority konfiguriert haben sollten als der Rest um so immer sauber den Root Switch und die Root Ports im STP festzulegen. Der Wert muss immer in 4096er Schritten angegeben werden und unter dem Default Wert 32768 liegen! Kleinerer Wert = größere Priotity.
Ein sauberes Spanning Tree Design und Konfig ist also immer Pflicht! (Dieser Thread behandelt u.a. diese Thematik die oft übersehen und falsch gemacht wird)

Desweiteren ist auffällig das der Port oben ohne ein Native VLAN (PVID VLAN) konfiguriert ist?! Ist das so explizit gewollt und auf der Gegenseite (Backbone) auch exakt so definiert?? Auch das könnte eine mögliche Fehlerquelle sein (Error Disable Mode) wenn der Port ungleich konfiguriert ist.

Sehr hilfreich wäre ein "sh spanning-tree detail blockedports" gewesen um überhaupt zu sehen ob dieser Port durch RSTP Blocking nichts forwardet oder ob das andere Gründe hat. Hier dann ein "sh interface TenGigabitEthernet1/0/22"
Leider fehlen all solche hilfreichen Informationen für eine zielführende Lösung so das auch wir erstmal nur kristallkugeln können. face-sad