Dampsoft beschleunigen

Mitglied: StefanKittel

StefanKittel (Level 5) - Jetzt verbinden

15.02.2021 um 22:58 Uhr, 1213 Aufrufe, 9 Kommentare, 1 Danke

Hallo,

eine Praxis verwendet Dampsoft und die Geschwindigkeit ist langsam.
Seit wann weiß keiner so genau. Server und Software wurden nicht vor kurzem geändert.

System: ESXi 6.7, Veeam Backup and Replication, Windows Server 2016 Std als VM, PCs Windows 10 Prof 20H2, 1GBit LAN RJ45, Feste IPv4-Adressen
Server ist ein Fujitsu TX1320M3 mit intel i210 Netzwerkkarten.

Alle Vorgaben von Dampsoft (SMB1, etc) wurden damals konfiguriert.

Info: Auf den PCs ist nur eine Verknüpfung ein ein paar Einstellungen.
Alle EXE-Dateien und Datenbanken liegen auf einem Netzwerklaufwerk welches mit dem Server verbunden ist.

Was heisst langsam.
Man startet Dampsoft auf einem PC und dann gibt es in der Software Karteireiter für die einzelnen Module.
Wenn ich nun auf ein Modul klicke dauert das 5-10 Sekunden beim 1. Mal für jedes Modul.
Danach ist es schnell.

Klingt für mich als ob er das Modul im RAM speichert beim 1. Aufruf.
Aber was sollte sich gegenüber früher geändert haben?

Nun gehe ich auf den Server und starte über das Netzwerklaufwerk die Software.
Auch langsam.

Nun trenne ich am Server das Netzwerklaufwerk und verbinde den gleichen Buchstaben mit dem gleichen Verzeichnis mit subst.
Nun ist die Software schnell.

Also ist das Problem nicht der Storage (SSD Raid 5) sondern der SMB-Server.

Ich habe mal testhalber die NIC von E1000 auf VMXNET umgestellt aber ohne Erfolg.
Offloading bringt auch nichts.

Netio ist auch unauffällig.

Hat da noch Jemand einen Tipp für mich?
Ich bin mir nicht sicher ob mir der Support helfen kann und wird weil es eher ein Netzwerkproblem ist.

Danke
Stefan
Mitglied: cykes
16.02.2021 um 05:51 Uhr
Moin,

kenne die Software zwar nicht, aber laut Deinem anderen Thread muss ja zwingend SMB1 aktiviert sein, damit die Software problemlos läuft. Das dürfte insbesondere auf Clientseite immer schwieriger werden, das über Updates hinaus bei aktuellen Windows 10 Builds aktiv zu halten.

Weiterhin würde ich die Einstellungen des Virenscanners überprüfen, ggf. wird da vom Client auf Netzlaufwerken (einmalig) gescannt und das bremst den Erststart aus.

Gruß

cykes
Bitte warten ..
Mitglied: lcer00
16.02.2021 um 07:03 Uhr
Hallo,

habe mir grade die Einrichtungsdokumentation von Dampsoft durchgelesen. Die meinen das mit SMB1 tatsächlich ernst. Gruselig.

Virenscanner wären auch meine erste Idee. Wir unterschätzen gerade bei Clients die Auswirkungen gelegentlich.

Grüße

lcer
Bitte warten ..
Mitglied: cykes
16.02.2021 um 07:37 Uhr
Wobei es bereits eine aktualisierte Anleitung für Server 2019 gibt, in der keine Rede mehr von SMB1 aktivieren und SMB2 deaktivieren ist.

Also vielleicht diesen Punkt einfach mal rückgängig machen?

War auch schwer vorstellbar, dass das mit SMB2/3 nicht funktionieren sollte. Vermutlich hatten sie damals ihre Software noch nicht angepasst.

Das sollte eigentlich auch Dein anderes Problem mit Veeam lösen.
Bitte warten ..
Mitglied: StefanKittel
16.02.2021 um 08:13 Uhr
Zitat von @cykes:
Wobei es bereits eine aktualisierte Anleitung für Server 2019 gibt, in der keine Rede mehr von SMB1 aktivieren und SMB2 deaktivieren ist.

Moin,
nein, das Update hatte ich auch gesehen, gilt angeblich nur für Win2019.
Unter 2016 mit SMB2+3 gab es Abstürze innerhalb der Software. Vermutlich hat das mit deren Datei-basierten-Datenbanken zu tun.

Stefan
Bitte warten ..
Mitglied: StefanKittel
16.02.2021, aktualisiert um 08:14 Uhr
Moin,

der Virenscanner (ESET Endpoint Antivirus an den PCs und File Security am Server) an den PCs prüft das Netzwerklaufwerk gar nicht und am Server sind bestimmte Dateien von der Prüfung ausgeschaltet.

Stefan
Bitte warten ..
Mitglied: cykes
16.02.2021 um 09:01 Uhr
Das klingt aber noch merkwürdiger. Unter 2019 funktioniert es ohne SMB1 und unter 2016 nicht?
Auf jeden Fall wirst Du das nicht lösen können, ohne die Einstellungen für 2019 zu aktivieren und hier ist der Hersteller gefragt, das zu reparieren. Eigentlich sollten für die Praxis die Clienteinstellungen aus der 2019 Anleitung gelten und die Servereinstellungen eingeschränkt aus der 2016 bzw. 2019. Sonst fällt Dir das immer wieder auf die Füße.

Ich kenne den ESET jetzt nicht so gut, aber vielleicht schlägt da auch eine Verhaltensanalyse zur Laufzeit zu.

Gruß

cykes
Bitte warten ..
Mitglied: altmetaller
16.02.2021 um 09:29 Uhr
Hallo,

teste mal:

HKLM\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters

Neuer Eintrag:

DirectoryCacheLifetime Dword=0

Gruß,
Jörg
Bitte warten ..
Mitglied: marvhartmann
17.02.2021, aktualisiert um 10:41 Uhr
Moinsen,

schau mal ob dies Abhife schafft
https://www.dampsoft.de/wp-content/uploads/2020/04/DS-Informationen-zur- ...

Betrifft zwar in erster Linie HyperV aber auch das Gast-OS.

Ansonsten würde ich auch eher auf Virenscanner etc. tippen.
Clients und Server laut Systembetreueranleitungen konfiguriert?


Bevor die Leute hier sich den Mund über SMB1, warum in Server 2016 und nicht mehr in 2019 etc fusselig reden:

Dampsoft arbeitet auf Fileserverbasis und nicht mit einer DB im Hintergrund.
SMB1 stellt bis einschl. Server 2016 die Möglichkeit Opportunistic Locking zu deaktivieren, SMB2 lässt dieses nicht zu (erst ab Server 2019)

PS: Vorsicht ab Windows 10 ab Ver. 2004: Beim Runterfahren der Clients die Netzlaufwerke trennen lassen da sonst, in Kombination mit SMB1, der Netzwerkpfad der vorherigen Verbindung nicht gefunden werden kann (z.B. wenn Netzlaufwerk über DNS Namen des Servers verbunden war ist dieser nicht mehr darüber erreichbar, aber über die IP und den FQDN. Verbindet man dann darüber das Netzlaufwerk, funktioniert nach dem Neustart dieser Weg nicht mehr, aber DNS wieder, usw .....)

Gruß Marv
Bitte warten ..
Mitglied: StefanKittel
21.02.2021, aktualisiert um 22:54 Uhr


Ansonsten würde ich auch eher auf Virenscanner etc. tippen.
Habe ich mal deinstalliert


Clients und Server laut Systembetreueranleitungen konfiguriert?
Ja, aber aktuell teste ich ja nur auf dem Server

Ich installiere mal eine 2019 VM und schaue ob das dort anders ist.

Stefan
Bitte warten ..
Heiß diskutierte Inhalte
Netzwerkgrundlagen
Frage der anderen Art
NeuerleVor 1 TagFrageNetzwerkgrundlagen16 Kommentare

Hi an alle, Ich bin InformatikStudi. Habe Ende des Monats Klausur im Fach Netzwerke zu schreiben und komme gar nicht klar. Entweder ich bin ...

Ubuntu
Cups-Server mit SMB lehnt Verbindungen ab (smb.conf)?
ErikHeinemannVor 1 TagFrageUbuntu17 Kommentare

Guten Morgen, ich habe einen Ubuntu 20.04 Server mit Cups als Printspooler. Nun Soll noch Samba hinzugefügt werden für eine einfache Verwendung unter Windows. ...

Exchange Server
Kaspersky for Exchange Meldungen
gelöst wieoderwasVor 1 TagFrageExchange Server11 Kommentare

Guten Morgen, wir haben bei uns einen Exchange 2013 mit Kaspersky for Exchange und Sophos auf Dateiebene. Heute Morgen habe ich einige von diesen ...

Groupware
Lokale Mini-Groupware für Mail, Adressbuch und Kalender gesucht
AndreasKasselVor 1 TagFrageGroupware10 Kommentare

Hallo zusammen, ich habe insgesamt 2 PCs, 1 Notebook, 1 Android-Tablet und ein Android-Smartphone. Weiterhin habe ich 2 Mail-Adressen bei 1&1 mit einer eigenen ...

Grafikkarten & Monitore
Unerklärliche Aussetzer Bildschirm und Maus
nixwissenderVor 1 TagFrageGrafikkarten & Monitore10 Kommentare

hallo! wir haben aktuell das unerklärliche phänomen, dass sich am arbeitsplatz vom mitarbeiter eines der beiden bildschirme kurzzeitig ausschaltet (und zwar der, der per ...

CPU, RAM, Mainboards
CPU Lüfter ausbauen
gelöst ben1300Vor 1 TagFrageCPU, RAM, Mainboards9 Kommentare

Hallo zusammen, ich habe mir damals einen Fertig PC gekauft. Ich würde gerne den Arbeitsspeichern austauschen, allerdings muss ich dafür - so wie es ...

Backup
Backup Datei
gelöst KanrishaVor 1 TagFrageBackup5 Kommentare

Hallo Zusammen, ich habe eine Frage ich will eine Backup bat Datei schreiben habe jedoch ein kleines Problem. Ich möchte ein Laufwerk in das ...

DNS
Android 10 und mein DNS Server
gelöst CyborgWeaselVor 1 TagFrageDNS7 Kommentare

Hallo allesamt, ich spiele gerade etwas mit einer Synology herum, habe unter Anderem einen eigenen DNS jetzt aufgesetzt. Die lokale Domäne ist HomeDomain.local und ...