alaim89
Goto Top

Debian 7.4 stable, Ifconfig wird nicht ohne root und pfad ausgeführt

Hallo liebe Gemeinde,

ich habe heute auf meinem Client die Debian 7.4 stable Version aufgesetzt.
Mir ist aufgefallen nachdem ich mal schauen wollte welche IP-Adresse mir zugewiesen worden ist,
das ifconfig nicht "einfach" ausführbar ist als standard user.
Es kommt die Meldung:
bash: ifconfig: Kommando nicht gefunden.

Kommt mir komisch vor. Denn ich habe unter /sbin/ geschaut und dort ist ifconfig aufgeführt.

Dann habe ich diesen Befehl nochmals mit sudo ifconfig gestartet und tatsächlich hat dieser funktioniert und mir die Auswertung ausgegeben.

Anschließend habe ich mir gedacht, das kann doch nicht wahr sein.
Zur zwischeninfo vllt nochmal, mein Konto habe ich zuvor dem sudoers hinzugefügt gehabt.

Blitzschnell kam mir die Idee mal einfach /sbin/ifconfig ohne sudo auszuführen. Das hat tatsächlich geklappt.

Ich versteh nicht wieso ich den Pfad unbedingt mit angeben muss, um ifconfig auszuführen face-sad
Vielleicht hat da jemand eine Antwort für mich parat. Denn ich habe auch schon im Handbuch nachgeschaut aber ich kann mir das irgendwie nicht zusammen reimen.

Mit besten Grüßen


alaim89

Content-Key: 232100

Url: https://administrator.de/contentid/232100

Printed on: June 22, 2024 at 19:06 o'clock

Member: Lochkartenstanzer
Solution Lochkartenstanzer Mar 08, 2014, updated at Mar 16, 2014 at 13:57:59 (UTC)
Goto Top
Zitat von @alaim89:

Ich versteh nicht wieso ich den Pfad unbedingt mit angeben muss, um ifconfig auszuführen face-sad
Vielleicht hat da jemand eine Antwort für mich parat. Denn ich habe auch schon im Handbuch nachgeschaut aber ich kann mir das
irgendwie nicht zusammen reimen.

Weil der Pfad sbin nicht im Standardpfad der User ist und auch nicht sein sollte, damit die nicht auf dumme Ideen kommen. Der ist für den sysadmin gedacht.

Und wenn man /sbin im Pfad haben will, trägt man den halt in .login oder .bashrc mit ein.

lks
Member: Lochkartenstanzer
Lochkartenstanzer Mar 11, 2014 updated at 17:00:41 (UTC)
Goto Top
Und? Problem gelöst?

lks
Member: alaim89
alaim89 Mar 13, 2014 at 21:11:47 (UTC)
Goto Top
Hi LKS,
ich bin da noch nicht so wirklich hintergekommen. Den Ansatz den du mir gegeben hast scheint aber mit Sicherheit schon mal richtig zu sein.
Momentan habe ich das System nicht in Reichweite und werde es übers Wochenende nochmal angehen. Ich werder auf jeden fall bescheid geben.


Gruß

alaim89
Member: Lochkartenstanzer
Lochkartenstanzer Mar 14, 2014, updated at Mar 16, 2014 at 13:58:14 (UTC)
Goto Top
Zitat von @alaim89:

Hi LKS,
ich bin da noch nicht so wirklich hintergekommen. Den Ansatz den du mir gegeben hast scheint aber mit Sicherheit schon mal richtig
zu sein.
Momentan habe ich das System nicht in Reichweite und werde es übers Wochenende nochmal angehen. Ich werder auf jeden fall
bescheid geben.


Wie gesagt, kannst Du das entweder beim User oder generell ins System einbinden. Du kannst das natürlich auch einfach dadurch machen, daß Du in /bin einen symblischen Link zu /sbin/ifconfig anlegst.

lks
Member: alaim89
alaim89 Mar 16, 2014 at 14:01:33 (UTC)
Goto Top
HI LKS,

nachdem ich mir dein Link nochmals genauer durchgearbeitet habe, hat sich das folgende Problem, das ich besaß nun erledigt.
Es wurden die angeforderten Ausführungen einfach nach /bin verschoebn und voila, es hatte funktioniert.


Gruß


alaim89
Member: Lochkartenstanzer
Lochkartenstanzer Mar 16, 2014 at 14:30:29 (UTC)
Goto Top
Zitat von @alaim89:

Es wurden die angeforderten Ausführungen einfach nach /bin verschoebn und voila, es hatte funktioniert.

Verschieben ist das Falsche, weil Du spätestens beim nächsten Update probleme bekommst (z.B. mehrere Versionen desselben Programms). Sinnvoller wäre es entweder die PATH-Variable in /etc/environment zu erweitern oder symbolische Link von /bin/ nach /sbin anzulegen.

lks