thecky
Goto Top

Direkte Routing Verbindung zwischen 2 MikroTik Geräten

Hallo,

ich fange gerade an, mich mit den Mikrotik-Modellen zu beschäften und stolpere über ein eigentliches einfaches Problem; was ich nicht nachvollziehen kann.

Ich habe ein RB4011 und einen CRS326, die ich direkt per Routing-Ports verbinden möchte. Sinn und Zweck ist einfach sich mit den Geräte zu beschäftigen und Erfahrung zu sammeln.

Dazu habe ich bei beiden Geräte die Default-Config gelöscht und ein paar IP's eingerichtet (Loopback und IP's direkt auf den Ports). Mein Problem ist jetzt, dass sie sich gegenseitig nicht per IPv4 pingen können. Auch wenn ich die Modelle direkt mit meinem Laptop verbinde (entsprechende IP eingerichtet), erfolgt kein erfolgreichen Ping. Da es bei beiden Geräte auftritt, denke ich dass ich irgendwie noch einen Denkfehler habe. Per IPv6 über die Link-Lokal Adresse funktioniert der Ping.

Anbei mal die Terminalauszüge.

RB4011:
[admin@MikroTik] > /ip address print
Columns: ADDRESS, NETWORK, INTERFACE
# ADDRESS           NETWORK          INTERFACE        
0 1.1.1.1/32        255.255.255.255  lo               
1 192.168.100.1/32  255.255.255.0    sfp-Uplink_Switch
2 192.168.200.1/32  255.255.255.252  ether10   
       
[admin@MikroTik] > /ip route print
Flags: D - DYNAMIC; I - INACTIVE, A - ACTIVE; c - CONNECT; H - HW-OFFLOADED
Columns: DST-ADDRESS, GATEWAY, DISTANCE
     DST-ADDRESS         GATEWAY            DISTANCE
DIcH 255.255.255.0/32    sfp-Uplink_Switch         0
DIcH 255.255.255.252/32  ether10                   0
DAc  255.255.255.255/32  lo                        0

[admin@MikroTik] > /export
/interface ethernet
set [ find default-name=sfp-sfpplus1 ] auto-negotiation=no name=sfp-Uplink_Switch
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/port
set 0 name=serial0
set 1 name=serial1
/ip address
add address=1.1.1.1 interface=lo network=255.255.255.255
add address=192.168.100.1 interface=sfp-Uplink_Switch network=255.255.255.0
add address=192.168.200.1 interface=ether10 network=255.255.255.252
/system note
set show-at-login=no

[admin@MikroTik] > /ip neighbor print
Columns: INTERFACE, ADDRESS, MAC-ADDRESS, IDENTITY, VERSION, BOARD
#  INTERFACE  ADDRESS        MAC-ADDRESS        IDENTITY  VERSION                              BOARD         
0  ether10    192.168.200.2  D4:01:C3:3A:FA:DF  MikroTik  7.14.2 (stable) 2024-03-27 07:48:52  CRS326-24G-2S+

[admin@MikroTik] > ping 192.168.200.2 count=2
Columns: SEQ, STATUS
SEQ  STATUS          
  0  no route to host
  1  no route to host

Und vom CRS326:
[admin@MikroTik] > /ip address print
Columns: ADDRESS, NETWORK, INTERFACE
# ADDRESS           NETWORK          INTERFACE         
0 2.2.2.2/32        255.255.255.255  loopback          
1 192.168.100.2/32  255.255.255.0    sfp2-Uplink_Router
2 192.168.200.2/32  255.255.255.252  ether23           

[admin@MikroTik] > /ip route print                   
Flags: D - DYNAMIC; I - INACTIVE, A - ACTIVE; c - CONNECT; H - HW-OFFLOADED
Columns: DST-ADDRESS, GATEWAY, DISTANCE
     DST-ADDRESS         GATEWAY             DISTANCE
DIcH 255.255.255.0/32    sfp2-Uplink_Router         0
DAcH 255.255.255.252/32  ether23                    0
DAc  255.255.255.255/32  loopback                   0

[admin@MikroTik] > /export
/interface bridge
add name=bridge1 port-cost-mode=short
add name=loopback
/interface ethernet
set [ find default-name=sfp-sfpplus2 ] auto-negotiation=no name=sfp2-Uplink_Router
/interface ethernet switch
set 0 l3-hw-offloading=yes
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip hotspot profile
set [ find default=yes ] html-directory=hotspot
/port
set 0 name=serial0
/ip firewall connection tracking
set udp-timeout=10s
/ip neighbor discovery-settings
set discover-interface-list=!dynamic
/ip address
add address=2.2.2.2 interface=loopback network=255.255.255.255
add address=192.168.100.2 interface=sfp2-Uplink_Router network=255.255.255.0
add address=192.168.200.2 interface=ether23 network=255.255.255.252
/system note
set show-at-login=no
/system routerboard settings
set boot-os=router-os enter-setup-on=delete-key

[admin@MikroTik] > /ip neighbor print
Columns: INTERFACE, ADDRESS, MAC-ADDRESS, IDENTITY, VERSION, BOARD
#  INTERFACE  ADDRESS        MAC-ADDRESS        IDENTITY  VERSION                              BOARD     
1  ether23    192.168.200.1  2C:C8:1B:AE:43:84  MikroTik  7.14.2 (stable) 2024-03-27 07:48:52  RB4011iGS+

[admin@MikroTik] > ping 192.168.200.1 count=2 
Columns: SEQ, STATUS
SEQ  STATUS          
  0  no route to host
  1  no route to host

Ich habe einmal das Netzt 192.168.100.0/24 und 192.168.200.0/30. Die aktuellen Test laufen mit dem 192.168.200.0/30 Netz. Über das 192.168.100.0/24 hatte ich eine Verbindung zwischen den SFP-Ports, die mit einem DAC Kabel verbunden sind. Zuerst war das ein /30, was ich zu Testzwecken dann auch ein /24 geändert hatte. Um hier irgendwas auszuschließen, habe ich die Verbindung über die "normalen" Ports hergestellt (RB4011 ether10 <-> CRS326 ether23).

Mich verwundert nur das "no route to host", denn eigentlich müssten die Geräte ja die Route haben - die sind ja quasi Direct-Connected. Irgendwelche neuen Routing-Tables oder VRFs habe ich auch nicht eingerichtet - daher hätte ich erwartet, dass es nach der minimalen Konfiguration "out-of-the-box" arbeitet.

Eventuell kann mir jemand bitte mal einen Tipp geben, wie man diese - eigentliche einfache - Konfig zum Laufen bringt?

Danke und Gruß
Thomas

Content-Key: 91444694281

Url: https://administrator.de/contentid/91444694281

Printed on: May 28, 2024 at 07:05 o'clock

Member: adminst
Solution adminst Apr 19, 2024 at 15:23:17 (UTC)
Goto Top
Hallo Thomas
Ich kenne die Mikrotik nicht aber:
- Wieso verwendest du für die Loopback IPs Public IPs? - z.B. 1.1.1.1 = Cloudflare DNS Resolver
- Dann gibst du die Netzmaske bei Network ein Anstelle der Netzerk ID
- Wenn die zueinander geroutet sein sollen, müssen die in der selben Netzmaske sein. Sicher nicht /32 sondern als Beispiel /24

Beispiel
router A 192.168.55.1/24 192.168.55.0
router B 192.168.55.2/24 192.168.55.0

Gruss
adminst
Member: aqui
Solution aqui Apr 19, 2024 updated at 16:06:49 (UTC)
Goto Top
Du hast soweit alles richtig gemacht wenn man einmal von dem Fauxpas mit der Loopback Adressierung absieht. Von der Konfig her ist das alles OK und eigentlich sollte ein Ping mit dem WinBox Ping Tool klappen.
⚠️ Achtung: hier lauert der Teufel im Detail...!
Wenn du mit dem WinBox Ping Tool pingst und vergessen hast unter Advanced eine Source IP zu setzen, dann verwendet der Ping deine Loopback Adresse als Absenderadresse der ICMP Eche Pakete!
Das kommt dann auch beim Gegenüber an aber wenn du dort vergessen hast unter IP --> Routes die statischen Routen für die Loopback Netze einzutragen auf der jeweils anderen Seite scheitert die Rückroute mit den Echo Replies!
Pingst du also die 192.168.100.2 dann muss die Source IP am 4011er auf 192.168.100.1 gesetzt sein sofern du noch keine Routen für die Loopbacks eingetragen hast!

Checke zusätzlich an den Ports das du auch einen aktiven Link hast und die MDI-X Negotiation sauber funktioniert (Link LEDS leuchten und Interface Counter zählen hoch) wenn du ohne Crossover Kabel arbeitest, da du ja eine direkte Switch zu Switch Verbindung hast.
Beachte bei DAC/Twinax und AOC Kabeln funktioniert keine Autonegotiation wie bei RJ-45! Hier musst du bei SFP+ Ports also zwingend immer die Speed setzen sofern du nicht beidseitig mit 10G (SFP+) arbeitest!

Übrigens...
Für reine Punkt zu Punkt IP Netze kannst du auch /31 Subnetzmasken verwenden! Die gehen etwas ökonomischer mit den verfügbaren Adressen um. face-wink
https://packetlife.net/blog/2008/jun/18/using-31-bit-subnets-on-point-po ...

Tip zu den Loopbacks:
  • Damit die sich abheben nimm z.B. die RFC-6598 Shared IP Adressen. Z.B. 100.100.100.1 fürs erste Gerät, 100.100.100.2 fürs 2te usw. Da sind deiner Phantasie keine Grenzen gesetzt. Auch der RFC 1918 Bereich ist ja hinreichend groß das du dich da austoben kannst. face-wink
  • Loopback Adressen sind in der Regel /32er Adressen und auch die Routen dahin sind dann Hostrouten wenn du statisch routest. Bei dynamischem Routing mit RIPv2, OSPF usw. geht das alles eh dynamisch.
Member: thecky
thecky Apr 19, 2024 at 17:10:34 (UTC)
Goto Top
Hallo,

danke für Eure Antworten und hilfreichen Tipps. Es lag - wie ich schon vermutete - ein PEBKAC vor.
Ich habe mich von der Winbox täuschen lassen, bzw. habe nicht richtig gelesen und habe bei Network die Netzmaske eingetragen ... ohne Worte face-wink
Nach der Korrektur und dem richtigen eintragen der Adressen hat es dann auch geklappt.
Zeigt aber auch wieder, dass es gut ist Abstand zu nehmen und jemanden anderen einmal rüber schauen zu lassen.

Damit hat dann auch der gleich der weitere "Spielschritt" mit OSPF funktioniert face-smile

Bei den Loopbacks habe ich mir ehrlich gesagt keine Gedanken gemacht, da die Büchsen so eh nicht ans Netz kommen (will halt erst einmal Erfahrung mit den Teilen sammeln). Aber ja, intuitiv habe ich bei den anderen Netzen RFC1918 genommen und bei den LO's einfach 1 und 2 genommen.
RFC6598, ja könnte man nehmen - nutzen allerdings die ISP auch für CGNAT (ich habe z.B. eine aus dem Bereich an meinem Anschluss).

Das mit dem Ping und der Source bei der Winbox ist ein guter Tipp - so etwas habe ich schon vermutet, dass hier eventuell auch noch ein Fehlerteufel liegen könnte.

Danke und Gruß
Thomas
Member: aqui
aqui Apr 19, 2024 updated at 18:00:32 (UTC)
Goto Top
ich habe z.B. eine aus dem Bereich an meinem Anschluss
OK, bei so einer DS-Lite Krücke zuhause sind die dann natürlich Tabu. Aber auch mit einer 0 weniger gibts ja genu Optionen. face-wink
Damit hat dann auch der gleich der weitere "Spielschritt" mit OSPF funktioniert
👏 👍 Glückwunsch! Ein bisschen Futter dazu auch hier:
Verständnisfrage zu OSPF-Routing bei MikroTik-Routern (RouterOS)
Cisco, Mikrotik, pfSense VPN Standort Vernetzung mit dynamischem Routing
Routing Frage welches Protokoll für Mobile Geräte
IPv6 über Cisco IPv4 IPsec Tunnel

Wenn es das denn wir bitte deinen Thread dann auch als erledigt schliessen!
How can I mark a post as solved?