Direkte Weiterleitung zu HTTPS ohne .htaccess

Mitglied: stuuii

stuuii (Level 1) - Jetzt verbinden

19.02.2016, aktualisiert 11:30 Uhr, 1699 Aufrufe, 6 Kommentare

Hallo zusammen

Ich möchte, dass ein User, welcher im Browser "domain.xyz" eingibt (also den Request "http://domain.xyz" ausführt), immer auf https://www.domain.xyz weitergeleitet wird.
Jedoch möchte ich dies ohne Zwischenschritt - also: http://domain.xyz > https://domain.xyz > https://www.domain.xyz oder http://domain.xyz > http://www.domain.xyz > https://www.domain.xyz - hinbekommen, da dies unnötig Zeit beansprucht und die Ladegeschwindigkeit der Seite negativ beeinflusst.
Kennt jemand eine Möglichkeit?

Bestenfalls ohne .htaccess.
Ich habe Plesk 12.5.30 auf Ubuntu 14.04

Danke für eure Hilfe!

Freundliche Grüsse
stuuii
Mitglied: 117643
117643 (Level 2)
19.02.2016 um 10:59 Uhr
Also wenn die komplette Seite nur noch per HTTPS und die www. adresse erreichbar ist, sollte auch google das erkennen
und in den suchergebnissen die optimierte seite verwenden.

htaccess dürfte in deinem fall der richtige weg sein, kenne plesk nicht genau, aber wenn du dort die apache direktiven anpassen kannst,
könntest du den redirect auch dort hinterlegen.

Den zwischenschritt https://domain.xyz > https://www.domain.xyz kannst du dir übrigens sparen, das geht auch in einem rutsch
Bitte warten ..
Mitglied: Chonta
LÖSUNG 19.02.2016, aktualisiert um 11:30 Uhr
Hallo,

du machst im V-Host deines Webservers der ja auf domain.xyz und www.domain.xyz lauscht eineen redirekt auf https.
Der vhostteil für https muss natürlich auch auf beides lauschen.

Gruß

Chonta
Bitte warten ..
Mitglied: wiesi200
19.02.2016 um 11:19 Uhr
Hallo,

zusätzlich währ noch HSTS interessant.
https://de.wikipedia.org/wiki/HTTP_Strict_Transport_Security
Bitte warten ..
Mitglied: stuuii
19.02.2016 um 11:29 Uhr
Danke für den Tipp. Habe das jetzt so gelöst:



Google PageSpeed Insights sagen auch, dass das gut sei. https://i.imgur.com/erl9xwP.png

Danke für die Hilfe!

Freundliche Grüsse
stuuii
Bitte warten ..
Mitglied: Chonta
19.02.2016 um 11:32 Uhr
Hallo,

ServerName "www.domain.xyz:443"
das :443 im Namen würde ich wegmachen.
Duchr Virtualhost *:443 wird ja schon gesagt welcher Port.

Gruß

Chonta
Bitte warten ..
Mitglied: agowa338
20.02.2016 um 04:18 Uhr
Ich hab es folgendermaßen gemacht:


Für dich interessant ist die Zeile mit Strict-Transport-Security, diese sorgt dafür, dass die Weiterleitung :80 => :443 nur beim ersten mal verwendet wird.
Das [R=301,L] im :80 VirtualHost sorgt für eine HTTP 301 Weiterleitung, also ein Moved Permanently, dadurch teilst du allen (auch Suchmaschinen) mit, dass die Seite permanent umgezogen ist auf :443 in diesem Fall.

Und hier noch etwas, falls du die Ladezeiten effektiv verkürzen willst (zumindest nach dem ersten mal Laden ;-) face-wink ). Einfach in den :443 VirtualHost einfügen:

Bitte warten ..
Heiß diskutierte Inhalte
Festplatten, SSD, Raid
Festplatte aus defekten Notebook ausgebaut - wird nicht erkannt - Wie gelange ich an meine Daten?
gelöst 1nCoreVor 1 TagFrageFestplatten, SSD, Raid15 Kommentare

Hallo liebe Community, nach 7 Jahren hat mein XMG Notebook seinen Geist aufgegeben In dem Notebook waren zwei Festplatten verbaut (eine für System und ...

Erkennung und -Abwehr
Wie geschickt sich Malware verstecken kann - Ein Beispiel aus der Praxis eines Security Experts
colinardoVor 1 TagTippErkennung und -Abwehr5 Kommentare

Servus Kollegen und Mitstreiter, da ja in letzter Zeit die Exchange-Lücken die Admin-Landschaft ziemlich aufgewirbelt haben und dabei auch immer mal wieder "sogenannte" Admins ...

Exchange Server
Exchange Update CU19 auf CU20 Fehler - Eine weitere Version dieses Produkts ist bereits installiert
gelöst StefanKittelVor 1 TagFrageExchange Server6 Kommentare

Hallo, ich habe hier einen Exchange 2016 mit CU19 (15.1.2176.2). Darauf wollte ich nun CU20 installiert. Download Es erscheint Eine weitere Version dieses Produkts ...

Windows Server
Hat Microsoft die WindowsServerSicherung oder diskpart zerpatcht?
anteNopeVor 20 StundenFrageWindows Server3 Kommentare

Hallo, kann es eventuell sein, dass Microsoft mit seinen letzten Updates die WindowsServerSicherung bzw. diskpart zerschossen hat? Es häufen sich bei mir seit gestern ...

Windows 10
Windows 10 Updates im Abgesicherten Modus nicht möglich!
gelöst Yuuto.LucasVor 1 TagFrageWindows 1016 Kommentare

Hallo, ich habe aktuell ein Problem bei einem Kunden Rechner. Bei diesem gibt es Probleme mit dem Soundkarten Treiber hdaudio.inf wegen dem der PC ...

Windows 10
Lokales Profil wird beim Herunterfahren gelöscht!
Yuuto.LucasVor 1 TagFrageWindows 1012 Kommentare

Hallo, ich habe aktuell folgendes Problem. An einem Kundenrechner ist aktuell ein Lokales Profil eingerichtet (vorher ein Server Profil bei dem das gleiche Problem ...

Ubuntu
Cups-Server mit SMB lehnt Verbindungen ab (smb.conf)?
ErikHeinemannVor 10 StundenFrageUbuntu17 Kommentare

Guten Morgen, ich habe einen Ubuntu 20.04 Server mit Cups als Printspooler. Nun Soll noch Samba hinzugefügt werden für eine einfache Verwendung unter Windows. ...

Exchange Server
Kaspersky for Exchange Meldungen
gelöst wieoderwasVor 9 StundenFrageExchange Server11 Kommentare

Guten Morgen, wir haben bei uns einen Exchange 2013 mit Kaspersky for Exchange und Sophos auf Dateiebene. Heute Morgen habe ich einige von diesen ...