marvil
Goto Top

EXCEL - Funktion oder Formel um Zellenwert um variablen Aufschlag zu erhöhen

WENN Funktion reicht leider nicht aus...

Folgendes hab ne Exceltabelle wo u.a. Artikel und Preise drinstehen, es gibt einen Schlüssel(siehe unterhalb) je nachdem wie hoch der EK-Preis ist um wieviel dieser aufgeschlagen werden und in nebenstehender Zelle ausgegeben werden soll.

Der Schlüssel:
von EK bis EK Aufschlag
0,01 ? 20,00 ? +13,00 ?
20,01 ? 35,00 ? +15,00 ?
35,01 ? 50,00 ? +17,00 ?
50,01 ? 75,00 ? +19,00 ?
75,01 ? 100,00 ? +20,00 ?
100,01 ? 125,00 ? +22,00 ?
125,01 ? 150,00 ? +25,00 ?
150,01 ? 175,00 ? +28,00 ?
175,01 ? aufwärts +32,00 ?

zB...
sprich liegt der EK zwischen 0 - 20 ? sollen 13 ? aufgeschlagen werden und dass Ergebnis in einer neuen Zelle ausgegeben werden.
liegt der EK zwischen 20,01 - 35 ? sollen 15 ? aufgeschlagen werden
usw...

mit der WENN Funktion klappt das leider nicht, da diese nur 7 Verschachtelungen zulässt die würde so aussehen.....

=WENN(J8<=20;J8+Aufschlaege!C3;

WENN(UND(J8>20;J8<=35);J8+Aufschlaege!C4;

WENN(UND(J8>35;J8<=50);J8+Aufschlaege!C5;

WENN(UND(J8>50;J8<=75);J8+Aufschlaege!C6;

WENN(UND(J8>75;J8<=100);J8+Aufschlaege!C7;

WENN(UND(J8>100;J8<=125);J8+Aufschlaege!C8;

WENN(UND(J8>125;J8<=150);J8+Aufschlaege!C9;

WENN(UND(J8>150;J8<=175);J8+Aufschlaege!C10;

J8+Aufschlaege!C11))))))))


jedoch meckert er mir ab der letzten Anweisung WENN(UND(...


Hat jemand von Euch ne Idee wie man das machen könnte und im Ansatz wie ? Danke im voraus!


Gruß, Martin

Content-Key: 33877

Url: https://administrator.de/contentid/33877

Printed on: February 2, 2023 at 10:02 o'clock

Member: baertel
baertel Jun 08, 2006 at 19:33:33 (UTC)
Goto Top
Hallo Martin,

versuche das ganze mit der SVERWEIS-Formel!
Mach eine Tabelle, die in der ersten Spalte den höchsten Wert jedes Aufschlags enthält.
Aufsteigend sortiert (wichtig!!)
In der zweiten Spalte den Aufschlag.

Dann beziehst Du Dich in Deiner Berechnung auf den eingegebenen EK als Suchkreterium.
Wenn Du dann den eingetragenen EK-Preis mit dem Aufschlag addierst, hast Du Dein Ergebnis!

Wenn das nicht verständlich genug war, bitte nochmal melden.

Gruß Bärtel
Member: marvil
marvil Jun 09, 2006 at 04:11:54 (UTC)
Goto Top
Thx für deine Hilfe - komm aber leider nich ganz klar damit... könntest Du mir eine einfache Mustertabelle basteln und per email zukommen lassen ? marvil@gmx.net

Häng beim SVERWEIS u wie ich dass dann addieren soll.....


Gruß, Martin
Member: marvil
marvil Jun 09, 2006 at 08:32:42 (UTC)
Goto Top
Guten Morgen,

ich habs selbst hinbekommen, hab zuerst die Tabelle gemacht wo in der ersten Spalte der höchste Wert jedes Aufschlags enthält aufsteigend daneben den jeweiligen Aufschlag, dann mit der EXCEL-Hilfe die Syntax des SVERWEIS rausgefunden.

Nur die Abfrage war noch fehlerhaft wenn ich den EK dementsprechend verändert hab.

Lösung des ganzen indem ich die Tabelle (Matrix für SVERWEIS)in den ersten zwei Spalten folgendermaßen verändert hab...

0,01 13
20 13
20,01 15
35 15
35,01 17
...
...
150,01 28
175 28
175,01 32

und siehe da es klappt.


Schwere Geburt - aber gesund :D

Bärtel, Merci nochmal für den Tipp

Gruß, Martin