Exchange 2010 Datenbank bei Prüfung inkonsistent (Logs fehlen)

flashy
Goto Top

Konsistenz-Check der MSX2010 DB schlägt fehlt, weil einige Transaktionsprotokolle fehlen

Hallo zusammen,

ich habe ein Server von einem Admin mit Halbwissen übernommen. Leider läuft das Backup des Exchange-Servers nicht so wie es sollte.
Daher brauche ich mal einen Rat von Kollegen, die mit 'korrupten' Datenbanken hier Erfahrungen haben.

Problem ist, ich wollte im ersten Schritt erst einmal ein halbwegs brauchbares Backup der DB mit Boardmitteln durch das Windows Server Backup einrichten.
Bei der Durchführung prüft das Tool die Exchange DB auf Konsistenz, was leider fehlschlägt und somit kein brauchbares/verlässliches Backup erstellt.

Die Logdateien sagen ganz klar aus, dass einige Transaction-Logs fehlen.
Diese sind leider "nicht mehr da". Die wurden per Hand gelöscht, weil die Festplatte vollgelaufen war.

So, meine Frage ist. Wie kann ich auf sicherem Weg die Exchange-DB dazu zwingen, wieder Konsistent zu sein?
So das die Prüfung vor dem Backup erfolgreich verläuft.

Ich bin bei der Suche auf die Option "ESEUTIL /P" gestoßen.
Ist das der richtige Weg bei fehlenden Logs?

Danke & Gruß,
Daniel

Content-Key: 169941

Url: https://administrator.de/contentid/169941

Ausgedruckt am: 19.08.2022 um 09:08 Uhr

Mitglied: Hubert.N
Hubert.N 18.07.2011 um 16:28:46 Uhr
Goto Top
Moin

Kannst du die Bereitstellung der Datenbank aufheben ?
Mitglied: GuentherH
GuentherH 18.07.2011 um 18:50:49 Uhr
Goto Top
Hallo.

- Stelle die Transaktionslogs um auf Umlaufprotokollierung
- führe ein Backup durch - wird, muss fehlerfrei durchlaufen - wenn nein, dann hast du ein DB Problem, sonst nicht
- lösche die nicht mehr benötigiten Transaktionslogs
- stelle wieder auf Standardprotokollierung um

Lasse bevor du dies Änderungs durchgeführt hast, die Finger von den Zusatztool.

LG Günther
Mitglied: Flashy
Flashy 19.07.2011 um 09:38:41 Uhr
Goto Top
Bisher konnte ich die Bereitstellung aufheben, Dienste neustarten und auch die DB neu mounten.
Da schien bisher alles sauber.

Danke Günther, genau auf so einen Tipp habe ich erst einmal gehofft!
Das werde ich am Wochenende in Ruhe ausprobieren.

Gruß,
Daniel
Mitglied: Flashy
Flashy 24.07.2011 um 12:51:20 Uhr
Goto Top
perfekt !

Danke, das hat geholfen!
Habe die Umlaufprotokolierung aktiviert, die Bereitstellung aufgehoben und wieder aktiviert. Danach waren automatisch alle allten Logs gelöscht.

Backup erfolgreich durchgelaufen und danach die Umlaufprotokolierung wieder deaktiviert.
Mitglied: GuentherH
GuentherH 24.07.2011 um 13:27:28 Uhr
Goto Top
Hallo.

Fein, dass es geklappt hat, und danke für die Rückmeldung face-smile

LG Günther