Exchange Datenbank leer

dukeofterror
Goto Top
Hallo,

wir hatten diese woche einen Ausfall des Exchange Serers bei dem die DB sich erabschiedet. Dies ist auch nicht mehr funktionstüchtig. Wir hatten nun am Donnerstag eine neue DB aufgesetzt was auch wunderbar funktioniert hat. Am Freitag morgen war die DB ohne jeden ersichtlichen Grund leer. Die DB's hatten 0kb was nicht sein kann da ja am Tag zuvor damit gearbeitet wurde.

Die Frage ist nun ob dies durch einen Virus oder einen Trojaner geschehen ist. Wir haben wieder einen Komplett neuen Server aufgesetzt mit neuer DB und wollen jetzt Backups einspielen, wenn dann jedoch die DB wieder leer ist hat das ja wenig sinn.

Info zum Server und Exchange.

Server ist ein Intel Q6600 2,4GHz mit einer 1TB WD Platte und 6GB RAM. Wir benutzen Exchange 2003 mit Windows Server 2003 64-bit. Als Antiviren Schutz benutzen wir NOD32 auf jedem Rechner und Server im Netzwerk.

Hat jemand eine Idee wieso die DB auf einmal leer gewesen sein kann?

MfG Raetke

Content-Key: 132024

Url: https://administrator.de/contentid/132024

Ausgedruckt am: 20.05.2022 um 14:05 Uhr

Mitglied: filippg
filippg 20.12.2009 um 14:57:39 Uhr
Goto Top
Hallo,

was sagt denn das Eventlog?
Eine 0kb große DB-Datei ist eher ungewöhnlich... Ich könnte mir einen Dateisytemfehler vorstellen,oder vielleicht auch, dass der Virenscanner eine Virus erkannt hat, und die Datei sicherheitshalber mal gelöscht hat. Ein Datei-Virenscanner darf niemals auf die Exchange-DB zugreifen, hier benötigt man immer eine speziellen Exchange-Virenscanner.

Ich würde die Festplatte nochmal prüfen (chkdsk o.ä.), den Virenscanner deaktivieren, Backup restoren, sicherstellen, dass im Virenscanner die Ausschlüssel hinterlegt sind (sowohl für die Exchange Prozesse, als auch für die Files, von MS gibt es einen KB-Artikel hierzu) und den Virenscanner wieder starten.

Gruß

Filipp
Mitglied: 48507
48507 20.12.2009 um 15:02:25 Uhr
Goto Top
Als erstes ein RAID1 einrichten und dann erst weitermachen... Ach ja, der Exchange 2003 läuft nicht unter 64-Bit.
Mitglied: filippg
filippg 20.12.2009 um 15:28:27 Uhr
Goto Top
Hallo,

Ach ja, der Exchange 2003 läuft nicht unter 64-Bit.
stimmt, das war mir entgangen http://support.microsoft.com/?scid=kb%3Ben-us%3B555468&x=23&y=1 .... Frage ist natürlich, wie Raetke den Server dann aufgesetzt hat, das sollte eigentlich bei der Installation schon fehlschlagen.

Gruß

Filipp
Mitglied: DukeofTerror
DukeofTerror 21.12.2009 um 09:10:44 Uhr
Goto Top
danke für eure antworten.

ich war wegen des betriebssystems nicht mehr auf dem neuesten stand denn es wurde natürlich die 32-bit installiert das habe ich nur nicht mitbekommen. der tipp mit dem a programm war allerdings schon sehr gut. wir haben es nun ohne av programm vorlaüfig und die db war heute morgen prall gefüllt. vielen dank für eure antworten. puh, vielleicht komm ich ja nu zu meine wochenende :D

danke noch mal,

Raetke
Mitglied: DMeyer
DMeyer 21.12.2009 um 22:02:55 Uhr
Goto Top
Hallo,

- Festplattencontroller fehlerhaft?
- Virenscanner, der die Datenbank gescannt und Virus erkannt hat und die DB gekillt hat
- Vielleicht Dateisystemfehler

Gruß

Daniel