Dieser Beitrag ist schon älter. Bitte vergewissern Sie sich, dass die Rahmenbedingungen oder der enthaltene Lösungsvorschlag noch dem aktuellen Stand der Technik entspricht.

Exchange Server 2007 lokale E-mails versenden

Mitglied: gmax2007
Hallo,

habe ein kleines Konfigurations- bzw. evtl. auch Verständisproblem:

Wir haben ins unserer Firma einen Windows 2008 Small Business Server installiert. Exchange 2007 läuft dort standardmäßig mit und ist einsatzbereit.
Die interne Domäne ist xyz.local und die Nutzer können im Intranet problemlos e-Mails versenden & empfangen. Der Win2008SB Server selbst ist nur lokal erreichbar und nicht von außen.

Die "echten" E-Mail Adressen sind extern und lauten jedoch ...@xyz.de. Sie werden über den Provider 1&1 versendet und empfangen.
Dank des in Exchange 2007 integrierten POP3-Connectors werden nun die externen E-Mails bspw. h.mustermann@xyz.de abgeholt und an das jeweilige lokalen Postfach des internen Nutzer (h.mustermann@xyz.local) weitergeleitet.

PROBLEM: Wenn der interne Nutzer nun eine e-Mail Nachricht vom internen Netz aus (bspw. h.mustermann@xyz.local) an e.musterfrau@t-online.de versenden möchte, können die Mails nicht zugestellt werden. Dies liegt natürlich an denn SMTP Einstellungen der einzelnen Nutzer; allerdings konnte ich keine Einstellung unter Exchange 2007 finden um dies zu konfigurieren.

Danke für ein paar Hilfen und Tipps.

Content-Key: 101898

Url: https://administrator.de/contentid/101898

Ausgedruckt am: 04.08.2021 um 01:08 Uhr

Mitglied: Janni
Janni 15.11.2008 um 13:24:01 Uhr
Goto Top
Du musst Deinem Exchange noch sagen wie er die E-mails versenden soll. Dazu benötigst Du einen SMTP Connector, siehe http://www.msexchangefaq.de/howto/e2k7sendconnector.htm

Du kannst die E-mail direkt oder über einen Server von 1&1 senden (war, glaube ich SMTP-Server: smtp.1und1.com).
Mitglied: gmax2007
gmax2007 15.11.2008 um 13:26:20 Uhr
Goto Top
Hi Janni,

super vielen Dank! Ich teste das gleich aus und gebe Bescheid.
Wußte nicht, dass es auch einen SMTP-Connector gibt.
Mitglied: Janni
Janni 15.11.2008 um 13:34:25 Uhr
Goto Top
Falls Du Deine E-mails direkt versenden möchtest, dann brauchst Du noch einen MX-Record Eintrag mit kleiner Priorität (siehe http://de.wikipedia.org/wiki/Mx_record) auf Eure öffentliche IP Adresse, da einige Server (z.B. GMX) den abfragen, um die Echtheit des Senders zu prüfen (Spamvermeidung).
Mitglied: gmax2007
gmax2007 15.11.2008 um 13:48:36 Uhr
Goto Top
Also bei einer Sache hänge ich jetzt trotzdem fest:

Jede externe E-mail Adresse hat eine interne. Bspw:

h.mustermann@xyz.de -> h.mustermann@xyz.local
e.musterfrau@xyz.de -> e.musterfrau@xyz.local

Das sind jeweils Postfächer - sowohl intern als auch extern - die eine Authentifizierung erfordern. Bei 1&1 ist das so geregelt, dass sich der Nutzer mit seiner e-mail adresse (Nutzername) und passwort dort anmelden muss.
Posteingangsserver ist pop.1und1.de und der Ausgangsserver smtp.1und1.de

wenn jetzt der lokale User h.mustermann@xyz.local von intern aus eine e-Mail nach draußen versendet, dann muss sich doch dieses Postfach wieder extern authentifizieren bei h.mustermann@xyz.de. Dies gilt dann für jeden Nutzer separat.


Aktuell hänge ich da mit den Konfigurationseinstellungen des SMTP-Connectors fest.
Mitglied: Janni
Janni 15.11.2008 um 14:16:20 Uhr
Goto Top
Es reicht, wenn sich irgendein User für den SMTP Connector authentifiziert. Der smtp.1und1.de möchte nur wissen, ob Ihr berechtigt seid überhaupt E-mails über ihn zu senden. Ich würde bei 1&1 einen Dummy-User auth@firma.de anlegen und diesen dann zum anmelden benutzen.
Mitglied: gmax2007
gmax2007 15.11.2008 um 14:34:00 Uhr
Goto Top
Danke! Das werde ich machen und hoffe es funktioniert.

Geklappt hat der erste Schritt noch nicht.
Beim Anlegen des SMTP-Connectors stellt sich zunächt die Frage ob die "MX-Datensätze zum Weiterleiten von E-Mail weiterleiten" oder "E-Mails über Smarthost" weitergeleitet werden sollen.


Bei MX-Datensätze kann ich leider nur den per default eingetragenen SERVER verwenden. Bei Smarthost würde sich dann die Frage nach der korrekten IP-Adresse oder FQDN ergeben.

Hmmm... irgendwie ist das doch komplizierter als ich dachte. ;-(
Mitglied: gmax2007
gmax2007 15.11.2008 um 14:36:57 Uhr
Goto Top
... oder die Frage sollte eher lauten:

Wie weiß der Exchange Server, dass der interne Nutzer h.muster@xyz.local die externe Adresse h.muster@xyz.de besitzt?
Mitglied: Janni
Janni 15.11.2008 um 14:39:09 Uhr
Goto Top
Weil Du das in den Eigenschaften des Users im AD mit angibst ..... wie immer schon ......
Mitglied: gmax2007
gmax2007 15.11.2008 um 14:49:52 Uhr
Goto Top
korrekt, nur wo da?
Also: "Active Directory-Benutzer und Computer" -> xyz.local -> users -> SBSusers -> h.muster -> ?
Mitglied: filippg
filippg 15.11.2008 um 16:27:29 Uhr
Goto Top
Hallo,

du darfst/solltest den Nutzern gar keine "internen" Adresse mit xyz.local vergeben. Vergib nur Adressen mit xyz.de. Bei denen, die schon eine .lokal haben entferne die entweder ganz, oder mache (wenn du sie nicht entfernen willst, weil sie z.B. schon in internen Adressbüchern ist) die .de zur primären.

Für die ausgehenden Mails musst du "E-Mails über Smarthost" wählen. Und der Hostname dafür? Ja, keine Ahnung, eben der 1u1-Host, über den du Mails versenden kannst.

Gruß

Filipp
Mitglied: gmax2007
gmax2007 15.11.2008 um 16:38:28 Uhr
Goto Top
Vielen Dank!

Es wäre sozusagen im ersten Schritt hilfreich, wenn die interne und externe Domäne gleich heißen würden; auch wenn die beide Domänen nichts mit einander zu tun haben. Ich benenne also die xyz.local in xyz.de komplett um und die User haben dann auch automatisch dieselben E-Mail Adressen intern wie extern.

Habe hier auch indirekt noch folgende Hilfe erhalten: https://www.administrator.de/Exchange_-_interne_und_externe_Exchange-Dom ...
Mitglied: filippg
filippg 15.11.2008 um 17:00:56 Uhr
Goto Top
ICH HASSE MEINEN BROWSER! Jetzt hatte ich einen schönen langen Text geschrieben, dann aus versehen falsch gedrückt - schwups ist alles weg.

Also Kurzfassung:
Verwechsle nicht SMTP-Domain und AD-Domain. Erstere sollte immer global auflösbar sein, letztere in den allermeisten Fällen nicht.
Belasse den Namen deiner AD-Domain bei .local (kann man, wenn Exchange installiert ist, eh nicht mehr ändern). Füge aber bei Exchange die xyz.de als AcceptedDomain hinzu und mache sie zur Default-Domain (Set-AcceptedDomain in der ManagementShell). Typ: Wenn es beim Prodivder keine Email-Adressen gibt, die es bei dir nicht gibt mache sie zu Authoritative, andernfalls zur ExternalRelay (Aufklärung über die Begriffe findet sich im Internet, es geht darum, wie Exchange mit Mails verfährt die an Adressen aus der jeweiligen DOmain gerichtet sind, die er aber nicht kennt).
Nach dem Hinzufügen der neuen SMTP-Domain haben die Nutzer nicht automatisch die selben Adressen intern wie extern, da muss man separat ran.

Gruß

Filipp
Mitglied: gmax2007
gmax2007 15.11.2008 um 17:12:49 Uhr
Goto Top
Oh verdammter Browser! :-) face-smile Hätte gerne den Text gelesen.

Ganz herzlichen Dank an Dich für die Erklärungen. Ich bin sozusagen ein Laie auf dem Thema und schon super froh, dass alles so gut von Anfang an und ohne Probleme funktioniert hat mit der Installation und Konfiguration. Ja sogar der Virenscanner funktioniert tadellos ;-) face-wink

Das Einzige an dem es hängt ist die genannte Geschichte. Ich werde nun Deine "Kurzfassung" beherzigen und umsetzen. Bis morgen sollte ich es dann hoffentlich geschafft haben (am Montagabend soll das ganze dann offiziell in Betrieb gehen).

Melde mich asap

Grüße
gmax
Mitglied: gmax2007
gmax2007 15.11.2008 um 17:57:51 Uhr
Goto Top
Kurzes Feedback:

Habe es so gemacht wie Du sagtest. Was jetzt funktioniert ist, dass wenn der lokale nutzer (von LOKAL aus) h.muster@xyz.local eine e-mail bspw. an die beiden Adressen h.muster@xyz.de und e.frau@xyz.de versendet, diese direkt über den lokalen Exchange-Server in die jeweiligen @xyz.local Postfächer wandern.


Was leider immer noch nicht geht ist folgendes:
hans muster sitzt lokal im LAN am Rechner und sendet von seinem Postfach aus (bspw. via OWA) eine e-Mail an irgendwem@aol.com, dann können die Nachrichten einfach nicht zugestellt werden ins Internet.

Einen SMTP-Sendeconnector habe ich erstellt und auch gesagt, dass er sich mit einem registrierten externen E-Mail Account (bspw. info@xyz.de + password) dort anmelden soll...
Mein Gefühl sagt mir, dass hier etwas unvollständig ist und ich was übersehen habe.
Mitglied: filippg
filippg 15.11.2008 um 19:44:02 Uhr
Goto Top
Hallo,

sprich: ausgehendes Routing in's Internet funktioniert nicht. Richtig?
Dann ist die Frage ja, was mit dem Mails passiert. Hängen sie bei dir in der Queue fest? Das ist das wahrscheinlichste. Dann solltest du aber irgendwann einen Benachrichtigung bekommen, dass es nicht funktioinert und der Server die Zustellversuche aufgibt. So eine schonmal bekommen? Was steht dabei?
Es gibt zwei wahrscheinliche Ursachen:
1. die ausgehende Verbindung wird von der Firewall geblockt
2. der 1u1-Server nimmt die Mails aus Sicherheitsgründen nicht an
Um das weiter einzugrenzen hilft telnet. Starte das auf dem Exchange, auf der Kommandozeile "telnet DeinSmarthost 25". Was passiert? Wenn der Smarthost antwortet wird es nicht 1. sein. Versuche eine Mail zu senden. Wie das geht steht z.B. hier: http://www.msexchangefaq.de/internet/smtptelnet.htm Was kommt raus? Wahrscheinlich will der Host ein SMTP-Auth. Dann wird es kniffelig. Eine Anleitung dazu gibt's unter http://blog.computer-tipps.info/2006/09/27/smtp-auth-mit-telnet-testen/ aber dazu braucht man ein Linux-Tool für die Codierung.
Weiterhin gibt's ja auch die Logs in Exchange. Siehe hierzu http://exchangepedia.com/blog/2007/05/exchange-server-2007-logging-smtp ... Was findet sich da?

Was noch gut möglich ist ist, dass als Absenderadresse nur der Account, mit dem du dich am Smarthost anmeldest erlaubt ist. Teste das aus, indem mal versuchst, mit diesem Postfach von Exchange eine Mail zu schicken (um bei obigen Namen zu bleiben: gib einem Testpostfach im Exchange die Absenderadresse auth@firma.de und sende von diesem aus).

Gruß

Filipp
Mitglied: Janni
Janni 15.11.2008 um 21:17:23 Uhr
Goto Top
Was noch gut möglich ist ist, dass als Absenderadresse nur der
Account, mit dem du dich am Smarthost anmeldest erlaubt ist.

Bei 1&1 kannst Du einen Dummy-User einsetzen (funktioniert jedenfalls bei einem Kunden der bei 1&1 ist, irgendsoein Business Tarif von 1&1).

Ich würde so aus dem Bauch heraus einmal auf eine Firewall oder einen Schreibfehler oder so tippen. Schau bitte aber erst einmal in die Warteschlange des Exchange, ob da Mail drinnen sind. Dort steht dann auch eine Fehlermeldung dazu (die der Admin aber auch per E-mail bekommt).
Mitglied: gmax2007
gmax2007 16.11.2008 um 10:45:26 Uhr
Goto Top
Hallo ihr Beiden,

vielen Dank an euch. Ich mache mich jetzt an die Arbeit.

Kurz zu euren Meinungen:

1. Ja, es kann eine Verbidnung bspw. via "telnet smtp.1und1.de 25" problemlos aufgebaut werden. Die Firewall blockt zum Glück nichts.
2. Korrekt! E-Mails die nach extern versendet werden können nicht zugetellt werden. Exchange sendet folgende Nachricht an den User zurück: "Die Zustellung an folgende Empfänger oder Verteilerlisten wurde verzögert: (...) Diese Nachricht wurde noch nicht zugestellt. Microsoft Exchange versucht auch weiterhin, die Nachricht in Ihrem Auftrag zuzustellen. Die Zustellung dieser Nachricht wird bis 17.11.2008 14:53:38 (GMT+01:00) Amsterdam, Berlin, Bern, Rom, Stockholm, Wien versucht. Microsoft Exchange benachrichtigt Sie wenn die Nachricht bis zu diesem Zeitpunkt nicht zugestellt werden kann."


Ich checke jetzt mal alles durch und hoffe ich löse das Problem. Melde mich aber so oder so ;-) face-wink

Grüße

gmax
Mitglied: gmax2007
gmax2007 16.11.2008 um 12:55:03 Uhr
Goto Top
Okay, es hängt leider immer noch an dieser Sache.
In der "Exchange-Verwaltungskonsole -> Organisationskonfiguration -> Hub-Transport -> Akzeptierte Domänen" habe ich zusätzlich die Domäne meinefirma.de als Externes Relay eingetragen.

Unter -> Sendeconnectors ist jetzt auch richtig der smtp.1and1.com drin.

Aus irgendeinem unerklärlichen Grund werden dennoch die mails nicht rausgesendet, sonder sind in der Warteschlange bis zum Ablauf.
Es ist wie verhext!
Mitglied: gmax2007
gmax2007 16.11.2008 um 13:16:22 Uhr
Goto Top
so, jetzt habe ich es mit telnet einmal manuell versucht:
telnet "smtp.1and1.com 25" (1and1.com 25 geht leider nicht, deshalb .smtp davor) und ich erhalte das:

220 smtp.perfora.net (mrus0) Welcome to Nemesis ESMTP server
ehlo
501 EHLO requires domain address
helo
501 HELO requires domain address
ehlo meinefirma.com
250-mrus0.perfora.net
250-STARTTLS
250-AUTH LOGIN PLAIN
250-AUTH=LOGIN PLAIN
250-PIPELINING
250-SIZE 52428800
250 HELP
HELP
214 no help available
mail from:info@meinefirma.com
250 mail from: <info@einefirma.com> ok
rcpt to:support@meinefirma.com
550 must be authenticated

Hat jemand eine Idee?
Mitglied: Janni
Janni 16.11.2008 um 13:35:51 Uhr
Goto Top
Unter -> Sendeconnectors ist jetzt auch richtig der smtp.1and1.com
drin.


1and1.com kenne ich leider nicht, aber smtp.1und1.de sollte gehen.

550 must be authenticated
Irgendwo verschrieben (User oder Passwort) ?

Hattest Du hier: http://www.msxfaq.de/howto/e2k7sendconnector.htm auch einmal rein geschaut ?
Mitglied: gmax2007
gmax2007 16.11.2008 um 14:42:39 Uhr
Goto Top
@Janni: Ja habe ich, aber es hakt trotzdem noch irgendwo. Nur leider weiß ich echt nicht mehr wo ich noch nachschauen soll bzw. Einstellungen modifizieren/hinzufügen kann.
Mitglied: filippg
filippg 16.11.2008 um 16:31:45 Uhr
Goto Top
Hallo,

nachdem Firewall ausgeschlossen ist, schau dir mal die SMTP-Send-Logs vom Exchange an.
Im Zusammenhang mit Auth und TLS ist Telnet leider kaum zu gebrauchen.

Hast du denn schonmal die 1und1 Support-Seiten durchsucht? Den Servernamen scheinst du ja geraten zu haben, vielleicht liegt hier schon der Fehler?

Gruß

Filipp
Mitglied: gmax2007
gmax2007 16.11.2008 um 17:16:13 Uhr
Goto Top
@fillipp: Danke! Wo finde ich speziell die SMTP-Send-Logs vom Exchange? Konnte sie (noch) nicht finden!
Mitglied: filippg
filippg 16.11.2008 um 17:34:35 Uhr
Goto Top
Hallo,

hatte ich oben gepostet (und findet sich im Internet). http://exchangepedia.com/blog/2007/05/exchange-server-2007-logging-smtp ...

Vergiß nicht, mal bei 1u1 zu schauen, ob sich da sachdienliche Hinweise finden.

Gruß

Filippp
Mitglied: gmax2007
gmax2007 17.11.2008 um 11:53:31 Uhr
Goto Top
Hi!

Das funktioniert leider alles nicht. ich schreibe mal den Support bei 1&1 an und frage konkret nach.
Sobald ich die Lösung habe poste ich sie hier.

Bis dann

gmax
Heiß diskutierte Beiträge
question
Backup-Konzept für HeimgebrauchmossoxVor 1 TagFrageBackup13 Kommentare

Guten Tag zusammen, ich bin mir nicht sicher, ob ich das richtige Unterforum gewählt habe, denn meine Frage berührt auch den Bereich Hardware und Netzwerke. ...

question
Günstiges Open-Source NAS für HeimgebrauchpanguuVor 1 TagFrageSAN, NAS, DAS10 Kommentare

Hallo, mit NAS-Systemen hatte ich bisher gearbeitet: Synology, QNAP, Buffalo, etc. Dabei kommen proprietäre Betriebssysteme zum Einsatz, die sich natürlich von Hersteller zu Hersteller unterscheiden ...

question
Domains, die mir gehören gelöst IT-EinsteigerVor 1 TagFrageInternet Domänen5 Kommentare

Hi, Ich habe verschiedene Domain, bei verschiedenen Hostern. Da ich hier und da nur eine Domain gekauft habe, um den Hoster zu testen, habe ich ...

question
Ipv6 RouterliodiceVor 1 TagFrageDSL, VDSL10 Kommentare

Hallo zusammen, ich hoffe ihr könnt mir weiterhelfen, ich benötigen einen ADSL Router (Kabelgebundenen) der IPv4 und IPv6 kann, also Dual Stack (DHCP Extern und ...

question
PC geht ohne Vorwarnung aus und fährt wieder hochWasserstrahlbiegezangeVor 1 TagFrageHardware14 Kommentare

Hi, vor einiger Zeit hat mein PC angefangen sich merkwürdig zu verhalten. Er stürzte einfach ab, ging dabei teilweise ohne Vorwarnung aus, und fuhr wieder ...

question
Server 2019 std. auf deutsch umstellenBender999Vor 11 StundenFrageWindows Server19 Kommentare

Hallo, kann mir einer erklären wie um alles in der Welt ich meinen Server 2019 std. auf deutsch umstellen kann? ...

question
Prozess bzw. Programm zu Verbindung auf IP herausfinden gelöst dcmindenVor 1 TagFrageWindows Netzwerk8 Kommentare

Wir bekommen bei diversen Kunden regelmäßig (alle 6 - 8 Tage) Alarmmeldungen von der Firewall zu einer geblockten Verbindung zu 68.183.140.225 Port 443. Jetzt möchten ...

question
Textdatei anhand xy-Koordinaten auslesen gelöst LeaX55Vor 1 TagFrageBatch & Shell11 Kommentare

Hallo Gemeinde, gibt es in Powershell eine Möglichkeit ein Text/Zahl aus einer Textdatei auszulesen anhand xy-Koordinaten? Als Beispiel habe ich eine Textdatei, aus der ich ...