Explorer.exe startet nicht mehr, suche Diagnosemöglichkeiten

rafiki
Goto Top

Einen Virus verseuchten PC, nur so zum lernen, genau untersuchen und verstehen

Hallo Admins,

ich habe hier gerade einen PC mit WinXP-home von einem Freund der zwar alle Software die man so im Internet bekommen kann installiert hat, aber eine Antivirussoftware war nie dabei. Der Explorer startet nicht mehr nach dem anmelden. Das heißt der Desktop baut sich nicht mehr auf. Über den Taskmanager kann man andere Programme starten. Sogar mmc -> compmgmt funktioniert!

Die wenigen wichtigen Dateien haben wir gerettet und am Montag wird der PC platt gemacht. Aber bis Montag, wenn er seine Recovery CD gefunden hat, ist der Rechner mein Spielzeug. <fieses Lachen: Hi hi hi > Nun habe ich bereits die Festplatte ausgebaut, in einem anderen PC dahinter gehängt und die Sammlung von 16(!) Viren und Trojanern gelöscht. Leider läuft der Explorer Prozess noch nicht wieder. Ich vermute das ein Virus (oder sonstiges Programm) Einstellungen in der Registry vorgenommen hat die falsch sind. Wenn die Explorer.EXE über den Taskmanager starte dann zuckt der Explorer kurz auf dem Bildschirm. Der Startbutton ist für Sekundenbruchteile zu sehen dann ist der Task wieder aus der Prozessliste verschwunden. Dann ist der Desktop wieder leer.
Es gibt keinen Eintrag im Eventlog der auf einen Fehler schließen lässt. Mit autoruns (von http://www.sysinternals.com) habe ich bereits gut aufgeräumt. Dial-a-fix hat auch nicht geholfen und selbst eine Reparaturinstallation war NICHT erfolgreich.

Ich wieder hole mich gerade, aber am Montag wird der PC eh platt gemacht. Also bitte keine Kommentare wg. Das wird doch nichts und Zeitverschendung. Abgesehen davon: "Mit Linux wäre das nicht passiert" und "Gates ist schuld". Es geht mir einfach nur darum zu lernen was kaputt ist.

Wer kennt weitere Reparaturtricks?
Gibt es eine Diagnosemöglichkeit warum sich der Explorer sofort wieder beendet?
Regedit HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon sieht für mich gut aus. Die winlogon.exe versucht ja auch tatsächlich den Explorer zu starten.
Gemäß ProcessExplorer scheint jetzt kein Virus mehr aktiv zu sein.
Ich bin für eure kreativen Vorschläge offen.

Gruß Rafiki

Content-Key: 38792

Url: https://administrator.de/contentid/38792

Ausgedruckt am: 18.05.2022 um 05:05 Uhr

Mitglied: 17243
17243 26.08.2006 um 18:24:00 Uhr
Goto Top
Hi Rafiki

Sorry, wenn das nun etwas "hart" rüberkommt.
Aber für solche Spielereien werde ich sicher keine Zeit investieren. Wie du schreibst, wird der Rechner am Montag sowieso Platt gemacht.

Es geht mir einfach nur darum zu lernen
Auch wenn du es nicht hören willst: das ist Zeitverschwendung!
Viele von uns sind Admins im professionellen Umfeld. Da ist es nicht möglich, solche Sachen mit tagelangem Probieren herauszufinden.
Auch wenn du den explorer.exe wieder zum Leben erwecken kannst: aus Erfahrung kann ich dir sagen, dass dir dieser Rechner immer wieder Probleme machen wird.

Versuche doch selber, den Fehler zu finden. Das ist viel Interessanter als wenn dir hier jemand die Lösung gibt. Heute ist erst Samstag! Wenn dir einer die Lösung Heute sagt: was machst du dann am Sonntag??
Darum: tüfteln...suchen...probieren... > du hast Zeit bis Montag ;-) face-wink

gretz drop
Mitglied: LordSealSound
LordSealSound 26.08.2006 um 18:37:41 Uhr
Goto Top
Tag, "Gates is schuld" :-D face-big-smile

Nein, mal im Ernst es gibt da schon noch ein paar Dinge die man machen kann.
Da du ja weißt dass es keinen Sinn hat kann man sich jetzt auf´s experimentieren konzentrieren.

In der Norton SystemWorks Suite gibt´s n Tool namens PC-Doktor, es gibt Leute die diese Programmm nicht mögen aber ich find´s super, es gibt gewiss eine Trilaversion.

Man kann mit bestimmten Tools auch einfach komplette Regestrypfade von einem System zum anderen portieren (sprich: nehme Regisrtypfad A von System A und importiere es in System B mit Regisrty B).
Damit hat man eine Chance die kaputte Regisrty zu Reparieren obwohl es auch gute Diagnose Tools speziell für die Regisrty gibt.

Wenn du interesse hast einfach mal googlen, sag bescheid dann kann ich auch mal schauen wenn du möchtest.
Mitglied: LordSealSound
LordSealSound 26.08.2006 um 18:44:11 Uhr
Goto Top
Tag drop_ch (Ivo)


Viele von uns sind Admins im professionellen
Umfeld. Da ist es nicht möglich, solche
Sachen mit tagelangem Probieren
herauszufinden.

Er weiß dass es Sinnlos ist, Du weißt es und ich weiß es auch aber ich denke dass Rafiki eben nicht nach einer Lösung gefragt hat sondern nach einer Anregung weiter zu tüfteln (siehe mein Beitrag).

Klar hast du Recht damit dass sich Administratoren meist nicht mit sowas aufhalten können, aber er hat diese Zeit und will lernen. Manchmal ist ein kleiner Anstoß in die richtige Richtung nicht verkehrt.

(wir sinn ja zum Probleme lösen hier)

Greetz LordSealSound
Mitglied: taxer
taxer 25.10.2007 um 13:31:52 Uhr
Goto Top
Ist zwar schon einiges her, aber es gibt eine Lösung für dieses Problem ohne Neuinstallation.

1. Taskmanager öffnen und neuen Task ausführen.
2. c:\windows\system32\appwiz.cpl eingeben.
3. Den GoogleDesktop deinstallieren.
4. Neustart

Und schon läuft wieder alles.
Mitglied: Rafiki
Rafiki 25.10.2007 um 21:26:28 Uhr
Goto Top
Danke für den Tipp. Das habe ich gleich mal nachgesehen, der Google Desktop war/ist nicht installiert.
Nur so als Info am rande, aus dem Rechner habe ich ein Virtual Machine gemacht. Das Problem konnte ich bis heute noch nicht lösen.

Der echte Rechner ist längst frisch installiert und arbeitet noch immer, dank DSL Router, AntiVirus Software und deutlich weniger "gesaugte" Software.

Gruß Rafiki
Mitglied: taxer
taxer 26.10.2007 um 08:40:30 Uhr
Goto Top
Ich hatte es auch nicht installiert. Es steckte aber trotzdem irgendwo im System. Hab den Google Desktop installiert und wieder deinstalliert und schon ging alles wieder.
Mitglied: 1lluvatar
1lluvatar 25.11.2007 um 13:28:22 Uhr
Goto Top
Super, genau das hat mir jetzt auch geholfen:

1. Google Desktop installieren
2. Google Desktop deinstallieren
3. Neustart

und schon ist alles wieder wie gehabt.
Vielen Dank =)
Mitglied: jopru
jopru 02.09.2008 um 09:23:26 Uhr
Goto Top
Hallo Rafiki,

habe sehr ähnliches Problem. Nur dass wenn ich die explorer.exe über den Taskmanager starte, kommt die Meldung, dass er die explorer.exe nicht findet, obwohl diese natürlich da ist. Übergangslösung : Eine Kopie der explorer.exe auf explorer1.exe, die registry unter winlogon entsprechend geändert auf explorer1.exe und es läuft wieder. Dies kann natürlich nicht die entgültige Lösung sein, auch ich wäre an der Ursache des Problems interessiert, liegt wahrscheinlich an einem fehlerhaften registry Eintrag, da die explorer.exe sicher ok ist. Auslöser war der Trojaner/Wurm AntivirusXP 2008.

jopru