Hop 2 bei tracert auf eine IP im Internet ist in einem anderen Netzwerk als externe Schnittstelle von Hop 1?!

Mitglied: manotada

manotada (Level 1) - Jetzt verbinden

13.02.2016 um 16:19 Uhr, 1405 Aufrufe, 12 Kommentare

Hallo zusammen,
ich habe ein bisschen was mit Tracert ausprobiert und dabei folgendes festgestellt: Die Adresse des zweiten Hops ist immer die gleiche, was ja auch völlig normal ist. Allerdings befindet sich diese Adresse in einem anderen Netzwerk, als die Adresse der externen Schnittstelle meines Heimrouters (also Hop 1). Subnetzmaske habe ich zwar keine, aber die eine Adresse war 80.x.x.x und die andere 90.x.x.x und solch große Netzwerke sind mir nicht bekannt.
Ich frag mich also, wie das sein kann. Eigentlich müsste zwischen beiden Routern noch mindestens ein weiterer Router sein, der diese Netze verbindet. Ich sehe davon beim Tracert aber nichts.
Mitglied: michi1983
13.02.2016 um 16:40 Uhr
Hallo,

wie wäre es wenn du uns 1. eine Skizze deines Netzes inkl. verwendeter Komponenten und IP Adressierung hier rein stellst und 2. die Ausgabe deines tracert postest? ;-) face-wink

Gruß
Bitte warten ..
Mitglied: manotada
13.02.2016 um 17:11 Uhr
Ja, kein Problem. Es geht hier übrigens nicht um "mein" Netz, sondern um das meines ISPs:
Skizze (nicht schön, aber selten)

Bitte warten ..
Mitglied: michi1983
13.02.2016 um 17:19 Uhr
Ich weiß nicht genau worauf du hinaus möchtest?
Die Hops sind allesamt von der deutschen Telekom (dein Provider) und gehen dann ins Netz von heise über.
Was ist daran also komisch?

Gruß
Bitte warten ..
Mitglied: manotada
13.02.2016 um 17:34 Uhr
Wie in der Skizze und im Text dargestellt geht es mir nur um den Teil zwischen meinem Router und dem ersten Router der Telekom. Diese sind nach meiner Theorie nicht im gleichen Netz und ich frage mich, wie das sein kann. Falls du dich fragst, wie ich da drauf komme: Habe die externe IP meines Routers im Webinterface nachgeschaut und die ist 90.x.x.x
Bitte warten ..
Mitglied: jsysde
13.02.2016 um 18:19 Uhr
N'Abend.

Würde dir dein Router statt seiner internen die externe IP ausgeben, wäre diese eben jene 90.x.x.x.

Cheers,
jsysde
Bitte warten ..
Mitglied: manotada
13.02.2016 um 19:25 Uhr
Das ist mir schon klar. Irgendwie versteht keine meine Frage :/
Die externe IP meines Routers ist 90.x.x.x (abgelesen am Router)
Die IP der nächsten Routerschnittstelle ist 80.x.x.x (abgelesen Hop 2 von Tracert)
Daraus folgere ich, dass diese beiden Adressen nicht im gleichen Netzwerk sind. Es wäre mit einer Subnetzmaske von /2 zwar möglich, aber ich denke nicht, dass es soetwas gibt. Wie kann es also sein das die beiden Routerschnittstellen miteinander kommunizieren können? Eigentlich wäre ja mindestens ein weiterer Router dazwischen notwendig.
Bitte warten ..
Mitglied: LordGurke
13.02.2016 um 20:42 Uhr
Das liegt daran, dass du per PPP (Point-To-Point) mit dem Einwahlrouter der Telekom verbunden bist. Bei PPP spielen Netzmasken im Prinzip reine Rolle, weil da die Adressierung der Pakete anders erfolgt als über das normale, nackte Ethernet.

Davon abgesehen kann es passieren, dass Router auf einem Interface mehrere IP-Adressen haben und dann nicht zwingend mit der "erwarteten" IP-Adresse antworten sondern mit der, die als erstes am Interface gebunden ist.
Bitte warten ..
Mitglied: manotada
13.02.2016 um 21:43 Uhr
Juhu, endlich jemand der mit versteht :) face-smile
Jetzt zum Thema: IP ist aber doch in der Schicht über PPP. Das funktioniert doch unabhängig von einander und kann nicht einfach ignoriert werden oder? IP- und MAC-Adressen sind im Normalfall ja auch unabhängig von einander.

Die Sache mit mehreren Adressen pro Interface war mir nicht bekannt. Kenne das bisher nur von IPv6.
Bitte warten ..
Mitglied: Lochkartenstanzer
14.02.2016, aktualisiert um 10:27 Uhr
Zitat von @manotada:
Jetzt zum Thema: IP ist aber doch in der Schicht über PPP. Das funktioniert doch unabhängig von einander und kann nicht einfach ignoriert werden oder? IP- und MAC-Adressen sind im Normalfall ja auch unabhängig von einander.


Ganz einfach: wenn Du einen Punkt-zu-Punkt-Link hast sind die IP-Adressen im Prinzip egal. Sie werden nur genutzt, um den Link zu identifizieren.Als Gateway der Route steht dann nur der Link drin. Da wird keine Adresse aus dem gleichen "Netz" benötigt, weil es genaugenommen ga keine Netze bei solche Links gibt, sodnern nur ggenau zwei Nodes, die miteinender reden. Das ganze Brimborium mit Netzmaske, MAC-Adresse, IP-Adresse brauchst Du nur in Topologien, wo mehrere Ziele adressiert werden können, wie z.B. Token ring oder Ethernet. Bei Punkt-zu-Punkt-Verbindungen ist das prinzipiell unnötig, wird aber des Konsistenz halber verwendet.

lks

PS: Die Telekom hat das AS3320. Da sind sehr viele große Adressbereiche drin. Welche das sind überlasse ich zur Übung dem TO. :-) face-smile
Bitte warten ..
Mitglied: Lochkartenstanzer
14.02.2016 um 10:31 Uhr
Zitat von @manotada:

Subnetzmaske habe ich zwar keine, aber die eine Adresse war 80.x.x.x und die andere 90.x.x.x und solch große Netzwerke sind mir nicht bekannt.

Nur weil Du sie nicht kennst, heißt das nicht, daß sie nicht existieren. :-) face-smile

lks
Bitte warten ..
Mitglied: manotada
14.02.2016 um 17:10 Uhr
Ok, meint ihr jetzt, dass der Hop 2 mit 80.x.x.x tatsächlich der zweite Hop ist und ich mit diesem per PPP verbunden bin oder eher, dass da noch ein anderer Router für PPP dazwischen ist, der bei Tracert nicht erscheint?
Bitte warten ..
Mitglied: LordGurke
14.02.2016 um 18:26 Uhr
Was zwischen den zwei PPP-Endpunkten liegt kannst du in einem Traceroute so erstmal nicht sehen.
Bei PPPoE (bei DSL) hast du nur ein reines Ethernet-Netzwerk zwischen dir und dem PPP-Router, welches entweder tatsächlich reines L2-Switching ist oder per MPLS irgendwohin "geroutet" wird.

Für dich ist das aber trotzdem der zweite Hop, da du ja mit dem Traceroute nur herausfindest, welchen Weg ein Paket über eine bestimmte Verbindung zu einem bestimmten Ziel nimmt. Also ist der zweite Hop tatsächlich der zweite Hop für die Verbindung durch PPP ;-) face-wink
Bitte warten ..
Heiß diskutierte Inhalte
Festplatten, SSD, Raid
Festplatte aus defekten Notebook ausgebaut - wird nicht erkannt - Wie gelange ich an meine Daten?
gelöst 1nCoreVor 1 TagFrageFestplatten, SSD, Raid15 Kommentare

Hallo liebe Community, nach 7 Jahren hat mein XMG Notebook seinen Geist aufgegeben In dem Notebook waren zwei Festplatten verbaut (eine für System und ...

Erkennung und -Abwehr
Wie geschickt sich Malware verstecken kann - Ein Beispiel aus der Praxis eines Security Experts
colinardoVor 1 TagTippErkennung und -Abwehr5 Kommentare

Servus Kollegen und Mitstreiter, da ja in letzter Zeit die Exchange-Lücken die Admin-Landschaft ziemlich aufgewirbelt haben und dabei auch immer mal wieder "sogenannte" Admins ...

Windows Netzwerk
MS Lizenzierung - externe Scandienstleistung
monstermaniaVor 1 TagFrageWindows Netzwerk9 Kommentare

Hallo Allerseits, ich habe da mal eine Frage an die MS Lizenzspeziallisten. Eine externe Firma soll Scandienstleistungen für uns erledigen. Dazu ist angedacht, dass ...

Exchange Server
Exchange Update CU19 auf CU20 Fehler - Eine weitere Version dieses Produkts ist bereits installiert
gelöst StefanKittelVor 1 TagFrageExchange Server6 Kommentare

Hallo, ich habe hier einen Exchange 2016 mit CU19 (15.1.2176.2). Darauf wollte ich nun CU20 installiert. Download Es erscheint Eine weitere Version dieses Produkts ...

Windows Server
Hat Microsoft die WindowsServerSicherung oder diskpart zerpatcht?
anteNopeVor 20 StundenFrageWindows Server3 Kommentare

Hallo, kann es eventuell sein, dass Microsoft mit seinen letzten Updates die WindowsServerSicherung bzw. diskpart zerschossen hat? Es häufen sich bei mir seit gestern ...

Windows 10
Windows 10 Updates im Abgesicherten Modus nicht möglich!
gelöst Yuuto.LucasVor 1 TagFrageWindows 1016 Kommentare

Hallo, ich habe aktuell ein Problem bei einem Kunden Rechner. Bei diesem gibt es Probleme mit dem Soundkarten Treiber hdaudio.inf wegen dem der PC ...

Windows 10
Lokales Profil wird beim Herunterfahren gelöscht!
Yuuto.LucasVor 1 TagFrageWindows 1012 Kommentare

Hallo, ich habe aktuell folgendes Problem. An einem Kundenrechner ist aktuell ein Lokales Profil eingerichtet (vorher ein Server Profil bei dem das gleiche Problem ...

Ubuntu
Cups-Server mit SMB lehnt Verbindungen ab (smb.conf)?
ErikHeinemannVor 9 StundenFrageUbuntu17 Kommentare

Guten Morgen, ich habe einen Ubuntu 20.04 Server mit Cups als Printspooler. Nun Soll noch Samba hinzugefügt werden für eine einfache Verwendung unter Windows. ...