Hyper V - RDP Connection breaks

Mitglied: samrein

samrein (Level 1) - Jetzt verbinden

26.10.2020, aktualisiert 11:04 Uhr, 275 Aufrufe, 7 Kommentare

Hallo zusammen,

Fehler zu finden ohne eine entsprechende Fehlermeldung gestalt sich doch etwas schwierig... aber trotzdem versuch ich mein Glück im Forum weil es vielleicht das Problem schon mal bei jemanden gab.

Konstellation:

Hyper-V Server 2016, Clusterstorage ISCSI-LUN, 10 GB, NTFS Formatiert,
Terminal Server Windows Server 2016

Auf dem Hyper V Server sind mehrere Terminalserver installiert, in unregelmäßigen Abständen friert für 2-3 Minuten die Sitzung ein, das Bild bleibt erhalten, man kann einfach nur nix mehr klicken.
Die Netzqualität ist hervorragend. Diese Timeouts sind über den Tag verteilt zu unterschiedlichen Zeiten, ohne das im Ereignisprotokoll des Hyper-V Servers, als auch der VM etwas auftaucht.
Es scheint so als wäre die Netzwerkverbindung unterbrochen. Am Anfang hatte das Clustervolume in Verdacht, aber auch hier finde ich keinerlei Systemmeldungen.

Auf dem Hyper V Server sind 2x 10 GB zum Teaming konfiguriert. Hier wäre mein nächster Ansatz, das hier vielleicht was nicht koscher läuft, allerdings kann ich auch hier keine Einträge sehen.
Die VM´s sind in einem anderen VLAN als der Hyper-V Server.

Ich hatte bezüglich der Netzwerkproblematik mal einen interessanten Beitrag gefunden, allerdings sind meine Messungen immer hervorragend, ich habe zwar keine Jumboframes aktiviert, aber dennoch "messtechnisch" einen sehr hohen Durchsatz. Auch die Schreib- Lesezugriffe auf das Storage sind hervorragend.

Hyper V und RDP

Vielleicht weiss jemand aus Eurem Erfahrungsschatz, wo man hier noch weiter graben könnte. Ich kann auch keine verlorenen Pakekte sehen....

Ich vermute das das Problem beim Hyper-V Host liegen muss....

Freu mich über Tips und Anrregungen, wenn noch Infos fehlen um die Glaskugel auszuschließen... liefere ich die gerne nach.

Grüße
Stefan
Mitglied: tech-flare
26.10.2020 um 10:38 Uhr
Die Netzqualität ist hervorragend. Diese Timeouts sind über den Tag verteilt zu unterschiedlichen Zeiten, ohne das im Ereignisprotokoll des Hyper-V Servers, als auch der VM etwas auftaucht.
Es scheint so als wäre die Netzwerkverbindung unterbrochen. Am Anfang hatte das Clustervolume in Verdacht, aber auch hier finde ich keinerlei Systemmeldungen.
Wo soll sie denn d. M. n. unterbrochen? Vom Clients zum TS ? Hyper zum Storage?

Wie sieht die Verbindung direkt auf dem TS über die Konsole auf? Läuft es dort den ganzen Tag stabil?


Auf dem Hyper V Server sind 2x 10 GB zum Teaming konfiguriert.
Wie sieht die Konfig aus? Da gibts ja verschiedene....Switche auch entsprechend konfiguriert?

Hier wäre mein nächster Ansatz, das hier vielleicht was nicht koscher läuft, allerdings kann ich auch hier keine Einträge sehen.
Die VM´s sind in einem anderen VLAN als der Hyper-V Server.
Und wo befinden sich die Clients? Im gleichen VLAN wie die Terminalserver, oder müssen die auch geroutet werden?

Vielleicht weiss jemand aus Eurem Erfahrungsschatz, wo man hier noch weiter graben könnte. Ich kann auch keine verlorenen Pakekte sehen....
Ich hatte mal Probleme, wenn die Thinclients zum Terminalserver geroutet werden mussten
Bitte warten ..
Mitglied: samrein
26.10.2020 um 11:04 Uhr
Zitat von tech-flare:
Wo soll sie denn d. M. n. unterbrochen? Vom Clients zum TS ? Hyper zum Storage?

Hallo Tech-flare,

danke für Deine Antwort.

Intern verwenden wir VMware HyperVisior, für ein paar externe die über SPLA laufen einen Hyper-V Server.
Die Verbindung wird von extern als auch von intern immer wieder mal für 2-5 Sekunden eingefroren. Wobei von intern keiner drauf arbeitet, ist mir nur beim testen aufgefallen, es muss schon fast ein Zufall genau so einen Zeitpunkt des einfrierens zu erwischen.

Wie sieht die Verbindung direkt auf dem TS über die Konsole auf? Läuft es dort den ganzen Tag stabil?
Auf der Konsole hatte ich bislang noch keine einzige Unterbrechung.


Auf dem Hyper V Server sind 2x 10 GB zum Teaming konfiguriert.
Wie sieht die Konfig aus? Da gibts ja verschiedene....Switche auch entsprechend konfiguriert?
hab mal zwei Screens angehängt dazu. Ich habe unter NIC-Teaming ein Team erstellt und dort die Schnittstellen konfiguriert.

Hier wäre mein nächster Ansatz, das hier vielleicht was nicht koscher läuft, allerdings kann ich auch hier keine Einträge sehen.
Die VM´s sind in einem anderen VLAN als der Hyper-V Server.
Und wo befinden sich die Clients? Im gleichen VLAN wie die Terminalserver, oder müssen die auch geroutet werden?
Bei meinen Testzugriffen bin ich im selben VLAN... wie gesagt, der Rest kommt dann von extern...

Vielleicht weiss jemand aus Eurem Erfahrungsschatz, wo man hier noch weiter graben könnte. Ich kann auch keine verlorenen Pakekte sehen....
Ich hatte mal Probleme, wenn die Thinclients zum Terminalserver geroutet werden mussten


Ich hatte oben versehentlich Windows Server 2019 Hyper V geschrieben, es ist aber noch ein 2016.

Danke und Grüße
Stefan
bild1 - Klicke auf das Bild, um es zu vergrößern
bild2 - Klicke auf das Bild, um es zu vergrößern
Bitte warten ..
Mitglied: tech-flare
26.10.2020 um 11:27 Uhr
Zitat von samrein:

Zitat von tech-flare:
Wo soll sie denn d. M. n. unterbrochen? Vom Clients zum TS ? Hyper zum Storage?

Hallo Tech-flare,

danke für Deine Antwort.

Intern verwenden wir VMware HyperVisior, für ein paar externe die über SPLA laufen einen Hyper-V Server.
ok...das verstehe ich gerade nicht ganz

Also habt ihr hat grundsätzlich vmware, aber die TS laufen auf dem Hyper-V? Ist das so gemeint?

Wie sieht die Verbindung direkt auf dem TS über die Konsole auf? Läuft es dort den ganzen Tag stabil?
Auf der Konsole hatte ich bislang noch keine einzige Unterbrechung.
Also wird es doch eher ein Netzwerkproblem sein

Auf dem Hyper V Server sind 2x 10 GB zum Teaming konfiguriert.
Wie sieht die Konfig aus? Da gibts ja verschiedene....Switche auch entsprechend konfiguriert?
hab mal zwei Screens angehängt dazu. Ich habe unter NIC-Teaming ein Team erstellt und dort die Schnittstellen konfiguriert.
Alles klar....das ist der "einfache" Modus. Kein richtiges LACP - da könntest du nachbesser - alternativ erstmal nur mit einer NIC testen

Hier wäre mein nächster Ansatz, das hier vielleicht was nicht koscher läuft, allerdings kann ich auch hier keine Einträge sehen.
Die VM´s sind in einem anderen VLAN als der Hyper-V Server.
Und wo befinden sich die Clients? Im gleichen VLAN wie die Terminalserver, oder müssen die auch geroutet werden?
Bei meinen Testzugriffen bin ich im selben VLAN... wie gesagt, der Rest kommt dann von extern...
Das spricht dafür, dass es doch ein Netzwerkproblem ist.....wie gesagt...ich hatte manchmal 2...3 Sekunden RDP Aussetzer, wenn VLAN übergreifen die Thinclients auf den TS geroutet wurden. Die Verbindung war da, aber es kam für 2-3 Sekunden RDP Connection Lost
Bitte warten ..
Mitglied: samrein
26.10.2020, aktualisiert um 12:06 Uhr
Intern verwenden wir VMware HyperVisior, für ein paar externe die über SPLA laufen einen Hyper-V Server.
ok...das verstehe ich gerade nicht ganz

Wenn Du externen (Nicht Betriebszughörigen) Zugang zu Deinem System erlaubst, müsstest Du VMware Provider sein und die Lizenzen bezahlen. Um diese Lizenzkosten zu sparen, haben wir für diese Kunden einen eigenen Server, hier fallen auch Lizenzkosten an, aber eben nur einmal. Diese werden monatlich über SPLA rapportiert und bezahlt.


Also habt ihr hat grundsätzlich vmware, aber die TS laufen auf dem Hyper-V? Ist das so gemeint?
ja intern VMware, und die externen Kunden die arbeiten wie oben beschrieben auf einem seperaten Host mit Hyper-V.


Wie sieht die Verbindung direkt auf dem TS über die Konsole auf? Läuft es dort den ganzen Tag stabil?
Auf der Konsole hatte ich bislang noch keine einzige Unterbrechung.
Also wird es doch eher ein Netzwerkproblem sein


Alles klar....das ist der "einfache" Modus. Kein richtiges LACP - da könntest du nachbesser - alternativ erstmal nur mit einer NIC testen
Das probiere ich mal aus... und nehme im ersten Schritt eine NIC raus.




Und wo befinden sich die Clients? Im gleichen VLAN wie die Terminalserver, oder müssen die auch geroutet werden?
Bei meinen Testzugriffen bin ich im selben VLAN... wie gesagt, der Rest kommt dann von extern...
Das spricht dafür, dass es doch ein Netzwerkproblem ist.....wie gesagt...ich hatte manchmal 2...3 Sekunden RDP Aussetzer, wenn VLAN übergreifen die Thinclients auf den TS geroutet wurden. Die Verbindung war da, aber es kam für 2-3 Sekunden RDP Connection Lost
Das entspricht genau meinem Fehlerbild.... werde aber auch nochmal einen Blick auf die Firwall werfen über die das Routing zwischen extern > und VLAN läuft.

Grüße
Stefan
bild3 - Klicke auf das Bild, um es zu vergrößern
Bitte warten ..
Mitglied: mbehrens
26.10.2020 um 21:18 Uhr
Zitat von samrein:

Konstellation:

Hyper-V Server 2016, Clusterstorage ISCSI-LUN, 10 GB, NTFS Formatiert,
Terminal Server Windows Server 2016

Auf dem Hyper V Server sind mehrere Terminalserver installiert, in unregelmäßigen Abständen friert für 2-3 Minuten die Sitzung ein, das Bild bleibt erhalten, man kann einfach nur nix mehr klicken.

[...]

Freu mich über Tips und Anrregungen, wenn noch Infos fehlen um die Glaskugel auszuschließen... liefere ich die gerne nach.

Druckertreiber, VMQ, unterstützt das Storage LACP oder nur MPIO, Hardwaretreiber/BIOS aktuell, Paketgrößen, Virenscanner, Profilmanagement.
Bitte warten ..
Mitglied: samrein
27.10.2020 um 09:31 Uhr
Hallo zusammen,

weiter geht die Suche,

Druckertreiber sind auf dem Host gar keine installiert, das Storage ist über MPIO angebunden, Bios und Treiber des DELL Servers sind aktuell.
Virenscanner ist keine drauf. Allerdings hab ich jetzt doch wahrscheinlich einen Grund gefunden, vielleicht kann mir hier jemand noch was zu sagen ob ich mit meiner Vermutung richtig liege.

Die Breaks finden immer statt wenn im Ereignislog der folgende Eintrag zu finden ist

Dienst "Volumeschattenkopie" befindet sich jetzt im Status "Ausgeführt".
Dienst "Volumeschattenkopie" befindet sich jetzt im Status "Beendet".

Nicht als Fehler sondern nur als Information.

Ich muss jetzt mal herausfinden warum der alle paar Stunden sich beendet und dann wieder startet...

Grüße
Stefan
bild4 - Klicke auf das Bild, um es zu vergrößern
Bitte warten ..
Mitglied: samrein
02.11.2020 um 21:57 Uhr
Hallo zusammen,

mein Problem mit den RDP-Breaks ist scheinbar jetzt gelöst.
Falls es jemanden interessiert... auf dem Server war/ist der Backup Exex Agent installiert, und obwohl in den betroffenen Zeitfenstern kein Backup läuft, hat dieser scheinbar diese Snapshots ausgelöst.
Ich werde jetzt nochmal bei Veritas ein Ticket auf machen, vielleicht können die mir näheres dazu sagen.
Seit dem Deaktivieren des Dienstes gab jedenfalls kein Breaks mehr.

Danke und Grüße
Stefan
Bitte warten ..
Heiß diskutierte Inhalte
Hardware
Schwarmwissen gefragt: Rätselstunde am Samstag Abend - LWL Verkabelung
gelöst Xaero1982FrageHardware32 Kommentare

Nabend Zusammen, heute Abend gibt es ein kleines Rätsel für euch was es zu lösen gilt. Die Lösung werde ...

Netzwerke
Aufbau Praxisnetzwerk mit Fragen (TI, Switch, Firewall, VoIP, Netzwerkdesign)
razorrFrageNetzwerke21 Kommentare

Hallo, ich bin neu hier, aber habe hier schon sehr lange im Forum mitgelesen bzw. mich schlau gemacht und ...

Vmware
ESXi für Raspberry Pi
sabinesInformationVmware18 Kommentare

VMware hat den ESXi für den Raspberry Pi (zu Testzwecken) vorgestellt, läuft 180 Tage auf dem Pi 4 mit ...

Backup
Veeam Backup-Server aus der Domäne nehmen
redhorseFrageBackup15 Kommentare

Guten Morgen, da in unserer Backupumgebung ein Hardwaretausch ansteht, konzipiere ich gerade Möglichkeiten die Sicherheit zu erhöhen. Konkret geht ...

Windows Server
Server mit AMD EPYC 7F52 (1Socket) wird als 2 Socket Server angezeigt
LordXearoFrageWindows Server11 Kommentare

Hallo Zusammen, ich komme mit meinem Problem nicht so recht weiter und hoffe aufjemanden der noch weitere Ideen hat. ...

Notebook & Zubehör
Surface pro 3 oder aktueller
devazubiFrageNotebook & Zubehör9 Kommentare

Moin moin zusammen, ich möchte eine kurze Umfrage/Feedbackrunde starten. Ich habe gerade angefangen Wirtschaftsinformatik berufsbegleitend zu studieren. Ich würde ...

Ähnliche Inhalte
Windows Server
V-Server Windows 2016, RDP und VPN
gelöst VisuciusFrageWindows Server3 Kommentare

Guten Morgen ins Forum, bin neu hier im Forum. Beschäftige mich sonst eher mit MacOS, der Client-Seite und ein ...

Windows Server

Hochverfügbarkeit RD Connection Broker

gelöst chris123FrageWindows Server2 Kommentare

Hallo, ich habe vor unseren RD Connection Broker hochverfügbar zu konfigurieren. Ich hatte damals bei der Installation den Fehler ...

Netzwerke

Wie Nutzern erlauben den Internet-Break-out-Point zu wählen?

julibeFrageNetzwerke9 Kommentare

Hallo in die Runde, ich habe ein Netzwerk, das aus mehreren Standorten besteht, die über LANCOM-Router per IPSec-VPN miteinander ...

Netzwerkgrundlagen

The Illustrated TLS Connection

LochkartenstanzerInformationNetzwerkgrundlagen4 Kommentare

Moin, Unter findet man eine gelungene Erläuterung von TLS. Fördert sehr das verständnis darüber, was da passiert. lks

Hyper-V

Hyper-V geht die Verbindung zur VM auch ohne RDP?

gelöst DennisWeberFrageHyper-V11 Kommentare

Hallo zusammen, ich habe mir auf meinem Heim-PC eine VM (Win 10) per Hyper-V eingerichtet. Alles auch soweit gut. ...

Linux Netzwerk

Connection refused bei cert Import

winlinFrageLinux Netzwerk1 Kommentar

Hallo Leute habe ne source VM (Linux) und ne Windows VM. Möchte von der source einen curl absetzen mit ...

Neue Fragen
Administrator Magazin
11 | 2020 Virtualisierung ist aus der IT nicht mehr wegzudenken. In der November-Ausgabe des IT-Administrator Magazins dreht sich der Schwerpunkt um das Thema "Server- und Storage-Virtualisierung". Darin erfahren Sie, wie sich die Virtualisierungstechnologie entwickelt hat, welche Varianten es im Bereich Server und Speicher gibt und wie ...
Neue Beiträge
Neue Jobangebote
Server- und Storage-VirtualisierungServer- und Storage-VirtualisierungBerechtigungs- und IdentitätsmanagementBerechtigungs- und IdentitätsmanagementWebdienste und -serverWebdienste und -serverDatenbankenDatenbankenMonitoring & SupportMonitoring & SupportHybrid CloudHybrid Cloud