IProute2 leider ohne Erfolg

bzloeffler
Goto Top
Hallo Leute,

ich hoffe es kann mir jemand weiterhelfen. Irgendwo habe ich einen Fehler und finde die Lösung nicht.

Folgenden Aufbau habe ich.

1 Mailserver mit 3 Netzwerkkarten mit openSuse und Plesk als Mailsoftware mit Postfix als Mailagent.

eth0=intern 10.0.10.10 --> interner Switch
eth1=extern1 10.10.10.10 --> Router 10.10.10.1 --> WAN
eth2=extern2 10.20.10.10 --> Router 10.20.10.1 --> WAN

Wenn die default auf eth1 und GW 10.10.10.1 gestellt ist geht alles i.O.

Jedoch soll es ja die Möglichkeit geben, wenn extern1 ausfällt das es dann über extern2 geht. Also default gelöscht und IProute2 eingestellt:

nano /etc/iproute/rt_tables --> neue Einträge --> 1 rt1 und 2 rt2
ip route add 10.10.10.0/24 dev eth1 src 10.10.10.10 table rt1
ip route add default via 10.10.10.1 dev eth1 table rt1

gleiches auch für rt2
ip route add 10.20.10.0/24 dev eth2 src 10.20.10.10 table rt2
ip route add default via 10.20.10.1 dev eth1 table rt2

dann noch die Regeln
ip rule add from 10.10.10.10/32 table rt1
ip rule add to 10.10.10.10/32 table rt1
ip rule add from 10.20.10.10/32 table rt2
ip rule add to 10.20.10.10/32 table rt2

Soweit so gut, die Mails kommen jetzt auf beiden externen WAN Anschlüssen am Server an, jedoch geht nichts mehr raus. Ping auf die 10.10.10.1 und 10.20.10.1 gehen, jedoch nicht an die 8.8.8.8, somit auch keine DNS Auflösung.

In der /etc/resolv.conf steht der nameserver 46.182.19.48 und nameserver 213.73.91.35 und in der /etc/sysconfig/network/ifcfg-ethx stehen die IPAddressen 10.x.10.10. Auch das eintragen eines DNS1 oder DNS2 hat keinen Erfolg gebracht.

Hat jemand ein Ansatz wo der Fehler sein kann?

Content-Key: 448155

Url: https://administrator.de/contentid/448155

Ausgedruckt am: 28.06.2022 um 05:06 Uhr

Mitglied: Tideon
Tideon 07.05.2019 um 11:24:47 Uhr
Goto Top
Hey,

bin jetzt noch kein IT-Profi, deshalb bitte nur als Denkanstoß sehen und nicht als Lösung:
-Müsste es bei rt2 nicht eth2 sein, da sonst keine Redundanz?
-analog dazu die Regeln von 10.20.10.10/32 table rt2

Oder bin ich hier voll auf dem Holzweg?
Gruß tideon
Mitglied: bzloeffler
bzloeffler 07.05.2019 aktualisiert um 14:04:05 Uhr
Goto Top
Zitat von @Tideon:

-Müsste es bei rt2 nicht eth2 sein, da sonst keine Redundanz?
-analog dazu die Regeln von 10.20.10.10/32 table rt2

Oder bin ich hier voll auf dem Holzweg?
Gruß tideon

Danke für den Hinweis, aber das habe ich leider falsch aufgeschrieben und hiermit in dem Post geändert. Leider nur ein Fehler im Beitrag.
Mitglied: Tideon
Tideon 09.05.2019 um 07:00:15 Uhr
Goto Top
moin, geht es denn inzwischen wieder?
Wenn ja was war die Lösung?
Mitglied: bzloeffler
bzloeffler 09.05.2019 um 09:10:37 Uhr
Goto Top
Zitat von @Tideon:

moin, geht es denn inzwischen wieder?
Wenn ja was war die Lösung?

Guten Morgen,

nein leider habe ich noch keine Lösung dafür gefunden.