athi1234
Goto Top

Kein AD-Replikation da Schema unterschiedlich

Moin zusammen,

hoffe hier kann mir jmd helfen.

SBS2008 und 2008R2-RODC an einem eigenen Standort.

Habe heute festgestellt, dass seit einer Woche keine AD-Replikation mehr stattfindet und wollte diese nun manuell anstossen. Diese bricht aber immer mit der Meldung ab, dass die Schemas zwischen den beteiligten Replikationspartner unterschiedlich sind. Wenn ich mit ADSIEdit auf dem SBS und den RODC nachschaue, entdecke ich dass bei "objectVersion" in beiden Fällen "nicht gesetzt" drin steht.

Ein weitere RODC an einem anderem Standort lässt sich ohne Probleme replizieren und hat auch keine Probleme.

Meine Frage nun, wie kann ich den Fehler beheben? Ist es Möglich eine Schemaaktualisierung zu erzwingen? Oder gibt es noch einen anderen Lösungsweg?

Danke schonmal,
athi

Content-Key: 162035

Url: https://administrator.de/contentid/162035

Printed on: February 22, 2024 at 04:02 o'clock

Member: xdrxdr
xdrxdr Mar 04, 2011 at 10:08:18 (UTC)
Goto Top
Also ich hätte die Schemaversion jetzt in der Registry überprüft.

\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NTDS\Parameters\Schema Version

Bei 2008 müsste die auf "44" stehen
Member: athi1234
athi1234 Mar 04, 2011 at 10:17:02 (UTC)
Goto Top
Schemaversion ist auf allen Server "47" für 2008R2.
Lediglich der SBS2008 hat als "System Schema Version" den Wert "44". Die RODCs haben jeweils "Schema Version"="47".
Member: xdrxdr
xdrxdr Mar 04, 2011 at 10:27:15 (UTC)
Goto Top
Stimmt 2008 R2 ist auf 47. Kannst Du den SBS nicht via Adprep von der 2008R2 auf Schema 47 bringen. Dürfte doch eigentlich gehen. Habs selber aber noch nicht getestet ob sich ein 2008 SBS auf Schema 47 bringen lässt. Weiss auch nicht wie sich das mit den RODC verhält.
Member: athi1234
athi1234 Mar 04, 2011 at 10:32:39 (UTC)
Goto Top
Der SBS hat als "Schema Version" auch 47. Lediglich die "System Schema Version" ist 44. Und die Replikation hat ja schonmal getan. Was ich feststellen konnte, waren Störungen in der Standortanbindung vor und während der letzten erfolgreichen Replikation.
Member: athi1234
athi1234 Mar 09, 2011 at 11:17:41 (UTC)
Goto Top
Naja, hat sich erledigt inzwischen. Hab den RODC per dcpromo.exe aus der Domäne rausgenommen und wieder integriert und dann lief auch die Replikation wieder an...