LAN over VoIP?

Hallo zusammen,

der Titel meiner Frage ist natürlich unsinnig, spiegelt aber etwa das Fragezeichen wieder, welches ich hinsichtlich einer Installation im Gesicht habe.

Ein Telefonie-Dienstleister hat bei einem meiner Kunden neue Tischtelefone (Yealink SIP-T46S) mit TAPI-Anbindung an das CRM eingerichtet.
Ich war nun etwas irritiert als mein Kunde mir erzählte, dass man bei ausgeschaltetem Rechner das Telefon nicht mehr benutzen könne und bei ausgeschaltetem Telefon am Rechner quasi nichts mehr läuft.

Kurzer Blick auf die Situation: der Dienstleister hat die ursprüngliche Netzwerkverkabelung aufgelöst, nun hängen die Telefone (über Patchdosen) direkt am Switch und die Rechner am zweiten LAN-Port des jeweiligen Telefons.
Jeglicher Netzwerk-Verkehr der Rechner läuft nun also durch die Telefone...

Immerhin haben die Yealinks offenbar einen Gigabit-"Switch" verbaut, so dass die Geschwindigkeit im LAN nicht deutlich ausgebremst wird, trotzdem mutet das Ganze recht seltsam an.

Da ich selbst nur gelegentlich mit Telefonie-Hardware zu tun habe: Ist diese Installation "normal" oder ziemlicher Murks? Wirklich gut fühlt sich der zusätzliche Hop bei allen Rechnern für mich derzeit nicht unbedingt an.

Content-Key: 1094944857

Url: https://administrator.de/contentid/1094944857

Ausgedruckt am: 21.09.2021 um 16:09 Uhr

Mitglied: Mystery-at-min
Mystery-at-min 27.07.2021 um 22:14:54 Uhr
Goto Top
Wenn es zu wenig Netzwerkports gibt. Einen großen Unterschied macht es nicht.

Übrigens, Netzwerkstruktur aufgelöst?

Was der ausgeschaltete PC mit dem Telefon macht, dass es dann disfunktional ist weisst wohl nur du.
Mitglied: C.Caveman
C.Caveman 27.07.2021 um 22:19:49 Uhr
Goto Top
Moin,

Lass dir die Dokumentation geben und schau auf die Switchkonfiguration. Dort wird sich sicher etwas verändert haben.

Gruß
C.C.
Mitglied: Looser27
Looser27 27.07.2021 um 22:22:39 Uhr
Goto Top
Normale Verkabelung. Du kannst Telefon und PC über den Switch in separate VLan schieben. Eine spürbare Reduzierung des Durchsatzes gibt es hierbei nicht. Ausserdem ist das weniger Kabelsalat.

Gruß Looser
Mitglied: Datenreise
Datenreise 27.07.2021 um 22:26:30 Uhr
Goto Top
Zitat von @Mystery-at-min:

Wenn es zu wenig Netzwerkports gibt. Einen großen Unterschied macht es nicht.
Gibt es eigentlich nicht.


Übrigens, Netzwerkstruktur aufgelöst?
Netzwerkverkabelung aufgelöst (verändert).

Was der ausgeschaltete PC mit dem Telefon macht, dass es dann disfunktional ist weisst wohl nur du.
Solche passiv-aggressiven Kommentare liebe ich ja. :-D face-big-smile
Erstens war das die Aussage meines Kunden und zweitens hat er mir demonstriert, dass das Telefon direkt eine Betriebs-Fehlermeldung ausgibt, sobald man den zugehörigen Rechner auch nur in den S3 fährt.
Mitglied: Datenreise
Datenreise 27.07.2021 um 22:28:38 Uhr
Goto Top
Zitat von @C.Caveman:

Moin,

Lass dir die Dokumentation geben und schau auf die Switchkonfiguration. Dort wird sich sicher etwas verändert haben.
Nein, ich habe den Switch überprüft, es gab nichtmal einen Login. Scheint wirklich "nur" umgesteckt worden zu sein.
Mitglied: Datenreise
Datenreise 27.07.2021 um 22:31:02 Uhr
Goto Top
Zitat von @Looser27:

Normale Verkabelung. Du kannst Telefon und PC über den Switch in separate VLan schieben. Eine spürbare Reduzierung des Durchsatzes gibt es hierbei nicht. Ausserdem ist das weniger Kabelsalat.

Vielen Dank für die Einschätzung.
Das mit dem Kabelsalat stimmt ja aber doch nur in seltenen Fällen, denn es werden ja weiterhin zwei Patchkabel benötigt.
Zusätzlich wurde leider nicht in PoE-Versorgung investiert, so dass der Kabelsalat eher zugenommen hat... :-( face-sad
Mitglied: aqui
aqui 27.07.2021 aktualisiert um 22:34:34 Uhr
Goto Top
trotzdem mutet das Ganze recht seltsam an.
Nein, ist eine durchaus gängige und auch allgemein übliche Installation bei VoIP. Allemal wenn wenig LAN Anschlußdosen am Arbeitsplatz vorhanden ist.
Sie ist zudem ein Muß wenn in der VoIP Installation mit Voice Priorisierung im Layer 2 mit 802.1p gearbeitet wird. Zu all diesen wichtigen Punkten machst du leider wenig keinerlei weitere Angaben so das eine zielführende Antwort schwer wird. :-( face-sad Da kann man dann auch nur wild rumraten.
Wenn das alles richtig und korrekt installiert wurde beinflusst das eine niemals das andere. Dein geschildertes Verhalten zeigt also das derjenige der es installiert hat gravierende Fehler gemacht hat.
Sofern du genug Ports am Arbeitsplatz hast dann lös das auf und gib jeder Komponente einen dedizierten LAN Port. Wo ist dein wirkliches Problem ?
Mitglied: C.Caveman
C.Caveman 27.07.2021 aktualisiert um 22:39:58 Uhr
Goto Top
Zitat von @Datenreise:

Zitat von @C.Caveman:

Moin,

Lass dir die Dokumentation geben und schau auf die Switchkonfiguration. Dort wird sich sicher etwas verändert haben.
Nein, ich habe den Switch überprüft, es gab nichtmal einen Login. Scheint wirklich "nur" umgesteckt worden zu sein.

Ist eigentlich unüblich. Voip packt man in ein eigenes VLAN und legt QoS drauf.

Weitere Fragen lauten auch. Wie stehen die Telefone mit dem uns unbekanntem CRM in Verbindung? Was wurde konfiguriert?
Mitglied: Datenreise
Datenreise 27.07.2021 um 22:50:31 Uhr
Goto Top
Vielen Dank aqui und C-Cavemann (hier schon zum zweiten Mal :-) face-smile ).

VLANs existieren in dem Netzwerk nicht, der Switch könnte es, die restlichen Komponenten aber nicht. Ist allerdings auch nur eine sehr kleine Kanzlei mit fünf Arbeitsplätzen.

@aqui: Mein "Problem" bestand nur darin, dass mir die Installation komisch vorkam, ich das Ganze aber mangels eigener Erfahrung nicht direkt als Murks bewerten wollte.
Ihr habt mir ja hier auch schon schnell und sinnvoll bei der Wissenserweiterung geholfen, danke dafür.

Zitat von @aqui:
Sie ist zudem ein Muß wenn in der VoIP Installation mit Voice Priorisierung im Layer 2 mit 802.1p gearbeitet wird.
Kannst Du das noch näher ausführen? Warum kann eine Priorisierung im Netzwerk nur stattfinden, wenn Telefon und PC am selben Kabel mit dem Switch verbunden sind?

Wenn das alles richtig und korrekt installiert wurde beinflusst das eine niemals das andere. Dein geschildertes Verhalten zeigt also das derjenige der es installiert hat gravierende Fehler gemacht hat.

Naja, selbst mit eingerichteten VLANs nimmt ein defektes oder abgeschaltetes Telefon dem Rechner ja seine Netzwerkverbindung weg, das finde ich strukturell nicht so schön (auch wenn es vermutlich ein edge case ist).
Aber ja, die Installation lief wohl wie so oft nach dem Schema "muss nur schnell irgendwie laufen" statt bzw. wurden die Telefone angeboten ohne überhaupt vorher mal auf die vorhandene Infrastruktur zu schauen.
Mitglied: Mystery-at-min
Mystery-at-min 27.07.2021 um 22:53:20 Uhr
Goto Top
Zitat von @Datenreise:
Solche passiv-aggressiven Kommentare liebe ich ja. :-D face-big-smile
Erstens war das die Aussage meines Kunden und zweitens hat er mir demonstriert, dass das Telefon direkt eine Betriebs-Fehlermeldung ausgibt, sobald man den zugehörigen Rechner auch nur in den S3 fährt.

heute ist wohl alles passiv agressiv was etwas direkter formuliert ist.

Normal juckt es ein Telefon nicht, wenn der dahinterliegende PC aus ist. Aber ist dein Kunde - du verdienst damit Geld, du musst die Infos liefern. Was für eine Fehlermeldung? Oder haust du hier einfach aufgrund eines Anrufs des Kunden hier direkt die Frage rein ohne auch nur ansatzweise etwas geprüft zu haben?
Mitglied: cykes
cykes 28.07.2021 aktualisiert um 07:44:21 Uhr
Goto Top
Moin,
Zitat von @Datenreise:
Ein Telefonie-Dienstleister hat bei einem meiner Kunden neue Tischtelefone (Yealink SIP-T46S) mit TAPI-Anbindung an das CRM eingerichtet.
Ich war nun etwas irritiert als mein Kunde mir erzählte, dass man bei ausgeschaltetem Rechner das Telefon nicht mehr benutzen könne und bei ausgeschaltetem Telefon am Rechner quasi nichts mehr läuft.
Was Du bisher nicht erwähnt hast, welche VoIP Telefonanlage verwendet der Kunde denn (Cloud oder on premises?) bzw. was hat da der Dienstleister installiert? Welches Softphone ist auf den PCs installiert?
Auch das mit der TAPI-Anbindung klingt etwas merkwürdig, handelt es sich vielleicht eher um CTI? Welches CRM ist das?
Erstens war das die Aussage meines Kunden und zweitens hat er mir demonstriert, dass das Telefon direkt eine Betriebs-Fehlermeldung ausgibt, sobald man den zugehörigen Rechner auch nur in den S3 fährt.
Der exakte Wortlaut der Fehlermeldung wäre noch interessant, daraus kann man eventuell auf die Ursache schließen.
Vermutung: Die CRM-Anbindung läuft über den PC (vermutlich via Outlook o.ä.) und das Telefon kann das CRM im Standby/Aus natürlich nicht mehr erreichen.

Das wäre dann tatsächlich etwas schnell zusammengeklöppelt, hört sich im ersten Moment aber auch so an, als wäre keine VoIP-TK-Anlage vorhanden.

Gruß

cykes

P.S. Für Dich wäre es empfehlenswert, wenn Du Dich mit dem TK-Dienstleister auseinandersetzt und Dir zumindest Grundlagenwissen zum Thema VoIP aneigenest. Der Kunde wird als erstes Dich bei Problemen fragen.
Mitglied: Visucius
Visucius 28.07.2021 aktualisiert um 08:59:47 Uhr
Goto Top
VLANs existieren in dem Netzwerk nicht,
Das ist wohl der erste Ansatz: Trenne die beiden Komponenten.

Davon dürften beide Seiten profitieren. Und dass es ohne Trennung Probleme gibt habe ich schon von unterschiedlichen Seiten gehört
Mitglied: Lochkartenstanzer
Lochkartenstanzer 28.07.2021 aktualisiert um 09:41:58 Uhr
Goto Top
Zitat von @Datenreise:

Ein Telefonie-Dienstleister hat bei einem meiner Kunden neue Tischtelefone (Yealink SIP-T46S) mit TAPI-Anbindung an das CRM eingerichtet.
Ich war nun etwas irritiert als mein Kunde mir erzählte, dass man bei ausgeschaltetem Rechner das Telefon nicht mehr benutzen könne und bei ausgeschaltetem Telefon am Rechner quasi nichts mehr läuft.

Moin,

Ich habe den Verdacht, daß da mehrere Sachen zusammenkommen.

  1. Meine Kristallkugel sagt: Die Telefone sind vermutlich so eingerichtet, daß sie einen Dienst auf dem angeschlossen PC benötigen, um die TAPI-Funktionalität zu bieten und sind daher "funktionslos", weil sie diesen Dienst nicht erreichen. Du könntest testweise mal schauen, ob die Telefone gehen, wenn die Kisten ins BIOS booten, d.h. "an" sind, aber kein Windows läuft. Alternativ könntest Du einfach ein Live-Linux oder Live-Windows booten und dann die Telefone testen.

  1. Dadurch, daß die Telefone als switch "mißbraucht" werden, müssen diese auch immer an sein, damit der PC sein Netzwerk sieht. Ohne switch keine Netzwerkkonnektivität. Das kann man am einfachsten "hinbiegen", wenn man getrennte Leitungen verwendet.

lks
Mitglied: Reini82
Reini82 28.07.2021 aktualisiert um 11:26:20 Uhr
Goto Top
Hi,

Ich würde noch Port Autentifizierung am Switch in den Raum werfen. Wenn das Netzwerk damit abgesichert ist und die Telefone nicht als Clients registriert sind dann klappt die Freigabe nur, wenn der PC sich am Netzwerk anmeldet. Aber wie Kollege @Lochkartenstanzer schon sagte, ist alles nur Spekulation.

Gruß
Mitglied: Lochkartenstanzer
Lochkartenstanzer 28.07.2021 aktualisiert um 11:30:12 Uhr
Goto Top
Zitat von @Reini82:

Hi,

Ich würde noch Port Autentifizierung am Switch in den Raum werfen.

Jupp, das wäre auch eine Erklärung.

genaugenommen, ist es sogar "Punkt1" meines Verdachts. Der Dienst wäre dann die "Anmeldung am switch". :-) face-smile

Da soltle man also mal asprobieren, wie sich das setup verhält, wenn der PC mit einem anderen OS hochgefahren wird oder nur ins BIOS geschickt wird. Wenn es dann geht, wäre Port-Security zu vermuten. Ansonsten ein Dienst im laufenden Windows.

lks
Mitglied: Mystery-at-min
Mystery-at-min 28.07.2021 um 11:34:38 Uhr
Goto Top
Aber das sollte er als Admin doch eigentlich am besten wissen (ich vermute: Das (Port Auth) ist es nicht)
Mitglied: Lochkartenstanzer
Lochkartenstanzer 28.07.2021 aktualisiert um 11:38:07 Uhr
Goto Top
Nachtrag: Sind eigentlich die RJ-45-Kabel "richtig herum" im Telefon? D.h. der PC dort wo PC dransteht angestöpselt und der switch dort wo Internet dransteht?

yealink-connectors.

Ich könnte mir vorstellen, daß das ggf, auch Probleme gibt, wenn man die vertauscht.

lks
Mitglied: Lochkartenstanzer
Lochkartenstanzer 28.07.2021 um 11:39:04 Uhr
Goto Top
Zitat von @Mystery-at-min:

Aber das sollte er als Admin doch eigentlich am besten wissen (ich vermute: Das (Port Auth) ist es nicht)

Aber nur wenn der Admin auch dafür zuständig ist. :-) face-smile
Mitglied: C.Caveman
C.Caveman 28.07.2021 aktualisiert um 16:15:59 Uhr
Goto Top
Bevor man an dem Konstrukt rumfummelt, sollten doch erst einmal essenzielle Fragen geklärt werden.
Was wurde Wie aufgebaut?
Warum wurde es so aufgebaut?
Was wurde vom Kunden, bei der anderen Firma in Auftrag gegeben? Hier gab es sicher eine Produktvorstellung, Planung und Einweisung.
Warum wurde der TO nicht eingebunden?
Wer zahlt die Zeche, für die Neustrukturierung?
Heiß diskutierte Beiträge
question
Rechner im Netzwerk frieren nach Neustart einCZF-MarkusVor 1 TagFrageWindows Netzwerk15 Kommentare

Seit einer Woche frieren unsere Rechner (Windows 10) im Firmennetzwerk nach einem Neustart ein, mal ist es die Outlook.exe, mal die Explorer.exe, mal die .exe ...

question
Macadresse fest auf dem Board ändernDippsVor 1 TagFrageHardware12 Kommentare

Hallo ich habe ein Mainboard was defekt ist. Nun habe ich das Typgleiche geholt und ausgetauscht. Es läuft ein Linux drauf mit einer Software die ...

question
Kauftipp für einfaches KabelmodemTheEPOCHVor 1 TagFrageHardware5 Kommentare

Hallo zusammen, ich bräuchte eine kleine Kaufberatung. Ich suche ein ganz einfaches Kabelmodem. Das Gerät soll vor eine OPNsense und das Internet bereitstellen. DOCSIS 3.0 ...

question
Clonen einer SSD Platte auf eine grösserejensgebkenVor 23 StundenFrageFestplatten, SSD, Raid9 Kommentare

Hallo Gemeinschaft habe in meinem Rechner eine alte SSD 128 und eine neu installierte mit Windows 10 drauf 512 GB nun möchte ich gerne die ...

question
Aufbau Netzstruktur für CARP mit OPNsense gelöst screemyVor 1 TagFrageLinux Netzwerk6 Kommentare

Guten Abend, wir betreiben auf 2 ProxmoxVE Hosts jeweils eine OPNsense. Diese möchten wir mittels CARP hochverfügbar konfigurieren für die LAN/WAN Schnittstelle. Folgender Aufbau ist ...

info
Druckprobleme an PrintServern nach Sept. 2021 UpdatekgbornVor 1 TagInformationWindows Server

FYI: Seit die Sicherheitsupdates vom Patchday 14. September 2021 ausgerollt wurden, stehen Administratoren vor dem Problem, dass Clients eventuell nicht mehr an einem Terminalsever oder ...

question
Fritzbox als VPNClientproton34Vor 1 TagFrageRouter & Routing7 Kommentare

Hallo, ich habe dem letzt gelesen, dass es nicht möglich sein soll eine FritzBox 7490 als VPNClient zu verwenden. Den Beitrag findet ihr hier:. Jetzt ...

tip
Outlook 2019 Konto hinzufügen - Kein Benutzername mehr bei IMAP Einstellungen - LösungFrankVor 2 StundenTippOutlook & Mail20 Kommentare

Eine weitere Kuriosität unter Office 2019 ist bei mir gerade hart aufgeschlagen. Ich wollte ein normales IMAP/SMTP Konto zu Outlook 2019 hinzufügen. Das war aber ...