Dieser Beitrag ist schon älter. Bitte vergewissern Sie sich, dass die Rahmenbedingungen oder der enthaltene Lösungsvorschlag noch dem aktuellen Stand der Technik entspricht.

Linux Server mit 2 NIC´s in zwei Netzen, antwortet nur auf einem Netz

Mitglied: mike-berlin
Hallo "Kollegen",

folgendes Problem.
Wir haben einen Server konfiguriert (Linux) welcher mit zwei NIC's in zwei verschiedenen Subnetzen hängt (192.168.1.x sowie 192.168.200.x).
Versucht jemand aus dem Netz 192.168.1.x den Server auf der Ip 192.168.1.168) zu erreichen kommt eine Antwort. Ein Ping auf die Server IP 192.168.200.168 (zweitze NIC im zweiten Subnetz 192.168.200.x) aus dem Netz 192.168.1.x funzt nicht., obwohl sonst sämtliche Geräte im Netz 192.168.200.x erreicht werden können.
Genaus umgekehrt. Ein Zugriff aus dem Netz 192.168.200.x auf die Server IP 192.168.200.168 klappt. Ein Zugriff aus dem Net 192.168.1.x auf die Server IP 192.168.200.168 klappt nicht, obwohl sonst auch alle Gerät vom Netz 192.168.200.x in dem Netz 192.168.1.x erreichbar sind.

Ganz offenbar ist dem Server nicht ganz klar auf welcher der beiden karten er Antworten soll.
Wie kann ich ihm klar machen das Anfragen aus dem Netz 192.169.1.x auf die Server IP 192.168.1.168 auch über diese Karte und bei Anfragen aus dem Netz 192.168.1.x auf die Server NIC 192.168.200.168 Antworten über diese Karte (IP) erfolgen sollen ?

Danke im voraus für jede Unterstützung !

Grüße aus Berlin,
Mike

Content-Key: 3043

Url: https://administrator.de/contentid/3043

Ausgedruckt am: 20.09.2021 um 06:09 Uhr

Mitglied: Atti58
Atti58 08.10.2004 um 09:32:06 Uhr
Goto Top
Nur so nebenbei, Deine Netze sind keine Subnetze sondern eigenständige Netze mit der Maske 255.255.255.0.

Zu Deinem Problem: Ich nehme an, Du musst auf Deinem Server statische Rouene eintragen, damit er weiß, dass er bei Anfragen an das 192.168.200.0 Netz das Interface 192.168.1.16 benutzen und bei Anfragen an 192.168.1.0 das Interface 192.168.200.1 verwenden soll. Dazu musst Du mit "route add" arbeiten, sieh Dir am besten die man-Pages an,

Gruß

Atti
Mitglied: das-omen
das-omen 08.10.2004 um 09:38:20 Uhr
Goto Top
Hi!

Habe ich das jetzt richtig verstanden. Der Server steht in beiden Teinetzen mit jeweils einer Karte. Dann müsste er auch normalerweise in beiden Netzen antworten können ohne dass du Routen eintragen musst weil er kennt ja beide Teilnetze schon. Kontrolliere mal genau die Einstellungen für die eine Netzwerkkarte. Da sie aus ihren eignen Teilnetz keinen Pong sendet könnte dort irgend was falsch konfiguriert sein. Liegt vieleicht ein Filter oder einer Firewall auf der KArte?


Tschau

Das Omen
Mitglied: Atti58
Atti58 08.10.2004 um 09:45:56 Uhr
Goto Top
@ Omen

... es sind keine Teilnetze! Und somit sollte das jeweilige Standardgateway auch nicht auf die andere Karte zeigen sondern auf die eigene.

@ Mike

Was gibt denn der Befehl "route" aus, vielleicht kabnnst Du das mal posten.

Gruß

Atti.
Mitglied: das-omen
das-omen 08.10.2004 um 09:53:50 Uhr
Goto Top
Hi!

@ atti

Sondern was für Netze? Der Server steht in beiden Netzen physisch mit einer Karte drin also sollte er beide Netze kennen. Wenn er keinen Pong auf der Karte zurücksenden die im Teilnetz steht dann hat es nichts mit Routen zu tun.


Tschau

Das Omen
Mitglied: mike-berlin
mike-berlin 08.10.2004 um 09:54:44 Uhr
Goto Top
Hallo "Kollegen",

erstmal danke für die prompte Unterstützung.

die Routingtabelle sieht wie folgt aus:


linux1:~# route
Kernel IP Routentabelle
Ziel Router Genmask Flags Metric Ref Use Iface
localnet 192.168.1.251 255.255.255.0 UG 0 0 0 eth0
localnet * 255.255.255.0 U 0 0 0 eth0
192.168.200.0 * 255.255.255.0 U 0 0 0 eth1
default 192.168.1.251 0.0.0.0 UG 0 0 0 eth0


eth0 hängt am Netz 192.168.1.x
eth1 am Netz 192.168.200.x
Mitglied: das-omen
das-omen 08.10.2004 um 09:56:46 Uhr
Goto Top
Hi!

Sorry verlesen! Hast du überhaut routing aktiviert?


Tschau

Das Omen
Mitglied: Atti58
Atti58 08.10.2004 um 09:58:08 Uhr
Goto Top
Worin besteht denn eigentlich Dein Problem, es kann doch nicht sein, dass es "nur" die fehlende Antwort der "entfernten" Netzwerkkarte des Servers ist? Sollen denn die User aus Netz A die PC's in Netz B nicht sehen (und umgekehrt)?

Gruß

Atti
Mitglied: mike-berlin
mike-berlin 08.10.2004 um 10:04:51 Uhr
Goto Top
Vielleicht noch eine Info dazu.

Für alle Geräte welche im Netz 192.168.1.x hängen ist das Standardtgateway die 192.168.1.251 (Layer3 Switch). Dieser arbeitet auch als Standardgateway für alle Geräte im Netz 192.168.200.x unter der Adresse 192.168.200.1.
Generell laufen also alle Netze auf diesem Switch auf. Eine Anfrage aus dem Netz 192.168.1.x an den Server und die karte eth0 (192.168.1.168) läuft über die 192.168.1.251 an die eth0 (an dieser Karte ist ja auch das Standardgateway 192.168.1.251 eingetragen).
Eine Anfrage aus dem Netz 192.168.1.x an den Server und die karte eth1 (192.168.200. 168) läuft auch über 192.168.1.251 und dann an die 192.168.200.168

Grüße,
Mike
Mitglied: das-omen
das-omen 08.10.2004 um 10:08:13 Uhr
Goto Top
Hi!

Hast du auf dem Server routing aktiviert?


Tschau

Das Omen
Mitglied: mike-berlin
mike-berlin 08.10.2004 um 10:11:47 Uhr
Goto Top
also das routing erfolgt direkt über den Layer3 switch an dem die beiden netze hängen.
sehen darf auch jeder alles. das klappt auch. alle geräte in allen netzen können alles anpingen ;-) face-wink
das problem ist eben nur das der server mit den zwei nic's nicht so antwortet wie er antworten sollte. anfagen aus dem netz 192.168.1.x auf server nix 192.168.1.168 klappen. anfragen aus dem netz 192.168.1.x auf server nic 192.168.200.168 klappen nicht.


grüße,
mike
Mitglied: mike-berlin
mike-berlin 08.10.2004 um 10:13:43 Uhr
Goto Top
auf dem server selber ist kein routing aktiviert. ist das denn erforderlich ? er soll ja eigentlich selber gar nicht routen. nur antworten. auf der richtigen karte.
wenn anfragen kommen an die 192.168.1.168 dann auch auf dieser karte. anfragen an die 192.168.200.168 dann auf dieser karte
Mitglied: das-omen
das-omen 08.10.2004 um 10:14:31 Uhr
Goto Top
Hi!

Ja sicher habe ich auch so verstanden. Versuche doch mal auf dem Server das Routing zu aktivieren.

Tschau

Das Omen
Mitglied: mike-berlin
mike-berlin 08.10.2004 um 11:00:56 Uhr
Goto Top
also Routing (unter Linux IP forwarding) hatten wir schon eingestellt und getestet. Leider auch ohne den gewünschten Erfolg :-( face-sad
Mitglied: das-omen
das-omen 08.10.2004 um 11:02:10 Uhr
Goto Top
Hi!

hmm muss mal anders Fragen warum ist es so wichtig das die andere Karte antwortet?


Tschau

Das Omen
Mitglied: mike-berlin
mike-berlin 08.10.2004 um 11:10:19 Uhr
Goto Top
Wir hatten vorher zwei getrennte Machinen. Eine im Netz 192.168.1.x und eine im Netz 192.168.200.x
Die Anwendungen der zweiten Maschine sollen auf die erste Kiste migriert werden (bessere Auslastung).
Da wir einen haufen Anwender/ Entwickler haben die mit der festen IP arbeiten bzw. die Anwendungen auf der Kiste auf die IP festgelegt sind, war es aus unserer Sicht einfacher die bisherige Adresse beizubehalten. Eine Änderung / Anspassung der IP's bei den Anwendungen und bei den Usern ist mit einem irren Aufwand verbunden und defakto nciht machbar / vertretbar.
daher eine kiste mit zwei NIC's unter beibehaltung der IP Konfig. So zumindest die Idee ;-) face-wink
Haben auch schon versucht beide Adressen / Netze an nur eine Karte zu binden. aber das war leider auch nicht so richtig von erfolg gekrönt.


Grüße,
Mike
Mitglied: Atti58
Atti58 08.10.2004 um 13:02:51 Uhr
Goto Top
Wenn ich mir die Routingtabelle so ansehe, sehe ich nur ein Standardgateway für beide Karten. Meiner Meinung nach müsstest Du ein zweites Standardgateway in das 192.168.200.0 Netz der Karte eth1 zuweisen.

Gruß

Atti
Mitglied: mike-berlin
mike-berlin 08.10.2004 um 13:49:29 Uhr
Goto Top
also mit zwei standardgateways haben wir es zar auch schon versucht, aber das hat nicht geklappt. macht auch eigentlich keinen sinn da das standardgateway nur dann zum einsatz kommt wenn eine adresse nicht aufgelöst werden kann. generell gibt es meines wissens nur ein standardgateway auf jedem rechner.
noch n paar ideen ? ;-) face-wink


Grüße,
Mike
Heiß diskutierte Beiträge
question
Optimale Konfig Synology ISCSI 10GBit an Windows Server gelöst meltersVor 1 TagFrageSAN, NAS, DAS12 Kommentare

Hallo zusammen, an einem Synology Storage habe ich einen Speicherpool, Raid 6 mit 100 TB erstellt. Die 100 TB sollen als ein Gesamtvolume an einem ...

question
LAN Verkabelung, DNS Fehler 651 und anderesSabineGVor 23 StundenFrageServer6 Kommentare

Ich habe seit 1.5 Jahren Problem mit dem Internet. Provider ist A1 (Österreich), ewige Geschichte, inzwischen 700 EUR weiter und keiner kann mir helfen. Modemtausch ...

question
Installation als Standardbenutzer oder als AdministratorUserUWVor 1 TagFrageWindows Installation5 Kommentare

Ist die Benutzerkontensteuerung aktiviert, kann auch ein Standardbenutzer Software installieren. Das Installationsprogramm, oder genauer, UAC fragt den Benutzer dann nach einem Administrator und dem Passwort ...

question
Rechner im Netzwerk frieren nach Neustart einCZF-MarkusVor 11 StundenFrageWindows Netzwerk12 Kommentare

Seit einer Woche frieren unsere Rechner (Windows 10) im Firmennetzwerk nach einem Neustart ein, mal ist es die Outlook.exe, mal die Explorer.exe, mal die .exe ...

question
Suche CPU-Tabelle als CSV oder XLS gelöst SarekHLVor 17 StundenFrageCPU, RAM, Mainboards8 Kommentare

Hallo zusammen, kennt jemand eine Tabelle möglichst aller 64Bit-PC- und Notebook-Prozessoren im CSV-, ODS oder XLS/XLSX-Format mit Bezeichnung, Anzahl der Kerne, Geschwindigkeit und vielleicht sogar ...

question
Scheduled Tasks mit MSA ausführenFestus94Vor 1 TagFrageWindows Server8 Kommentare

Hallo zusammen, ich hoffe, ihr habt ein ruhiges Wochenende. :-) Ich sitze seit ein paar Tagen vor einem Problem, bei dem ich vermutlich einfach den ...

question
Active Directory NTDS - Settings werden nicht automatisch generiertBombadilVor 1 TagFrageWindows Server5 Kommentare

Hallo Community :), dies ist mein erster Beitrag bzw. die erste Frage, also nur vorab so zur Info. Mein "Problem" ist aufgetaucht im Zuge des ...

question
Kauftipp für einfaches KabelmodemTheEPOCHVor 13 StundenFrageHardware5 Kommentare

Hallo zusammen, ich bräuchte eine kleine Kaufberatung. Ich suche ein ganz einfaches Kabelmodem. Das Gerät soll vor eine OPNsense und das Internet bereitstellen. DOCSIS 3.0 ...