antenope
Goto Top

Linux (Ubuntu) Partitionierung unter HyperV

Hallo zusammen,

ich habe hier gerade eine kleine Herausforderung mit Linux und Partitionen.

Setup:
  • HyperV
  • Generation 2 Gast (also UEFI)
  • 1x 50 GB VHDX auf SSD, 1x 9 TB VHDX auf HDD
  • Beide als GPT
  • Ubuntu 16.04 LTS x64

Mein Gedankengang ist wie folgt:
  • Auf die kleine SSD kommt alles außer /var, welches auf die HDD kommt
  • die SWAP Partition kommt an den Anfang der SSD, so dass man die Datenpartition dahinter problemlos erweitern kann.

Ubuntu macht folgendes im Standard:

clipboard01

Beim Setup lege ich also manuell die Partitionen an:

clipboard02

und die Partition für /var

clipboard03

Zusammengefasst also so:

clipboard04


Dann bekomme ich aber folgende Meldung und das Setup hängt sich auf (weder weiter noch zurück funktionieren)

clipboard05

Wo ist da mein Fehler? Hat da jemand eine Idee zu?

Content-Key: 348241

Url: https://administrator.de/contentid/348241

Printed on: April 15, 2024 at 12:04 o'clock

Member: Lochkartenstanzer
Lochkartenstanzer Sep 05, 2017 at 12:27:51 (UTC)
Goto Top
Zitat von @anteNope:

Wo ist da mein Fehler? Hat da jemand eine Idee zu?

Als was ist sdb formattiert? mbr oder gpt?

lks
Member: anteNope
anteNope Sep 05, 2017 at 12:41:11 (UTC)
Goto Top
Eine gute Frage ... das fragt Ubuntu mich leider nicht beim erstellen der Partitionstabelle. Ich nehme an gpt? Wie kann ich das beeinflussen im Setup?
Member: Lochkartenstanzer
Lochkartenstanzer Sep 05, 2017 updated at 14:32:36 (UTC)
Goto Top
Zitat von @anteNope:

Eine gute Frage ... das fragt Ubuntu mich leider nicht beim erstellen der Partitionstabelle. Ich nehme an gpt? Wie kann ich das beeinflussen im Setup?

Indem Du die Partitionen manuell anlegst.

Schau mal mit parted in der Konsole nach, welches Partitionsschema die Platte hat.

lks
Member: anteNope
anteNope Sep 05, 2017 updated at 15:11:12 (UTC)
Goto Top
Zitat von @Lochkartenstanzer:
Schau mal mit parted in der Konsole nach, welches Partitionsschema die Platte hat

Die Platten sind noch komplett blank.

Indem Du die Partitionen manuell anlegst.

Ich habe jetzt mal die Live-Umgebung gestartet und mit gparted gpt manuell gpt Partitionstabellen angelegt. Dann die Partitionen angelegt und ... gleicher Meldung.
Member: anteNope
anteNope Sep 05, 2017 updated at 15:55:54 (UTC)
Goto Top
Ok mit ner Generation 1 VM funktioniert es seltsamer Weise direkt, selbst aus dem Setup heraus. Und anstatt wie die 60 GB Platte mit Quickformat wird nun die 9,2 TB große Partition komplett formatiert!?! Nach welcher Logik wird denn das bitte ausgewürfelt ...

Langsam weiß ich wieder wieso Linux nur über Konsole läuft, die GUIs und sei es nur das Setup, sind doch ein schlechter Witz ...
Member: max
Solution max Sep 05, 2017 at 15:54:11 (UTC)
Goto Top
Hi,

auf den Screenshots sieht man es jetzt nicht wirklich, aber hast du auch die Einhängepunkte wieder gesetzt. Also "/" und "/boot/efi" sollten da auf jeden Fall wieder mit dabei sein face-smile Auch das Dateisystem dazu sollte gesetzt sein.

Dann bekomme ich aber folgende Meldung und das Setup hängt sich auf (weder weiter noch zurück funktionieren)

Hast du es mit den Ubuntu Standard Partitionen mal durchlaufen lassen? Geht es da?

Gruß
max
Member: max
max Sep 05, 2017 updated at 16:07:30 (UTC)
Goto Top
Ach, jetzt erinnere ich mich wieder, der Fehler kam mir doch bekannt vor:

Generation 2 virtual machines have secure boot enabled by default and Generation 2 Linux virtual machines will not boot unless the secure boot option is disabled. You can disable secure boot in the Firmware section of the settings for the virtual machine in Hyper-V Manager or you can disable it using Powershell: 

Set-VMFirmware –VMName "VMname" -EnableSecureBoot Off   

Before attempting to copy the VHD of an existing Generation 2 VHD virtual machine to create new Generation 2 virtual machines, follow these steps:
Log in to the existing Generation 2 virtual machine.
Change directory to the boot EFI directory:cd /boot/efi/EFI
Copy the ubuntu directory in to a new directory named boot:sudo cp –r ubuntu/ boot
Change directory to the newly created boot directory:cd boot
Rename the shimx64.efi file:sudo mv shimx64.efi bootx64.efi

Schau dir mal diesen Beitrag hier an und und lese die @colinardo Lösung durch.

Gruß
max
Member: anteNope
anteNope Sep 05, 2017 updated at 16:04:20 (UTC)
Goto Top
Die Ubuntu Standard-Partitionen (also automatisch vom Setup angelegt) funktioniert seltsamer Weise. Nur dann ist /var halt nicht auf sdb.

/ und /var hatte ich gesetzt. /boot/efi nicht, weil das nicht zur Auswahl steht -.-

Also müsste bei der EFI-Partition der Einhängepunkt /boot/efi sein mit Fat32. Hätte gedacht, dass das Setup das dann selbst macht, immerhin kopiert es ja auch irgendetwas dort hin?


Secure-Boot hatte ich bereits deaktiviert. So funktioniert ja auch das Auto-Setup =)
Member: max
max Sep 05, 2017 at 16:11:49 (UTC)
Goto Top
Also müsste bei der EFI-Partition der Einhängepunkt /boot/efi sein mit Fat32. Hätte gedacht, dass das Setup das dann selbst macht, immerhin kopiert es ja auch irgendetwas dort hin?

ok, das weiß ich auch nicht genau, bin vor Jahren auf Fedora umgestiegen. Früher war es zwingend notwenig.

Gruß
max
Member: anteNope
anteNope Sep 05, 2017 updated at 17:05:49 (UTC)
Goto Top
Ich vermute stark, dass das Setup buggy ist und nicht auf die beiden Schaltflächen reagiert (danach sollte das Setup eigentlich anfangen). Bei der ESP gibt es jedenfalls keine weiteren Optionen:

clipboard06


Wie man Stunden mit Partitionieren verbringen kann ... ich fall hier gleich vom Stuhl ...
Member: anteNope
anteNope Sep 05, 2017 updated at 17:52:00 (UTC)
Goto Top
So nun die Lösung des Ganzen ...

1. HyperV VM Gen 2 anlegen und Secure Boot deaktivieren

Sonst funktioniert Linux nicht

2. Festplatten per Befehl anlegen (PowerShell > New-VHD –Path C:\MyVHDs\test.vhdx –SizeBytes 127GB –Dynamic –BlockSizeBytes 1MB)

Hat den Hintergrund, dass VHDX eine 32 MB Bockgröße hat. In Kombination mit EXT3/4 ist selbst ein frisch formatiertes Laufwerk als VHDX lächerlich groß. So ist ein 9 TB VHDX dynamisch gleich nach der Formatierung mehrere hundert GB groß ...

3. Beim Ubuntu Setup nur das Laufwerk wählen und die Partitionen nicht anfassen

Benötigte Partitionen werden erstellt

4: Meldung "Datenträger entfernen und Enter drücken"

Tya nimmt kein "Enter" an, einfach die VM hart neustarten ...

5. Ubuntu startet | gparted installieren
  • Partitionstabelle auf 2. VHD
  • Partition erstellen und mit EXT4 formatieren (bei 9 TB ist dann die VHDX 6,2 GB groß; besser ...)

6. Neustarten und erneut ins Setup booten

7. Nun Partitionen anpassen

  • SWAP löschen
  • Datenpartition löschen
  • SWAP neu anlegen
  • Datenpartition neu anlegen und mit EXT4 sowie als / Mountpoint angeben
  • zweite Datenpartition ändern > Mountpoint als /var angeben

8. Installation fortsetzten

Hurra keine Fehlermeldung =)

9. "Datenträger entfernen und Enter drücken" > und wieder einfach neustarten ...


Und damit ist es GG

clipboard07
Member: max
max Sep 05, 2017 at 22:00:15 (UTC)
Goto Top
Super,

dann Danke, dass du uns den Weg zur Lösung beschrieben hast. Werde es bei Gelegenheit mal nach nachspielen.

face-wink

Gruß
max