arcorpi
Goto Top

Mikrotik VLAN - NTP Server

Auf meinem Mikrotik Router RB750Gr3 (HEX) habe ich VLAN´s eingerichtet.
Wie richte ich NTP korrekt ein, damit meine Clients die NTP-Zeit vom Router und nicht selbst von einem Zeitserver beziehen müssen?

Ich habe das hier eingebaut:

/system ntp client
set enabled=yes
/system ntp server
set enabled=yes manycast=yes multicast=yes
/system ntp client servers
add address=0.de.pool.ntp.org
add address=1.de.pool.ntp.org
add address=2.de.pool.ntp.org
add address=3.de.pool.ntp.org

dd action=accept chain=input comment="allow specific devices to NTP" dst-port=123 in-interface-list=LAN protocol=udp  
add action=accept chain=input comment="allow users to DNS services - upd" dst-port=53 in-interface-list=LAN protocol=udp  
add action=accept chain=input comment="allow users to DNS services - tcp" dst-port=53 in-interface-list=LAN protocol=tcp  

Muss ich die einzelnen IP-Adressen auch bei "DHCP Network" angeben (dort kann man keine Namen verwenden)?

Wie kann ich z.B. auf einem Linux-Client nachprüfen, ob das funktioniert

Content-Key: 5896495174

Url: https://administrator.de/contentid/5896495174

Printed on: June 12, 2024 at 18:06 o'clock

Member: aqui
Solution aqui May 21, 2024 updated at 16:18:52 (UTC)
Goto Top
Besser ist es im NTP Server Pool lokale Provider NTP Server oder nahe Server zu verwenden wie z.B. hier: https://www.heise.de/ratgeber/oeffentliche-Zeitquellen-322978.html
Den ntp.org Pool solltest du immer besser dediziert länderspzifisch einstellen z.B. auf DE sofern du in D bist mit de.pool.ntp.org. (Siehe hier: https://www.ntppool.org/de/use.html )
Der Rest ist OK.
Ob du den Mikrotik über seine lokale VLAN IP Adresse als NTP Server per DHCP an die Endgeräte in den jeweiligen VLANs propagierst (Option 42) ist Geschmackssache.
Schaden kann es zumindestens nicht wenn du Endgeräte hast die die DHCP Option nutzen wie z.B. andere Mikrotik Geräte usw.

Wie kann ich z.B. auf einem Linux-Client nachprüfen, ob das funktioniert
Das macht bei systemd Rechnern in der Regel das Tool timedatectl z.B. mit timedatectl timesync-status was dir dann den selektierten NTP Server anzeigt:
root@linux:/# timedatectl timesync-status
       Server: 130.149.17.21 (ntps1-0.cs.tu-berlin.de)
Poll interval: 34min 8s (min: 32s; max 34min 8s)
         Leap: normal
      Version: 4
      Stratum: 1
    Reference: PPS
    Precision: 4us (-18)
Root distance: 305us (max: 5s)
       Offset: +53us
        Delay: 5.958ms
       Jitter: 537us
 Packet count: 1484
    Frequency: +80.420ppm 
Eingestellt wird es in der Datei /etc/systemd/timesyncd.conf
[Time]
NTP=ntps1-0.cs.tu-berlin.de
FallbackNTP=de.pool.ntp.org 
Einige Distros nutzen auch den chrony Daemon wo das das Kommando chronyc erledigt z.B. chronyc sources Daten aller in chrony.conf eingestellten NTP Sources.
Ein chronyc tracking zeigt dir dann die obigen Daten der Systemuhr zum NTP Server wie im o.a. timedatectl Beispiel.

HowTos wie immer unter man timedatectl oder man chronyc!
Member: ArcorPi
ArcorPi May 21, 2024 at 16:51:35 (UTC)
Goto Top
Danke @aqui!