Bei einer .MSI Installationsdatei mittels CMD die Parameter ändern

Hallo ich muss eine Software installieren.
Hierbei habe ich eine .msi Installationsdatei erhalten.

In der Anleitung steht man soll die Parameter ändern, dass kann man mittels CMD tun, aber wie habe ich noch nicht ganz festgestellt.
Parameter die ich ändern soll (beispiel):

BACKEND_SERVERNAME=myserver\SQLEXPRESS


in der Anleitung steht ich soll folgendes auführen:

msiexec /i "Software BackEnd Database.msi"

aber damit starte ich ja nur die Installation, wie änder ich vorher noch die parameter?

Content-Key: 667463

Url: https://administrator.de/contentid/667463

Ausgedruckt am: 21.06.2021 um 18:06 Uhr

14 Kommentare
Mitglied: Luci0815

/qn für quiet und ohne Interface.
Mitglied: Franz-Josef-II
Guten Morgen

Indem Du es so startest?

msiexec /i "Software BackEnd Database.msi" BACKEND_SERVERNAME=myserver\SQLEXPRESS

😎
Mitglied: PeterPanter
Moin, sollte z.B. so funktionieren (ggf. aus einer elevated Console):
Welche Parameter es genau gibt, musst du der Doku zur MSI entnehmen.
Siehe auch hier: https://docs.microsoft.com/de-de/windows-server/administration/windows-c ...
/pp
Mitglied: Marco98
Am besten noch /norestart dazu. Je nach Software, gibts sonst evtl. einige sehr traurige User.

Mitglied: Mrhallo19981
leider kriege ich immer eine Fehlermeldung:

firewall sollte auf sein, deswegen weiß ich nicht wieso das immer noch nicht geht :( face-sad
10.06 - Klicke auf das Bild, um es zu vergrößern
Mitglied: Franz-Josef-II
Hat der User die Rechte? Kannst Du Dich mit der DB verbinden?
........... und vor allem RTFM 😎 ..... ähhh, was sagt die Installationsanleitung?
Mitglied: Marco98
Versuche mal BACKEND_SERVERNAME in der Notation wie bei @PeterPanter

Mitglied: TK1987
Moin,

Zitat von @Mrhallo19981:
leider kriege ich immer eine Fehlermeldung:
du hast beim BACKEND_SERVERNAME auch einen slash statt einem backslash verwendet.

Gruß Thomas
Mitglied: Franz-Josef-II
Zitat von @TK1987:
..... einen slash statt einem backslash verwendet.

Stimmt 😊
Mitglied: Mrhallo19981
hi, das hab ich schon bemerkt, daran liegts aber nicht der fehler kommt dennoch. aktuell schalten wir mal einen weiteren port 50001 frei, meine kollegin meinte daran könnte es liegen. mal sehen.
Mitglied: Marco98
Troubleshooting mit Processexplorer und Wireshark hilft immer.

Je nach Kompetenz des Softwareentwicklers, auch mal den Fragen.
Gibt halt leider sehr viele die braindead sind und keine Ahnung von ihrem Job haben und dann von irgendwelchen omninösen "Berechtigungs- und Netzwerkprobleme" brabbeln.

VG Marco
Mitglied: Luci0815
Es ist einfacher, in der Windows-Firewall die entsprechende exe zu "erlauben", statt Ports zu verwenden. Gute Entwickler erzeugen beim Setup entsprechende Ausnahmen in der Windows-Firewall, sollten aber auch darauf hinweisen.
Mitglied: Franz-Josef-II
Zitat von @Mrhallo19981:
.... aktuell schalten wir mal einen weiteren port 50001 frei ....

SQL verwendet die Ports 1433 und 1434 .....
DNS? Sprich Servername auflösbar?
Mitglied: mayho33
Also zuerst fällt mit auf dass deine CMD nicht mit administrativen Rechten läuft. Das kann OK sein, wenn es sich um eine PerUser-Installation handelt. Denke aber nicht.

Laut der Anleitung soll man die exe.Config entsprechend anpassen.

Und euer Server heißt wirklich DE9342SDB und die SQLInstanz DE9342RMS ???

Verwende mal den FQDN des Servers. Ich glaube da stimmt was mit der Namensauflösung nicht.
Heiß diskutierte Beiträge
Router & Routing
Deutsche Glasfaser. NT direkt an pfSense möglich oder besser Kaskade?
fnbaluVor 1 TagFrageRouter & Routing23 Kommentare

Hallo zusammen, am kommenden Mittwoch wird bei mir der Deutsche Glasfaser Anschluss aktiviert. Anfangs wird darüber kein Telefon laufen, aber vielleicht später. Mir stellt sich ...

Notebook & Zubehör
Alt-Laptop Vergleichsmeinungen
winlinVor 1 TagFrageNotebook & Zubehör12 Kommentare

Hallo zusammen Habe zwei Laptops und einen mini pc und würde gerne wissen was ihr zu den beiden Laptops sagt??? Was dürfte ich Max an ...

Batch & Shell
Problem mit einer Batchdatei
stevie72Vor 1 TagFrageBatch & Shell11 Kommentare

Guten Abend zusammen! Ich habe ein problem eine Batch ans laufen zu bekommen. Folgende Problem Stellung: Wir haben etwa 20 Rechner in der Bibliothek. Darauf ...

Firewall
OpenVPN-Problem
gelöst ingorosVor 1 TagFrageFirewall20 Kommentare

Hallo, habe gestern mit ipfire einen OpenVPN-Server aufgesetzt. Der läuft auch wunderbar. Sowohl Win7, wie auch Win10pro können sich problemlos anmelden. Ein Laptop mit Win10 ...

Windows 10
Remotedesktopzugang mit Openvpn sicher?
LegofrauVor 1 TagFrageWindows 108 Kommentare

Guten Morgen, wie sicher ist es wenn man Remotedesktopzugang durch einen Openvpn Tunnel betreibt? Der Openvpn Tunnel ist mit aktuellen Zertifikaten abgesichert. Der Pc hat ...

Windows Server
AD Replikation zwischen Standorten schlägt fehl nach Level auf 2008R2
diematrix125Vor 1 TagFrageWindows Server14 Kommentare

Hallo zusammen, ich habe ein (mittelschweres?) Problem mit dem AD. Ausgangssituation: Standort A: 3 DCs unter Win 2008R2 Standort B: 1 DC unter Win 2008R2 ...

LAN, WAN, Wireless
Gastnetzwerk für Restaurant mit FritzBox 4040
gelöst Net-ZwerKVor 9 StundenFrageLAN, WAN, Wireless11 Kommentare

Moin! Ich soll in einem kleinen Restaurant ein WLAN als Gastnetz einrichten. Aktuell ist vorhanden: Telekom Digitalisierungsbox Premium im Keller (macht ein WLAN, welches der ...

Windows 10
Win 10 Fehler 0xc000000e und bootmbr fehlt
dressaVor 1 TagFrageWindows 1010 Kommentare

Hallo miteinander. Ein guter Kollege von mir kam auf mich zu weil sein PC mit wichtigen Daten nicht mehr läuft. Er hatte laut seinen Aussagen ...