gravelking
Goto Top

Netzlaufwerke per GPO Probleme

Hallo zusammen,

ich habe aktuell ein Problem, bei der Zuweisung der Netzlaufwerke per GPO.
Grundsätzlich läuft es, aber wir haben immer wieder User, bei denen entweder gar keine Laufwerke oder nicht alle Laufwerke verbunden werden.
Das Eventlog auf den Clients ist ohne Fehler und ein "gpupdate" läuft ohne Problem durch.
Auch ein rsop.msc zeigt sauber an, das die Richtlinie angewendet wird.
Als Aktion für die Verbindung ist aktualisieren angegeben und die Zuweisung erfolgt über Zielgruppenadressierung auf
Sicherheitsgruppen oder wenn nicht anders möglich auf einzelne User
Hier mal ein paar Screenshots der Richtlinie:
2023-08-09 10_41_52-mremoteng - confcons.xml - ladcsrv02
2023-08-09 10_46_28-mremoteng - confcons.xml - ladcsrv02
2023-08-09 10_47_09-mremoteng - confcons.xml - ladcsrv02
2023-08-09 10_47_32-mremoteng - confcons.xml - ladcsrv02
2023-08-09 10_48_39-mremoteng - confcons.xml - ladcsrv02

Bin aktuell ziemlich ratlos, was ich noch prüfen könnte.

Hat jemand eine Idee, was ich hier übersehe oder was noch geprüft werden kann?

Grüße

Content-Key: 8086063288

Url: https://administrator.de/contentid/8086063288

Printed on: April 19, 2024 at 14:04 o'clock

Member: Mr-Gustav
Mr-Gustav Aug 09, 2023 updated at 09:07:59 (UTC)
Goto Top
Eventuell hängt sich das Windows beim erstellen des Laufwerks B: aus und dann bricht er ab.
A/B sollte man eigentlich nicht verwenden da das Überreste der DOS / Anfänge Windows sind und früher eigentlich Diskettenlaufwerke waren.

Ich hab eben auch gesehn das du Laufwerk B: als Bsp. mehrfach Vergeben ist bzw. auf ein anderes Ziel verweist.
Ja du arbeitest mit ITEM Level Targeting und Security Groups aber wenn ein Benutzer in beiden Gruppen ist führt das unweigerlich ebenfalls zu Problemen.
Windows weiß dann nicht welches der zwei Laufwerke B: zugewiesen werden soll und dann knallt es ggf. Gilt natürlich auch für die anderen Laufwerksverknüpfungen. Du musst sicherstellen das Pro Laufwerk ( als BSP B: ) immer nur eine Zuweisung gemacht wird. Sprich du musst irgendwie verhindern das ein Benutzer sozusagen das Laufwerk zweimal zugewiesen wird.

Ach ja und die Option AKTUALISIEREN ändert nur und erstellt keine Laufwerke. Wenn auf dem Rechner noch nie Netzlaufwerke erstellt / gemapped waren so muss die Funktion ERSTELLEN heißen. Aktualisieren ändert nur - Erstellen erstellt. Kleiner aber feiner Unterschied

Was sagt eigentlich das Eventlog von Windows ? Da steht def. was drinne unter GPO.......
Member: kpunkt
kpunkt Aug 09, 2023 at 09:06:58 (UTC)
Goto Top
Eventvwr?
Member: NordicMike
NordicMike Aug 09, 2023 at 09:21:38 (UTC)
Goto Top
Laufwerk A und B sind normal benutzbar, keine Probleme bei uns.

Vermutlich wurden die Geräte ohne Netzwerkverbindung hoch gefahren. Ein Abmelden und wieder anmelden sollte es jedoch wieder neu mappen.
Member: ukulele-7
ukulele-7 Aug 09, 2023 at 09:34:50 (UTC)
Goto Top
Und bitte nicht ERSETZEN verwenden, dann spuckts richtig weil die Laufwerke bei GPO Aktuallisierung kurz weg sind.
Member: gravelking
gravelking Aug 09, 2023 at 09:50:33 (UTC)
Goto Top
Zitat von @Mr-Gustav:

Eventuell hängt sich das Windows beim erstellen des Laufwerks B: aus und dann bricht er ab.
A/B sollte man eigentlich nicht verwenden da das Überreste der DOS / Anfänge Windows sind und früher eigentlich Diskettenlaufwerke waren.

Ich hab eben auch gesehn das du Laufwerk B: als Bsp. mehrfach Vergeben ist bzw. auf ein anderes Ziel verweist.
Ja du arbeitest mit ITEM Level Targeting und Security Groups aber wenn ein Benutzer in beiden Gruppen ist führt das unweigerlich ebenfalls zu Problemen.
Windows weiß dann nicht welches der zwei Laufwerke B: zugewiesen werden soll und dann knallt es ggf. Gilt natürlich auch für die anderen Laufwerksverknüpfungen. Du musst sicherstellen das Pro Laufwerk ( als BSP B: ) immer nur eine Zuweisung gemacht wird. Sprich du musst irgendwie verhindern das ein Benutzer sozusagen das Laufwerk zweimal zugewiesen wird.

Ach ja und die Option AKTUALISIEREN ändert nur und erstellt keine Laufwerke. Wenn auf dem Rechner noch nie Netzlaufwerke erstellt / gemapped waren so muss die Funktion ERSTELLEN heißen. Aktualisieren ändert nur - Erstellen erstellt. Kleiner aber feiner Unterschied

Was sagt eigentlich das Eventlog von Windows ? Da steht def. was drinne unter GPO.......


Wie schon gesagt, das Eventlog Group Policy ist ohne Fehler:

Die Verarbeitung der Group Policy Files-Erweiterung wird gestartet.

Liste der anwendbaren Gruppenrichtlinienobjekte: (Änderungen wurden ermittelt.)

Netzlaufwerke


"Die Verarbeitung der Group Policy Files-Erweiterung wurde in 79 Millisekunden abgeschlossen."


Meines Wissens nach erstellt "Aktualisieren" Verbindungen, die noch nicht vorhanden sind.

Das ein User in mehreren Gruppen vorhanden ist, kann ich eigentlich fasst ausschließen, das Abteilungsbezogen separate Sicherheitsgruppen nur für die Netzlaufwerke erstellt wurden.

Abgesehen davon wurde bei dem User aus meinen vorherigen Screenshots Laufwerk B: problemlos verbunden.
Bei dem Fall wurde z.B. Laufwerk B: und J: verbunden und F: K: und P. nicht.
Sonst hätte ich die Reihenfolge in Verdacht gehabt.
Member: gravelking
gravelking Aug 09, 2023 at 09:54:10 (UTC)
Goto Top
Zitat von @NordicMike:

Laufwerk A und B sind normal benutzbar, keine Probleme bei uns.

Vermutlich wurden die Geräte ohne Netzwerkverbindung hoch gefahren. Ein Abmelden und wieder anmelden sollte es jedoch wieder neu mappen.

Die Richtlinie "Beim Neustarten de Computers und bei der Anmeldung immer auf das Netzwerk warten" ist aktiv.
Abmelden/Anmelden löst das Problem nicht, ein gpupdate sollte ja das gleiche machen.
Member: kpunkt
kpunkt Aug 09, 2023 at 09:56:29 (UTC)
Goto Top
Was sagt denn ein net use bei so einem User?
Member: gravelking
gravelking Aug 09, 2023 at 09:58:29 (UTC)
Goto Top
Zitat von @kpunkt:

Was sagt denn ein net use bei so einem User?

Es werden nur die Laufwerke angezeigt, die auch im Explorer sichtbar sind.
Member: Mr-Gustav
Mr-Gustav Aug 09, 2023 at 10:28:31 (UTC)
Goto Top
Die Berechtigungen der Freigaben passt aber ?
Was passiert wenn du die Freigabe manuell hinzufügst an einem betroffenen PC
Member: gravelking
gravelking Aug 09, 2023 at 11:16:42 (UTC)
Goto Top
Zitat von @Mr-Gustav:

Die Berechtigungen der Freigaben passt aber ?
Was passiert wenn du die Freigabe manuell hinzufügst an einem betroffenen PC

Die Berechtigungen sollten auch in Ordnung sein, da es ja vorher über Anmeldescripte jahrelang problemlos funktioniert hat.
Die Berechtigungen der Freigabe ist "Ändern" für alle "Authentifizierten Benutzer".

Was mir jetzt noch aufgefallen ist, das er beim gpresult /H eine Warnung für die Gruppenrichtlinie Netzlaufwerke gibt:

Netzlaufwerke AD/SYSVOL - Versionskonflikt

Im Detail sieht es dann so aus:

Revision AD (1007), SYSVOL (927)

Ich konnte aber leider nichts dazu finden.
Member: NordicMike
NordicMike Aug 09, 2023 at 11:17:33 (UTC)
Goto Top
Um die Berechtigungen auszuschließen, kann der Benutzer das Laufwerk noch manuell mappen?
Member: em-pie
em-pie Aug 09, 2023 at 11:17:50 (UTC)
Goto Top
Zitat von @gravelking:
Zitat von @NordicMike:
Vermutlich wurden die Geräte ohne Netzwerkverbindung hoch gefahren. Ein Abmelden und wieder anmelden sollte es jedoch wieder neu mappen.
Die Richtlinie "Beim Neustarten de Computers und bei der Anmeldung immer auf das Netzwerk warten" ist aktiv.
Abmelden/Anmelden löst das Problem nicht, ein gpupdate sollte ja das gleiche machen.

Moin,

und welche Wartezeit ist eingestellt?
https://admx.help/?Category=Windows_10_2016&Policy=Microsoft.Policie ...
Wir haben da 60 Sekunden (nach div. versuchen) eingestellt. Dank SSDs/ NVMes ist der Rechner zu schnell oben, erkennt eine Netzwerkverbindung aber ggf. sind noch nicht alle Dienste da...

Teste das einfach mal aus.
Member: gravelking
gravelking Aug 09, 2023 at 11:18:08 (UTC)
Goto Top
Zitat von @NordicMike:

Um die Berechtigungen auszuschließen, kann der Benutzer das Laufwerk noch manuell mappen?

Das funktioniert ohne Probleme
Member: kpunkt
kpunkt Aug 09, 2023 at 11:30:01 (UTC)
Goto Top
Hm....mal ganz blöd....
Bastel mal eine neue GPO für einen User, bei dem das Mapping nicht funktioniert.
Member: gravelking
gravelking Aug 09, 2023 at 12:06:37 (UTC)
Goto Top
Zitat von @em-pie:

Zitat von @gravelking:
Zitat von @NordicMike:
Vermutlich wurden die Geräte ohne Netzwerkverbindung hoch gefahren. Ein Abmelden und wieder anmelden sollte es jedoch wieder neu mappen.
Die Richtlinie "Beim Neustarten de Computers und bei der Anmeldung immer auf das Netzwerk warten" ist aktiv.
Abmelden/Anmelden löst das Problem nicht, ein gpupdate sollte ja das gleiche machen.

Moin,

und welche Wartezeit ist eingestellt?
https://admx.help/?Category=Windows_10_2016&Policy=Microsoft.Policie ...
Wir haben da 60 Sekunden (nach div. versuchen) eingestellt. Dank SSDs/ NVMes ist der Rechner zu schnell oben, erkennt eine Netzwerkverbindung aber ggf. sind noch nicht alle Dienste da...

Teste das einfach mal aus.

Alles klar, das versuche ich mal, wenn mir auch immer noch nicht klar ist, warum ein gpupdate die Netzlaufwerke nicht verbindet, obwohl der PC schon eine Weile läuft.

Welche Key ist den jetzt der richtige?

HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\System\GpNetworkStartTimeoutPolicyValue

oder

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\WinlogonGpNetworkStartTimeoutPolicyValue

OS ist Windows 10 & 11
Member: em-pie
em-pie Aug 09, 2023 at 13:05:17 (UTC)
Goto Top
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\WinlogonGpNetworkStartTimeoutPolicyValue
Den haben wir definiert (Win 7 bis Win 11)
Member: support-m
support-m Aug 10, 2023 at 14:17:50 (UTC)
Goto Top
Hi!

Zitat von @Mr-Gustav:
Ach ja und die Option AKTUALISIEREN ändert nur und erstellt keine Laufwerke. Wenn auf dem Rechner noch nie Netzlaufwerke erstellt / gemapped waren so muss die Funktion ERSTELLEN heißen. Aktualisieren ändert nur - Erstellen erstellt. Kleiner aber feiner Unterschied
Das ist falsch, Aktualisieren erstellt auch neue Laufwerke, wenn sie noch nicht existieren.

Zitat von @gravelking:
Was mir jetzt noch aufgefallen ist, das er beim gpresult /H eine Warnung für die Gruppenrichtlinie Netzlaufwerke gibt:

Netzlaufwerke AD/SYSVOL - Versionskonflikt

Im Detail sieht es dann so aus:

Revision AD (1007), SYSVOL (927)

Das klingt nicht gut, das solltest du genauer prüfen. Das sieht für mich danach aus, dass du ein Replikationsproblem mit deinen Domaincontrollern hast, nämlich dass dein SYSVOL Verzeichnis nicht korrekt repliziert wird. Das kann das von dir genannte Verhalten auslösen, mal wird der eine DC zur Anmeldug genutzt, mal der andere. Und je nach Replikationsstatus greifen mal die Einstellungen des einen DCs und mal die des anderen DCs.

Hast du mehrere AD Standorte?

Andere Frage: Stelle sicher, dass es am lokalen Client keine USB Laufwerke oder Cardreader gibt, die die zu mappenden Laufwerke schon nutzen. Nimm denen die Buchstaben weg oder vergebe Buchstaben, die nicht als Netzlaufwerk gemappt werden!

MfG