Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Netzwerkproblem mit Router bei gleicher Domain intern und extern

Mitglied: Andres

Andres (Level 1) - Jetzt verbinden

08.09.2007, aktualisiert 17.09.2007, 5896 Aufrufe, 12 Kommentare

Hallo alle zusammen,

folgendes Problem beschäftigt mich bereits mehrere Tage:

Der DC ist ein Windows 2000 Server. Die Domain wurde leider netzwerk.de genannt und nicht .local oder .lan. Jetzt habe ich einen neuen Router installiert (LevelOne FBR-4000) der mir die Möglichkeit gibt ein Loopback einzurichten, also netzwerk.de Anfragen werden an den DNS auf dem DC 192.168.1.100 geleitet. Nur funktioniert die Sache nicht korrekt. Die Folgen sind: Rechneranmeldungen dauern manchmal lange, manchmal funktioniert der Zugriff auf den Server nicht, die Verbindung zum Netzwerk wird unterbrochen, Internetseiten werden verzögert aufgerufen. Klemme ich den Router ab, funktionieren die Netzwerkzugriffe perfekt.

Hier noch einige Daten:
- DC Windows 2000 Server mit DNS (Forward und Reverse), Wins
- Router mit fester IP
- nslookup funktioniert perfekt auf Server und Arbeitsstationen und Domain
- ping funktioniert perfekt auf Server und Arbeitsstationen und Domain

Habt ihr eine Ahnung woran das liegen kann?

Gruß
Andreas
Mitglied: filippg
08.09.2007 um 23:49 Uhr
Hallo,

"Loopback" klingt an der Stelle etwas seltsam, eigentlich ist das einfach die Angabe eines DNS-Servers, abweichend von dem, der ihm über das WAN zugeteilt wird.
Kannst du den DC nicht komplett zum DNS-Server machen? D.h. am Router entweder einstellen, dass alle DNS-Anfragen über ihn aufgelöst werden sollen, oder das eben bei den einzelnen Clients einstellen?
Ein Problem könnte sich evtl. ergeben, wenn der Router die Anfragen bzw. Antworten in einem Cache hält.
Hast du denn mal mit einem Sniffer geschaut, was da so abläuft?

Filipp
Bitte warten ..
Mitglied: Andres
09.09.2007 um 00:38 Uhr
Hallo Filippg,

ich meine die DNS Loopback-Einstellung ist dafür vorgesehen, wenn die lokale Domain bereits im Internet registriert ist und verhindert werden soll, dass ein Konflikt entsteht.

Der DC ist der DNS-Server. Wie kann im Router eingestellt werden, dass alle Anfragen am lokalen DNS-Server aufgelöst werden?

Den Cache habe ich gelöscht und nslookup zeigt alles korrekt an.

Sniffer habe ich nicht getestet.
Bitte warten ..
Mitglied: Andres
09.09.2007 um 01:33 Uhr
Es scheint doch etwas komplizierte zu sein. Hier noch einmal die Konfiguration etwas detailierter:

Topologie: Server, PCs und Router sind an einem Switch

Router:
IP: 192.168.1.1
WAN: Statische IP
Virtuelle Server:
DNS 192.168.1.100
POP3 192.168.1.100
SMTP 192.168.1.100
DNS Loopback: netzwerk.de -> 192.168.1.100

server1(DC und DNS-Server):
Domain: netzwerk.de (ist extern schon vergeben und gehört nicht zur Firma)
IP: 192.168.1.100
G: 192.168.1.1
DNS: 192.168.1.100
Weiterleitungen: DNS1+2 des ISP
Zonen: Forward und Reverse

server2 (Mitglied):
IP: 192.168.1.98
G: 192.168.1.1
DNS: 192.168.1.100

server3 (Mitglied):
IP: 192.168.1.97
G: 192.168.1.1
DNS: 192.168.1.100

Client-PCs:
IP: statisch
G: 192.168.1.1
DNS: 192.168.1.100

NSLOOKUP und PING reagieren sofort und korrekt auf alle o.g. Geräte.

NSLOOKUP auf netzwerk.de:

Server: server1.netzwerk.de
Adress: 192.168.1.100

Name: netzwerk.de
Adress: 192.168.1.100

Und trotzdem ist das Netzwerk nicht ständig erreichbar.
Bitte warten ..
Mitglied: cykes
09.09.2007 um 10:13 Uhr
Was passiert denn, wenn Du diese "Loopback" Geschichte aus der Routerkonfiguration entfernst?
Bitte warten ..
Mitglied: Andres
09.09.2007 um 12:29 Uhr
Das ändert leider nichts.
Bitte warten ..
Mitglied: cykes
09.09.2007 um 13:29 Uhr
Schau mal in die Ereignisanzeige auf den Cleints und dem Server, gibt es dort bei Anmeldung
(insbesondere, wenn es lange dauert) irgendwelche Fehler- bzw. Warnmeldungen?

Was sagt ein "dcdiag" auf dem Server?

Gruß

cykes
Bitte warten ..
Mitglied: Andres
09.09.2007 um 13:45 Uhr
In der EA steht z.B. 8032 Das Einlesen der Sicherungsliste durch den Suchdienst schlug auf Transport "\DeviceNetBT_Tcpip_.....zu oft fehl. Der Sicherungssuchdienst wird beendet.

Ist klar, denn das Netzwerk ist zeitweise zum Teil nicht erreichbar.

Mir ist aufgefallen, dass die Windows XP Clients das Problem nicht haben. Nur die Windows 2000 Clients und die Server untereinander. Der DC wird allerdings immer gefunden.

Das Tool dcdiag habe ich noch nicht getestet.
Bitte warten ..
Mitglied: Andres
09.09.2007 um 13:59 Uhr
Habe nach den Meldungen in der EA gegoogelt. Es muss etwas mit den alten Netzwerkkarten zu tun haben. Diese sind zwar im Gerätemanager nicht sichtbar, wenn an den Einstellungen etwas verändert wird kommt die Meldung:

Microsoft TCP/IP: Die Adresse "192.168.1.100", die Sie für diesen Netzwerkadapter eingegeben haben, ist bereits dem Adapter "VIA Rhine II Fast Ethernet Adapter" zugewiesen. "VIA Rhine...." wird im Ordner "Netzwerk- und DFÜ-Verbindungen" nicht angezeigt, weil er nicht physikalisch an den Computer angeschlossen ist..... Wenn dieselbe Adresse beiden Adaptern zugewiesen wird und beide aktiv werden, wird nur einer von beiden diese Adresse verwenden. Dies kann zu einer fehlerhaften Systemkonfiguration führen.

Nun ist die Frage wo lösche ich die alten, nicht aktiven NIC Infos raus. Vielleicht ist das des Rätsels Lösung.
Bitte warten ..
Mitglied: cykes
09.09.2007 um 15:13 Uhr
Du kannst mal auf der Kommandozeile folgenden Befehl: set devmgr_show_nonpresent_devices = 1
eingeben und dann im Gerätemanager im Menü Ansicht auf "ausgeblendete Geräte anzeigen"
gehen.
Dann solltest Du die Via Rhine Karte sehen und auch entfernen können.
Bitte warten ..
Mitglied: Andres
10.09.2007 um 15:55 Uhr
An den NICs lag es nicht. Habe alle NIC Leichen entfernt.

Mit dcdiag habe ich folgendes Ergebnis bekommen:

Domain Controller Diagnosis

Performing initial setup:
Done gathering initial info.

Doing initial required tests

Testing server: Standardname-des-ersten-Standorts\SERVER1
Starting test: Connectivity
......................... SERVER1 passed test Connectivity

Doing primary tests

Testing server: Standardname-des-ersten-Standorts\SERVER1
Starting test: Replications
[Replications Check,SERVER1] A recent replication attempt failed:
From MAIL-SERVER to SERVER1
Naming Context: CN=Schema,CN=Configuration,DC=netzwerk,DC=de
The replication generated an error (8524):
Ein DSA-Vorgang kann aufgrund eines DNS-Aufruffehlers nicht fortgesetzt werden.
The failure occurred at 2007-09-09 15:45.40.
The last success occurred at 2007-06-07 13:00.29.
2218 failures have occurred since the last success.
The guid-based DNS name b49a9aab-8d86-4326-8e03-03750577cedb._msdcs.netzwerk.de
is not registered on one or more DNS servers.
[MAIL-SERVER] DsBind() failed with error 1722,
Der RPC-Server ist nicht verfügbar..
[Replications Check,SERVER1] A recent replication attempt failed:
From DATEN-SERVER to SERVER1
Naming Context: CN=Schema,CN=Configuration,DC=netzwerk,DC=de
The replication generated an error (1722):
Der RPC-Server ist nicht verfügbar.
The failure occurred at 2007-09-09 15:45.41.
The last success occurred at 2007-02-06 18:47.51.
5125 failures have occurred since the last success.
[DATEN-SERVER] DsBind() failed with error 1722,
Der RPC-Server ist nicht verfügbar..
The source remains down. Please check the machine.
[Replications Check,SERVER1] A recent replication attempt failed:
From DATEN-SERVER to SERVER1
Naming Context: CN=Configuration,DC=netzwerk,DC=de
The replication generated an error (1722):
Der RPC-Server ist nicht verfügbar.
The failure occurred at 2007-09-09 15:45.40.
The last success occurred at 2007-02-06 19:15.50.
5125 failures have occurred since the last success.
The source remains down. Please check the machine.
[Replications Check,SERVER1] A recent replication attempt failed:
From MAIL-SERVER to SERVER1
Naming Context: CN=Configuration,DC=netzwerk,DC=de
The replication generated an error (8524):
Ein DSA-Vorgang kann aufgrund eines DNS-Aufruffehlers nicht fortgesetzt werden.
The failure occurred at 2007-09-09 15:45.40.
The last success occurred at 2007-06-07 13:00.29.
2218 failures have occurred since the last success.
The guid-based DNS name b49a9aab-8d86-4326-8e03-03750577cedb._msdcs.netzwerk.de
is not registered on one or more DNS servers.
[Replications Check,SERVER1] A recent replication attempt failed:
From DATEN-SERVER to SERVER1
Naming Context: DC=netzwerk,DC=de
The replication generated an error (1722):
Der RPC-Server ist nicht verfügbar.
The failure occurred at 2007-09-09 15:45.39.
The last success occurred at 2007-02-06 19:00.16.
5125 failures have occurred since the last success.
The source remains down. Please check the machine.
[Replications Check,SERVER1] A recent replication attempt failed:
From MAIL-SERVER to SERVER1
Naming Context: DC=netzwerk,DC=de
The replication generated an error (8524):
Ein DSA-Vorgang kann aufgrund eines DNS-Aufruffehlers nicht fortgesetzt werden.
The failure occurred at 2007-09-09 15:45.39.
The last success occurred at 2007-06-07 13:00.06.
2218 failures have occurred since the last success.
The guid-based DNS name b49a9aab-8d86-4326-8e03-03750577cedb._msdcs.netzwerk.de
is not registered on one or more DNS servers.
......................... SERVER1 passed test Replications
Starting test: NCSecDesc
......................... SERVER1 passed test NCSecDesc
Starting test: NetLogons
......................... SERVER1 passed test NetLogons
Starting test: Advertising
......................... SERVER1 passed test Advertising
Starting test: KnowsOfRoleHolders
......................... SERVER1 passed test KnowsOfRoleHolders
Starting test: RidManager
......................... SERVER1 passed test RidManager
Starting test: MachineAccount
......................... SERVER1 passed test MachineAccount
Starting test: Services
......................... SERVER1 passed test Services
Starting test: ObjectsReplicated
......................... SERVER1 passed test ObjectsReplicated
Starting test: frssysvol
Error: No record of File Replication System, SYSVOL started.
The Active Directory may be prevented from starting.
......................... SERVER1 passed test frssysvol
Starting test: kccevent
......................... SERVER1 passed test kccevent
Starting test: systemlog
An Error Event occured. EventID: 0xC000000F
Time Generated: 09/09/2007 15:30:43
(Event String could not be retrieved)
An Error Event occured. EventID: 0xC0001B61
Time Generated: 09/09/2007 15:31:34
(Event String could not be retrieved)
An Error Event occured. EventID: 0xC0001B58
Time Generated: 09/09/2007 15:31:34
(Event String could not be retrieved)
......................... SERVER1 failed test systemlog

Running enterprise tests on : netzwerk.de
Starting test: Intersite
......................... netzwerk.de passed test Intersite
Starting test: FsmoCheck
......................... netzwerk.de passed test FsmoCheck

Dann habe ich nachgeschaut, es sind tatsächlich zwei nicht vorhandene Server im AD unter Domain Controllers aufgeführt. Und zwar der mail-server und daten-server. Die lassen sich aber nicht entfernen. Es kommt die Meldung: Das DSA Objekt kann nicht entfernt werden.

Kann das die Ursache für den zeitweisen Ausfall des Netzwerkes sein?
Bitte warten ..
Mitglied: cykes
10.09.2007 um 16:29 Uhr
Ja, wenn die Replikation nicht korrekt durchgeführt werden kann, fängt das AD irgendwann an zu "spinnen". Eventuell wurde die beiden Server nur teilweise aus dem AD entfernt wurde.

Du kannst Dir mal folgenden KB Artikel durchlesen und so eventuell manuell die Einträge im AD
entfernen: http://support.microsoft.com/kb/216498

Gruß

cykes
Bitte warten ..
Mitglied: Andres
17.09.2007 um 14:24 Uhr
Habe die DC-Leichen erfolgreich mit ADSIedit entfernt, aber das Problem bleibt. Die Rechner/Server sind untereinander sporadisch nicht erreichbar.

Ist die Netzwerkkonfiguration doch nicht korrekt, beziehungsweise fehlen Einstellungen im Router?
Bitte warten ..
Ähnliche Inhalte
C und C++
Int to byte
gelöst Frage von Power-PolerC und C++11 Kommentare

Guten Tag, Habe gerade ein kleines Problem, welches mir Kopfzerbrechen bereitet. Und zwar will ich über den Pi an ...

TK-Netze & Geräte

Auerswald Anzeige Status andere int. Teilnehmer

gelöst Frage von the-buccaneerTK-Netze & Geräte5 Kommentare

Hi! Gibt es in der Kombination Auerswald Compact 5200 und Comfortel 2600IP die Möglichkeit, den Status der Mitarbeiter direkt ...

Humor (lol)

Javascript Evaluation (a gleich 1 und a gleich 2 und a gleich 3)

gelöst Frage von LochkartenstanzerHumor (lol)6 Kommentare

Viel Spaß beim Knobeln: Can (a 1 && a 2 && a3) ever evaluate to true? lks Du hast ...

CSS

Row gleich hoch

Frage von pcguyCSS10 Kommentare

Hallo zusammen, ich habe eine Frage betreffend bootstrap row. Ich habe folgende Einteilung: Die Bilder sind responsive, da sie ...

Neue Wissensbeiträge
Windows 10

Windows 10 V1809: Rollout ist gestartet - kommt per Windows Update

Information von kgborn vor 17 StundenWindows 101 Kommentar

Eine kurze Information für die Admins, die Windows 10 im Programm haben. Microsoft hat die letzte Baustelle (die Inkompatibilität ...

Sicherheit

Heise Beitrag Passwort-Sammlung mit 773 Millionen Online-Konten im Netz aufgetaucht

Information von Penny.Cilin vor 20 StundenSicherheit5 Kommentare

Auf Heise Online ist folgender Beitrag veröffentlicht worden: Heise Beitrag passwörter geleakt Ich bin mir jetzt nicht ganz sicher, ...

Microsoft Office
TEAMS - Skype for business
Tipp von Nebellicht vor 20 StundenMicrosoft Office

Hallo, ms ersetzt Skype for business durch TEAMS. Also, nicht wundern wenn mit der OFFICE365 Umgebung kein Skype for ...

Windows 10

Windows 10: Cortana und die Suche gehen bald wieder eigene Wege

Information von Frank vor 1 TagWindows 102 Kommentare

Microsoft hat einen neuen Insider Build von Windows 10 veröffentlicht (Fast Ring, Version 18317), wo die digitale Assistentin "Cortana" ...

Heiß diskutierte Inhalte
Windows Server
Uhren gehen immer wieder falsch
Frage von killtecWindows Server23 Kommentare

Hallo, ich habe folgende Konstellation: 1. Physischer DC Div. Virtuelle DC's auf Hyper-V Servern Die Hyper-V-Server, der Physische DC ...

Switche und Hubs
Medienkonverter mit 12 oder 24 Ports gesucht
Frage von wmuellerSwitche und Hubs22 Kommentare

Guten Morgen, ich bin auf der Suche nach einem größeren Medienkonverter, der "stumpf" 1:1 die Ports auf über ein ...

Windows Server
Client in die Domäne einbinden - Allgemeine Frage dazu
gelöst Frage von RalphTWindows Server19 Kommentare

Moin, ich habe 2 DCs in einer Hauptstelle und 2 DCs in einer Nebenstelle. Ich bringe in der Hauptstelle ...

Debian
OpenSSH Login mit Public Key schlägt fehl, mit Passwort funktioniert
gelöst Frage von DKowalkeDebian19 Kommentare

Hallo zusammen, ich hatte hier schon nach einer Anleitung für einen SFTP Server mit Linux gefragt, habe dort auch ...