mpanzi
Goto Top

Neuer Exchange zieht altes Adressbuch

Hallo zusammen,

komisches Problem: Vor etwa zwei Monaten haben wir den Exchange-Server von 2012 auf 2019 umgestellt. Die Umstellung an sich ist gut verlaufen. Läuft seither problemlos. Der alte (virtuelle) Exchange-Server ist ausgeschaltet.

Jetzt ist aber etwas aufgefallen, was erst nach Useränderungen gemerkt wurde. Das Adressbuch wird nicht aktualisiert. Letzte Woche sind zwei User ausgeschieden und drei hinzugekommen.

Die können ganz normal Mails senden und empfangen, aber das Globale Adressbuch interessieren die Änderungen nicht.

Zunächst habe ich das Offline Addressbuch mal neu heruntergeladen, nutzte nichts. Dann habe ich bei mir den Ordner "Offline Address Books" in Appdata gelöscht. Er wurde neu generiert - aber mit den alten Usern.

Interessant ist, dass in OWA die gelöschten User rausgenommen sind - aber die neuen nicht hinzugefügt wurden.

Im Exchange Administration Center sind die User gepflegt.

Nachdem keine Meldung kommt, dass das Adressbuch nicht aktualisiert werden kann, muss er eines finden. Aber irgendwie das alte. Kann man irgendwo sehen, wo er danach sucht?

Content-Key: 53811286047

Url: https://administrator.de/contentid/53811286047

Printed on: July 24, 2024 at 16:07 o'clock

Member: Pjordorf
Pjordorf Jun 06, 2024 at 10:25:49 (UTC)
Goto Top
Hallo,

Zitat von @mpanzi:
haben wir den Exchange-Server von 2012 auf 2019 umgestellt.
Von Links nach Rechts oder von unten nach oben? Das 2012 ist aber nur ein Server OS, welches Exchange läuft denn bei euch?

Die Umstellung an sich ist gut verlaufen. Läuft seither problemlos.
Deinem vernehmen nach ist wohl nicht so problemlos verlaufen...

Nachdem keine Meldung kommt, dass das Adressbuch nicht aktualisiert werden kann, muss er eines finden.
Der Pöse Exchange findet sachen aber du nicht. Ich frag gar nicht erst über welches wissen (nein, den ein und auszuschalten ist kein wissen) du über deinen Exchange verfügst face-smile

Aber irgendwie das alte. Kann man irgendwo sehen, wo er danach sucht?
Auch ein Exchange kann dir so viele Logs produzieren das auch kleinere Datenträger damit voll gemacht werden können. Dann noch die Logs korrekt gelesen und da sollte irgendwo stehen was nicht passt. Gurgel ist eine gute Anlaufstelle heutzutage, aber die wollen auch erst deine Exchange Version wissen.

Gruss,
Peter
Member: Heididliho
Heididliho Jun 06, 2024 at 10:27:56 (UTC)
Goto Top
Passen die Virtual Directories?
Scheint mir ein Zuordnungsthema zu sein.
OAB einmal sauber neu anlegen - und dann weiter testen.


Lg
Member: mpanzi
mpanzi Jun 06, 2024 at 11:40:19 (UTC)
Goto Top
Exchange 2019 auf einem Server 2022. Bei dem alten hatte ich mich vertan - war ein 2016 auf einem 2012er Server.

Hatte ja geschrieben - bisher problemlos face-smile. So lange es keine Useränderungen gab, funktionierte es einwandfrei. Jetzt gibt es eben ein Problem.

In den Logs gibt es keinen Fehler, der passen würde. Hatte ich schon geschaut. Nur eine überschaubare Menge an Fehlern/Warnungen überhaupt - keiner, der was mit dem Adressbuch zu tun hat. Weder in der Ereignisanzeige noch in den Log-Dateien.

Die Directories stimmen - war auch mein erster Gedanke.
Member: Heididliho
Heididliho Jun 06, 2024 at 11:58:22 (UTC)
Goto Top
so wird das nichts...
Member: mpanzi
mpanzi Jun 06, 2024 updated at 12:29:24 (UTC)
Goto Top
Der Fehler liegt vielleicht woanders - weiß aber nicht wo.

Ist mir erst jetzt aufgefallen: Wenn ich in Outlook das globale Adressbuch öffne - stimmt es. Alte User sind weg, neue sind drin.

Aber wenn ich an "alle Mitarbeiter" schreibe (was das globale Adressbuch sein sollte), dann kommen die falschen Empfänger.

Das ist eine Verteilergruppe, die sollte eigentlich automatisch über ein script aktualisiert werden - das funktioniert offensichtlich nicht. Muss ich mir mal das script anschauen.
Member: mpanzi
mpanzi Jun 06, 2024 at 12:47:40 (UTC)
Goto Top
Jetzt gehts. Tatsächlich die ganze Zeit an der falschen Stelle gesucht. Hatte nichts mit dem Globalen Adressbuch zu tun. Nur mit der Verteilergruppe, die nicht aktualisiert wurde.