OpenVPN kann einen Server im Netz nicht erreichen, alle anderen funktionieren

bigbootykilla
Goto Top
Hi,

ich habe vor ein paar Monaten unser Lancom VPN, durch OpenVPN auf Ubuntu 18.04 ersetzt. Eigentlich hat auch alles wunderbar funktioniert. Vor ein paar Tagen habe ich ein Tool installiert, welche mir die IPTABLES automatisch nach einem Reboot wieder lädt. Das Tool hieß iptables-persistent. Ich habe dann die IPTABLES einmal wie immer ausgeführt und sie dann in die Datei /etc/iptables/rules.v4 schreiben lassen bzw. hat er bei der Installation des Tools iptables-persistent die bereits bestehenden IPTABLES automatisch reingeschrieben.

Danach hab ich die Kiste in der VM mal neu gestartet und alles ging reibungslos. Heute musste ich mal auf einen Server 192.168.1.2 via Remotedesktop und plötzlich musste ich feststellen, dass das Ding nicht erreichbar ist. Alle anderen Server in dem Netz 192.168.1.0/24 sind erreichbar. Verändert habe ich nichts. Wie kann das sein?

An meiner Routing Tabelle kann ich jetzt auch nichts erkennen, was da falsch läuft.

Witzigerweise läuft das alte Lancom VPN noch, quasi als Backup VPN. Verbinde ich mich darüber ist der Server erreichbar. Intern im Netz ist er auch anpingbar. Vom OpenVPN Server direkt ist er auch nicht erreichbar, alle anderen Server jedoch sehr wohl.

Hat da jemand einen Tipp woran das liegen könnte?

Erwähnt soll hier noch sein, dass der OpenVPN Server mit er IP 192.168.1.24 auf einer Hyper-V Maschine läuft. Dieser Hyper-V Server hat nämlich die IP 192.168.1.2, der er nicht erreichen kann. Kann es daran liegen?

Content-Key: 551824

Url: https://administrator.de/contentid/551824

Ausgedruckt am: 13.08.2022 um 12:08 Uhr

Mitglied: Dr.Bit
Dr.Bit 27.02.2020 aktualisiert um 09:29:56 Uhr
Goto Top
Zitat von @bigbootykilla:
Erwähnt soll hier noch sein, dass der OpenVPN Server mit er IP 192.168.1.24 auf einer Hyper-V Maschine läuft. Dieser Hyper-V Server hat nämlich die IP 192.168.1.2, der er nicht erreichen kann. Kann es daran liegen?


Also: Wenn ich das richtig verstehe, versuchst Du den Host zu erreichen? Die Vm´s auf dem Host sind erreichbar? Und der OpenVPN Server läuft auf dem gleichen Host?
Wenn der OpenVPN auf dem Host liegt, den er anpingen soll und nicht kann, kann ich mir vorstellen, daß in der virtuellen Netzwerkkarte des HyperV irgend etwas nicht richtig eingestellt ist.

Gruß
Stephan
Mitglied: samet22
samet22 27.02.2020 um 08:47:03 Uhr
Goto Top
welche IP-Adresse beziehst du wenn du über den "neuen" Open-VPN Server verbunden bist? Hast du schon mal in die Windows Firewall vom HYPER-V geschaut ob du eventuell die neue IP freigeben musst?