freneticstar
Goto Top

OpenWebStart greift nicht

Hallo erstmal,

wir sind gerade dabei zwei neue Terminalserver einzurichten. Hat auch bis dato wunderbar geklappt.

Nun habe Ich das Problem, dass von unserer Firma vorgegeben ist, dass wir Java deinstallieren sollen und OpenWebStart 1.6.0 installieren sollen. Auf allen anderen Terminalservern ist OWS 1.4.0 drauf - funktioniert top.

Nun funktioniert ein Aufruf aus unserem DMS auf eine Webseite leider nicht. Hier öffnet sich nach Aufruf immer die https://www.java.com/de/download/ Seite. Allerdings natürlich nur auf den 2 neuen Terminalservern.

Dann natürlich mal OWS 1.4.0 installiert - funktioniert aber auch nicht. Sobald man Java installiert funktioniert der Aufruf natürlich..

Die Konfiguration der OWS Settings sind exakt die selben, bin hier nun schon tausend mal durchgegangen.

Habt Ihr noch Tipps was Ich vergessen haben könnte, ich glaube Ich steh gerade einfach nur enorm auf dem Schlauch.

Besten Dank schonmal!

Content-Key: 32703167351

Url: https://administrator.de/contentid/32703167351

Printed on: April 12, 2024 at 23:04 o'clock

Member: wollekuj
wollekuj Feb 28, 2024 updated at 19:30:55 (UTC)
Goto Top
Hallo,

falls das DMS webbasiert aufgerufen wird und von dort dann per Browser der Absprung auf die Website passiert, müssen evtl. dort im Browser die jnlp Dateien mit openwebstart geöffnet werden( wenn es denn welche gibt).
Vlt ist auch unter Windows für den dateityp jnlp nicht javaws hinterlegt wie zb. javaws.exe" -allowredirect -jnlp "%1"
Wenn mal Java nachinstalliert wurde und nicht ows danach erneut kann es sein dass die Zuordnung nicht mehr passt.
Ansonsten vielleicht im Openwebstart Setup das Logging aktivieren und das Logfile prüfen. Welche config wurde angepasst die user oder die systemconfig?

Edit:
Vlt muss die Url auch noch mit in die Whitelist?
deployment.security.whitelist=meinserver.de?

Es kann auch helfen die jnlp einmalig als administrator direkt aus dem browser aufzurufen und anschließend mit ows zu öffnen, erst dann wird die jvm installiert.

Ist viel geraten dabei, aber vielleicht hilft es ja schon, wenn nicht wären mehr infos über verwendete browser und die angepassten configs hilfreich.
Member: Dani
Dani Mar 03, 2024 at 10:14:45 (UTC)
Goto Top
Moin,
un habe Ich das Problem, dass von unserer Firma vorgegeben ist, dass wir Java deinstallieren sollen und OpenWebStart 1.6.0
Es gibt doch inzwischen Version 1.91. Warum installierst du eine solche alte Version?!

Nun funktioniert ein Aufruf aus unserem DMS auf eine Webseite leider nicht.
Was ist den seitens des Herstellers vom DMS die Vorgabe für den Betrieb?!


Gruß,
Dani