manfrednuding
Goto Top

ping erreicht Rechner im eignen Netzwerk nicht

Obwohl zwei Rechner im selben Netz stehen, finden Sie sich über ping nicht.

Wir betreiben mehrere Netzwerke, die durch eine Firewall voneinander getrennt sind. Die Firewall fungiert gleichzeitig als Router zwischen diesen Netzen.

Ein Solaris-Rechner wurde nun testweise aus einem dieser Netze in ein anderes Netz transferiert. Nach Abschluß der Tests wurde er wieder in das alte Netz zurückgestöpselt. Die IP-Adresse und die Subnetmask wurden korrekt zurückgesetzt. Der Rechner wurde auch neu gebootet.

Jetzt kann der Rechner zwar sich selber und die Firewall per ping erreichen, nicht aber einen weiteren, im gleichen Netz liegenden Solaris-Rechner.

Seltsamerweise wird nach dem erfolglosen ping im arp-Cache als MAC-Adresse für den angepingten Rechner die MAC-Adresse des Routers (der Firewall) eingetragen. M.E. sollte ping aber zunächst im eigenen Netz suchen und nicht das Defaultgateway abfragen.
Von einem dritten Netzwerk aus kann ich auf beide Rechner per ping und telnet zugreifen.

Der arp-Cache auf den betroffenen Rechnern und auf der Firewall (wird extern betreut) wurden angeblich gelöscht.
Wie finden sich meine beiden Rechner wieder?

Content-Key: 433

Url: https://administrator.de/contentid/433

Ausgedruckt am: 29.09.2022 um 22:09 Uhr

Mitglied: Lord-Blood
Lord-Blood 12.11.2002 um 23:53:52 Uhr
Goto Top
Hi,

und wenn du mal selbst die arp-caches leerst, die Netzwerkeinstellungen nochmal komplett löschen tust, und dann wieder Rebootest, alles wieder neu einstellst und dann wieder rebootest, dann müssten doch die adress tables gelöscht und umkonfiguriert sein, oder??
Das wäre eine möglichkeit,
die andere wäre, wenn du mal versuchst einen Laptop in das netz des Solaris zu hängen und dann mal versuchen den über den Laptop zu finden, also so zur fehlersuche.

Viel Glück

Euer Lord_Blood
Mitglied: atbits
atbits 13.11.2002 um 10:34:32 Uhr
Goto Top
Benutzt Ihr einen Switch oder einen Hub.

Switches halten auch die MAC-Adressen gespeichert, möglicherweise hilft es, den Switch einmal neu zu starten.

Für mich klingt es aber eher danach, dass noch irgendwelche Net- oder Host-Spefic-Routes in der Routingtabelle stehen.

Gruss David
Mitglied: ManfredNuding
ManfredNuding 25.11.2002 um 09:28:47 Uhr
Goto Top
Inzwischen ist das Problem gelöst.

Auf der (fremdbetreuten) Firewall war auf dem betroffenen Interface definert, dass generell alle Broadcasts von der Firewall beantwortet werden. Dies hatte zur Folge, dass der ping nicht den Weg zum Rechner im eigenen Netz fand, da die Antwort immer von der Firewall kam.
Jetzt wurde die Firewall umkonfiguriert, so dass nur noch die Broadcasts beantwortet werden, die nicht aus dem eigenen Netz kommen.