netzer2021
Goto Top

Proxmox VLAN setup

Hallo Community,

die docs und learning by doing bringt mich aktuell leider noch nicht ans Ziel. Daher folgende Frage an euch.

Ich habe folgendes in Proxmox vor:

Aktuell:
Nach einer neuen Installation habe ich nach wahl des Netzwerkdevice (enps04 - ehternet) eine vmbr0 erhalten. Die Bridge hält das Netzwerk 192.168.20.1/24 mit IP x.x.20.20. So weit so gut . es läuft erstmal. Stelle ich allerdings auf zwei vlans am Port des Switchs um bekommt der Proxmox host keine IP mehr. Da wahrscheinlich die Entscheidungslogig fehlt aus welchem Netz denn die IP kommen sollen?


Ziel:
Ich habe zwei vlans auf der opnsene "prod" 192.168.20.1/24 (tag 20) und "test" 192.168.21.1/24 (tag 21) Beide VLANs möchte ich auf die physikalische Ethernetschnittstelle meines HM80 die "enps04" legen. Dazu muss erstmal der Port meines Switchs beide vlans weiter routen - wie beschrieben.
Letzten Endes möchte ich pro VM oder LXC entscheiden können welche Bridge und damit das Netzwerk (prod oder test) ausgewählt wird.
Nach meinem aktuellen Verständnis muss ich das device enps04 auf vlan aware schalten damit hier die vlans auch durch kommen. Damit kann ich meine beiden bridges vmbr0.20 für das 20er Netz und vmbr1.21 für das 21er Netz erstellen. Beide nutzen enps04 als Port. Ist das erstmal so korrekt? Muss ich die Bridge ebenfalls auf vlan aware stellen? nehem ich an? Bei der Erstellung einer VM oder LCX wähle ich dann die entsprechende bridge und gut. DHCP der OPNsense weißt dann entsprechend eine IP zu.

Möchte ich aktuell eine weitere Bridge erstellen, bekomme ich zb die Fehlermeldung das mein Gateway 192.168.20.1 bereits genutzt wird auch wenn ich für das 21Netz das gateway 192.168.21.1 nehme. Was soll denn da sonst hin? Gatway der FW?


Ist der skizzierte Weg überhaupt richtig? Da nicht geht face-smile wohl scheinbar nicht ganz....

Danke für euer Feedback.

Content-Key: 4975841123

Url: https://administrator.de/contentid/4975841123

Printed on: May 23, 2024 at 12:05 o'clock

Member: netzer2021
Solution netzer2021 Dec 15, 2022 at 22:10:23 (UTC)
Goto Top
SIeht dann doch etwas anders aus:

auto vmbr0
iface vmbr0 inet static
bridge-ports enp4s0
bridge-stp off
bridge-fd 0
bridge-vlan-aware yes
bridge-vids 2-4094

auto vmbr0.20
iface vmbr0.20 inet static
address 192.168.20.20/24
gateway 192.168.20.1
#Prod Network

auto vmbr0.21
iface vmbr0.21 inet static
address 192.168.21.20/24
#Test Network
Member: aqui
aqui Dec 16, 2022 at 08:30:46 (UTC)
Goto Top
auf die physikalische Ethernetschnittstelle meines HM80 die "enps04" legen
Bedenke auch immer das sowohl auf dem Hypervisor als auch auf der Firewall die physikalische Schnittstelle immer untagged sendet!
Das ist auch so bei (fast) allen Switches auf Trunk Ports (Tagged Ports) üblich das das PVID VLAN immer untagged gesendet wird. Nur das was von den virtuellen VLAN Schnittstellen kommt hat dann einen entsprechenden VLAN Tag.