kirschi
Goto Top

Psexec nur noch lokal ausführbar, Wildcardaufruf schlägt fehl

Hallo zusammen,

seit kurzem gelingt es mir nicht mehr, domänenweit psexec einzusetzen, konkret: psexec \\* wuauclt /detectnow.
Es werden diverse Fehlercodes gemeldet (58, 64...). Das Ausführen mit einem konkreten Rechnernamen funktioniert. Habt ihr eine Idee, an was das liegen könnte?
Es gab zwischendurch diverse Neustarts der kompletten Infrastruktur aufgrund Storagemigration. W2K12R2, sonst fällt mir nichts ein dazu.

Content-Key: 395032

Url: https://administrator.de/contentid/395032

Printed on: June 12, 2024 at 15:06 o'clock

Member: Penny.Cilin
Penny.Cilin Dec 07, 2018 updated at 13:04:59 (UTC)
Goto Top
Hallo,

hat den der Wildcardaufruf überhaupt mal funktioniert?
Außerdem gibst Du KEIN Benutzer und Passwort mit, also -u und -p oder gar -s?
Entweder
psexec -u <admin> -p <Password> \\* wuauclt /detectnow
oder
psexec -s \\* wuauclt /detectnow

Gruss Penny
Member: Kirschi
Kirschi Dec 07, 2018 updated at 13:19:48 (UTC)
Goto Top
Hi Penny,
ja, hat vor 3 Wochen noch funktioniert, in einer cmd als Admin, ohne weitere Parameter.

Gruß
Andreas
Mitglied: 137846
137846 Dec 07, 2018 updated at 15:58:25 (UTC)
Goto Top
Mögliche Ursache:
Netzwerkzone wurde an den Kisten als neu erkannt, und damit benötigte Ports geschlossen.
Oder psexec kann die Domain-Computer wegen DNS-Fehler oder aktivem NETBIOS nicht mehr ermitteln.
Wenn Kiste von außerhalb der Domain, dann LocalAccountTokenFilterPolicy wegen UAC beachten!
Würde ich mich sowieso nicht drauf verlassen und die Computer selbst per Powershell (z.B. Get-ADComputer oder LDAP Abfrage) ermitteln und per WMI Befehle absetzen.

Gruß A.
Member: Kirschi
Kirschi Dec 12, 2018 at 06:21:33 (UTC)
Goto Top
Danke euch, mittlerweile ist das Problem gelöst. Die Ursache kann im Nachhinein nicht mehr genau ermittelt werden. Es wurden die DNS-Dienste auf den DCs bereinigt und neu gestartet sowie unter VMWare die Netzwerkeinstellungen (Vertrauen) angepaßt.