spartacus
Goto Top

QNAP TVS 672XT - Probleme mit der Netzwerkkonfiguration

Moinsen,
ich habe jetzt meine neue Qnap am Start. Bestückt ist sie zur Zeit mit 2 x 2 TB NVMe
im Raid 1. Es ist ein einziges Thick Volume mit der Möglich Snapshots zu machen eingerichtet.
Soweit geht das auch. Die 4 x 8TB WD Red. sind noch nicht geliert, diese sollen aber als Speichermedium für Daten und Multimediainhalte dienen.

Allerdings tue ich mich sehr schwer mit der Konfiguration der Netzwerkadapter. Ich hoffe, es kann jemand helfen...

Plan:
  • Hostname Qnap: "Sonnenblume"
  • alle VMs werden auf den M2 SSDs gehostet
  • ETH1 10G: soll für den Datenaustausch der Daten und Multimedianhalte dienen
  • ETH2 1GB: soll im VLAN99 hängen (Administration)
  • ETH3 1GB: VLAN-Trunk für meine Dienste, die als VMs auf der QNAP gehostet werden (MYSQL, Radius, deCONZ, fhem...etc)

aktuell habe ich ein paar VMs über die Virtualisation Station an den Start gebracht und quäle mich mit der Netzwerkkonfiguration herum. Gerne hätte ich Docker eingesetzt, aber ich habe es nicht hinbekommen, einem Containere einem VLAN zuzuordnen. Irgendwie gibt es kann man das in der Netzwerkkonfiguration nicht konfigurieren, oder ich habe es nicht gefunden.

im Moment sieht das Netzwerk in der Qnap so aus:
virtualnetwork

die Übersicht über die Adapter:
adapterqnap

  • Schnittstelle1 (Daten 10G) ist untagged an einen Cisco switch angeschlossen und bekommt aus VLAN10 eine Adresse

  • An Schnittstelle 2 (Admin 1G) habe ich einen virtuellen Switch gekoppelt, der sich eine IP aus dem VLAN99 zieht. auch dieser Port hängt untagged an dem Cisco Switch und stellt das VLAN99 bereit.

  • An Schnittstelle 3 (VLANs 1G) habe ich drei VLAN Adapter konfiguriert und für jeden VLAN Adapter einen eigenen virtuellen Switch angelegt, der sich aber keine eigene IP zieht. Das verhindert, dass sich der Qnap Host "Sonnenblume" nicht in jedem VLAN-Subnetz als eigener Host einträgt.

Für Schnittstelle 2 ist das ja ok, denn dies befindet sich ja im Admin VLAN und stellt somit die Verbindung zum Webinterface der Qnap her.

Die VMs habe ich dann mit ihren Netzwerkadaptern an die jeweiligen "virtuellen Switche" gepackt.

Soweit habe ich es aktuell am Start.

  • was mich aber stört ist bzw. was ich nicht verstehe:
  • welchen Sinn hat es, den virt. Switchen IP-Adressen zu vergeben, oder habe ich hier etwas komplett falsch konfiguriert?
  • wieso kann man in der Container-Station keine VLAN-Adapter oder die jeweiligen Switche auswählen den einzelnen Containern zuordnen

Entweder ist das Ganze sehr umständlich gelöst, oder ich habe es noch nicht geschnallt. Außerdem finde ich es sehr unpraktisch, dass man die Qnap-eigenen Dienste (MySQL, TFTP) nicht einem VLAN zuordnen kann. Hier muss man m.E. separate VMs aufsetzten...(btw. gibt es einen schönen TFTP-, MySQL- oder Freeradius-Server als fertiges VM-Image?)

für Tipps und Anregungen wäre ich dankbar,
Spartacus.

Content-Key: 634275

Url: https://administrator.de/contentid/634275

Printed on: February 22, 2024 at 04:02 o'clock

Member: tech-flare
tech-flare Dec 22, 2020 at 18:37:27 (UTC)
Goto Top
Die VMs habe ich dann mit ihren Netzwerkadaptern an die jeweiligen "virtuellen Switche" gepackt.

Soweit habe ich es aktuell am Start.

  • was mich aber stört ist bzw. was ich nicht verstehe:
  • welchen Sinn hat es, den virt. Switchen IP-Adressen zu vergeben, oder habe ich hier etwas komplett falsch konfiguriert?
ÜBer diese IP kannst du z.B. auch das QNAP aufrufen. Wichtig ist aber, dass bei den virtuellen Switche keine Schleifen gebaut werden.
ICh habe hier ein virt. Switch und dort 2 Ports dran.
Port 1 -> Switch vom netzwerk
Port 2 -> DAC Verbindung zum Macbook 10 Gbit

Somit greife ich über das kompeltte Netzwerk über diese eine IP auf das QNAP zu.
qnap_netzwerk

* wieso kann man in der Container-Station keine VLAN-Adapter oder die jeweiligen Switche auswählen den einzelnen Containern zuordnen
Kann man doch?
contaner_netzwerk


Entweder ist das Ganze sehr umständlich gelöst, oder ich habe es noch nicht geschnallt. Außerdem finde ich es sehr unpraktisch, dass man die Qnap-eigenen Dienste (MySQL, TFTP) nicht einem VLAN zuordnen kann.
Vielen vergessen, dass das QNAP dennoch ursprünglich ein "einfaches" NAS war. Jedoch kannst du bestimmte Dieneste an verschiedene Ports hängen, welche wiederrum ja an AccessPorts am Switch hängen können, welche verschiedene VLAN haben
qnap_dienste

Hier muss man m.E. separate VMs aufsetzten...(btw. gibt es einen schönen TFTP-, MySQL- oder Freeradius-Server als fertiges VM-Image?)
Bei Docker gibts dies doch alles in der ContainerStation
Member: Spartacus
Spartacus Dec 23, 2020, updated at Dec 24, 2020 at 10:09:45 (UTC)
Goto Top
Hallo,
vielen Dank für die ausführliche Antwort.
Wenn ich es richtig verstehe, nutz man die IP der virtuellen Switche nur für den Zugriff auf die Qnap.....und das will ich ja eigentlich nur über mein Admin Interface, welches untagged sein muss, damit man zur Not auch noch auf die Kiste kommt, wenn etwas schief geht. Das ist bei mir der Adapter 2 an den ich noch über einen virtuellen Switch eine VM koppeln muss, den den Radius-Server für mein Netz zur Verfügung stellt. Die Qnap ist dann natürlich über die Switch-IP administrierbar. Ich denke, dass ist dann so wohl ok.

Adapter 1 (das10G Interface) hängt dann in meinem Office VLAN (VLAN 10). Da werden dann die Clients ihre Daten ziehen können. Und das ist dann die zweite IP über die man die Qnap erreichen kann. In den Einstellungen zum Netzwerkzugang habe ich dann u.a. das Webinterface der Qnap abgeschaltet. Somit stelle ich sicher, dass niemand aus dem Office LAN die Admin Konsole der Qnap erreichen kann....

Adapter 3 hat dann für jedes VLAN, in dem VMs laufen müssen, einen Switch. Hier habe ich allerdings auch noch einmal das VLAN 10 (siehe Adapter 1) eingebunden, welches für eine Windows VM benötigt wird. Ist das jetzt so eine Schleife, die man meiden sollte? Dann muss ich das VLAN von dem Adapter 3 löschen und an Adapter 1 binden.

In der Container Station, sehe ich die nur die Adapter, nicht die Switche. Ich habe die Container Station jetzt mehrfach neu installiert. Aber ich sehe die virtuellen Switche bzw. die virtuellen Adapter nicht. Ich habe OS 4.5.1.1, quasi die neuste Version.

Oder muss man hier bei der Netzwerkkonfiguration der ContainerStation etwas den Default-Einstellungen ändern?

Danke und Gruß,
Spartacus

Nachtrag:
@ tech-flare: Wo kommen denn die 6 Ethernet-Adapter aus deinem Screenshot her? Ich habe nur 3 Physikalische an die ich die VLANs binden kann. Und dann kann ich die dienste auch nur pro physikalischem Adapter einstellen. Ist das bei dir anders, oder hast Du einfach noch ein paar Netzwerkkarten eingebaut.
Member: tech-flare
tech-flare Dec 24, 2020 at 11:45:51 (UTC)
Goto Top
Hallo,

vielen Dank für die ausführliche Antwort.
Wenn ich es richtig verstehe, nutz man die IP der virtuellen Switche nur für den Zugriff auf die Qnap.....und das will ich ja eigentlich nur über mein Admin Interface, welches untagged sein muss, damit man zur Not auch noch auf die Kiste kommt, wenn etwas schief geht. Das ist bei mir der Adapter 2 an den ich noch über einen virtuellen Switch eine VM koppeln muss, den den Radius-Server für mein Netz zur Verfügung stellt. Die Qnap ist dann natürlich über die Switch-IP administrierbar. Ich denke, dass ist dann so wohl ok.
Ja das passt

Adapter 1 (das10G Interface) hängt dann in meinem Office VLAN (VLAN 10). Da werden dann die Clients ihre Daten ziehen können. Und das ist dann die zweite IP über die man die Qnap erreichen kann. In den Einstellungen zum Netzwerkzugang habe ich dann u.a. das Webinterface der Qnap abgeschaltet. Somit stelle ich sicher, dass niemand aus dem Office LAN die Admin Konsole der Qnap erreichen kann....
ja so ist das "sehr gut". Wenn du vermeiden willst, dass jemand auf die Adminoberfläche kommt, kannst du auch die Interne Firewall vom QNAP verwenden und sagen aus welchen Netz wer wo zugreifen darf....du musst nur aufpassen, dass du dich nicht aussperrst.

Adapter 3 hat dann für jedes VLAN, in dem VMs laufen müssen, einen Switch. Hier habe ich allerdings auch noch einmal das VLAN 10 (siehe Adapter 1) eingebunden, welches für eine Windows VM benötigt wird. Ist das jetzt so eine Schleife, die man meiden sollte?
Nein das ist keine schleife, aber letztendlich sinnfrei, da der Adapter ja 10G ist und du diesen ja sicherlich nicht ausreizt oder? Vom Verwaltungsaufwand wäre es bedeutend einfacher, wenn du diese VM an den Adapter 1 bindest.


In der Container Station, sehe ich die nur die Adapter, nicht die Switche. Ich habe die Container Station jetzt mehrfach neu installiert. Aber ich sehe die virtuellen Switche bzw. die virtuellen Adapter nicht. Ich habe OS 4.5.1.1, quasi die neuste Version.
Oder muss man hier bei der Netzwerkkonfiguration der ContainerStation etwas den Default-Einstellungen ändern?

Du musst zuerst einen virtuelle switch nur für Docker anlegen und diesen an einen physischen Port binden, welcher ein untagged VLAN am phyischen Switchport hat, mit du das phyische Kabel verbindet. Sobald du an der Schnittele im QNAP ein VLAN hinterlegen willst, trennt es den Docker vSwitch
qnap_docker_1 kopie

Danach sieht das ganze in der Netzwerkkonfiguration so aus:
qnap_docker2 kopie

Im Anschluss kannst du im Docker bei der Konfiguration im Netzwerk den Docker vSwitch auswählen.
qnap_docker3 kopie

Wenn du somit unterschiedliche VLAN in Docker nutzen willst benötigst du für jedes VLAN einen eigenen Docker vSwitch, welcher an einen untaggged VLAN Port hängt.

Nachtrag:
@ tech-flare: Wo kommen denn die 6 Ethernet-Adapter aus deinem Screenshot her? Ich habe nur 3 Physikalische an die ich die VLANs binden kann. Und dann kann ich die dienste auch nur pro physikalischem Adapter einstellen. Ist das bei dir anders, oder hast Du einfach noch ein paar Netzwerkkarten eingebaut.
Ich habe eine TVS-871, diese hat 4 x1 Gbit und ich habe zusätzlich eine 10Gbit DualPort SFP+ Karte eingebaut.
Member: Spartacus
Spartacus Dec 24, 2020 updated at 13:04:58 (UTC)
Goto Top
Hallo,
ganz lieben Dank für deine Antwort. Ich werde das morgen mal testen. Heute ist Weihnachten mit der Familie angesagt und dann kann ich spielen! Besuche gibt es ja keine!

Eine TVS871! Das ist schon eine Nummer! Ich habe mich für die 672 entschieden, die meine alte TS 559 Pro+ mit 5 x 2TB ablöst. Die läuft jetzt seit fast 11 Jahren ohne Ausfälle und ich bin gespannt, ob die TVS672 mit seinen 8TB-WDs das auch hinkriegen wird. Speichermäßig sind die 16TB netto auf jeden Fall mehr als genug und zur Not habe ich ja noch 2 Plattenslots.

Schöne Weihnachten,
Spartacus.

P.S. Wo finde ich denn die FW? Muss man die aus dem Appcenter installieren?