Dieser Beitrag ist schon älter. Bitte vergewissern Sie sich, dass die Rahmenbedingungen oder der enthaltene Lösungsvorschlag noch dem aktuellen Stand der Technik entspricht.

Routing Konfiguration

Mitglied: xmenchen
Habe eine Aufgabe die ich leider mit meinem Wissen nicht ganz verstehe und nun etwas Hilfe benötige.

Anhand meiner Netzwerkskizze will ich alle Routen (also auch in die jeweiligen lokalen Netze) eintragen,die notwendig sind, damit alle angegebenen Teilnetze von allen Komponenten erreicht werden können.

9c03afa9998fa2c475a079364bfc08c7-netzwerk

Wer kann mir Zeigen wie zB. für rechner 1 und zB. router3 die Konfiguration aussehen müsste.???

net-lab-ueb 01
Nr. Ziel Subnetmask Router Interface
1
2
3
4

net-lab-router 03
Nr. Ziel Subnetmask Router Interface
1
2
3
4

Content-Key: 66807

Url: https://administrator.de/contentid/66807

Ausgedruckt am: 22.09.2021 um 12:09 Uhr

Mitglied: 51705
51705 22.08.2007 um 18:26:46 Uhr
Goto Top
netz-lab-router-02:
172.16.100.0/24 -> kennt er
172.16.101.0/24 -> kennt er
172.16.102.0/24 -> 172.16.101.253
172.16.103.0/24 -> 172.16.101.253

netz-lab-router-03
172.16.100.0/24 -> 172.16.101.254
172.16.101.0/24 -> kennt er
172.16.102.0/24 -> kennt er
172.16.103.0/24 -> 172.16.102.254

netz-lab-router-04
172.16.100.0/24 -> 172.16.102.253
172.16.101.0/24 -> 172.16.102.253
172.16.102.0/24 -> kennt er
172.16.103.0/24 -> kennt er

Jeder PC muß einen Router aus dem lokalen Subnet als Default Gateway haben, dann klappt es.

;)
Mitglied: xmenchen
xmenchen 22.08.2007 um 19:49:05 Uhr
Goto Top
Cool Danke.

D.h. die routingtabelle für den Rechner netz-lab-ueb-01 würde so aussehen:

172.16.100.0/24 kennt er
172.16.101.0/24 -> 172.16.100.254
172.16.102.0/24 -> 172.16.100.254
172.16.103.0/24 -> 172.16.100.254

korrekt ??

Also ganz einfach wenn ichs nun verstanden hab :-) face-smile
Mitglied: 51705
51705 22.08.2007 um 19:58:52 Uhr
Goto Top
Cool Danke.

D.h. die routingtabelle für den Rechner
netz-lab-ueb-01 würde so aussehen:

172.16.100.0/24 kennt er
172.16.101.0/24 -> 172.16.100.254
172.16.102.0/24 -> 172.16.100.254
172.16.103.0/24 -> 172.16.100.254

korrekt ??
:) face-smile

netz-lab-ueb-01 würde so aussehen:

172.16.100.0/24 kennt er
0.0.0.0 -> 172.16.100.254 (das ist die default Route ;)
Mitglied: xmenchen
xmenchen 22.08.2007 um 20:15:28 Uhr
Goto Top
Hmm okay, sieht schöner aus, und wichtig wenn man ins Internet will,
aber sonst würde meins doch auch funzen wenns nur die 4 Teilnetze gibt oder etwa nicht?

Hab ja nicht gesagt das ich es 100% verstanden hab :) face-smile
Mitglied: 51705
51705 23.08.2007 um 11:47:45 Uhr
Goto Top
Du hast recht, würde auch funktionieren. Ist einfach mein Weg, das Routen den Routern zu überlassen...
Mitglied: aqui
aqui 23.08.2007 um 16:23:08 Uhr
Goto Top
...und das ist natürlich auch der richtige Weg ! Niemals oder nur in sehr seltenen Ausnahmen werden Routern auf Endgeräten konfiguriert. Die Infrastruktur also das Netz soll routen und für die Wegefindung verandwortlich sein und niemals Endsysteme !

Also bekommen alle PCs (ueb-01 + ueb-02) im Subnetz 172.16.100./24 normal die 172.16.100.254 als Gateway eingetragen !

Analog alle PCs (ueb-09 bis ueb-11) im Subnetz 172.16.103./24 normal die 172.16.103.254 als Gateway eingetragen !

Ein Sonderfall sind die Netze 172.16.101.0/24 und 172.16.102.0/24 , da diese Netze parallel an 2 Routern angeschlossen sind !!
Du hast nun 2 Möglichkeiten auf den PCs Gateways einzutragen nämlich einmal mit der .253 und einmal mit der .254 Beides funktioniert natürlich !
Allerdings hat so ein Szenario ja meist einen Sinn das man den Anschluss dieser Netze eben redundant haben möchte als Hochverfügbarkeit, denn wenn die .253 einmal ausfällt können alle Geräte weiter über die .254 arbeiten.
Das geht aber natürlich nicht wenn du die .253 auf den PCs fest eingestellt hast ohne das du alle PCs umkonfigurieren musst...ist also Mist !
2. Variante ist du konfigurierst die Hälfte der PCs auf die .254 und die andere Hälfte auf die .253. Das hätte den Effekt das bei Ausfall eines Gateways (Routerinterfaces) wenigstens 50% der PC Endgeräte weiterarbeiten können. Ist aber auch nicht das Gelbe vom Ei denn meist ist nach Murphy der Rechner betroffen der der Wichtigste ist ! ;-) face-wink

Dafür gibt es aber als Lösung das VRRP Protokoll (Virtual Router Redundancy Protocol) oder da du vermutlich nach den Bezeichnungen deiner Ethernet Interface Cisco Systeme einsetzt deren proprietäres HSRP (Hot Standby Router Protocol). Achtung HSRP ist nicht kompatibel mit NICHT Cisco Systemen dann solltest du also immer besser VRRP nehmen !!!
Damit nutzen die beiden Router .253 und .254 eine gemeinsame IP Adresse die dann im Fehlerfalle automatisch auf den jeweils anderen Router übergeht. Damit bist du dann vollends gesichert gegen einen Ausfall !!

Hier mal ein Beispiel für eine VRRP Konfig mit dem Subnetz 172.16.102.0/24

netz-lab-router-03
interface ethernet 0/0
ip address 172.16.102.253 255.255.255.0
vrrp 1 ip 172.16.102.252

netz-lab-router-04
interface ethernet 0/0
ip address 172.16.102.254 255.255.255.0
vrrp 1 ip 172.16.102.252

Die PCs zeigen dann mit dem Gateway natürlich dann auf die 172.16.102.252 denn das ist die virtuelle Adresse die die Interfeces teilen und die im Ausfall immer aktiv ist ! Analog machst du das mit dem 172.16.101.0/24er Netz bzw. den Interfaces dazu !

Die statischen Routen auf den Routern lauten dann folgendermaßen:

netz-lab-router-02
ip route 172.16.102.0 255.255.255.0 172.16.101.253
ip route 172.16.103.0 255.255.255.0 172.16.101.253

Alle anderen Netze sind lokal und die kennt er !

netz-lab-router-03
ip route 172.16.100.0 255.255.255.0 172.16.101.254
ip route 172.16.103.0 255.255.255.0 172.16.102.254

Alle anderen Netze sind lokal und die kennt er !

netz-lab-router-04
ip route 172.16.100.0 255.255.255.0 172.16.102.253
ip route 172.16.101.0 255.255.255.0 172.16.102.253

Alle anderen Netze sind lokal und die kennt er !

Spannend wäre ja auch mal eine dynamische Routingvariante mit z.B. OSPF. Das erspart dir dann die Eingabe der statischen Routen.
Die Konfig (für Cisco) dafür sieht so aus:

netz-lab-router-02
router ospf 1
network 172.16.100.0 0.0.0.255 area 0
network 172.16.101.0 0.0.0.255 area 0

netz-lab-router-03
router ospf 1
network 172.16.101.0 0.0.0.255 area 0
network 172.16.102.0 0.0.0.255 area 0

netz-lab-router-04
router ospf 1
network 172.16.102.0 0.0.0.255 area 0
network 172.16.103.0 0.0.0.255 area 0

Damit werden deine Routing Tabellen dynamisch aufgebaut und alle Netze machen sich bei allen Routern über OSPF bekannt.
Mitglied: 51705
51705 23.08.2007 um 16:48:20 Uhr
Goto Top
Ein Sonderfall sind die Netze
172.16.101.0/24 und 172.16.102.0/24 , da
diese Netze parallel an 2 Routern
angeschlossen sind !!
Du hast nun 2 Möglichkeiten auf den PCs
Gateways einzutragen nämlich einmal mit
der .253 und einmal mit der .254 Beides
funktioniert natürlich !
Allerdings hat so ein Szenario ja meist
einen Sinn das man den Anschluss dieser Netze
eben redundant haben möchte als
Hochverfügbarkeit, denn wenn die .253
einmal ausfällt können alle
Geräte weiter über die .254
arbeiten.
Das geht aber natürlich nicht wenn du
die .253 auf den PCs fest eingestellt hast
ohne das du alle PCs umkonfigurieren
musst...ist also Mist !
2. Variante ist du konfigurierst die
Hälfte der PCs auf die .254 und die
andere Hälfte auf die .253. Das
hätte den Effekt das bei Ausfall eines
Gateways (Routerinterfaces) wenigstens 50%
der PC Endgeräte weiterarbeiten
können. Ist aber auch nicht das Gelbe
vom Ei denn meist ist nach Murphy der Rechner
betroffen der der Wichtigste ist ! ;-) face-wink

3. Variante
2 default Routen mit unterschiedlicher Metrik, da bleiben 100% am Netz :) face-smile
Mitglied: aqui
aqui 23.08.2007 um 17:40:01 Uhr
Goto Top
Sicher machbar, aber dafür musst du wieder umständlich alle Endgeräte anfassen...Kommen die in andere Segmente muss das alles wieder entfernt werden.... keine wirklich gute Lösung !
Auch wenn du DHCP machst in den Segmenten geht es wieder gar nicht.
VRRP hat da schon seinen Sinn ;-) face-wink
Mitglied: 51705
51705 23.08.2007 um 17:44:05 Uhr
Goto Top
Gerade mit DHCP geht es prima, wo siehst du da ein Problem?
Mitglied: aqui
aqui 23.08.2007 um 17:53:16 Uhr
Goto Top
Stimmt..statische Route hat Priorität vor der Default Route die ggf. per DHCP kommt...Denkfehler, sorry.
So oder so aber ein umständliche Lösung die in der Praxis meist nie verwendet wird, da abgesehen vom der umständlichen, starren und statischen Konfig der Endgeräte du meist Timeouts hast. Der Client muss das neue Gateway neu ARPen usw. VRRP oder HSRP hat aber einen sub second Failover und ist daher immer vorzuziehen.
OK, in Umfeldern wo das Mangels Feature Ausstattung von Routern oder Switches nicht umzusetzen ist, ist das sicher ein quick and dirty Workaround der auch klappt, keine Frage ;-) face-wink
Mitglied: 51705
51705 23.08.2007 um 19:32:25 Uhr
Goto Top
Um Router redundant zu betreiben ist VRRP die deutlich bessere Wahl (um das mal vorab, dir zustimmend, klar zu stellen).

Nur was willst du mit statischen Routen auf den Clients? Ein DHCP-Server kann doch einem DHCP-Client leicht mehrere Router als default Route 'mitgeben'. Da ist wirklich kein 'Turnschuh-Admin' notwendig. Auch in ARP kann ich kein Problem erkennen. Die Verzögerung durch das 'Bemerken' des fehlenden Gateways ist allerdings vorhanden.

Insgesamt stimme ich dir jedoch zu, die für den jeweiligen Fall entwickelte Technik vorzuziehen.

Grüße, Steffen
Mitglied: aqui
aqui 24.08.2007 um 19:32:08 Uhr
Goto Top
Damit sollte xmenchens Routing Problem das eigentlich keins ist ;-) face-wink normalerweise geloest sein ! Bitte dann
https://www.administrator.de/index.php?faq=32
nicht vergessen !
Heiß diskutierte Beiträge
tip
Outlook 2019 Konto hinzufügen - Kein Benutzername mehr bei IMAP Einstellungen - LösungFrankVor 23 StundenTippOutlook & Mail30 Kommentare

Eine weitere Kuriosität unter Office 2019 ist bei mir gerade hart aufgeschlagen. Ich wollte ein normales IMAP/SMTP Konto zu Outlook 2019 hinzufügen. Das war aber ...

question
Clonen einer SSD Platte auf eine grösserejensgebkenVor 1 TagFrageFestplatten, SSD, Raid9 Kommentare

Hallo Gemeinschaft habe in meinem Rechner eine alte SSD 128 und eine neu installierte mit Windows 10 drauf 512 GB nun möchte ich gerne die ...

question
Ablösung alte M.2 SSDUrx1974Vor 1 TagFrageFestplatten, SSD, Raid7 Kommentare

Hallo, ich habe in einem (anderen) Laptop eine ITE-ON CV3-8D128-11 128GB M2 / M.2 SSD 2280 drin. Ich wollte diese jetzt durch eine 1TB SSD ...

question
Dienst-PCs per Image sichern?Yan2021Vor 20 StundenFrageBackup10 Kommentare

Hallo Ihr Lieben ;-) So, Urlaub vorbei und schon kommt mal wieder eine Frage von mir. Wir haben hier so rund gerechnet 10 PCs. Da ...

general
VPN-Einwahl für UnternehmensnetzwerkjoergVor 1 TagAllgemeinLAN, WAN, Wireless12 Kommentare

Hallo zusammen, aktuell beschäftige ich mich mit der Frage, ob unsere aktuelle User-VPN-Lösung noch die Richtige ist oder ob es bessere Alternativen gibt. Wir setzen ...

question
Problem mit gespiegelten BackupsystemfisiyouVor 1 TagFrageCluster8 Kommentare

Hi liebe Community, Bin derzeit als Umschüler (Fisi) im Betriebspraktikum unterwegs. Mir wurde jetzt ein Problem mit unseren Backupstorage mitgeteilt, wo ich mir eine Lösung ...

question
Webseite signierenUserUWVor 21 StundenFrageInternet9 Kommentare

Gelegentlich möchte man auf einer Webseite kritische Daten veröffentlichen, zum Beispiel Checksummen von Dateien/Programmen oder den Fingerprint eines Schlüssels. Frage: Wie kann man diese Information ...

question
"Aktualisieren und Herunterfahren" nach Windows Update erzwingenFrM222Vor 20 StundenFrageWindows Update7 Kommentare

Hallo Zusammen, wir verteilen unsere Windows Updates über WSUS (2016) und haben hier inzwischen eigentlich einen ganz guten Stand. Die Updates werden sehr zügig auf ...