goconnect2k4
Goto Top

Routing zwischen 2 Subnetzen über einen Cisco Router (1800er Series)

Hallo liebe Admins!

Ich bin neu hier und auf der Suche nach einer Lösung für mein kleines Netzwerk Problem. Ich habe bereits die Suche genutzt aber nichts vergleichbares gefunden.

Nun zu meinem Problem:

Ich habe zu Testzwecken einen Cisco 1800 Series Router um das routing zwischen 2 Subnetzen auf einem Cisco Router zu simulieren. Ich möchte für diesen Zweck 2 PCs mit unterschiedlichen Subnetzen über diesen Cisco Router zum "miteinander reden" bringen.

Der Router hat 2 Anschlüsse (Interfaces), einmal FastEthernet 0/0 (Fa0/0) und FastEthernet0/1 (Fa0/1).

IP Adressen der Interfaces am Router:

Fa0/0: 192.168.100.25
Maske: 255.255.255.0

Fa0/1: 192.168.200.25
Maske: 255.255.255.0


IP Adressen der beiden PCs:

PC1: 192.168.100.50
Maske: 255.255.255.0

PC2: 192.168.200.50


Jetzt ist PC1 an Fa0/0 angeschlossen (gleiches Subnetz) und PC2 an Fa0/1 (gleiches Subnetz). Auf dem Router kann ich per Console beide PCs anpingen. Es ist kein Routing Protocol aktiviert (da nur 1 Router) und es sind auch keine statischen Routen eingegeben, da beide Subnetze ja "directly conneted" sind und daher ja keine statischen Routen gebraucht werden bzw. berücksichtigt würden. Dies ist auch unter "show ip route" sichtbar. Der Router erkennt also beide PCs. "Ip Routing" ist natürlich eingegeben und aktiviert.

Jetzt kann ich aber nicht von PC1 den PC2 anpingen und umgekehrt. Ich kann von beiden PCs aber beide Interfaces am Router anpingen (Fa0/0 und Fa0/1).

Anscheinend weiß der Router nicht, dass er "routen" soll zwischen den beiden Subnetzen.

Frage: Wie krieg ich das jetzt hin? Oder habe ich einen logischen Denkfehler?


Zur Verdeutlichung hier einmal vom Router "show ip route":

Router(config)#do show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C 192.168.200.0/24 is directly connected, FastEthernet0/1
C 192.168.100.0/24 is directly connected, FastEthernet0/0


Und einmal die Running Config vom Router:

Router#sh run
Building configuration...

Current configuration : 910 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 25
ip cef
!
!
!
!
no ip domain lookup
ip name-server 192.168.100.2
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
ipv6 unicast-routing
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 192.168.100.25 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.200.25 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0/0
no ip address
shutdown
clock rate 2000000
!
interface Serial0/1/0
no ip address
shutdown
clock rate 2000000
!
ip forward-protocol nd
!
!
ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
!
line con 0
logging synchronous
line aux 0
line vty 0 4
login
!
scheduler allocate 20000 1000
end


Ich hoffe dass jemand sich hier auskennt und mir weiterhelfen kann. Eventuell ist es ja nur ein Befehl der eingegeben werden muss.

Das ganze dient zu Testzwecken, um mich mit den Routern von Cisco vertraut zu machen und das Routing zwischen zwei Subnetzen zu simulieren. Habe jede erdenkliche Suche bei Google durchgeführt und jede Menge Tutorials, Bücher und HowTos durchgelesen. Leider ohne Erfolg.

Vielen Dank im Voraus und viele Grüße!

Content-Key: 227070

Url: https://administrator.de/contentid/227070

Printed on: June 19, 2024 at 10:06 o'clock

Member: Lochkartenstanzer
Lochkartenstanzer Jan 19, 2014 updated at 09:05:05 (UTC)
Goto Top
Mal ganz dumm gefragt:

Wissen denn die PCs, wo Sie Pakete hinschicken müssen, d.h. habe die mindestenes eine statische Route oder ein default gateway eingetragen?

nachtrag 1: Mach mal ein ipconfig/all auf den Kisten.

nachtrag 2: Mach mal Tipp mal ip routing auf Deiner Cisco, um das routing einzuschalten, auch wenn ich mir keine Grudn vorstellen kann, warum das abgeschaltet sein sollte.

lks
Member: colinardo
colinardo Jan 19, 2014 updated at 12:18:56 (UTC)
Goto Top
Hallo GoConnect,
wenn dein Gateway auf deinen Rechnern korrekt auf den CISCO zeigt könnte es sein das du wahrscheinlich in der Windows-Firewall ICMP-Traffic für andere Subnetze nicht erlaubt hast! Standardmäßig blockt Windows ICMP-Traffic aus anderen Subnetzen als des eigenen. Trage also das entfernte Subnetz in der Firewall-Einstellung entsprechend ein oder erlaube Pings von überall wie im Screenshot.

67127aa5381f480218d79382f2bcdd43

Grüße Uwe
Member: GoConnect2k4
GoConnect2k4 Jan 19, 2014 updated at 12:42:10 (UTC)
Goto Top
Hallo!

@ lochkartenstanzer
Dnake für deinen Beitrag. Die Gateways sind richtig eingetragen auf beiden PCs und ip routing auf dem Router ist auch aktiviert. Der Fehler ist gefunden. Es lag an der Firewall auf beiden Windows Kisten. Vielen Dank für die Hilfe.


@ colinardo
DANKE !!!! Das war der Fehler! Ich hatte auf beiden Windows Kisten Kaspersky Firewall und diese Kaspersky Firewall auch deaktiviert. Aber dadurch gingen dann die Windows Firewalls an und die haben das blockiert. Denn wenn ich diese jetzt deaktiviere, geht der Ping durch! Vielen Dank!

Eine Frage habe ich aber noch dazu: Wieso wird dieser Traffic überhaupt blockiert? Wenn ich über einen Router ins Internet gehe, muss der ja auch den Traffic aus einem anderen Subnetz akzeptieren. Stehe da ein wenig auf dem Schlauch, warum das geblockt wird. In einem Firmennetzwerk müssten dann ja alle PCs von Hand konfiguriert werden, damit unterschiedliche Subnetze bei Windows kommunizieren können. Ich dachte das würde der Router irgendwie "regeln". Kannst du mich da vielleicht aufklären?

Viele Grüße und danke nochmal!
Member: colinardo
colinardo Jan 19, 2014 updated at 12:49:37 (UTC)
Goto Top
Es wird nur nicht vom Client angeforderter ICMP-Traffic aus anderen Subnetzen geblockt. Mit ausgehenden Verbindungen des Clients hat das nichts zu tun denn dabei wird ja eine Verbindung vom Client aus aufgebaut und der Traffic der zu dieser Verbindung gehört (related traffic) wird auch wieder reingelassen.

Grüße Uwe
Member: GoConnect2k4
GoConnect2k4 Jan 19, 2014 at 12:51:25 (UTC)
Goto Top
Alles klar. Vielen Dank für die Erklärung und die Lösung des Problems. Macht Sinn das ganze face-smile

Viele Grüße
Member: aqui
aqui Jan 19, 2014, updated at Dec 29, 2014 at 13:06:32 (UTC)
Goto Top
Grundlagen zu dem Szenario findest du auch hier:
Routing von 2 und mehr IP Netzen mit Windows, Linux und Router
und etwas zur Cisco spezifischen Syntax hier:
Cisco 880, 890 und ISR Router Konfiguration mit xDSL, Kabel oder FTTH Anschluss plus VPN und IP-TV
Da die IOS Syntax auf allen Modellen identisch ist gilt das auch fürt deinen 1800ern.
Tip:
Da steht wie du dem Cisco beibringen kannst auch DHCP Server für beide Segmente zu spielen ! Hier das Beispiel für dich:
ip dhcp excluded-address 192.168.100.25 192.168.100.254
!
ip dhcp excluded-address 192.168.200.25 192.168.200.254
!
ip dhcp pool netz1
network 192.168.100.0
default-router 192.168.100.25
dns-server 192.168.100.25
domain-name goconnect.intern
!
ip dhcp pool netz2
network 192.168.200.0
default-router 192.168.200.25
dns-server 192.168.200.25
domain-name goconnect.intern

Damit bekommen die PCs auch dynamische IPs im Bereich .1 bis .24 vom Router.
Design Tip: Router IPs sollten mit ihrer IP Adresse immer "ganz oben" oder "unten" liegen im Adressbereich und NICHT mitten drin um Überschneidungen zu vermeiden also bei 24 Bit Netzen immer am besten .1 oder .254 verwenden !

Noch ein Tip zum Pingen (ICMP): Ab Windows 7 blockiert die Windows Firewall ICMP (Ping) komplett. Um das wieder zum Fliegen zu bringen mit einem Mausklick in den Settings der lokalen Firewall sieht man hier nach:
http://www.windowspro.de/tipp/ping-windows-7-server-2008-r2-zulassen