badger
Goto Top

SBS 2011 erkennt TCPIP Port für Drucker nicht

Hallo Leute,

- Druckserver: SBS 2011
- Drucker: Tally Dascom 2600
- Netzinterne Firewall gibt es nicht
- Der Drucker ist immer über ping erreichbar

folgendes Problem beim installieren des Druckers:
- Ich installiere als erst im Druckserver den Treiber - funktioniert ohne Probleme.
- Ich füge nun den Anschluss hinzu (Standard TCP/IP Port) und führe dabei die Erkennung des TCP/IP Ports aus: es wird nichts erkannt, ich muss die Daten selbst eingeben (prinzipiell kein Problem, aber komisch [mehr dazu später]).
- Ich füge nun den Drucker hinzu. Läuft auch alles ohne Fehlermeldung.

Die Sache ist aber, dass das ausdrucken massive Probleme macht.
Drucke ich eine Testseite aus, wird entweder diese gar nicht ausgedruckt (Fehler) oder diese wird erst nach ~ 1 Minute ausgedruckt.
Schalte ich SNMP ein, erscheint der Drucker beinahe immer als offline, obwohl ich ihm pingen kann

Ich habe daraufhin versucht, einen neuen Anschluss (selbe IP - anderer Name) zu erstellen sowie einen anderen Treiber zu verwenden (Generic text only). Aber selbes Problem.


Das interessante ist, dass die Installation des Druckers unter Win 8.1 ohne Probleme funktioniert. Hier funktioniert selbst die Erkennung des TCP/IP Ports auf Anhieb.


Habe auch schon einen "externen" Printserver für den Drucker probiert. Mit diesem funktioniert es sowohl unter Server 2011 als auch unter Win 8.1 anstandslos.


Könnt ihr mir sagen, wo hier das Problem liegt?
Liegt es an der NW-Karte des Druckers oder ist das ein Server 2011 Problem?

Beste Grüße
Patrick

Content-Key: 249526

Url: https://administrator.de/contentid/249526

Printed on: March 2, 2024 at 06:03 o'clock

Member: keine-ahnung
keine-ahnung Sep 18, 2014 at 07:26:27 (UTC)
Goto Top
Moin,
Könnt ihr mir sagen, wo hier das Problem liegt?
Du liegst vor dem Server face-wink?

Ist das eine Beta vom Server-OS? Mir ist kein Server 2011 bekannt??

LG, Thomas
Member: Badger
Badger Sep 18, 2014 updated at 07:40:19 (UTC)
Goto Top
Also in Ohnmacht bin ich noch nicht gefallen face-smile
Und das es sich um einen Error 40 handelt hoffe ich ja doch nicht ;)

Server 2011 = Server 2008 R2

Grüße
Patrick
Member: keine-ahnung
keine-ahnung Sep 18, 2014 at 08:12:58 (UTC)
Goto Top
Server 2011 = Server 2008 R2
Server 2008R2 = Server2008R2
Habe auch schon einen "externen" Printserver für den Drucker probiert. Mit diesem funktioniert es sowohl unter Server 2011 als auch unter Win 8.1 anstandslos.
Ein externer printserver? Meinen? Oder meinst Du einen com oder USB-server? Und wenn das funktioniert, warum lässt Du das nicht einfach so?

Und wenn Du das nicht lassen willst, warum schaust dann nicht im event-log des (vermutlichen) SBS nach? Da gibt es auch Einträge zur Printserverrolle face-wink.
Nadeldrucker können schon immer mal ein wenig divenhaft daherkommen ...

LG, Thomas
Member: Badger
Badger Sep 18, 2014 updated at 10:09:58 (UTC)
Goto Top
Hallo Thomas,

Zitat von @keine-ahnung:

Server 2008R2 = Server2008R2

Der SBS heißt halt 2011 und basiert auf 2008 R2.

Ein externer printserver? Meinen? Oder meinst Du einen com oder USB-server? Und wenn das funktioniert, warum lässt Du das
nicht einfach so?
Sorry: schlecht ausgedrückt. Meinen einen Printserver für die parallele Schnittstelle.
Warum ich es nicht lasse: Weil ich ungern einen neuen Drucker kaufe, der dann nur halb funktioniert. Ja: es wäre eine Lösung, dass ich es mit dem Printserver für die parallele Schnittstelle mache. Aber anders wäre es mir lieber.

Und wenn Du das nicht lassen willst, warum schaust dann nicht im event-log des (vermutlichen) SBS nach? Da gibt es auch
Einträge zur Printserverrolle face-wink.
Nadeldrucker können schon immer mal ein wenig divenhaft daherkommen ...
Habe mir die Eintrage "Anwendung", "System" und "PrintService" und auch sonst alle Fehler von allen Logs angezeigt. Leider nichts brauchbares dabei, was auf dieses Problem zutreffen könnte.

Dafür habe ich jetzt was anderes feststellen können: Selbst wenn ich ein Dokument drucke und dann nach ~ 1 Minute als Warteschlangenstatus "Fehler" angezeigt wird, wird irgendwann mal dieses Dokument gedruckt. Habe jetzt 5 Minuten gewartet und siehe da: es wird gedruckt.
Werde das Gefühl nicht los, dass es hier ein NW Problem zwischen SBS 2011 und dem Drucker ist.
Werde mal Whireshark anwerfen..

Danke für deine Hilfe!
Member: Badger
Badger Sep 18, 2014 at 09:42:03 (UTC)
Goto Top
So: Habe jetzt einen Capture, wo das Drucken auf dem Drucker (unter SBS 2011) ohne Probleme geht und einmal, wo das Dokument auf dem gleichen Rechner erst nach Minuten ausgedruckt wird.

Beim "Bad Print Capture" sind haufenweise "Retransmission" zu sehen, was ja eigentlich auf Paketverluste hindeuten könnte.
Habe jetzt das NW-Kabel vom Drucker getauscht und auch den Drucker an einem anderen Switch angehängt -> ändert nichts.

Meine Fragen:
- eigentlich kann ich einen defekt der Leitungen Drucker zu Switch ausschließen, da ich 1) die Kabel getauscht habe und 2) das Drucken unter Win 8.1 ja geht und 3) es ja mit dem Printserver für die parallele Schnittstelle geht (wo ich die selben Kabeln verwendet habe)
- und eigentlich kann ich einen defekt der Leitungen Server zu Switch ausschließen, da dies ja ebenfalls mit dem Printserver für die parallele Schnittstelle funktioniert.

Beim Druck über den Printserver für die parallele Schnittstelle ist keine einzige Retransmission zu sehen.


Wo könnte hier jetzt noch das Problem begraben liegen?
Member: keine-ahnung
keine-ahnung Sep 18, 2014 updated at 10:08:18 (UTC)
Goto Top
Der SBS heißt halt 2011 und passiert auf 2008 R2a
nein, macht er nicht. Aber auf 2008R2 (ohne a) basieren ... das macht er. Ist ja aber nix passiert face-wink
Warum ich es nicht lasse: Weil ich ungern einen neuen Drucker kaufe, der dann nur halb funktioniert.
Das kann man auschliessen - der Drucker funktioniert!

Entweder ist das ein physisches Problem, da käme jetzt in meiner Kristallkugel erstmal der connect zwischen Server und Drucker auf der gesamten betroffenen distance in Betracht ... oder der printserver-Dienst auf dem SBS hat ein Problem. Beides kann ich von hier aus nicht prüfen, aber wenn Du sicher bist, dass da in den log's nichts steht ...

Rein pragmatisch würde ich jetzt entweder jemanden dazu holen, der das Netz mal fachmännisch checken kann ... oder halt den com-Server hernehmen, wenn es damit funktioniert. Eventuell hat ja auch der Treiber eine Macke, was die TCP-Anbindung angeht ... aber warum sollte er dann an einem com-Server funktionieren? Eher also auch als Ursache auszuschliessen.

LG, Thomas
Member: Badger
Badger Sep 18, 2014 at 10:17:28 (UTC)
Goto Top
Zitat von @keine-ahnung:
Entweder ist das ein physisches Problem, da käme jetzt in meiner Kristallkugel erstmal der connect zwischen Server und
Drucker auf der gesamten betroffenen distance in Betracht ... oder der printserver-Dienst auf dem SBS hat ein Problem. Beides kann
ich von hier aus nicht prüfen, aber wenn Du sicher bist, dass da in den log's nichts steht ...

Rein pragmatisch würde ich jetzt entweder jemanden dazu holen, der das Netz mal fachmännisch checken kann ... oder halt
den com-Server hernehmen, wenn es damit funktioniert. Eventuell hat ja auch der Treiber eine Macke, was die TCP-Anbindung angeht
... aber warum sollte er dann an einem com-Server funktionieren? Eher also auch als Ursache auszuschliessen.

LG, Thomas

Einen miserablen NW-Controller am Drucker schließt du aus?
Member: keine-ahnung
keine-ahnung Sep 18, 2014 at 10:29:15 (UTC)
Goto Top
Warum sollte der miserabel sein, wenn er direkt mit einem Client über TCP gut kommuniziert?

LG, Thomas
Member: Badger
Badger Sep 18, 2014 at 10:34:02 (UTC)
Goto Top
Zitat von @keine-ahnung:

Warum sollte der miserabel sein, wenn er direkt mit einem Client über TCP gut kommuniziert?

LG, Thomas

Ich will nur alles Mögliche ausschließen!

Danke für deine Hilfe.

Patrick
Member: Pjordorf
Pjordorf Sep 18, 2014 updated at 12:14:42 (UTC)
Goto Top
Hallo,

Zitat von @Badger:
So: Habe jetzt einen Capture, wo das Drucken auf dem Drucker (unter SBS 2011) ohne Probleme geht
Dann hör auf zu basteln wenn es jetzt geht.

und einmal, wo das Dokument auf dem gleichen Rechner erst nach Minuten ausgedruckt wird.
Also ich drucke auf einen Drucker, aber vom Rechner aus.
Was denn jetzt, mal geht's es (oben) und dann wieder nicht?

das Drucken unter Win 8.1
Nutzt du dort WSD (reift zwar auch auf die IP des Druckers zurück, aber intern wird's anders abgefackelt)?

Wie ist dein Drucker denn so eingerichtet?

PS. Ein Server 2011 gibt es nicht, und ein SBS 2011 ist nicht nur ein Server OS und keiner sagt zu einem Mercedes BMW (auch wenn dort identische Bauteile drin sind).

Gruß,
Peter
Member: Badger
Badger Sep 18, 2014 updated at 12:13:38 (UTC)
Goto Top
Hallo Peter,

Zitat von @Pjordorf:

> und einmal, wo das Dokument auf dem gleichen Rechner erst nach Minuten ausgedruckt wird.
Also ich drucke auf einen Drucker, aber vom Rechner aus.
Was denn jetzt, mal geht's es (oben) und dann wieder nicht?

Vlt. diesmal besser ausgedrückt: Einmal geht das Drucken vom SBS 2011 aus ohne "Retransmission" und beim nächsten mal habe ich wieder haufenweise "Retransmissions". Und das ohne Änderungen von Einstellungen oder "basteln".


> das Drucken unter Win 8.1
Nutzt du dort WDS (reift zwar auch auf die IP des Druckers zurück, aber intern wird's anders abgefackelt)?
Wenn du damit "Wireless Distribution System" meinst: Der Drucker hängt über Kabel im Netzwerk, nicht über WLAN.

Wie ist dein Drucker denn so eingerichtet?
Die LAN Einstellungen des Druckers sind sehr begrenzt. Prinzipiell nur IP, Subnet, Gateway sind eingestellt.
SNMP kann man nicht abstellen. Und dass er über LPR geht kann man auch nicht umstellen.


P.S: Habe die Überschrift der Frage nun angepasst.
Member: Pjordorf
Pjordorf Sep 18, 2014 at 12:17:18 (UTC)
Goto Top
Hallo,

Zitat von @Badger:
Wenn du damit "Wireless Distribution System" meinst
Nein, da mich meine Rechtschreibkorrektur erwischt. Sollte WSD bedeuten (oben korrigiert).

und beim nächsten mal habe ich wieder haufenweise
Dann schau an deiner Quelle warum du mal Retransmission hast und mal nicht. Auch dein Switch oder dessen Auslastung kann....

Gruß,
Peter
Member: Badger
Badger Sep 18, 2014 at 12:43:32 (UTC)
Goto Top
Nein, da mich meine Rechtschreibkorrektur erwischt. Sollte WSD bedeuten (oben korrigiert).

Nein, nutze ich nicht.

Dann schau an deiner Quelle warum du mal Retransmission hast und mal nicht. Auch dein Switch oder dessen Auslastung kann....
werde ich machen!
Member: Badger
Badger Oct 08, 2014 at 08:30:47 (UTC)
Goto Top
Drucker geht auch mit einer Crossover Verbindung nicht ohne Retransmission.
Auch probiert mit einem Unix-Rechner.

Liegt also definitiv am Drucker.

Danke dennoch für eure Hilfe.