goscho
Goto Top

Scan to SMB auf Windows 2008 R2 DC schlägt fehl

Moin Leute,

im Rahmen der Migration einer Domäne mit W2K3 DC auf 2008 R2 DCs sollen auch die Freigaben der Netzwerkscanner (Samsung MFG) angepasst werden.
Diese waren bisher auf einem W2K3 DC und sollen nun auf einen W2K8R2 DC umgezogen werden.

Leider bekomme ich dort beim Scannen auf die Scan-Freigabe einen Netzwerkfehler am Gerät angezeigt (ja, sehr aussagekräftig, ich weiß).

Richte ich diese Freigabe an einem W2K8 R2 Memberserver ein, klappt das Scannen problemlos, wie auch am W2K3 DC der selben Domäne.
Auf einen W2012 R2 Memberserver kann ich auch nicht scannen.

  • Firewall ist deaktiviert
  • Zeit am Gerät mit der Domäne identisch
  • Anmeldedaten und Freigabeberechtigungen habe ich natürlich gescheckt

Der Zugriff von anderen Geräten (Windows/Linux/Android) auf diese Freigaben am W2K8 R2 DC klappen problemlos.

Hat jemand eine Idee, wo der Fehler zu suchen ist?

Content-Key: 242220

Url: https://administrator.de/contentid/242220

Printed on: July 18, 2024 at 17:07 o'clock

Member: Xaero1982
Xaero1982 Jun 30, 2014 at 10:55:44 (UTC)
Goto Top
Hi Goscho,

ich hätte jetzt als erstes auf das übliche Problem der Authentifizierung getippt, aber du sagst ja, dass es am Memberserver, der ebenfalls 2008 R2 hat klappt. Sicher?

Ich stand vor dem gleichen Problem und hab es letztlich für einen FTP Server gelöst. Anders hab ich es nicht hinbekommen auf einen Windows 7 oder 2011 SBS zu scannen.

Ab Windows 7 hat sich die Authentifizierung geändert. Bei XP kein Problem.

Gruß
Member: goscho
goscho Jun 30, 2014 at 11:02:06 (UTC)
Goto Top
Zitat von @Xaero1982:

Hi Goscho,

ich hätte jetzt als erstes auf das übliche Problem der Authentifizierung getippt, aber du sagst ja, dass es am
Memberserver, der ebenfalls 2008 R2 hat klappt. Sicher?
Ja, sicher
Ich stand vor dem gleichen Problem und hab es letztlich für einen FTP Server gelöst. Anders hab ich es nicht hinbekommen
auf einen Windows 7 oder 2011 SBS zu scannen.
Auf W7 kann ich seit jeher scannen.
Ab Windows 7 hat sich die Authentifizierung geändert. Bei XP kein Problem.
Bei mir sieht es folgendermaßen aus:

Scan auf W2003 DC - erfolgreich
Scan auf W2008R2 Member - erfolgreich
Scan auf Windows 7 - erfolgreich

Scan auf W2008R2 DC - Netzwerkfehler
Scan auf W2012R2 Member - Netzwerkfehler
Member: apfelqoo
apfelqoo Jun 30, 2014 at 12:36:20 (UTC)
Goto Top
Was für Samsung Geräte sind das genau ? Ich kann gerne mal schauen, ob es eine TI bei Samsung dazu gibt.
Member: goscho
goscho Jun 30, 2014 at 12:51:59 (UTC)
Goto Top
Zitat von @apfelqoo:

Was für Samsung Geräte sind das genau ? Ich kann gerne mal schauen, ob es eine TI bei Samsung dazu gibt.
Was ist eine TI?

Es handelt sich um einen SCX-6322DN.
Auf Samsung würde ich bei diesem Problem nicht setzen. face-wink
Member: apfelqoo
apfelqoo Jun 30, 2014 at 13:12:37 (UTC)
Goto Top
TI = Technische Info - also Informationen zu häufigen Fehlern die Samsung seinen Technikern zur Verfügung stellt.

Leider gibt es jedoch zu dem gerät nicht allzu viel hilfreiches... Letzte Firmware ist von Ende 2012 (V1.01.01.33) - leider ohne Info, was behoben wurde -.-

Ich habe jedoch eine Vermutung - schau mal bitte, ob bei dem 2008er Server, auf dem es funktioniert evtl SMB 2 deaktiviert wurde. Das findest du via regedit herraus:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters
Wenn dort ein Schlüssel namens "SMB2" mit dem Wert 0 vorhanden ist, auf dem Server auf dem es nicht funktioniert jedoch nicht, könnte es daran liegen.
Member: goscho
goscho Jul 01, 2014 at 13:28:11 (UTC)
Goto Top
Zitat von @apfelqoo:

TI = Technische Info - also Informationen zu häufigen Fehlern die Samsung seinen Technikern zur Verfügung stellt.
Danke, wieder was gelernt.
Hi
Bisher war TI für mich Texas Instruments
Leider gibt es jedoch zu dem gerät nicht allzu viel hilfreiches... Letzte Firmware ist von Ende 2012 (V1.01.01.33) - leider
ohne Info, was behoben wurde -.-
Danke für den Tipp.
Bei mir ist noch die 1.1.1.20 drauf.
Leider kann es bei diesem Gerät passieren, dass nach dem Firmwareupdate die komplette Konfiguration neu erstellt werden muss.
Das macht bei 10 Usern mit Scan-to-Mail und reichlich Netzwerkscanzielen natürlich viel Freude.
Eine Sicherungsfunktion existiert nicht.

Ich werde jetzt trotzdem mal das Update per usbupdater durchführen.
Ich habe jedoch eine Vermutung - schau mal bitte, ob bei dem 2008er Server, auf dem es funktioniert evtl SMB 2 deaktiviert wurde.
Das findest du via regedit herraus:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters
Wenn dort ein Schlüssel namens "SMB2" mit dem Wert 0 vorhanden ist, auf dem Server auf dem es nicht funktioniert
jedoch nicht, könnte es daran liegen.
Nein, ist auf beiden W2008R2 identisch, der Wert SMB2 existiert auf beiden nicht.
Member: apfelqoo
apfelqoo Jul 01, 2014 updated at 14:14:48 (UTC)
Goto Top
Ich habe soebend auf der Suche nach einer Anleitung für einen Kollegen noch etwas gefunden, was für Dich spannend sein könnte:

Zitat:<<
" ganz wichtig im Zusammenhang mit der Einrichtung Scan to SMB ist folgender Punkt: Bei der Einrichtung auf der Webseite unserer Geräte (SCX-5530, SCX-6322 etc.) kann man einen Scanordner angeben.Dieser ist nicht identisch mit dem freigegebenen Ordner (Share) auf dem PC, sondern beschreibt einen Zielordner innerhalb des freigegebenen Ordners.Trägt man einen Scanordner ein und exisitiert dieser auf dem PC nicht, so erhält man einen Netzwerkfehler.Solltet Ihr also Anfragen haben, dass Scan to SMB nicht zu funkionieren scheint, bitte einfach diesen Tipp geben."
Zitat Ende<<

Und noch etwas:
In den erweiterten Eigenschaften der LAN-Verbindung (TCP/IP V4) WINS auf "Enable NetBIOS over TCP/IP" stehen. Diese TI habe ich gestern übersehen. Sie wurde Ende 2007 eingestellt und betrifft alle damals aktuellen MFC´s von Samsung, zu denen auch deines zählen sollte.
Member: goscho
goscho Jul 01, 2014 updated at 14:43:07 (UTC)
Goto Top
Danke schonmal für deine Hilfe. face-smile

Das Firmwareupdate hätte ich mir (wie befürchtet) schenken können.
Danach durfte ich das komplette Gerät neu konfigurieren (Ausnahme: Netzwerkeinstellungen).
Da ich aber von diesem Typ schon mehr als ein Dutzend eingerichtet habe, ist mir das mittlerweile recht geläufig.


Zitat von @apfelqoo:
>>Zitat:<<
" ganz wichtig im Zusammenhang mit der Einrichtung Scan to SMB ist folgender Punkt: Bei der Einrichtung auf der Webseite
unserer Geräte (SCX-5530, SCX-6322 etc.) kann man einen Scanordner angeben.Dieser ist nicht identisch mit dem freigegebenen
Ordner (Share) auf dem PC, sondern beschreibt einen Zielordner innerhalb des freigegebenen Ordners.Trägt man einen Scanordner
ein und exisitiert dieser auf dem PC nicht, so erhält man einen Netzwerkfehler.Solltet Ihr also Anfragen haben, dass Scan to
SMB nicht zu funkionieren scheint, bitte einfach diesen Tipp geben."
>>Zitat Ende<<
Danke für diese Info, aber das war mir bereits bekannt.
Als ich das erste Mail Scan-to-smb an so einem Teil eingerichtet habe, hätte ich diese Info benötigt. Da habe ich stundenlang getestet, bis es dann klappte. face-sad

Und noch etwas:
In den erweiterten Eigenschaften der LAN-Verbindung (TCP/IP V4) WINS auf "Enable NetBIOS over TCP/IP" stehen. Diese TI
habe ich gestern übersehen. Sie wurde Ende 2007 eingestellt und betrifft alle damals aktuellen MFC´s von Samsung, zu
denen auch deines zählen sollte.
Habe ich auch getestet -> ohne Erfolg

Jetzt habe ich noch einen weiteren Server getestet, der kein DC ist, einen virtuellen W2008R2 Memberserver mit Exchange 2010.

Auf diesen kann ich auch nicht scannen, selber Fehler.
So sieht es jetzt aus:

Scan auf physikal. W2003 DC - erfolgreich
Scan auf physikal. W2008R2 Member - erfolgreich
Scan auf physikal. Windows 7 - erfolgreich
Scan auf virt. Windows 7 - erfolgreich

Scan auf virt. W2008R2 DC - Netzwerkfehler
Scan auf virt. W2008R2 Member- Netzwerkfehler
Scan auf physkal. W2012R2 Member - Netzwerkfehler
Member: keine-ahnung
keine-ahnung Jul 01, 2014 at 15:26:17 (UTC)
Goto Top
Moin goscho,

da springt einen ja das Mitleid direkt ins Gesicht face-wink. Warum haust Du diesen Samsung-Schrott nicht dahin, wo er hingehört? Also dort, wo Brother- und HP-Teile bereits umweltfreundlich entsorgt werden ...??

Duck und wech, Thomas
Member: goscho
goscho Jul 02, 2014 updated at 06:59:34 (UTC)
Goto Top
Zitat von @keine-ahnung:

Moin goscho,

da springt einen ja das Mitleid direkt ins Gesicht face-wink. Warum haust Du diesen Samsung-Schrott nicht dahin, wo er hingehört?
Weil in meinem Keller kein Platz mehr zu finden ist und auch die Garage mit IT-Schrott zugestellt wurde.

Und dann bin ich gezwungen, gelegentlich doch was zu drucken, zu scannen oder zu kopieren (worauf ich eigentlich fast vollständig verzichten könnte)

Also dort, wo Brother- und HP-Teile bereits umweltfreundlich entsorgt werden ...??
Da ist ja kein Platz mehr, außerdem ist das Teil noch fast neuwertig (Anschaffung 2007) face-big-smile
Member: keine-ahnung
keine-ahnung Jul 02, 2014 at 07:38:18 (UTC)
Goto Top
Da ist ja kein Platz mehr
Ich gebe Dir kerne die Kontaktdaten eines lokal führenden Entsorgungsunternehmens ....
außerdem ist das Teil noch fast neuwertig (Anschaffung 2007)
ooops ... eventuell nimmst Du das Dingens ja erstmal aus der Umverpackung ... face-wink

LG, Thomas
Member: goscho
goscho Jul 02, 2014 at 07:48:24 (UTC)
Goto Top
Zitat von @keine-ahnung:

> Da ist ja kein Platz mehr
Ich gebe Dir kerne die Kontaktdaten eines lokal führenden Entsorgungsunternehmens ....
Wie, soll ich jetzt meinen Schrott auch noch nach Sachsen karren?

Außerdem dachte ich, du bist Arzt.
Reicht wohl nicht und so sammelst du auch noch alte asiatische Plastikteile mit Platinen und Walzen? face-big-smile
Member: keine-ahnung
keine-ahnung Jul 02, 2014 at 07:51:18 (UTC)
Goto Top
Wie, soll ich jetzt meinen Schrott auch noch nach Sachsen karren?
Für Kohle machen wir alles --> Du musst Dich nur bemühen. Und sparen!
Reicht wohl nicht und so sammelst du auch noch alte asiatische Plastikteile mit Platinen und Walzen?
Ich sammel alles - auch randthüringische IT'ler face-wink

LG, Thomas
Member: Xaero1982
Xaero1982 Jul 02, 2014 at 08:01:59 (UTC)
Goto Top
Sieht ja spannend aus hier...

Auch wenn es nicht die Lösung des eigentlichen Problems ist funktioniert es aber mit der vorgeschlagenen Lösung problemlos.
FTP Server einrichten und in den eingerichteten Ordner scannen.

Wenns natürlich nicht so akut ist viel Spaß beim weiter probieren ;)

PS: Hast du mal versucht den Netzwerktraffic zu lesen?
Member: goscho
goscho Jul 02, 2014 updated at 08:11:15 (UTC)
Goto Top
Zitat von @Xaero1982:

Sieht ja spannend aus hier...
Ja, brauchst auch noch ein bisschen Elektronikschrott? face-wink
Auch wenn es nicht die Lösung des eigentlichen Problems ist funktioniert es aber mit der vorgeschlagenen Lösung
problemlos.
FTP Server einrichten und in den eingerichteten Ordner scannen.
Das mit dem FTP ist korrekt, aber ich wollte keinen FTP-Server dafür einrichten.
Wenns natürlich nicht so akut ist viel Spaß beim weiter probieren ;)
Mir geht's auch darum, herauszubekommen, warum es bei dem einen W2K8R2 geht und bei einem anderen nicht.
Ein paar Unterschiede gibt es bei den Systemen schon noch.
Leider fehlt mir die Zeit, das ausgiebig zu testen.
PS: Hast du mal versucht den Netzwerktraffic zu lesen?
Nein.
Member: Xaero1982
Xaero1982 Jul 02, 2014 at 08:12:50 (UTC)
Goto Top
Och nee lass mal... hab gerade welchen bekommen zum Ausschlachten face-smile

Kann ich beides verstehen. Sollte auch erst mal nur als Zwischenlösung dienen, wenn es dringlich ist.

Dann versuchs mal. Vielleicht findest du darüber raus wo es hängt.
Member: goscho
goscho Jul 02, 2014 at 08:17:29 (UTC)
Goto Top
Zitat von @Xaero1982:
Kann ich beides verstehen. Sollte auch erst mal nur als Zwischenlösung dienen, wenn es dringlich ist.
Als Zwischenlösung habe ich ja die funktionierenden SMB-Freigaben.
Zum Schluss sollte es aber schon ohne Umwege auf dem Fileserver landen und bei dem klappts nicht. face-sad
Dann versuchs mal. Vielleicht findest du darüber raus wo es hängt.
Ja, so ich die Zeit dafür finde.
Member: Xaero1982
Xaero1982 Jul 02, 2014 updated at 08:38:56 (UTC)
Goto Top
Apropo Fileserver...sind die Server bei denen es geht auch Fileserver? Also ist dort die Rolle/das Feature (weiß gerade nicht was es ist^^) eingerichtet?

Nochwas: Sagt das Eventlog irgendwas an dem DC an dem es nicht geht?
Member: goscho
goscho Jul 02, 2014 at 08:55:18 (UTC)
Goto Top
Zitat von @Xaero1982:

Apropo Fileserver...sind die Server bei denen es geht auch Fileserver? Also ist dort die Rolle/das Feature (weiß gerade
nicht was es ist^^) eingerichtet?
Die Rolle heißt Dateidienste und ist auf den anderen W2K8 auch installiert.
Nochwas: Sagt das Eventlog irgendwas an dem DC an dem es nicht geht?
Nein, das spricht nicht mit mir und ich konnte auch keinen Eintrag mit Bezug zu dem Kopiere finden.