Sony Xperia Z1 compact mit DNS-Redirect extremst langsam

Mitglied: STRUBartacus

STRUBartacus (Level 1) - Jetzt verbinden

21.12.2015, aktualisiert 08:28 Uhr, 1681 Aufrufe, 3 Kommentare

Hallo zusammen

Da Android ja die (eigentlich skandalöse) Angewohnheit hat, DNS-Server, welche per DHCP oder RA vorgegeben werden, zu ignorieren - um stattdessen stets Google-DNS Server zu benutzen- habe ich auf meiner pfSense eine DNS-Umleitungsregel eingerichtet. Dies geschah mittels einer NAT-Regel welche sämtliche DNS Anfragen, welche als Destination nicht das LAN aufweisen, auf meinen lokalen DNS-Server umleiten. Dank dieser Regel erreiche ich nun endlich auch lokale Ressourcen mittels Hostnamen von meinem Android-Handy aus. Auf dem Handy meiner Freundin, einem Xperia Z1 compact, hat diese Regel jedoch zur Folge, dass das Internet unbenutzbar langsam wird. Mir ist dieses Verhalten absolut schleierhaft. Wo könnte hier der Fehler liegen?
Mitglied: LordGurke
21.12.2015, aktualisiert um 10:28 Uhr
Huuuh? Diese "Android-Eigenart" scheint eher eine Sony-Eigenart zu sein. Ich habe hier mehrere Android-Geräte verschiedener Version und verschiedener Hersteller im Netz die ausschließlich die vorgegebenen DNS-Server nutzen können (und es auch tun) - alle anderen sind nämlich per Firewall gesperrt.
Es gibt jedoch vereinzelt Apps von Drittanbietern, die DNS-Anfragen explizit an die 8.8.8.8 richten, vielleicht liegt da der Hund begraben.

Das einzige sinnvolle dürfte sein, wenn du mal in den Netzwerkverkehr reinhörst (mit Wireshark z.B.) um zu sehen welchen DNS-Server das Telefon fragt und was es als Antwort bekommt. Das dürfte vermutlich sogar direkt auf der pfSense gehen.


NACHTRAG: Welcher Browser wird denn genutzt? Ist das eventuell ein Chrome mit dieser "Surfen beschleunigen"-Funktion? Dann werden die Anfragen realistisch betrachtet sogar durch Google-Proxies geschoben...
Bitte warten ..
Mitglied: STRUBartacus
21.12.2015, aktualisiert um 10:38 Uhr
Zitat von @LordGurke:

Huuuh? Diese "Android-Eigenart" scheint eher eine Sony-Eigenart zu sein. Ich habe hier mehrere Android-Geräte verschiedener Version und verschiedener Hersteller im Netz die ausschließlich die vorgegebenen DNS-Server nutzen können (und es auch tun) - alle anderen sind nämlich per Firewall gesperrt.

Nein das ist keine Sony-Eigenart, bei meinem Motorola Moto X Play war es dasselbe. Durch den Redirect konnte ich ihm dieses Verhalten jedoch abgewöhnen. iOS, Windows, Ubuntu funktionieren dagegen wie gewünscht. Die Frage ist nur, wieso der Redirect das Sony so dermassen verlangsamt. Ich werde wohl wirklich mal den Netzwerkverkehr aufzeichnen müssen.

NACHTRAG: Meine Freundin benutzt in der Tat den Chrome. Werde ich heute Abend gleich mal abchecken.
Bitte warten ..
Mitglied: LordGurke
21.12.2015 um 12:17 Uhr
Wie gesagt kann ich das Verhalten so nicht nachstellen - nicht einmal mit Nexus-Geräten, die ja 100% "Google Branded" sind.
Hast du geprüft, ob deine Geräte wirklich die Google-Namserver fragen - sprich per tcpdump nachgeforscht?
Das ist definitiv kein Standardverhalten, gerade live mit einem Xperia M getestet. Auch im Firewall-Log kann ich keine Einträge finden, dass jemand im Netz fremde DNS-Server gefragt hat (da sind ca. 15 Android-Geräte angemeldet).
Bitte warten ..
Heiß diskutierte Inhalte
Sicherheit
Verpackter Laptop entwendet
r0x3llVor 1 TagFrageSicherheit11 Kommentare

Hallo. Mir wurde aus dem Büro ein noch verpackter Dell XPS Laptop mit einem Wert von ca 3.500€ gestohlen. Kann man da was orten? ...

Off Topic
Namenskonzept Kundengeräte
bitnarratorVor 1 TagFrageOff Topic5 Kommentare

Hallo, ich möchte gerne einmal die Diskussion anstoßen, weil ich eine hier in diese Richtung noch nichts gefunden habe. Es geht um die Bennenung ...

Netzwerkgrundlagen
Router für neues Heimnetzwerk - was will man 2021 haben?
billy01Vor 1 TagFrageNetzwerkgrundlagen7 Kommentare

Guten Abend zusammen, nachdem sich bei mir viel getan hat, stehe ich nun vor einem Umzug und dem Neuaufbau meines Heimnetzwerkes. Also weg von ...

LAN, WAN, Wireless
2x Fritzbox 7590 mit separatem DSL über WAN verbinden
gelöst FailixVor 22 StundenFrageLAN, WAN, Wireless19 Kommentare

Liebes Administrator Forum, Ich bin schon länger passiver Lese und habe mich jetzt entschlossen mit einer Frage den ersten Post hier zu schreiben. Über ...

Off Topic
Wie sieht eine korrekte IT-Organisation aus?
imebroVor 5 StundenFrageOff Topic17 Kommentare

Hallo, da unser IT-Verantwortlicher ja vor einem Jahr gehen musste, stelle ich mir die Frage, wie denn eine korrekte IT-Organisation überhaupt aussehen muss. Zur ...

LAN, WAN, Wireless
Cat 7 Patchkabel mit nur 11MBits im Download
gelöst RickHHVor 20 StundenFrageLAN, WAN, Wireless7 Kommentare

Moin zusammen, ich habe mir soeben ein paar Patchkabel (aus einem Cat 7 Kabel) fertig gemacht. Die Belegung ist: 1 weiß/grün 2 grün 3 weiß/orange 4 blau 5 weiß/blau ...

DNS
Network Scanner zeigt falschen Hostname an
gelöst vafk18Vor 22 StundenFrageDNS10 Kommentare

Ich habe in meinem Netzwerk 3 Fritzboxen im Betrieb. Die Fritzboxen haben in den Einstellungen als Namen "fb7270", "fb7369" und "fb7412". Jede Fritzbox hat ...

Windows 10
Windows 10 keine Eingabegeräte mehr erkannt - Anmelden nicht möglich
akira2012Vor 1 TagFrageWindows 107 Kommentare

Hallo Zusammen! Ich habe hier einen Windows 10 Rechner. Er bootet ganz normal aber nach dem hochfahren, werden die Eingabegeräte nicht mehr erkannt. Weder ...